Subject: RE: [Softwires] reworded charter

From: "Durand, Alain" <[email-masked]>
Date: Mon, 10 Oct 2005 09:57:54 -0400

> Is there a particular reason we can't have both types (or am
> I missing something here) ?

This is essentially a latency & routing issue. If the tunnel is set up for a 'long period of time',
latency at set-up time is not that critical an issue, at is is a one time cost.
If tunnels are created on a per connection basis, set-up latency is on the critical path.
Even more so if you are trying to figure out who you want to tunnel with on a per connection basis.
 
With pseudo static softwires, you can envision a very simple model where you send every packet
to a 'softwire concentrator' with a default route or a slightly more complex model where you have a  small
number of preconfigured softwires and an equally small number of static routes to help you pick the right one.
 
If you want to extend this model to dynamic tunnels, things get much more complex
and routing is not so obvious any more...
 
   - Alain.

_______________________________________________
Softwires mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/softwires

---

From: Tim Chown <[email-masked]>
Date: Tue, 11 Oct 2005 08:41:20 +0100

> and routing is not so obvious any more...

I think this will come out from the (hopefully quick) problem statement
formulation.  The problem statement in my view should be scenario driven.

This will clarify what the softwires are designed to run between, and the
requirements of long-lived vs on-demand (I would use those words rather
than static vs dynamic, which means something else to me).

When we discussed DSTM a month or two ago, Pekka raised some very good
questions about how and when DSTM tunnels would be created and (equally
importantly) torn down, where the IPv4 TEP global addresses for the IPv6
routed site infrastructure may be a scarce resource.   Those points
should probably be discussed and captured here for posterity and to help
us focus on what we can realistically achieve by July 2006.

Aside - I found it odd to see the IESG call regarding WG formulation on
the meeting day - I am sure the charter will be bashed by those present
in Paris... so comments now on the circulated charter may be premature
and/or be out of sync with list/meeting activity.

-- 
Tim/::1