Subject: [Softwires] FW:[Int-area] Stateless IPv4-in-IPv6 experiments && DS-Lite/NAT64 experiments

From: <[email-masked]>
Date: Thu, 7 Apr 2011 13:31:42 +0800

We have tested how applications behave when it has both DS-Lite IPv4 and NAT64 IPv6 (but not native IPv6). Firefox, IE, Skype, Google Earth v5.2.1, Live Messenger, uTorrent, BitComet, were on our test list. 

Despres,regarding your question ( maybe not answering your question exactly as we tested NAT64 IPv6 instead of native IPv6 ), uTorrent v2.2 used IPv6 for login/authentication but IPv4 for the data exchange, for IPv6 peer was not able to talk to IPv4 peer. Although BitComet v1.23 issued both A and AAAA quires, it completely ignored AAAA RR and only used IPv4 for communication.

Please also see some of other test results below. DS-Lite/NAT64 experiments could be documented if it is of interests. 

Tested Apps                   IPv4/IPv6 portion

Firefox (Non-vedio) v3.6.12   All IPv6                             

video website                 Half/ half            

IE (Non-vedio) v6.0           All IPv6                            

Skype v5.0                    Major IPv6                          

Google Earth v5.2.1           Major IPv6                    

Live Messenger 2009           Major IPv4            

uTorrent v2.2                 Major IPv4     

BitComet v1.23                All IPv4       

BR,

Xiaohong

opensource A+P: http://opensourceaplusp.weebly.com/

________________________________

	发件人: Rémi Després [mailto:[email-masked]] 
	发送时间: 2011年4月7日 0:21
	收件人: DENG Xiaohong ESP/PEK
	抄送: [email-masked]
	主题: Re: [Int-area] Stateless IPv4-in-IPv6 experiments

	Thank you, Xiahong, for sharing this interesting information. 

	In the case of BitComet and uTorrent, I wonder what happens if the host has both A+P IPv4 and IPv6, as opposed to just A+P IPv4.
	Did you try that?

	Regards,
	RD

	Le 6 avr. 2011 à 10:57, <[email-masked]> <[email-masked]> a écrit :

		Dear all,
		 
		An I-D about stateless IPv4-in-IPv6 experiments has been submitted. A URL for this Internet-Draft is: http://tools.ietf.org/html/draft-deng-aplusp-experiment-results-00 <http://tools.ietf.org/html/draft-deng-aplusp-experiment-results-00> .
		 
		A website introducing the detail of experiment results is also accessible via: http://opensourceaplusp.weebly.com/ <http://opensourceaplusp.weebly.com/> 
		 
		BR,
		Xiaohong
		_______________________________________________
		Int-area mailing list
		[email-masked]
		https://www.ietf.org/mailman/listinfo/int-area

---

From: "Lee, Yiu" <[email-masked]>
Date: Thu, 7 Apr 2011 14:11:02 +0000

Hi Xiaohong,

I am personally very interested in the data. Do you also document what may break the applications?

Thanks,
Yiu

From: <[email-masked]<mailto:[email-masked]>>
Date: Thu, 7 Apr 2011 13:31:42 +0800
To: <[email-masked]<mailto:[email-masked]>>
Subject: [Softwires] FW:[Int-area] Stateless IPv4-in-IPv6 experiments && DS-Lite/NAT64 experiments

BR,
Xiaohong

抄送: [email-masked]<mailto:[email-masked]>

Regards,
RD

Le 6 avr. 2011 à 10:57, <[email-masked]<mailto:[email-masked]>> <[email-masked]<mailto:[email-masked]>> a écrit :

Dear all,

An I-D about stateless IPv4-in-IPv6 experiments has been submitted. A URL for this Internet-Draft is: http://tools.ietf.org/html/draft-deng-aplusp-experiment-results-00.

A website introducing the detail of experiment results is also accessible via: http://opensourceaplusp.weebly.com/

BR,
Xiaohong
_______________________________________________
Int-area mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/int-area

_______________________________________________ Softwires mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/softwires

---

From: Tina Tsou <[email-masked]>
Date: Thu, 07 Apr 2011 11:15:31 -0700

Hi Xiao-hong,
How many kinds of ALG should we support when using NAT64?

We keep our promises with one another – no matter what!
 
Best Regards,
Tina TSOU
http://tinatsou.weebly.com/contact.html
 
From: [email-masked] [mailto:[email-masked]] On
Behalf Of [email-masked]
Sent: Wednesday, April 06, 2011 10:32 PM
To: [email-masked]
Subject: [Softwires] FW:[Int-area] Stateless IPv4-in-IPv6 experiments &&
DS-Lite/NAT64 experiments
 
We have tested how applications behave when it has both DS-Lite IPv4 and
NAT64 IPv6 (but not native IPv6). Firefox, IE, Skype, Google Earth v5.2.1,
Live Messenger, uTorrent, BitComet, were on our test list.
 
Despres,regarding your question ( maybe not answering your question exactly
as we tested NAT64 IPv6 instead of native IPv6 ), uTorrent v2.2 used IPv6
for login/authentication but IPv4 for the data exchange, for IPv6 peer was
not able to talk to IPv4 peer. Although BitComet v1.23 issued both A and
AAAA quires, it completely ignored AAAA RR and only used IPv4 for
communication.
 
Please also see some of other test results below. DS-Lite/NAT64 experiments
could be documented if it is of interests. 

        BR,
Xiaohong

  _____  

In the case of BitComet and uTorrent, I wonder what happens if the host has
both A+P IPv4 and IPv6, as opposed to just A+P IPv4.
Did you try that?
 
Regards,
RD
 
Le 6 avr. 2011 à 10:57, <[email-masked]>
<[email-masked]> a écrit :

Dear all,
 
An I-D about stateless IPv4-in-IPv6 experiments has been submitted. A URL
for this Internet-Draft is:
<http://tools.ietf.org/html/draft-deng-aplusp-experiment-results-00>
http://tools.ietf.org/html/draft-deng-aplusp-experiment-results-00.
 
A website introducing the detail of experiment results is also accessible
via:  <http://opensourceaplusp.weebly.com/>
http://opensourceaplusp.weebly.com/
 
BR,
Xiaohong

---

From: <[email-masked]>
Date: Fri, 8 Apr 2011 18:28:34 +0800

Hello Yiu,
 
Yes, some apps break by NAT64. We're going to document it.
 
BR,
Xiaohong

	发件人: Lee, Yiu [mailto:[email-masked]] 
	发送时间: 2011年4月7日 22:11
	收件人: DENG Xiaohong ESP/PEK; [email-masked]
	主题: Re: [Softwires] FW:[Int-area] Stateless IPv4-in-IPv6 experiments && DS-Lite/NAT64 experiments

	Hi Xiaohong,

	Thanks,
	Yiu

	From: <[email-masked]>
	Date: Thu, 7 Apr 2011 13:31:42 +0800
	To: <[email-masked]>
	Subject: [Softwires] FW:[Int-area] Stateless IPv4-in-IPv6 experiments && DS-Lite/NAT64 experiments

	video website                 Half/ half            

	Skype v5.0                    Major IPv6                          

	uTorrent v2.2                 Major IPv4     

	BitComet v1.23                All IPv4       

	BR,

	Xiaohong

		Regards,
		RD

			Dear all,

			 
			BR,
			Xiaohong

	_______________________________________________ Softwires mailing list [email-masked] https://www.ietf.org/mailman/listinfo/softwires