Subject: [Softwires] Fwd: v6ops - ietf81 recording

From: Fred Baker <[email-masked]>
Date: Wed, 7 Sep 2011 12:10:07 -0700

Alain:

I have a question. In your recent note to softwire, you seem to be changing the charter that you and Jari stated in v6ops at IETF-81. At IETF-81, you stated that there was no need for a translation-related working group because translation (specifically the dIVI proposal, but more generally translation) would be part of the ongoing softwire charter. In your more recent statements, you appear to be saying that the topic would be discussed in a "vs" setting and buried "because the IETF has decided to not work on translation". I'll remind you that the IETF has not only chosen to work on translation, but to standardize it along with tunneling technologies.

I call on you to not only give lip service to discussion, but to allow and support open discussion of stateless a+p tunneling (as apposed to ds-lite, which is stateful) and translation, as you said you would.

Fred

> Alain's "translation" statement is ~2hrs 57 min into the recording at:
> http://www.ietf.org/audio/ietf81/ietf81-205abc-20110728-1256-pm.mp3
> 
> Transcript:
> 
>    Alain: This is done in Softwire.  We are planning to organize
>    an interim meeting in September, in some part of the world,
>    to actually go through all the technical solutions that have
>    been put forward and analyze them and do what we did at the
>    beginning of Softwires.  Pretty intensive interim meeting,
>    locked in a room, and figure out what we need.
> 
>    Fred: So, Alain, we are finally going to have the discussion.
> 
>    Alain: We are actually going to make technical progress on
>    this - more than just discussing.
> 
> Jari suggested doing everything in one group (implying a new WG).
> 
>    Alain:  there are no more groups.  We will just do it now.

---

From: Alain Durand <[email-masked]>
Date: Wed, 7 Sep 2011 13:58:35 -0700

Fred:

The way I phrased the call for the interim meeting on the mailling list might have created some unwanted confusion.

Yong and I are going to publish the agenda for the interim meeting very soon.
There will be ample time to discuss the various propositions on the table in the 'stateless' arena (that I can define loosely as no centralized CGN)
Some more stateless than others, some more stateful than others, some based on tunnels and some based on translation.
Giving ample time to discuss all those solution is the very reason of the interim meeting.

Is that clearer?

   - Alain.

---

From: Fred Baker <[email-masked]>
Date: Wed, 7 Sep 2011 14:41:26 -0700

> Giving ample time to discuss all those solution is the very reason of the interim meeting.

Hopefully. There is a pretty strong concern here that the meeting is being arranged to encourage certain outcomes. I'd really hope for a level playing field, whatever the outcome may turn out to be.

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 8 Sep 2011 08:24:46 -0700 (PDT)

Hi Fred,
  Please note the quotes on stateless in Alain's mail.

Some techniques are not as stateless as is claimed.

Please see the chair's slides in IETF 81.

Regards,

Behcet

>>  The way I phrased the call for the interim meeting on the mailling list 
> might have created some unwanted confusion.
>> 
>>  There will be ample time to discuss the various propositions on the table 
> in the 'stateless' arena (that I can define loosely as no centralized 
> CGN)
>>  Some more stateless than others, some more stateful than others, some based 
> on tunnels and some based on translation.
> Hopefully. There is a pretty strong concern here that the meeting is being 
> arranged to encourage certain outcomes. I'd really hope for a level playing 
> field, whatever the outcome may turn out to be.
> 
>>    - Alain.
>> 
>> 
>> 
>>>  I have a question. In your recent note to softwire, you seem to be 
> changing the charter that you and Jari stated in v6ops at IETF-81. At IETF-81, 
> you stated that there was no need for a translation-related working group 
> because translation (specifically the dIVI proposal, but more generally 
> translation) would be part of the ongoing softwire charter. In your more recent 
> statements, you appear to be saying that the topic would be discussed in a 
> "vs" setting and buried "because the IETF has decided to not work 
> on translation". I'll remind you that the IETF has not only chosen to 
> work on translation, but to standardize it along with tunneling technologies.
>>> 
>>>  I call on you to not only give lip service to discussion, but to allow 
> and support open discussion of stateless a+p tunneling (as apposed to ds-lite, 
> which is stateful) and translation, as you said you would.
>>> 
>>>  Fred
>>> 
> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires
>

---

From: Ralph Droms <[email-masked]>
Date: Thu, 8 Sep 2011 09:03:33 -0700

I think it would be useful to reframe the discussion away from "stateless/stateful" and more towards the issues that operators are interested in: capital investment and ongoing operational expense.  "stateless/stateful" is related to those expense issues but there is not, for any given operator, necessarily a direct relation between operator cost and statefulness.

It seems there are operators who feel their needs would be better served by a "less stateful" mechanism.  Whether that mechanism is completely "stateless" or "less stateful" is less important than what I hear as a need for "has state that is cheaper to deploy and run."  There may be other operational requirements for better service that would be met by "less stateful."

- Ralph

---

From: Qiong <[email-masked]>
Date: Fri, 9 Sep 2011 00:34:14 +0800

Hi Ralph,

Fully agree. From operator aspect, we do not care about whether it is a
stateful or a totally stateless one. We are just interested in a good
solution which is easy to use, operate and cost less. So any solution,
either "stateless" or "less stateful" , will be welcome if they can meet our
practical requirements.

Besides, I still think that our current discussion on stateless solutions is
too technical.  I think we should also discuss more about operational issues
for existing stateless solutions, e.g. how to make proper plan on the range
of v6domain, how to cope with different situations for addressing and
routing, and how to simply the configuration, etc. Hopefully we will get a
clear picture after discussing in our Interim meeting.

Best wishes

On Fri, Sep 9, 2011 at 12:03 AM, Ralph Droms <[email-masked]> wrote:

> I think it would be useful to reframe the discussion away from
> "stateless/stateful" and more towards the issues that operators are
> interested in: capital investment and ongoing operational expense.
>  "stateless/stateful" is related to those expense issues but there is not,
> for any given operator, necessarily a direct relation between operator cost
> and statefulness.
>
> It seems there are operators who feel their needs would be better served by
> a "less stateful" mechanism.  Whether that mechanism is completely
> "stateless" or "less stateful" is less important than what I hear as a need
> for "has state that is cheaper to deploy and run."  There may be other
> operational requirements for better service that would be met by "less
> stateful."
>
> - Ralph
>
> >>> Giving ample time to discuss all those solution is the very reason of
> the
> >> interim meeting.
> >>>
> >>> Is that clearer?
> >>

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 8 Sep 2011 08:21:42 -0700 (PDT)

Hi Fred,

Regards,

Behcet