Subject: [Softwires] Q of clarification on the draft-murakami-softwire-4rd-00

From: Leaf yeh <[email-masked]>
Date: Thu, 22 Sep 2011 09:17:06 +0000

http://datatracker.ietf.org/doc/draft-murakami-softwire-4rd/?include_text=1

Section 4

   The IPv4 prefix, IPv4 address or shared IPv4 address for use at a

   customer site is created by extracting the IPv4 embedded address (EA-

   bits) from the IPv6 prefix delegated to the site. …

   A mapping rule consist of the following elements: a Domain IPv6

   prefix and prefix length, a Domain 4rd prefix and prefix length, CE

   IPv6 Prefix length, and a Domain IPv6 suffix and length. …

Section 4.1

   The only remaining provisioning information the CE requires in order

   to calculate the 4rd address and enable IPv6 connectivity is an IPv6

   prefix for the CE.  This CE IPv6 prefix is configured as part of

   obtaining IPv6 Internet access (i.e., configured via SLAAC, DHCPv6,

   DHCPv6 PD, or otherwise).

----------------------------------------------------------------------------------------

Q1. Per the above description, the EA-bits of CE IPv6 prefix sounds from IAPrefix (option 26) of IA_PD (option 25) in DHCPv6. And the length of CE IPv6 prefix sounds a different one with the length of IAPrefix. Will the length of CE IPv6 prefix + the length of Domain IPv6 suffix = (be equal to) the length of IAPrefix?

----------------

Section 5.1.1

   <----------- CE IPv6 prefix (max 128) -------------->

   +-------------------------------+------------------------+

   |Domain IPv6 prefix     |  EA-bits         |

   +-------------------------------+------------------------+

   ...

   Figure 1: From a CE IPv6 Prefix to a CE 4rd Prefix

Section 5.1.4

   ...

                       Domain IPv6 suffix

                             |

   +- - - - - - - -----------+- - ------+--|-+----------------------------------+

   |Domain IPv6 prefix| EA-bits|  ' |       0               |

   +- - - - - - - -----------+- - ------+----+----------------------------------+

   <- - - - - ------- max 64 ------------>

   <- - - - - ----------------- CE IPv6 address (128) --------------------->

   Figure 4: From 4rd Prefix to IPv6 address (shared IPv4 address case)

--------------------------------------------------------------------------------------

Q2. There is a conflict in Fig.1 with Fig.5. I guess there is a typo in Fig.1. The max. length of CE IPv6 prefix sounds 64, right?

Q3. BTW, what is the design purpose of Domain IPv6 suffix?

Best Regards,

Leaf

---

From: Leaf yeh <[email-masked]>
Date: Sat, 24 Sep 2011 08:37:07 +0000

>    IPv6 Prefix length, and a Domain IPv6 suffix and length. …

Ole - no, the CE IPv6 prefix is the prefix delegated to the site. typically this is done with DHCPv6 and those prefixes are equal.

If the CE IPv6 prefix is the prefix delegated to the site, it sounds not necessary to include the CE IPv6 Prefix length to be the element of the address mapping rule. Right?

>    Figure 4: From 4rd Prefix to IPv6 address (shared IPv4 address case)

Ole - in theory it could be any prefix length. up to 128.

The sounds a correction in the above figure, the Fig.4.

>    Figure 1: From a CE IPv6 Prefix to a CE 4rd Prefix

Q4. If the CE IPv6 prefix is the prefix delegated to the site, it is implied that Domain IPv6 prefix is a part of the prefix delegated to the site (eg. through DHCPv6-PD) per the above figure. It sounds only need to include the length of Domain IPv6 prefix into the elements of the address mapping rule, not the include the Domain IPv6 prefix itself. Right?

Best Regards,

Leaf

-----Original Message-----
From: Ole Troan [mailto:[email-masked]]
Sent: Friday, September 23, 2011 8:23 PM
To: Leaf yeh
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: Q of clarification on the draft-murakami-softwire-4rd-00

Leaf,

> Q1. Per the above description, the EA-bits of CE IPv6 prefix sounds from IAPrefix (option 26) of IA_PD (option 25) in DHCPv6. And the length of CE IPv6 prefix sounds a different one with the length…

no, the CE IPv6 prefix is the prefix delegated to the site. typically this is done with DHCPv6 and those prefixes are equal.

> Q2. There is a conflict in Fig.1 with Fig.5. I guess there is a typo in Fig.1. The max. length of CE IPv6 prefix sounds 64, right?

in theory it could be any prefix length. up to 128.

> Q3. BTW, what is the design purpose of Domain IPv6 suffix?

the suffix need to be a well known value among all nodes within the 4rd domain. this is appended to create a full IPv6 address that is used to reach the tunnel end point (either on the BR or the CE). this could very well have been a well known value, but since there was some discussion on what it should be, it can also be provisioned. e.g. it could be ::, ::1, or follow the dIVI format.

cheers,

Ole

---

From: Ole Troan <[email-masked]>
Date: Fri, 23 Sep 2011 14:23:00 +0200

Leaf,

cheers,
Ole

---

From: Leaf yeh <[email-masked]>
Date: Mon, 26 Sep 2011 05:19:40 +0000

Question Revised:

1. If the CE IPv6 prefix is the prefix delegated to the site, it sounds not necessary to include the CE IPv6 Prefix length to be the element of the address mapping rule sent to CE. Right?

2. If the CE IPv6 prefix is the prefix delegated to the site, it is implied that Domain IPv6 prefix is a part of the prefix delegated to the site (eg. through DHCPv6-PD) per the above figure. It sounds only need to include the length of Domain IPv6 prefix into the elements of the address mapping rule sent to CE, not the include the Domain IPv6 prefix itself. Right?

Best Regards,

Leaf

________________________________
发件人: Leaf yeh
发送时间: 2011年9月24日 16:37
到: Ole Troan
Cc: [email-masked]; [email-masked]; [email-masked]
主题: RE: Q of clarification on the draft-murakami-softwire-4rd-00

Best Regards,

Leaf

-----Original Message-----
From: Ole Troan [mailto:[email-masked]]
Sent: Friday, September 23, 2011 8:23 PM
To: Leaf yeh
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: Q of clarification on the draft-murakami-softwire-4rd-00

Leaf,

cheers,

Ole