Subject: [Softwires] Question about draft-sun-softwire-stateless-4over6-00

From: Satoru Matsushima <[email-masked]>
Date: Mon, 26 Sep 2011 06:08:40 +0800

Hi auhtors,

I have quick question about your draft.

Section 5 says:

>    As described above, a stateless 4over6 initiator needs the sub-domain
>    rule containing subPre6, subPre4 and multiplexing ratio.  Since these
>    parameters are relatively stable, it can be configured in a variety
>    of provisioning methods, including
>    DHCPv6[I-D.cui-softwire-dhcp-over-tunnel], "TR-069", etc.  For
>    customer's IPv6 prefix, it will be delegated just in traditional way,
>    e.g.  DHCPv6, Prefix Delegation, etc.  And there is no impact on
>    current IPv6 addressing model.  The concentrator address can be
>    passed through the same option of ds-lite AFTR address.

However, section 10 says:

>    Stateless 4over6 does not need to inform multiple prefix mapping
>    rules to CPEs directly.  Thus, there is no need to introduce dynamic
>    protocol for distributing and maintaining 4rd rules.  This will turn
>    CPE to be a much simpler/dummier client, which will also
>    significantly reduce the burden of CPE management and trouble
>    shooting.

In terms of distribution mapping rule, what's the difference between 4over6 and 4rd?
It seems both of these could use all options, such as pre-configuration, DHCPv6 and TR-069, etc., I don't see any difference between them. Thought?

BTW, thank you for bring this draft before the interim meeting.;)

cheers,
--satoru

---

From: Qiong <[email-masked]>
Date: Mon, 26 Sep 2011 11:51:18 +0800

Hi, Satoru,

Thank you very much for your comments.

In stateless 4over6, an initiator will  only need to keep *ONE* sub-domain
rule of its own. So this would be much simpler to implement.

Actually, for stateless 4over6, there are three items for CPE:
1) sub-domain rule: including subPre6, subPre4 and multiplexing ratio. This
kind of rule is relatively stable and we think it can be configured via
TR-069, DHCP extension, etc. Maybe TR-069 is enough already.
2) IPv6 user-prefix: this is just a normal IPv6 address allocation process
and we do not need to extend any protocol. Based on this user-prefix and
sub-domain rule, we can infer shard-IPv4 address and port set for a specific
user (which is discussed in section 6.2).
3) concentrator address: this can be passed in a similar way of AFTR address
in DS-Lite

I will talk about this more in detail this afternoon. If you have any
question, we can discuss in this meeting.

Sorry that the draft has not explained this very clearly. We will improve it
later.

Thanks again.

Best wishes

Qiong Sun

 since there is only one sub-

On Mon, Sep 26, 2011 at 6:08 AM, Satoru Matsushima <
[email-masked]> wrote:

> It seems both of these could use all options, such as pre-configuration,
> DHCPv6 and TR-069, etc., I don't see any difference between them. Thought?
>
> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires
>

---

From: Satoru Matsushima <[email-masked]>
Date: Mon, 26 Sep 2011 14:47:01 +0800

Hi Qiong,

On 2011/09/26, at 11:51, Qiong wrote:

> In stateless 4over6, an initiator will  only need to keep *ONE* sub-domain rule of its own. So this would be much simpler to implement.
> 

Okay, if I understand correctly, you mean that an (super) domain has multiple mapping rules, but each CE which has only one mapping rule belong to a sub-domain, which sub-domain is a part of the super domain. Is that correct?

> 1) sub-domain rule: including subPre6, subPre4 and multiplexing ratio. This kind of rule is relatively stable and we think it can be configured via TR-069, DHCP extension, etc. Maybe TR-069 is enough already.

Ok.

> 2) IPv6 user-prefix: this is just a normal IPv6 address allocation process and we do not need to extend any protocol. Based on this user-prefix and sub-domain rule, we can infer shard-IPv4 address and port set for a specific user (which is discussed in section 6.2).

Ok, focus to keep CPE simple configuration with single rule.

> 3) concentrator address: this can be passed in a similar way of AFTR address in DS-Lite

Ok.

> 
> I will talk about this more in detail this afternoon. If you have any question, we can discuss in this meeting.
> 
> Sorry that the draft has not explained this very clearly. We will improve it later.
> 
> Thanks again.
> 

thanks too.

cheers,
--satoru

> On Mon, Sep 26, 2011 at 6:08 AM, Satoru Matsushima <[email-masked]> wrote:
> Hi auhtors,
>

---

From: Qiong <[email-masked]>
Date: Mon, 26 Sep 2011 14:59:53 +0800

Hi, Satoru,

Yes. You are right. Sub-domain is a part of the super domain and we still
make initiators to keep one sub-domain rule.

> Okay, if I understand correctly, you mean that an (super) domain has
> multiple mapping rules, but each CE which has only one mapping rule belong
> to a sub-domain, which sub-domain is a part of the super domain. Is that
> correct?
>
>
>
Best wishes

Qiong Sun