Subject: [Softwires] Softwire Interim Meeting, 2011 Sep. 26-27

From: Yong Cui <[email-masked]>
Date: Sat, 24 Sep 2011 23:16:58 +0800

Softwire Interim Meeting, 2011.9.26-27

Meeting venue, contact info, Agenda

MEETING VENUE
FIT Building, which is the first left building inside the East Gate of
Tsinghua University
Registration: West Lobby of FIT building during Monday morning 8:30~9:30am

http://maps.google.com/maps/ms?msid=202779846620144871057.0004aad8ce367b982
9372&msa=0&ll=39.996906,116.331664&spn=0.004044,0.008798

CONTACT
Ziye Li: (+86) 136-1112-2392, <[email-masked]>
Peng Wu: (+86) 135-8171-3436, <[email-masked]>

===================================================
                     AGENDA
===================================================
---------------9/26 Monday 9:00-17:30---------------

FIT BUILDING 1-315, TSINGHUA UNIVERSITY

1.Intro, logistic (30min) - Chairs
9:00-9:30
Taxonomy, problem space: (stateful/stateless, translation/tunneling, etc.)
Starting point: operator-driven Stateless motivation draft and the
4-quadrant discussion at Quebec
Goal: have a common terminology

2. Deep Dive (7hours) - Chairs and presenters
Technical dive in all proposal as they stand today
Goal: understand the various proposals according to the common terminology
and how they fit in the problem space
Goal2: Refine terminology/problem space as we go

9:30-10:30 Xiaohong Deng
1. Architectural considerations of Stateless A+P with a focus on SMAP
http://tools.ietf.org/html/draft-boucadair-behave-ipv6-portrange-04
2. DHCPv6 Options for Shared IP Addresses Solutions
http://tools.ietf.org/html/draft-boucadair-dhcpv6-shared-address-option-00

10:30-10:45 Coffee break

10:45-11:15 Peng Wu
DHCPv4 over IPv6
http://datatracker.ietf.org/doc/draft-cui-softwire-dhcp-over-tunnel

11:15-12:15 Naoki Matsuhira
Motivation for developing SA46T and SA46T-AS
http://tools.ietf.org/html/draft-matsuhira-sa46t-motivation-00
SA46T & SA46T-AS technology dive
http://tools.ietf.org/html/draft-matsuhira-sa46t-spec-02
http://tools.ietf.org/html/draft-matsuhira-sa46t-as-00

--------------- 12:15-13:30 Lunch ---------------

13:30-14:00 Tetsuya Murakami
IPv4 Residual Deployment on IPv6 infrastructure - protocol specification
http://tools.ietf.org/html/draft-murakami-softwire-4rd-00

14:00-14:30 Jacni Qin
Stateless Address Mapping for IPv4 Residual Deployment (4rd)
http://tools.ietf.org/html/draft-despres-softwire-4rd-addmapping-00

14:30-15:30 Wojciech Dec
1. Stateless 4Via6 Address Sharing
http://tools.ietf.org/html/draft-dec-stateless-4v6
2. Stateless port mapping algorithms overview

15:30-15:45Coffee break

15:45-16:15 Qiong Sun
Lightweight 4over6
http://tools.ietf.org/html/draft-cui-softwire-b4-translated-ds-lite-01

16:15-17:15 Xing Li
1. dIVI-pd: Dual-Stateless IPv4/IPv6 Translation with Prefix Delegation
https://datatracker.ietf.org/doc/draft-xli-behave-divi-pd
2. dIVI: Dual-Stateless IPv4/IPv6 Translation
https://datatracker.ietf.org/doc/draft-xli-behave-divi

17:30-21:00 Socail Event (depart at FIT West Lobby at 17:30)

--------------- Tuesday 8:30-17:30 ---------------

8:30-9:00 CERNET Operation Center tour (FIT 1-101, TSINGHUA UNIVERSITY)

FIT BUILDING 1-315, TSINGHUA UNIVERSITY

9:00-10:00 Gang Chen
1. 4via6 Stateless Translation
http://tools.ietf.org/html/draft-murakami-softwire-4v6-translation-00
2. Prefix Delegation in 4V6
http://www.ietf.org/internet-drafts/draft-chen-softwire-4v6-pd-00.txt

10:00-10:30 Xiaohong Deng
DS-Lite AFTR NAT Bypass: Co-located B4 and NAT Model
http://tools.ietf.org/id/draft-zhou-softwire-b4-nat-02.txt

10:30-10:45 Coffee break

3.Invited talks from operators (90min)
Operator's perspective

10:45-11:15 Satoru Matsushima
An operator's view, address mapping in particular with our cases

11:15-11:45 Xing Li
The operational requiements and the experience of the single and dual
stateless translation concerning CERNET (IPv4) and CNGI-CERNET2 (IPv6).

11:45-12:15 ChongfengXie
ChinaTelecom

--------------- 12:15-13:30 Lunch ---------------

FIT BUILDING 1-515, TSINGHUA UNIVERSITY

4.Divide& conquer (2 hours)
Map technologies into problem space
Goal: analyze overlaps & differences

13:30-14:00 Ole Troan
Comparision between encapsulation and translation

14:00-14:30 Linjian Song
Head compression

14:30-15:00 Hui Deng
Comparision between encapsulation and translation

15:00-15:30 Ole Troan
Port mapping rules

15:30-16:00 Rémi Després
Port mapping rules

16:00-16:30 Coffee break

5. Path forward (1 hour)
16:30-17:30
Goal: evolution of technologies, integration with existing mechanism, gap
analysis
Goal: winnow down list of candidates
Chairs

Alain and Yong

---

From: Yong Cui <[email-masked]>
Date: Sat, 24 Sep 2011 23:18:53 +0800

Please send your slides to the chair by Sunday 9PM (local time).

Alain and Yong

-----Original Message-----
From: Yong Cui <[email-masked]>
Date: Sat, 24 Sep 2011 23:16:58 +0800
To: <[email-masked]>
Cc: Yong Cui <[email-masked]>, Alain Durand
<[email-masked]>, liziye <[email-masked]>,
"weapon@csnet1" <[email-masked]>
Subject: Softwire Interim Meeting, 2011 Sep. 26-27

---

From: Ole Troan <[email-masked]>
Date: Sun, 25 Sep 2011 15:28:28 +0800

all,

we're working on many interrelated problems:

1. DS-lite with A+P (SMAP)
2. Provisioning of IPv4 over DS-lite (4over6)
3. Stateless IPv4 address sharing over IPv6 (4rd, dIVI)
4. Stateless IPv4 over IPv6 tunneling (SA46)

given that the main focus of the interim is 3. let me propose an alternative agenda for Monday.
same topics, just different structure.

Monday:
1. Intro, logistics, chairs

2. Stateless IPv4 address sharing overview and requirements
  - Xiaohong: http://tools.ietf.org/html/draft-boucadair-behave-ipv6-portrange-04
  - Xiaohong: http://tools.ietf.org/html/draft-boucadair-softwire-stateless-requirements-00
  - Satoru: http://tools.ietf.org/html/draft-ietf-softwire-stateless-4v6-motivation-00
  - Wojciech: http://tools.ietf.org/html/draft-dec-stateless-4v6-03
  - Xiaohong: http://tools.ietf.org/html/draft-deng-v6ops-aplusp-experiment-results-01

 2.1. dIVI
  - Xing: https://datatracker.ietf.org/doc/draft-xli-behave-divi-pd
  - Xing: https://datatracker.ietf.org/doc/draft-xli-behave-divi

 2.2. 4rd
  - Tetsuya: http://tools.ietf.org/html/draft-murakami-softwire-4rd-00

 2.3 Summary:
  - Ole Troan: Comparision between encapsulation and translation
  - Hui Deng: Comparision between encapsulation and translation

 2.4. Stateless address mapping algorithms
  - Ole port algorithm requirements, selection criteria
  - Remi: http://tools.ietf.org/html/draft-despres-softwire-stateless-analysis-tool-00
  - Xiaohong: http://tools.ietf.org/html/draft-bsd-softwire-stateless-port-index-analysis-00

Tuesday:
3. DS-lite enhancements (4over6, NAT bypass...)
4. Operator-session
5. Conclusions

cheers,
Ole

> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires

---

From: Naoki Matsuhira <[email-masked]>
Date: Sun, 25 Sep 2011 17:23:03 +0900

Ole, 

Please don't forget SA46T-AS. SA46T-AS have IPv4 address sharing capability with SA46T extension.

Naoki Matsuhira

On Sun, 25 Sep 2011 15:28:28 +0800
Ole Troan <[email-masked]> wrote:

> > 15:30-16:00 R??mi Despr??s
> > Port mapping rules
> > 
> > 16:00-16:30 Coffee break
> > 
> > 5. Path forward (1 hour)
> > 16:30-17:30

---

From: Ole Troan <[email-masked]>
Date: Sun, 25 Sep 2011 16:30:17 +0800

Naoki,

> Please don't forget SA46T-AS. SA46T-AS have IPv4 address sharing capability with SA46T extension.

agree, apologies, I missed the AS part.

remind me to ask you some questions about how you can use SA46T-AS for connecting IPv4 islands across an IPv6 network without having to assign special SA46T-AS prefixes, different from native IPv6 ones...

cheers,
Ole

---

From: <[email-masked]>
Date: Sun, 25 Sep 2011 18:24:37 +0800

Ole, all,

New agenda looks fine, with some comments and suggestions below. 

|-----Original Message-----
|From: Ole Troan [mailto:[email-masked]] 
|Sent: Sunday, September 25, 2011 3:28 PM
|To: Yong Cui; Alain Durand
|Cc: [email-masked]; liziye
|Subject: Re: [Softwires] Softwire Interim Meeting, 2011 Sep. 26-27
|
|all,
|
|we're working on many interrelated problems:
|
|1. DS-lite with A+P (SMAP)
|2. Provisioning of IPv4 over DS-lite (4over6) 3. Stateless 
|IPv4 address sharing over IPv6 (4rd, dIVI) 4. Stateless IPv4 
|over IPv6 tunneling (SA46)
|
|given that the main focus of the interim is 3. let me propose 
|an alternative agenda for Monday.
|same topics, just different structure.
|
|Monday:
|1. Intro, logistics, chairs
|
|2. Stateless IPv4 address sharing overview and requirements
|  - Xiaohong: 
|http://tools.ietf.org/html/draft-boucadair-behave-ipv6-portrange-04
|  - Xiaohong: 
|http://tools.ietf.org/html/draft-boucadair-softwire-stateless-r
|equirements-00
|  - Satoru: 
|http://tools.ietf.org/html/draft-ietf-softwire-stateless-4v6-mo
|tivation-00
|  - Wojciech: http://tools.ietf.org/html/draft-dec-stateless-4v6-03
|  - Xiaohong: 
|http://tools.ietf.org/html/draft-deng-v6ops-aplusp-experiment-r
|esults-01

Updated version:
http://tools.ietf.org/html/draft-deng-softwire-aplusp-experiment-results-00

|
| 2.1. dIVI
|  - Xing: https://datatracker.ietf.org/doc/draft-xli-behave-divi-pd
|  - Xing: https://datatracker.ietf.org/doc/draft-xli-behave-divi
|
| 2.2. 4rd
|  - Tetsuya: http://tools.ietf.org/html/draft-murakami-softwire-4rd-00
|
| 2.3 Summary:
|  - Ole Troan: Comparision between encapsulation and translation
|  - Hui Deng: Comparision between encapsulation and translation
|
| 2.4. Stateless address mapping algorithms
|  - Ole port algorithm requirements, selection criteria
|  - Remi: 
|http://tools.ietf.org/html/draft-despres-softwire-stateless-ana
|lysis-tool-00

Missed one item here? 

Jacni Qin:

|  - Xiaohong: 

Suggested speaker: Wojciech?

|http://tools.ietf.org/html/draft-bsd-softwire-stateless-port-in
|dex-analysis-00
|
|Tuesday:
|3. DS-lite enhancements (4over6, NAT bypass...) 4. 
|Operator-session 5. Conclusions
|
|cheers,
|Ole
|
|> ===================================================
|>                     AGENDA
|> ===================================================
|> ---------------9/26 Monday 9:00-17:30---------------
|> 
|> FIT BUILDING 1-315, TSINGHUA UNIVERSITY
|> 
|> 1.Intro, logistic (30min) - Chairs
|> 9:00-9:30
|> Taxonomy, problem space: (stateful/stateless, translation/tunneling, 
|> etc.) Starting point: operator-driven Stateless motivation draft and 
|> the 4-quadrant discussion at Quebec
|> Goal: have a common terminology
|> 
|> 
|> 2. Deep Dive (7hours) - Chairs and presenters Technical dive in all 
|> proposal as they stand today
|> Goal: understand the various proposals according to the common 
|> terminology and how they fit in the problem space
|> Goal2: Refine terminology/problem space as we go
|> 
|> 9:30-10:30 Xiaohong Deng
|> 1. Architectural considerations of Stateless A+P with a focus on SMAP
|> http://tools.ietf.org/html/draft-boucadair-behave-ipv6-portrange-04
|> 2. DHCPv6 Options for Shared IP Addresses Solutions 
|> 
|http://tools.ietf.org/html/draft-boucadair-dhcpv6-shared-address-optio
|> n-00
|> 
|> 10:30-10:45 Coffee break
|> 
|> 10:45-11:15 Peng Wu
|> DHCPv4 over IPv6
|> http://datatracker.ietf.org/doc/draft-cui-softwire-dhcp-over-tunnel
|> 
|> 11:15-12:15 Naoki Matsuhira
|> Motivation for developing SA46T and SA46T-AS 
|> http://tools.ietf.org/html/draft-matsuhira-sa46t-motivation-00
|> SA46T & SA46T-AS technology dive
|> http://tools.ietf.org/html/draft-matsuhira-sa46t-spec-02
|> http://tools.ietf.org/html/draft-matsuhira-sa46t-as-00
|> 
|> --------------- 12:15-13:30 Lunch ---------------
|> 
|> 13:30-14:00 Tetsuya Murakami
|> IPv4 Residual Deployment on IPv6 infrastructure - protocol 
|> specification 
|> http://tools.ietf.org/html/draft-murakami-softwire-4rd-00
|> 
|> 14:00-14:30 Jacni Qin
|> Stateless Address Mapping for IPv4 Residual Deployment (4rd) 
|> http://tools.ietf.org/html/draft-despres-softwire-4rd-addmapping-00
|> 
|> 14:30-15:30 Wojciech Dec
|> 1. Stateless 4Via6 Address Sharing
|> http://tools.ietf.org/html/draft-dec-stateless-4v6
|> 2. Stateless port mapping algorithms overview
|> 
|> 15:30-15:45Coffee break
|> 
|> 15:45-16:15 Qiong Sun
|> Lightweight 4over6
|> 
|http://tools.ietf.org/html/draft-cui-softwire-b4-translated-ds-lite-01
|> 
|> 16:15-17:15 Xing Li
|> 1. dIVI-pd: Dual-Stateless IPv4/IPv6 Translation with Prefix 
|> Delegation https://datatracker.ietf.org/doc/draft-xli-behave-divi-pd
|> 2. dIVI: Dual-Stateless IPv4/IPv6 Translation 
|> https://datatracker.ietf.org/doc/draft-xli-behave-divi
|> 
|> 17:30-21:00 Socail Event (depart at FIT West Lobby at 17:30)
|> 
|> 
|> --------------- Tuesday 8:30-17:30 ---------------
|> 
|> 8:30-9:00 CERNET Operation Center tour (FIT 1-101, TSINGHUA 
|> UNIVERSITY)
|> 
|> FIT BUILDING 1-315, TSINGHUA UNIVERSITY
|> 
|> 9:00-10:00 Gang Chen
|> 1. 4via6 Stateless Translation
|> http://tools.ietf.org/html/draft-murakami-softwire-4v6-translation-00
|> 2. Prefix Delegation in 4V6
|> http://www.ietf.org/internet-drafts/draft-chen-softwire-4v6-pd-00.txt
|> 
|> 10:00-10:30 Xiaohong Deng
|> DS-Lite AFTR NAT Bypass: Co-located B4 and NAT Model 
|> http://tools.ietf.org/id/draft-zhou-softwire-b4-nat-02.txt
|> 
|> 10:30-10:45 Coffee break
|> 
|> 
|> 3.Invited talks from operators (90min) Operator's perspective
|> 
|> 10:45-11:15 Satoru Matsushima
|> An operator's view, address mapping in particular with our cases
|> 
|> 11:15-11:45 Xing Li
|> The operational requiements and the experience of the single 
|and dual 
|> stateless translation concerning CERNET (IPv4) and 
|CNGI-CERNET2 (IPv6).
|> 
|> 11:45-12:15 ChongfengXie
|> ChinaTelecom
|> 
|> --------------- 12:15-13:30 Lunch ---------------
|> 
|> 
|> FIT BUILDING 1-515, TSINGHUA UNIVERSITY
|> 
|> 4.Divide& conquer (2 hours)
|> Map technologies into problem space
|> Goal: analyze overlaps & differences
|> 
|> 13:30-14:00 Ole Troan
|> Comparision between encapsulation and translation
|> 
|> 14:00-14:30 Linjian Song
|> Head compression
|> 
|> 14:30-15:00 Hui Deng
|> Comparision between encapsulation and translation
|> 
|> 15:00-15:30 Ole Troan
|> Port mapping rules
|> 
|> 15:30-16:00 Rémi Després
|> Port mapping rules
|> 
|> 16:00-16:30 Coffee break
|> 
|> 5. Path forward (1 hour)
|> 16:30-17:30
|> Goal: evolution of technologies, integration with existing 
|mechanism, 
|> gap analysis
|> Goal: winnow down list of candidates
|> Chairs
|> 
|> 
|> Alain and Yong
|> 
|> 
|> 
|> _______________________________________________
|> Softwires mailing list
|> [email-masked]
|> https://www.ietf.org/mailman/listinfo/softwires
|
|
|

---

From: Naoki Matsuhira <[email-masked]>
Date: Sun, 25 Sep 2011 19:38:15 +0900

Ole,

Thank you. I don't worry.

And thank you for the question.

In past experiments, SA46T prefix is assigned from native IPv6 address.
SA46T-AS prefix is the same.

If using SA46T or SA46T-AS in a AS(Provider) closely, SA46T prefix and SA46T-AS prefix does not advertise outside AS, so any prefix may possible, however we use SA46T prefix from native IPv6 address.

We also have two inter AS experiments. One is NICT and ThaiSarn and this case, SA46T prefix is allocated from NICT IPv6 address space, and the other is Interop Tokyo Shownet, NICT and ThaiSarn, this case, SA46T prefix is allocated from Interop Tokyo Shownet IPv6 address space.

Following is the another information from Thailand. 

http://www.apan.net/meetings/India2011/Session/Slides/fit/3-2.pdf

Naoki Matsuhira

On Sun, 25 Sep 2011 16:30:17 +0800

---

From: Wojciech Dec <[email-masked]>
Date: Sun, 25 Sep 2011 21:49:26 +0800

All,

Ole's agenda is a big improvement, as in it addresses the concerns I (and
others voiced) in the past weeks. That said, to make the proceedings follow
a more structured  Introduction; Requirements; Details, sequence, I would
like to propose the following (changes in the order of things proposed by
Ole):

 2.1 General
 - Satoru:
http://tools.ietf.org/html/draft-ietf-softwire-stateless-4v6-motivation-00
 - Wojciech: http://tools.ietf.org/html/draft-dec-stateless-4v6-03
 - Xiaohong:
http://tools.ietf.org/html/draft-boucadair-softwire-stateless-requirements-00

2.2 Operator's perspectives
 - Satoru: An operator's view, address mapping in particular with our cases
 - Xing: The operational requiements and the experience of the single and
dual
 stateless translation concerning CERNET (IPv4) and CNGI-CERNET2 (IPv6).
- ChongfengXie ChinaTelecom
- Hui Deng: Operator's Comparision between encapsulation and translation

3. Stateless solutions and mechanisms

  3.1. dIVI

  3.2. 4rd

  3.3 SMAP
 - Xiaohong:
http://tools.ietf.org/html/draft-boucadair-behave-ipv6-portrange-04
 - Xiaohong:
http://tools.ietf.org/html/draft-deng-v6ops-aplusp-experiment-results-01

3.4 SA46T-AS
 - Naoki: http://tools.ietf.org/html/draft-matsuhira-sa46t-as-00

4 Summary:
  - Ole Troan: Comparision between encapsulation and translation
 - All: Day 1 summary & initial conclusions

Tuesday:

 5.1. Stateless address mapping algorithms
 - Ole port algorithm requirements, selection criteria
 - Remi:
http://tools.ietf.org/html/draft-despres-softwire-stateless-analysis-tool-00
 - Xiaohong:
http://tools.ietf.org/html/draft-bsd-softwire-stateless-port-index-analysis-00
-  Jacni Qin:
http://tools.ietf.org/html/draft-despres-softwire-4rd-addmapping-00

5.2. DS-lite enhancements (4over6, NAT bypass...)

6. Day 2 & Meeting Conclusions

Regards,
Woj.

On 25 September 2011 15:28, Ole Troan <[email-masked]> wrote:

>  - Xiaohong:
>  - Xiaohong:
> http://tools.ietf.org/html/draft-boucadair-softwire-stateless-requirements-00
>  - Satoru:
> http://tools.ietf.org/html/draft-ietf-softwire-stateless-4v6-motivation-00
>  - Xiaohong:
> http://tools.ietf.org/html/draft-deng-v6ops-aplusp-experiment-results-01
>
>  2.1. dIVI
>  - Remi:
> http://tools.ietf.org/html/draft-despres-softwire-stateless-analysis-tool-00
>  - Xiaohong:
> http://tools.ietf.org/html/draft-bsd-softwire-stateless-port-index-analysis-00
>
> Tuesday:

---

From: Ole Troan <[email-masked]>
Date: Sun, 25 Sep 2011 22:11:00 +0800

> Ole's agenda is a big improvement, as in it addresses the concerns I (and others voiced) in the past weeks. That said, to make the proceedings follow a more structured  Introduction; Requirements; Details, sequence, I would like to propose the following (changes in the order of things proposed by Ole):

after meeting with the chairs this afternoon, I understand their reasoning for the original agenda and I'm fine with keeping it as originally proposed.

cheers,
Ole

>  - Xing: The operational requiements and the experience of the single and dual
> -  Jacni Qin: http://tools.ietf.org/html/draft-despres-softwire-4rd-addmapping-00
>

---

From: Hui Deng <[email-masked]>
Date: Sun, 25 Sep 2011 22:29:50 +0800

I agree this proposal to make this meeting has more clear target other than
scattered
just remind that there is orginal proposal about 4v6 translation

this two go to
thanks

-Hui
2011/9/25 Wojciech Dec <[email-masked]>

---

From: Satoru Matsushima <[email-masked]>
Date: Sun, 25 Sep 2011 22:34:14 +0800

On 2011/09/25, at 22:29, Hui Deng wrote:

> I agree this proposal to make this meeting has more clear target other than scattered

+1

cheers,
--satoru

---

From: Satoru Matsushima <[email-masked]>
Date: Sun, 25 Sep 2011 22:36:42 +0800

> after meeting with the chairs this afternoon, I understand their reasoning for the original agenda and I'm fine with keeping it as originally proposed.

I think that it sounds good to have Ole and Woj suggested agenda. But I'd like to know what their reasoning for the original agenda. Could you share it with us?

--satoru

---

From: Tao Sun <[email-masked]>
Date: Sun, 25 Sep 2011 22:47:42 +0800

Hi all,

Woj's proposal on the agenda looks good. I share the same view with Hui that
"4v6 translation" and "Prefix delegation in 4v6" belong to Section "3
Stateless solutions and mechanisms"

Regards,

Tao

---

From: GangChen <[email-masked]>
Date: Sun, 25 Sep 2011 22:53:25 +0800

> 3. Stateless solutions and mechanisms

+1
These two drafts should be taken into the agenda.

Gang

---

From: Wojciech Dec <[email-masked]>
Date: Sun, 25 Sep 2011 22:54:37 +0800

> These two drafts should be taken into the agenda.

+1 Agree. Apologies for not spotting them as missing from the original
agenda.

-Woj.

---

From: Tetsuya Murakami <[email-masked]>
Date: Sun, 25 Sep 2011 08:03:47 -0700

+1

The agenda posted by Woj looks good.

Thanks,
Tetsuya Murakami

---

From: Zhen Cao <[email-masked]>
Date: Sun, 25 Sep 2011 23:11:09 +0800

I support the idea of have a focus discussion as well as the agenda in
proposed by Woj.

And 4v6 translation/pd discussion ought to be included in item 3 as
suggested below.

-- 
Best regards,
Zhen