Subject: [Softwires] Requirements for extending IPv6 addresses with port range (draft-boucadair-softwire-stateless-rfc6052-update)

From: <[email-masked]>
Date: Wed, 7 Sep 2011 14:18:50 +0200

Dear all,

We submitted a new I-D identifying the requirements to be met when designing the format of IPv4-embedded IPv6 addresses/prefixes enclosing the port information. The first list of requirements is available at: 

http://tools.ietf.org/html/draft-boucadair-softwire-stateless-rfc6052-update-00#section-3

Contributions, comments and suggestions on the requirements section are encouraged.

Thanks.

Cheers,
Med

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de [email-masked]
Envoyé : mercredi 7 septembre 2011 13:56
À : [email-masked]
Objet : I-D Action: draft-boucadair-softwire-stateless-rfc6052-update-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title           : Embedding Port Information in IPv4-Translatable IPv6 Prefixes and IPv4- Embedded IPv6 Addresses
	Author(s)       : Mohamed Boucadair
                          Congxiao Bao
                          Nejc Skoberne
                          Xing Li
	Filename        : draft-boucadair-softwire-stateless-rfc6052-update-00.txt
	Pages           : 10
	Date            : 2011-09-07

   RFC6052 specifies the algorithmic translation of an IPv6 address to a
   corresponding IPv4 address, and vice versa.  In particular, RFC6052
   specifies the address format to build IPv4-converted and IPv4-
   translatable IPv6 addresses.  In order to be deployed in the context
   of stateless 4/6 solutions, RFC6052 should be updated so that IPv4-
   embedded IPv6 addresses convey the port information.  This document
   identifies a set of requirements to be taken into account when
   updating RFC6052 for that purpose.

   A companion effort, document at
   [I-D.bsd-softwire-stateless-port-index-analysis], is required to
   converge on one or a set of algorithms to be used by all stateless
   solutions.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-boucadair-softwire-stateless-rfc6052-update-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-boucadair-softwire-stateless-rfc6052-update-00.txt
_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: <[email-masked]>
Date: Wed, 7 Sep 2011 16:10:07 +0200

Dear Maoke,

Please see inline.

Cheers,
Med

________________________________
De : Maoke [mailto:[email-masked]]
Envoyé : mercredi 7 septembre 2011 15:43
À : BOUCADAIR Mohamed OLNC/NAD/TIP
Objet : Re: [Softwires] Requirements for extending IPv6 addresses with port range (draft-boucadair-softwire-stateless-rfc6052-update)

hi all,

i'd like to commet on the interesting question after REQ#5 "Do we allow the support of multiple algorithms?".

my answer is NO. intuitively, it sounds ok if we allow multiple algorithms, as long as the algorithm type is also encoded in the IPv4-embedded IPv6 address together with the port index. however, it is only applied for the case of translating an IPv4-embedded IPv6 address to IPv4. for the reverse direction, the algorithm selection might be randomly decided by the translator devices. inconsistency of port indexing algorithm violates the end-to-end transparency. coordinating algorithm selection is possible but it might must costs.
[Med] I see your point and it makes sense to me. There is also an underlying question we wanted to discuss: is it acceptable for the WG to specify several algorithms (see for instance RFC6056) but only one algorithm MUST be enabled in a network.

btw, it looks the reference on port indexing algorithm analysis should be ...-bsd-... rather than ...-boucadair-... ;-)
[Med] Fixed. Thanks.

best,
maoke

2011/9/7 <[email-masked]<mailto:[email-masked]>>
Dear all,

Thanks.

Cheers,
Med

-----Message d'origine-----
De : [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] De la part de [email-masked]<mailto:[email-masked]>
Envoyé : mercredi 7 septembre 2011 13:56
À : [email-masked]<mailto:[email-masked]>
Objet : I-D Action: draft-boucadair-softwire-stateless-rfc6052-update-00.txt

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-boucadair-softwire-stateless-rfc6052-update-00.txt
_______________________________________________
I-D-Announce mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
_______________________________________________
Softwires mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/softwires

--
Dr. Maoke CHEN,
FreeBit Co., Ltd.
13F, 3-6 Maruyamacho, Shibuya-ku, Tokyo 150-0044 Japan
Tel: +81 80 3930 1704
e-mail: [email-masked]<mailto:[email-masked]>
--

---

From: <[email-masked]>
Date: Fri, 9 Sep 2011 15:18:53 +0200

Dear all,

To avoid confusion with address format discussion, we generated an document grouping a set of requirements to be met by stateless solutions. I know some of you have in mind a set of features to be supported. These features may be "translated" into requirements. Comments and inputs are welcome.

The document is available at: http://tools.ietf.org/html/draft-boucadair-softwire-stateless-requirements-00

Cheers,
Med