Subject: Re: [Softwires] Second working group last call for draft-ietf-softwire-public-4over6-04

From: Qi Sun <[email-masked]>
Date: Wed, 2 Jan 2013 00:03:24 +0800

Dear Med,

As an extension to DS-Lite, Public 4over6 can support intercommunications between nodes within the same domain with public IPv4 address assigned. However, address sharing transition mechanism can't do that, i.e. two nodes sharing the same address aren't able to communicate directly.

What's more, Public 4over6 CE, which uses a full IPv4 address, can work as a server that is IPv4-globally reachable by the nodes outside the domain. This is of great importance to ICP-side transition. In this case, address sharing is not expected. 

In general, there are major differences between pb4o6 and lw4o6. If we put them together, some important features (as listed above) may be lost. The mechanism can be confused on some functionality, like intercommunications within a domain.

I think public 4over6 is mature enough to move forward.

Best Regards,
Qi

On 2012-12-17, at 下午4:54, <[email-masked]> <[email-masked]> wrote:

> Dear Suresh, all,
> 
> With all due respect to the authors of this draft, I really think this document should not move forward. 
> 
> The feature described in this draft can be easily integrated in the current unified CPE effort (binding mode: MAP1:1/Lw4over6) or the document needs to be extended to cover the port restriction feature.
> 
> Cheers,
> Med
> 
>> -----Message d'origine-----
>> De : [email-masked] 
>> [mailto:[email-masked]] De la part de Suresh Krishnan
>> Envoyé : lundi 17 décembre 2012 05:34
>> À : Softwires WG
>> Cc : Yong Cui; Ralph Droms
>> Objet : [Softwires] Second working group last call for 
>> draft-ietf-softwire-public-4over6-04
>> 
>> Hi all,
>> This message starts a second softwire working group last call on
>> advancing the draft about providing Public IPv4 over IPv6 
>> Access Network
>> as a Standards Track RFC. The authors believe that this version has
>> addressed the issues raised during the previous WGLC. The draft
>> is available at
>> 
>> http://www.ietf.org/id/draft-ietf-softwire-public-4over6-04.txt
>> http://tools.ietf.org/html/draft-ietf-softwire-public-4over6-04
>> 
>> Substantive comments and statements of support/opposition for advancing
>> this document should be directed to the mailing list. Editorial
>> suggestions can be sent directly to the authors. The chairs 
>> will send in
>> their comments as well during the last call period. This last call will
>> conclude on January 4, 2013.
>> 
>> Regards,
>> Suresh & Yong
>> 
>> _______________________________________________
>> Softwires mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/softwires
>> 
> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires

---

From: Sheng Jiang <[email-masked]>
Date: Fri, 4 Jan 2013 00:49:50 +0000

+1 for support.

Sheng

From: [email-masked] [mailto:[email-masked]] On Behalf Of Qiong
Sent: Monday, December 31, 2012 11:41 AM
To: Suresh Krishnan
Cc: Softwires WG; Yong Cui; Ralph Droms
Subject: Re: [Softwires] Second working group last call for draft-ietf-softwire-public-4over6-04

Dear Suresh,
I support this document to move forward. This version has solved all the technical issues, and it is quite simple for some specific use case. I think it is ready to move forward :)
Merry Christmas and Happy new year !
Qiong

On Mon, Dec 17, 2012 at 12:33 PM, Suresh Krishnan <[email-masked]<mailto:[email-masked]>> wrote:
Hi all,
  This message starts a second softwire working group last call on
advancing the draft about providing Public IPv4 over IPv6 Access Network
as a Standards Track RFC. The authors believe that this version has
addressed the issues raised during the previous WGLC. The draft
is available at

suggestions can be sent directly to the authors. The chairs will send in

Regards,
Suresh & Yong

_______________________________________________
Softwires mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/softwires

--
==============================================
Qiong Sun
China Telecom Beijing Research Institude

Open source code:
lightweight 4over6: http://sourceforge.net/projects/laft6/
PCP-natcoord: http://sourceforge.net/projects/pcpportsetdemo/
===============================================

---

From: "Liubing (Leo)" <[email-masked]>
Date: Fri, 4 Jan 2013 01:51:20 +0000

Dear Chairs & WG,

I support advancing it. 

Public IPv4 in 4over6 is a useful use case, especially for the operators who still have plenty of reserved public IPv4 addresses.
The architecture is simple, and the v4 address provision is different from the other 4over6 solutions, so it is quite reasonable to make it as an independent standard track. 

All the best
Bing

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Suresh Krishnan
> Sent: Monday, December 17, 2012 12:34 PM
> To: Softwires WG
> Cc: Yong Cui; Ralph Droms
> Subject: [Softwires] Second working group last call for