Subject: [Softwires] Required knowledge of destination port set in MAP

From: Tom Taylor <[email-masked]>
Date: Sun, 27 Jan 2013 15:39:53 -0500

I suppose it's the same as for any NAT situation, a node trying to send 
packets to another in a MAP domain has to know in advance what port to 
send to. Otherwise (for shared addresses), the packet is likely to be 
routed to the wrong CE. Should the examples mention that the port (e.g., 
port 9030 in example 2) is known in advance to be one that will reach 
the desired endpoint?

Is there anything special about MAP compared with the general NAT 
situation that makes it easier or harder for senders to learn what ports 
they can send to?

Tom Taylor

---

From: Ole Troan <[email-masked]>
Date: Mon, 28 Jan 2013 10:21:23 +0100

Tom,

> I suppose it's the same as for any NAT situation, a node trying to send packets to another in a MAP domain has to know in advance what port to send to. Otherwise (for shared addresses), the packet is likely to be routed to the wrong CE. Should the examples mention that the port (e.g., port 9030 in example 2) is known in advance to be one that will reach the desired endpoint?
> 
> Is there anything special about MAP compared with the general NAT situation that makes it easier or harder for senders to learn what ports they can send to?

no, not as far as I can see.
any end to end communication using TCP or UDP requires the initiator of the communication to know which port to connect to.

cheers,
Ole