Subject: [Softwires] I-D Action: draft-ietf-softwire-map-03.txt

From: [email-masked]
Date: Thu, 24 Jan 2013 03:15:31 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Softwires Working Group of the IETF.

	Title           : Mapping of Address and Port with Encapsulation (MAP)
	Author(s)       : Ole Troan
                          Wojciech Dec
                          Xing Li
                          Congxiao Bao
                          Satoru Matsushima
                          Tetsuya Murakami
	Filename        : draft-ietf-softwire-map-03.txt
	Pages           : 29
	Date            : 2013-01-24

Abstract:
   This document describes a mechanism for transporting IPv4 packets
   across an IPv6 network using IP encapsulation, and a generic
   mechanism for mapping between IPv6 addresses and IPv4 addresses and
   transport layer ports.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-softwire-map

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-softwire-map-03

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-softwire-map-03

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Ole Troan <[email-masked]>
Date: Thu, 24 Jan 2013 12:23:02 +0100

finally an update to the MAP draft.
I believe all the issues apart from #21 is resolved.

the main changes are:
- a complete rewrite of the port mapping section (going back to the simpler description from the 4rd draft).
- moving examples to a separate appendix
- removing the DMR, and replacing with a simple BR address.

please review and suggest text for changes.
I expect one more revision, and then I hope we can take this to WGLC.

Best regards,
Ole

On Jan 24, 2013, at 12:15 , [email-masked] wrote:

> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires

---

From: Tomoyuki Sahara <[email-masked]>
Date: Fri, 25 Jan 2013 01:54:33 +0900

Hi,

Example 2&3 were written for MAP-T and not updated for MAP(-E),
so we should make some corrections to them.

Suggested changes are:

draft-ietf-softwire-map-03:
>   Example 2:
> ...
>      MAP BR Prefix  2001:db8:ffff::/64

=> IPv6 address of MAP BR:  2001:db8:ffff::1

>      IPv6 source address  2001:db8:ffff:0:0001:0203:0400::

=> IPv6 source address  2001:db8:ffff::1

>   Example 3 - FMR:
>...
>      configured on the MAP CE as follows:
>
>      IPv6 address of BR used by MAP CE:  2001:db8:ffff::1
>...
>      IPv6 destination address:  2001:db8:ffff:0:0001:0203:0400::

=> IPv6 destination address:  2001:db8:ffff::1

Thanks,
Tomoyuki

---

From: Ole Troan <[email-masked]>
Date: Thu, 24 Jan 2013 23:48:33 +0100

Tomoyuki-san,

> so we should make some corrections to them.

excellent. getting the examples right has proven quite hard.
updated with the below.

cheers,
Ole