Subject: Re: [Softwires] [BEHAVE] Home NAPT44 - How many ports?

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Wed, 5 Jun 2013 16:27:59 +0000

On 6/5/13 1:23 PM, "Michael Richardson" <[email-masked]> wrote:

>
>>>>>> "repenno" == repenno  <Reinaldo> writes:
>    repenno> On the other hand, as Rajiv captured,the number of
>    repenno> UDP sessions can be much larger than the number of
>    repenno> TCP. Because the way
>    repenno> dynamic webpages are constructed today, there are sometimes
>    repenno> literally 100s
>    repenno> of DNS requests to download a single page.
>
>If one is doing CGN, wouldn't it be reasonable to point customers' at
>a recursive DNS server with an interface inside the CGN?

Yes. That's what I suggest. But some people use, say, Google's
DNS/OpenDns/etc and in some other cases the network is not setup correctly.

>
>This seems to also suggest that having a *caching* recursive DNS(SEC,
>HOMENET+, mDNS+) server inside the customer router is also a big win.

Yes, it is.

>
>-- 
>]               Never tell me the odds!                 | ipv6 mesh
>networks [ 
>]   Michael Richardson, Sandelman Software Works        | network
>architect  [ 
>]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails
>   [ 
>

---

From: kaname nishizuka <[email-masked]>
Date: Thu, 06 Jun 2013 03:15:57 +0900

With regard to the DNS packets, shortening the time-out of NAT table is 
another good solution.

In larger environment, we tested that when the time-out of DNS was 
shortened to 3sec, the impact of such DNS requests was much smaller than 
TCP sessions.
3 sec is sufficient  round-trip time in general situation.
I don't think it's necessary to place a recursive DNS server inside the CGN.

Though there are differences between Home NAPT44 and CGN, it will work 
well in both case.
That is because there are many devices in home and those seldom access 
the web site within a short time simultaneously.

regards,
--
kaname

(2013/06/06 1:27), Reinaldo Penno (repenno) wrote:
> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave

-- 
----
Kaname Nishizuka
Innovative Architecture Center
NTT Communications Corporation
+81-50-3812-4704

---

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Wed, 5 Jun 2013 18:57:05 +0000

> >If one is doing CGN, wouldn't it be reasonable to point customers' at a
> >recursive DNS server with an interface inside the CGN?
> 

And in some cases, it is not possible depending on where the NAT function is placed and where the DNS server is placed. I recently ran into this in a large mobile network design. 

Nonetheless, it is desired, but it is not really a big deal, since UDP NAT usage tends to be a lot less than that TCP NAT usage (barring few exceptions).

> >HOMENET+, mDNS+) server inside the customer router is also a big win.

Well, DNS resolver with or without proxy is a big win, I would say. 

Cheers,
Rajiv

> -----Original Message-----
> From: Reinaldo Penno (repenno)
> Sent: Wednesday, June 05, 2013 12:28 PM
> To: Michael Richardson; [email-masked]
> Cc: Poscic, Kristian (Kristian); Rajiv Asati (rajiva); Softwires-wg list
> ([email-masked]); [email-masked]; Erik Kline ([email-masked])
> Subject: Re: [BEHAVE] Home NAPT44 - How many ports?
> 
> 
> 
> >If one is doing CGN, wouldn't it be reasonable to point customers' at a
> >recursive DNS server with an interface inside the CGN?
>

---

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Wed, 5 Jun 2013 19:04:43 +0000

Kaname-san,

That's a good suggestion, though the captured data suggests that UDP NAT exhaustion is not a problem, but TCP NAT is.

Cheers,
Rajiv

> From: kaname nishizuka [mailto:[email-masked]]
> Sent: Wednesday, June 05, 2013 2:16 PM
> To: Reinaldo Penno (repenno)
> Cc: Michael Richardson; [email-masked]; Softwires-wg list
> ([email-masked]); Poscic, Kristian (Kristian); [email-masked]; Erik Kline
> ([email-masked]); Rajiv Asati (rajiva)

---

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Wed, 5 Jun 2013 19:27:38 +0000

There are some interesting measurements on this "background TCP
radiation", i.e., how much state (and bandwidth) a home consumes even when
there is no active use.

On 6/5/13 3:57 PM, "Rajiv Asati (rajiva)" <[email-masked]> wrote:

>And in some cases, it is not possible depending on where the NAT function
>is placed and where the DNS server is placed. I recently ran into this in
>a large mobile network design.
>
>Nonetheless, it is desired, but it is not really a big deal, since UDP
>NAT usage tends to be a lot less than that TCP NAT usage (barring few
>exceptions).
>