Subject: [Softwires] Stephen Farrell's No Objection on draft-ietf-softwire-multicast-prefix-option-12: (with COMMENT)

From: "Stephen Farrell" <[email-masked]>
Date: Tue, 31 Jan 2017 04:44:34 -0800

Stephen Farrell has entered the following ballot position for
draft-ietf-softwire-multicast-prefix-option-12: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-softwire-multicast-prefix-option/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

- (nit) section 3: it seems odd to say in the
figure that the prefixes are variable length but to
then say the lengths of two of them MUST be 96
bits. (I do think having the fields as is is good
for futureproofing, but would suggest changing the
figure.)

- (non-nit:-) section 3: I'm not getting why the
unicast-length can be >96? And what if the prefix
length is not one of those given in RFC6052? Don't
you need to say it needs to be?

- (not sure about nittyness:-) section 5: 1st
bullet: I'm not following what "matches" means
here. Probably my ignorance but is it clear?

---

From: <[email-masked]>
Date: Tue, 31 Jan 2017 13:30:49 +0000

Hi Stephen, 

Thank you for the review. 

Please see inline. 

Cheers,
Med

> -----Message d'origine-----
> De : Stephen Farrell [mailto:[email-masked]]
> Envoyé : mardi 31 janvier 2017 13:45
> À : The IESG
> Cc : [email-masked]; softwire-
> [email-masked]; [email-masked]; [email-masked]
> Objet : Stephen Farrell's No Objection on draft-ietf-softwire-multicast-
> prefix-option-12: (with COMMENT)
> 

[Med] Good catch. Fixed in my local copy. 

> you need to say it needs to be?

[Med] Good catch (again). As per RFC6052, the length values can be 32, 48, 56, 64, or 96. I updated the text accordingly:

NEW: 

"As specified in [RFC6052], the unicast-length MUST be one of 32, 48, 56, 64, or 96."

> here. Probably my ignorance but is it clear?

[Med] As you can read at https://tools.ietf.org/html/rfc2365#section-8, there is a mapping between the IPv6 multicast scope and IPv4 multicast prefixes. "Matches" is used to denote that.