Subject: Re: [Softwires] I-D Action: draft-ietf-softwire-yang-02.txt

From: Andy Wingo <[email-masked]>
Date: Wed, 08 Nov 2017 10:47:52 +0100

Hi,

On Mon 30 Oct 2017 16:12, [email-masked] writes:

>         Title           : A YANG Data Model for IPv4-in-IPv6 Address plus Port Softwires
>         Authors         : Qi Sun
>                           Hao Wang
>                           Yong Cui
>                           Ian Farrer
>                           Sladjana Zechlin
>                           Mohamed Boucadair
>                           Rajiv Asati
> 	Filename        : draft-ietf-softwire-yang-02.txt
> 	Pages           : 41
> 	Date            : 2017-10-30

I had a look at this for the Snabb lwAFTR and found a few issues.

 1. "hairpin-ipv4-packets" and "hairpin-ipv4-bytes" need to be state
    data, not config data.  Consider moving them inside the
    "traffic-stat" container.

 2. "dropped-ipv4-bytes", described as counting bytes from dropped IPv4
    fragments, should probably be named "dropped-ipv4-fragment-bytes" or
    something.  Note there is already "dropped-ipv4-byte" (sic) for
    dropped IPv4 bytes as a whole.

 3. "dropped-ipv4-bytes" (from (2)), "dropped-ipv4-fragments",
    "hairpin-ipv4-packets" (from (1)), and "hairpin-ipv4-bytes" (from
    (1)) are plural whereas the rest of the counters are singular.  One
    or the other should probably be chosen.

 4. The type of "icmpv6-errors-rate" is "uint16".  This is probably too
    restrictive.

Regards,

Andy

---

From: Ian Farrer <[email-masked]>
Date: Thu, 9 Nov 2017 14:58:19 +0100

Hi,

Thanks for your comments. Please see inline below.

Cheers,
Ian

> On 8. Nov 2017, at 10:47, Andy Wingo <[email-masked]> wrote:
> 
> Hi,
> 

[if - This was an oversight when we moved from ‘config false’ at the leaf level to the container level. The following change fixes it:

container traffic-stat {
              config false;
              description
                “traffic-stat”;
              uses softwire-common:traffic-stat;
              leaf hairpin-ipv4-bytes {
                type yang:zero-based-counter64;
                description “IPv4 packets locally routed between two CEs
                  (hairpinned).“;
              }

             leaf hairpin-ipv4-packets {
                type yang:zero-based-counter64;
                description “IPv4 bytes locally routed between two CEs
                  (hairpinned).“;
              }

             leaf active-softwire-num {
                type uint32;
                description
                  “The number of currently active softwires on the
                  lw4over6 (binding) instance.“;
              }
            }

I’ve also noticed that config false hasn’t been set for the algorithm traffic stats. I’ll fix that as well.

>    dropped IPv4 bytes as a whole.

[if - will fix]

>    or the other should probably be chosen.

[if - Will fix]

> 4. The type of "icmpv6-errors-rate" is "uint16".  This is probably too

[if - I’ll up it to uint32]

> 
> Regards,
> 
> Andy
> 
> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires