Subject: Re: [Softwires] Work Group Last call for draft-ietf-softwire-dslite-yang-07 - Ends 9th Nov

From: Ian Farrer <[email-masked]>
Date: Fri, 10 Nov 2017 10:15:43 +0100

Hi,

Here’s my review of v07 of the draft.

Cheers,
Ian

Overall comments:
o1. There is a lot of duplication of text between the descriptions given in Section 2 and the YANG model’s description fields. This makes the document less readable, and I don’t see it adds anything.
As much of the text in section 2 is taken directly from the RFCs that originally defined the functions, it would be better to remove the section 2 descriptions where not necessary (i.e. only described/enumerate the important nodes in reference to how they are used/relate to other models, and have pointers to the original RFC/section where more detail is necessary).
Keeping the more verbose descriptions in the model make sense as these are the ones that most users will actually see once published.

Model comments:
m1. v6-v4-dscp-preservation - deals with whether the DCSP of the incoming packet will be copied to the header of the outgoing packet or not.
Would this be better implemented as a feature in the model, as this would allow the use in the mapping entry to be made conditional (with if-feature) under the mapping-entry augment. 

m2. Recommendation 3 of RFC7785 describes a rate limit for how often a source address can be migrated. The model doesn’t give any way of configuring this. Also, if there is a rate limit on the source address change rate, a timestamp as to when the b4-ipv6-address was updated would be useful.

Gramatical Comments:
Section 1
g1. s/and adopts Network Management Datastore Architecture (NMDA)./and adopts the Network Management Datastore Architecture (NMDA)./

Section 2
g2. s/ The tunnel MTU to avoid fragmentation/The tunnel MTU, used to avoid fragmentation/

g3. The bullet point starting ‘The IPv4 DSCP marking of the IPv4 packet’ finishes with the following sentence
' This information can be used by the AFTR fro enforcing the poi’. Unsure what this is meant to say.

Section 7
g4. s/eraly ynagdoctors/early yangdoctors/

g5. s/comments/comments./

> On 26. Oct 2017, at 09:09, Ian Farrer <[email-masked]> wrote:
> 
> Hi,
> 
> The authors believe that draft-ietf-softwire-dslite-yang-07 is now ready for advancement. This email marks the start of a 2 week work group last call for the draft.
> 
> Please send your comments, either for or against, to the softwire WG mailing list. The WGLC will end on Nov. 9, 2017.
> 
> Thanks,
> 
> Yong & Ian
> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires

---

From: <[email-masked]>
Date: Fri, 10 Nov 2017 10:23:01 +0000

Hi Ian, 

Thank you for the review. 

All your comments are addressed. Please check the version available at: https://github.com/boucadair/draft-ietf-softwire-dslite-yang 

See inline.

Cheers,
Med

> -----Message d'origine-----
> De : Softwires [mailto:[email-masked]] De la part de Ian
> Farrer
> Envoyé : vendredi 10 novembre 2017 10:16
> À : Softwires list
> Cc : [email-masked]
> Objet : Re: [Softwires] Work Group Last call for draft-ietf-softwire-
> dslite-yang-07 - Ends 9th Nov
> 
> Hi,
> 
> o1. There is a lot of duplication of text between the descriptions given
> in Section 2 and the YANG model’s description fields. This makes the
> document less readable, and I don’t see it adds anything.
> As much of the text in section 2 is taken directly from the RFCs that
> originally defined the functions, it would be better to remove the section
> 2 descriptions where not necessary (i.e. only described/enumerate the
> important nodes in reference to how they are used/relate to other models,
> and have pointers to the original RFC/section where more detail is
> necessary).
> Keeping the more verbose descriptions in the model make sense as these are
> the ones that most users will actually see once published.

[Med] Done. 

> 
> 
> Model comments:
> m1. v6-v4-dscp-preservation - deals with whether the DCSP of the incoming
> packet will be copied to the header of the outgoing packet or not.
> Would this be better implemented as a feature in the model, as this would
> allow the use in the mapping entry to be made conditional (with if-
> feature) under the mapping-entry augment.

[Med] This is better handled by adding this statement:

    when "/if:interfaces/if:interface/dslite-aftr:v6-v4-dscp-preservation='true'";

> 
> m2. Recommendation 3 of RFC7785 describes a rate limit for how often a
> source address can be migrated. The model doesn’t give any way of
> configuring this. Also, if there is a rate limit on the source address
> change rate, a timestamp as to when the b4-ipv6-address was updated would
> be useful.
> 

[Med] Good point. Updated accordingly. 

> 
> Gramatical Comments:
> Section 1
> g1. s/and adopts Network Management Datastore Architecture (NMDA)./and
> adopts the Network Management Datastore Architecture (NMDA)./
> 
> 
> Section 2

[Med] Fixed all those. 

> > The authors believe that draft-ietf-softwire-dslite-yang-07 is now ready
> for advancement. This email marks the start of a 2 week work group last
> call for the draft.
> >
> > Please send your comments, either for or against, to the softwire WG
> mailing list. The WGLC will end on Nov. 9, 2017.
> >
> > Thanks,
> >
> > Yong & Ian

---

From: Ian Farrer <[email-masked]>
Date: Fri, 10 Nov 2017 12:42:31 +0100

Hi Med,

>    when "/if:interfaces/if:interface/dslite-aftr:v6-v4-dscp-preservation='true'";

Yes, that works.

Cheers,
Ian

---

From: <[email-masked]>
Date: Fri, 10 Nov 2017 12:17:31 +0000

Re-,

OK. The updated version with your comments will be submitted next Monday.

Cheers,
Med

De : Ian Farrer [mailto:[email-masked]]
Envoyé : vendredi 10 novembre 2017 12:43
À : BOUCADAIR Mohamed IMT/OLN
Cc : Softwires list; [email-masked]
Objet : Re: [Softwires] Work Group Last call for draft-ietf-softwire-dslite-yang-07 - Ends 9th Nov

Hi Med,

Model comments:

Yes, that works.

Cheers,
Ian

---

From: Ian Farrer <[email-masked]>
Date: Mon, 13 Nov 2017 11:35:06 +0800

Hi Med,

One small additional change (I don’t know why I haven’t seen this before) - Please can you rename the document 'YANG Data Modules for Dual-Stack Lite’ to be inline with the naming of other related RFCs.

Thanks,
Ian

> On 10. Nov 2017, at 20:17, <[email-masked]> <[email-masked]> wrote:
> 
> Re-,
>

---

From: <[email-masked]>
Date: Mon, 13 Nov 2017 07:26:23 +0000

Hi Ian,

Fixed.

Thanks.
Cheers,
Med

Envoyé : lundi 13 novembre 2017 04:35

Hi Med,

Thanks,
Ian

On 10. Nov 2017, at 20:17, <[email-masked]<mailto:[email-masked]>> <[email-masked]<mailto:[email-masked]>> wrote:

Re-,

Cheers,
Med

Cc : Softwires list; [email-masked]<mailto:[email-masked]>

Hi Med,

Model comments:

Yes, that works.

Cheers,
Ian