Subject: Re: [Softwires] WGLC for draft-ietf-softwire-iftunnel-01

From: [email-masked]
Date: Tue, 8 Jan 2019 17:48:01 +0100

HI Yong,

Sorry for the late response. I’m still catching up after the holidays…

As a co-author, I support this document progressing. As you mention below, separating out the iftunnels module from draft-ietf-softwire-yang into a new draft was requested during the IANA review.  meaning that draft-ietf-softwire-yang (currently with the IESG) now has a normative reference to this draft.

Regarding the draft itself, the iftunnel module itself has already been through the final WGLC for draft-ietf-softwire-yang. As it models the IANA tunnelType Definitions registry (https://www.iana.org/assignments/smi-numbers/smi-numbers.xhtml#smi-numbers-6 <https://www.iana.org/assignments/smi-numbers/smi-numbers.xhtml#smi-numbers-6>), we’ve tried to keep the format in line with other, similar documents with YANG modules for other IANA registries (e.g. RFC7224).

Thanks,
Ian

> On 19. Dec 2018, at 08:26, Yong Cui <[email-masked]> wrote:
> 
> Dear all,
> 
> There were the following progress on Softwire YANG and related work during the past couple of months:
> 	• draft-ietf-softwire-yang completed WGLC
> 	• During expert review, a YANG module for the iana-iftunnel registry was requested as the softwire module needs to reference it.
> 	• draft-ietf-softwire-yang was updated to include this module and Sheng ran a WGLC on the new content. This passed without comment.
> 	• During IANA review, it was requested that the iana-iftunnel YANG module was put into a separate document.
> 	• draft-ietf-softwire-yang was updated, removing the iana-iftunnel YANG module, and draft-ietf-softwire-iftunnel was published containing just the module (it was posted as a WG doc as the content etc. is already under the scope of draft-ietf-softwire-yang)
> 
> So now, we’d like to issue a WGLC for draft-ietf-softwire-iftunnel-01. 
> https://datatracker.ietf.org/doc/draft-ietf-softwire-iftunnel/
> 
> Considering the coming Christmas and New Year, I would extend the WGLC to 3 weeks, i.e. Dec. 19, 2018 - Jan. 9, 2019. Please send your comments to our softwire mailing list, including your support or concerns.
> 
> 
> Merry Christmas and Happy New Year!
> 
> Yong & Ian
>

---

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Wed, 9 Jan 2019 05:55:56 +0000

Support (as a co-author).

--
Cheers,
Rajiv

From: Softwires <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Date: Tuesday, January 8, 2019 at 11:48 AM
To: Yong Cui <[email-masked]>
Cc: Softwires-wg list <[email-masked]>
Subject: Re: [Softwires] WGLC for draft-ietf-softwire-iftunnel-01

HI Yong,

Regarding the draft itself, the iftunnel module itself has already been through the final WGLC for draft-ietf-softwire-yang. As it models the IANA tunnelType Definitions registry (https://www.iana.org/assignments/smi-numbers/smi-numbers.xhtml#smi-numbers-6), we’ve tried to keep the format in line with other, similar documents with YANG modules for other IANA registries (e.g. RFC7224).

Thanks,
Ian

On 19. Dec 2018, at 08:26, Yong Cui <[email-masked]<mailto:[email-masked]>> wrote:

Dear all,

Yong & Ian

---

From: [email-masked]
Date: Thu, 10 Jan 2019 09:13:58 +0100

Hi Yong,

Further to my previous email.

During the review of draft-ietf-softwire-yang, there is a comment about following the published format for the Security Considerations section of a document containing a YANG module. I wasn’t previously aware of this:

https://trac.ietf.org/trac/ops/wiki/yang-security-guidelines <https://trac.ietf.org/trac/ops/wiki/yang-security-guidelines>

As this comment will also be applicable to draft-ietf-softwire-iftunnel, I think we need to rewrite the Security Considerations section accordingly.

Thanks,
Ian

> On 8. Jan 2019, at 17:48, [email-masked] wrote:
> 
> HI Yong,
> 
>> On 19. Dec 2018, at 08:26, Yong Cui <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Dear all,
>> 
>> https://datatracker.ietf.org/doc/draft-ietf-softwire-iftunnel/ <https://datatracker.ietf.org/doc/draft-ietf-softwire-iftunnel/>
>> 
> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires

---

From: <[email-masked]>
Date: Thu, 10 Jan 2019 10:17:10 +0000

Hi all,

-02 will also implement a change requested by the smi expert to cite the RFCs defining the tunneling techniques instead of pointing to 4087. An action will be requested to IANA to update the table available at https://www.iana.org/assignments/smi-numbers/smi-numbers.xhtml#smi-numbers-6.

Cheers,
Med

De : Softwires [mailto:[email-masked]] De la part de [email-masked]
Envoyé : jeudi 10 janvier 2019 09:14
À : Yong Cui
Cc : Softwires-wg
Objet : Re: [Softwires] WGLC for draft-ietf-softwire-iftunnel-01

Hi Yong,

https://trac.ietf.org/trac/ops/wiki/yang-security-guidelines

Thanks,
Ian

On 8. Jan 2019, at 17:48, [email-masked]<mailto:[email-masked]> wrote:

HI Yong,

Thanks,
Ian

Dear all,

Yong & Ian

_______________________________________________
Softwires mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/softwires