Subject: Re: [lamps] CMPv2/LightWeiight-CMP profile over CoAP transport

From: Mohit Sahni <[email-masked]>
Date: Mon, 13 Jul 2020 15:06:03 -0700

Hi All
I have published the first draft for the document here is the link to the
draft
https://datatracker.ietf.org/doc/draft-msahni-ace-cmpv2-coap-transport/ .
As Jim mentioned that adopting this might need change in the ACE WG charter
can we please discuss that in IETF 108 ?

Thanks
Mohit

On Sat, Jun 6, 2020 at 10:01 AM Mohit Sahni <[email-masked]> wrote:

> Hi Jim,
> Thanks for the feedback. I will go over the EST document and update
> sections around DTLS and proxying and address your other comments. Once
> ready, I will post the draft in ACE WG.
>
> Regards,
> Mohit
>
>
> On Fri, Jun 5, 2020 at 7:19 PM Jim Schaad <[email-masked]> wrote:
>
>> I suppose that this could go into the ACE working group, but it will
>> require a charter change to do so.
>>
>>
>>
>> I would suggest that you review the EST document with special attention
>> to the sections on DTLS and proxying.  It would also help to have some idea
>> of guidance for when coap or coaps is going to be used.  I am not sure that
>> this strongly exists in CMP as my very vague memory was that it was assumed
>> that all transactions where going to be done over TLS with server
>> validation as a minimum.
>>
>>
>>
>> Jim
>>
>>
>>
>>
>>
>> *From:* Spasm <[email-masked]> *On Behalf Of *Mohit Sahni
>> *Sent:* Thursday, June 4, 2020 10:49 PM
>> *To:* Tomas Gustavsson <[email-masked]>
>> *Cc:* LAMPS WG <[email-masked]>
>> *Subject:* Re: [lamps] CMPv2/LightWeiight-CMP profile over CoAP transport
>>
>>
>>
>> Hi Tomas
>>
>> Thanks for the feedback, I was trying to write it in a way so that it can
>> work for both CMPv2 and LightWeight CMP, I have noted it your feedback and
>> I will try to make it more clear.
>>
>>
>>
>> -Mohit
>>
>>
>>
>> On Thu, Jun 4, 2020 at 10:40 PM Tomas Gustavsson <tomas@primekey..se
>> <[email-masked]>> wrote:
>>
>> Hi,
>>
>> I noticed that section 4, Proxy Support (good section btw), mentions
>> Announcement messages. These are excluded from the Lightweight
>> specification. Since the LIghtweight specification is mentioned in the
>> beginning, I'm not sure if that's worth mentioning here?
>>
>> Cheers,
>> Tomas
>>
>> On 2020-06-04 20:03, Mohit Sahni wrote:
>> > Hi Jim,
>> > There were some discussions about using CoAP as transport for the
>> > Lightweight CMP profile in the last LAMPS WG meeting. After having some
>> > discussions with Hendrik, David, and Andreas I have written an
>> > internet-draft for using CoAP as transport for CMPv2 / Light Weight CMP
>> > Profile. If I am not mistaken, the recommendation was to present this
>> > draft to ACE WG for the review instead of Lamps group, can you please
>> > advice on that?
>> >
>> > Here is the link to the internet-draft that I wrote
>> > https://www.ietf.org/id/draft-msahni-tbd-cmpv2-coap-transport-00.txt
>> >
>> > Thanks
>> > Mohit
>> >
>> > _______________________________________________
>> > Spasm mailing list
>> > [email-masked]
>> > https://www.ietf.org/mailman/listinfo/spasm
>> >
>>
>> _______________________________________________
>> Spasm mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/spasm
>>
>>

---

From: "Brockhaus, Hendrik" <[email-masked]>
Date: Tue, 14 Jul 2020 05:53:57 +0000

Mohit
Thanks for the update. I'm looking forward to the discussion in ACE.

Hendrik

Von: Mohit Sahni <[email-masked]> 
Gesendet: Dienstag, 14. Juli 2020 00:06

Hi All
I have published the first draft for the document here is the link to the draft https://datatracker.ietf.org/doc/draft-msahni-ace-cmpv2-coap-transport/. As Jim mentioned that adopting this might need change in the ACE WG charter can we please discuss that in IETF 108 ?

Thanks
Mohit 

On Sat, Jun 6, 2020 at 10:01 AM Mohit Sahni <mailto:[email-masked]> wrote:
Hi Jim,
Thanks for the feedback. I will go over the EST document and update sections around DTLS and proxying and address your other comments. Once ready, I will post the draft in ACE WG.

Regards,
Mohit 

On Fri, Jun 5, 2020 at 7:19 PM Jim Schaad <mailto:[email-masked]> wrote:
I suppose that this could go into the ACE working group, but it will require a charter change to do so.  
 
I would suggest that you review the EST document with special attention to the sections on DTLS and proxying.  It would also help to have some idea of guidance for when coap or coaps is going to be used.  I am not sure that this strongly exists in CMP as my very vague memory was that it was assumed that all transactions where going to be done over TLS with server validation as a minimum.
 
Jim

From: Spasm <mailto:[email-masked]> On Behalf Of Mohit Sahni
Sent: Thursday, June 4, 2020 10:49 PM
To: Tomas Gustavsson <mailto:[email-masked]>
Cc: LAMPS WG <mailto:[email-masked]>
Subject: Re: [lamps] CMPv2/LightWeiight-CMP profile over CoAP transport
 
Hi Tomas
Thanks for the feedback, I was trying to write it in a way so that it can work for both CMPv2 and LightWeight CMP, I have noted it your feedback and I will try to make it more clear.
 
-Mohit 
 
On Thu, Jun 4, 2020 at 10:40 PM Tomas Gustavsson <mailto:[email-masked]> wrote:
Hi,

Cheers,
Tomas

On 2020-06-04 20:03, Mohit Sahni wrote:
> https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fid%2Fdraft-msahni-tbd-cmpv2-coap-transport-00.txt&data=02%7C01%7Chendrik.brockhaus%40siemens.com%7C7553d8af26034360311208d82778f6a0%7C38ae3bcd95794fd4addab42e1495d55a%7C1%7C0%7C637302747769875510&sdata=%2BUhTMJjgH8J3gVVyVa8eYZe0cNO8AKZNK8Axi5RZAgc%3D&reserved=0 
> 
> Thanks
> Mohit  
> 
> mailto:[email-masked]
> https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fspasm&data=02%7C01%7Chendrik.brockhaus%40siemens.com%7C7553d8af26034360311208d82778f6a0%7C38ae3bcd95794fd4addab42e1495d55a%7C1%7C0%7C637302747769885467&sdata=SBDJa6P7%2Fd5OSQ4wnd8o%2FuO2PJg5esYnXtKmHlBcTao%3D&reserved=0
> 

_______________________________________________
Spasm mailing list
mailto:[email-masked]
https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fspasm&data=02%7C01%7Chendrik.brockhaus%40siemens.com%7C7553d8af26034360311208d82778f6a0%7C38ae3bcd95794fd4addab42e1495d55a%7C1%7C0%7C637302747769890437&sdata=h5iBuM%2BxucjGNAESzoAIQ26To55izeklFeuYGUkXYfc%3D&reserved=0