Subject: [lamps] Which S/MIME Clients have issues with current S/MIME Header Protection?

From: Bernie Hoeneisen <[email-masked]>
Date: Thu, 29 Oct 2020 18:23:08 +0100 (CET)

Hi!

One reason why we are working on Header Protection is that there have been 
reports that S/MIME Clients are not rendering Header Protected messages 
correctly. I was told that some clients e.g. display it as fowarded 
message and do not show the content at all or garbled.
However, so far we have been unable to reproduce that there is (still) a 
problem with S/MIME clients applying the currently standardized S/MIME.

May I ask those who experienced such issues to let us know which S/MIME 
clients were effected and how those (mis-)rendered the message?

Our intension is to research and better understand the extent of the 
problem, to help the WG to make an informed decision on whether 
or not we should change the MIME format for Header Protection in S/MIME.

In addition, we'd be also interested in the same information regarding 
PGP/MIME.

Looking forward to your answers!

cheers
  Bernie

--

http://ucom.ch/
Modern Telephony Solutions and Tech Consulting for Internet Technology

---

From: Russ Housley <[email-masked]>
Date: Thu, 29 Oct 2020 13:48:20 -0400

As part of the DKG experiment, I saw the rendering as a attached .eml file.

Russ

> On Oct 29, 2020, at 1:23 PM, Bernie Hoeneisen <[email-masked]> wrote:
> 
> Hi!
> 
> One reason why we are working on Header Protection is that there have been reports that S/MIME Clients are not rendering Header Protected messages correctly. I was told that some clients e.g. display it as fowarded message and do not show the content at all or garbled.
> However, so far we have been unable to reproduce that there is (still) a problem with S/MIME clients applying the currently standardized S/MIME.
> 
> May I ask those who experienced such issues to let us know which S/MIME clients were effected and how those (mis-)rendered the message?
> 
> Our intension is to research and better understand the extent of the problem, to help the WG to make an informed decision on whether or not we should change the MIME format for Header Protection in S/MIME.
> 
> In addition, we'd be also interested in the same information regarding PGP/MIME.
> 
> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spasm

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 29 Oct 2020 17:57:08 +0000

> As part of the DKG experiment, I saw the rendering as a attached .eml file.
At least Thunderbird does this. I need to check iOS mail and Outlook.

---

From: Russ Housley <[email-masked]>
Date: Thu, 29 Oct 2020 13:58:42 -0400

> On Oct 29, 2020, at 1:57 PM, Alexey Melnikov <[email-masked]> wrote:
> 

I was testing Mail.app and MailMate on Mac.

Russ

---

From: Bernie Hoeneisen <[email-masked]>
Date: Thu, 29 Oct 2020 20:09:11 +0100 (CET)

Russ,

> As part of the DKG experiment, I saw the rendering as a attached .eml file.

Just for clarification: Did this happen with some example(s) DKG 
documented in https://tools.ietf.org/id/draft-autocrypt-lamps-protected-headers-02.html 
and provided as read-only IMAP folder? Or did you try other examples?

cheers,
  Bernie

---

From: Russ Housley <[email-masked]>
Date: Thu, 29 Oct 2020 15:27:11 -0400

Bernie:

> Just for clarification: Did this happen with some example(s) DKG documented in https://tools.ietf.org/id/draft-autocrypt-lamps-protected-headers-02.html and provided as read-only IMAP folder? Or did you try other examples?

I did the testing with the messages in the draft.

Russ