Subject: [lamps] I-D Action: draft-ietf-lamps-lightweight-cmp-profile-03.txt

From: [email-masked]
Date: Fri, 02 Oct 2020 08:46:02 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Limited Additional Mechanisms for PKIX and SMIME WG of the IETF.

        Title           : Lightweight CMP Profile
        Authors         : Hendrik Brockhaus
                          Steffen Fries
                          David von Oheimb
	Filename        : draft-ietf-lamps-lightweight-cmp-profile-03.txt
	Pages           : 81
	Date            : 2020-10-02

Abstract:
   The goal of this document is to facilitate interoperability and
   automation by profiling the Certificate Management Protocol (CMP)
   version 2, the related Certificate Request Message Format (CRMF)
   version 2, and the HTTP Transfer for the Certificate Management
   Protocol.  It specifies a subset of CMP and CRMF focusing on typical
   uses cases relevant for managing certificates of devices in many
   industrial and IoT scenarios.  To limit the overhead of certificate
   management for more constrained devices only the most crucial types
   of operations are specified as mandatory.  To foster interoperability
   in more complex scenarios, other types of operations are specified as
   recommended or optional.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-lamps-lightweight-cmp-profile/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-lamps-lightweight-cmp-profile-03
https://datatracker.ietf.org/doc/html/draft-ietf-lamps-lightweight-cmp-profile-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-lamps-lightweight-cmp-profile-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Brockhaus, Hendrik" <[email-masked]>
Date: Fri, 2 Oct 2020 15:52:22 +0000

I submitted an update of the Lightweight CMP Profile today.

Theses are the main changes from version 02 -> 03:

   o  Updated the interoperability with [UNISIG-Subset137] in  Section 1.4.
   o  Changed Section 2.3 to a tabular layout to enhanced readability
   o  Added a ToDo to section 3.1 on aligning with the CMP Algorithms  draft that will be set up as decided in IETF 108
   o  Updated section 4.1.6 to add the AsymmetricKey Package structure  to transport a newly generated private key as decided in IETF 108
   o  Added a ToDo to section 4.1.7 on required review of the nonce  handling in case an offline LRA responds and not forwards the  pollReq messages
   o  Updated Section 4 due to the definition of the new ITAV OIDs in  CMP Updates
   o  Updated Section 4.4.4 to utilize controls instead of rsaKeyLen  (see thread "dtaft-ietf-lamps-cmp-updates and rsaKeyLen")
   o  Deleted the section on definition and discovery of HTTP URIs and  copied the text to the HTTP transport section and to CMP Updates  section 3.2
   o  Added some explanation to Section 5.1.2 and Section 5.1.3 on using  nested messages when a protection by the RA is required.
   o  Deleted the section on HTTP URI definition and discovery as some  content was moved to CMP Updates.  The rest of the content was  moved back to the HTTP transport section
   o  Deleted the ASN.1 module after moving the new OIDs id-it-caCerts,  id-it-rootCaKeyUpdate, and id-it-certReqTemplate to CMP Updates
   o  Minor changes in wording and addition of some open ToDos

Any feedback is welcome.

Hendrik

> -----Ursprüngliche Nachricht-----
> Von: Spasm <[email-masked]> Im Auftrag von [email-masked]
> Gesendet: Freitag, 2. Oktober 2020 17:46
> An: [email-masked]
> Cc: [email-masked]
> Betreff: [lamps] I-D Action: draft-ietf-lamps-lightweight-cmp-profile-03.txt
> 
> 
> https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatrack
> er.ietf.org%2Fdoc%2Fdraft-ietf-lamps-lightweight-cmp-
> profile%2F&amp;data=02%7C01%7Chendrik.brockhaus%40siemens.com%7C7e
> b40ee17fe9488b36b108d866ea77e1%7C38ae3bcd95794fd4addab42e1495d55a
> %7C1%7C0%7C637372504504442483&amp;sdata=6U2m8wV00wjvzjCbxMjz7Rj
> b%2B9Mdu8CaDh5vi70dR%2Bw%3D&amp;reserved=0
> 
> https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.
> org%2Fhtml%2Fdraft-ietf-lamps-lightweight-cmp-profile-
> 03&amp;data=02%7C01%7Chendrik.brockhaus%40siemens.com%7C7eb40ee17
> fe9488b36b108d866ea77e1%7C38ae3bcd95794fd4addab42e1495d55a%7C1%7
> C0%7C637372504504442483&amp;sdata=vcJFGESjAc%2B3NGhenVSeb7js36z%2
> FVUyUjbbGi%2FrdiBg%3D&amp;reserved=0
> https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatrack
> er.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-lamps-lightweight-cmp-profile-
> 03&amp;data=02%7C01%7Chendrik.brockhaus%40siemens.com%7C7eb40ee17
> fe9488b36b108d866ea77e1%7C38ae3bcd95794fd4addab42e1495d55a%7C1%7
> C0%7C637372504504442483&amp;sdata=vZ7CQCDIUh1tx0SMgcgyfff5GVc4kK
> AMM5AAIC4hw6M%3D&amp;reserved=0
> 
> https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.
> org%2Frfcdiff%3Furl2%3Ddraft-ietf-lamps-lightweight-cmp-profile-
> 03&amp;data=02%7C01%7Chendrik.brockhaus%40siemens.com%7C7eb40ee17
> fe9488b36b108d866ea77e1%7C38ae3bcd95794fd4addab42e1495d55a%7C1%7
> C0%7C637372504504442483&amp;sdata=80YLbaTQV3abMEi93td9T7BWzdXPr
> T08nrqoEozjhOo%3D&amp;reserved=0
> 
> 
> https://eur01.safelinks.protection.outlook.com/?url=ftp%3A%2F%2Fftp.ietf.org%
> 2Finternet-
> drafts%2F&amp;data=02%7C01%7Chendrik.brockhaus%40siemens.com%7C7eb
> 40ee17fe9488b36b108d866ea77e1%7C38ae3bcd95794fd4addab42e1495d55a
> %7C1%7C0%7C637372504504442483&amp;sdata=ER21ZTR45lNcvZ47S3DQFny
> gH%2BozhLNY3N34y7UKSKg%3D&amp;reserved=0
> 
> 
> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.
> org%2Fmailman%2Flistinfo%2Fspasm&amp;data=02%7C01%7Chendrik.brockha
> us%40siemens.com%7C7eb40ee17fe9488b36b108d866ea77e1%7C38ae3bcd95
> 794fd4addab42e1495d55a%7C1%7C0%7C637372504504442483&amp;sdata=b
> uASe6QRF5okMmV%2FwfxUa8%2Bl%2B0qql5dMMBKS5XEW0wQ%3D&amp;res
> erved=0