Subject: [lamps] draft-housley-lamps-crmf-update-algs

From: Russ Housley <[email-masked]>
Date: Sun, 25 Oct 2020 13:22:31 -0400

https://datatracker.ietf.org/doc/draft-housley-lamps-crmf-update-algs/

In order for the CMP algorithm document to drop SHA-1, this needs to happen too.  I think it is super straightforward.

The only real point to discuss in the SHOULD in the MAC algorithm section.  The choices are:
- Stick with AES-CMAC,
- Pick some other MAC (perhaps AES-GMAC),
- Drop the SHOULD altogether.

Once this question is resolved, I will ask Tim to make a call for adoption.

Russ

---

From: Sean Turner <[email-masked]>
Date: Thu, 29 Oct 2020 17:25:40 -0400

I’m no cryptographer, but it seems like we’re moving away from block encryption algorithms so maybe we should just adopt AES-GMAC? The caveat here is that I suspect AES-CMAC is just fine as a MAC algorithm (or somebody will correct me). But, I also feel like nobody is actually not going to use HMAC-SHA256. Putting that all together, I guess my order of preference is:

1. AES-GCM
2. drop the SHOULD
3. AES-CMAC

spt

> On Oct 25, 2020, at 13:22, Russ Housley <[email-masked]> wrote:
> 
> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spasm

---

From: Russ Housley <[email-masked]>
Date: Thu, 29 Oct 2020 18:12:10 -0400

For 1, you meant AES-GMAC, right?

> On Oct 29, 2020, at 5:25 PM, Sean Turner <[email-masked]> wrote:
>

---

From: Sean Turner <[email-masked]>
Date: Fri, 30 Oct 2020 09:26:32 -0400

Yes AES-GMAC. sorry I was think gets used so that’s what I wrote.

spt

Sent from my iPhone

> On Oct 29, 2020, at 18:12, Russ Housley <[email-masked]> wrote:
>

---

From: Russ Housley <[email-masked]>
Date: Sat, 31 Oct 2020 15:46:38 -0400

Sean:

Are you aware of an OID being assigned for AES-GMAC?  I just did a Google search and did not find one.

Russ