Subject: [lamps] DRAFT Liaison Statement to ISO/TC 154

From: Russ Housley <[email-masked]>
Date: Sat, 9 Jan 2021 13:23:31 -0500

I assume that everyone saw the note from the IAB Chair, Mirja Kühlewind.  I suggest that the LAMPS WG ask the IAB to send the following liaison statement.  We're asking the IAB to do this because the IETF does not have a liaison relationship with ISO/TC 154.  Please review and comment.

Russ

= = = = = = = = =

FROM: IAB
TO: ISO/TC 154

The Internet Architecture Board would like to make sure that you are aware of the recent work by the at IETF LAMPS Working group (https://tools.ietf.org/wg/lamps/) that lead to RFC 8954 (https://www.rfc-editor..org/rfc/rfc8954.txt) that updates RFC 6960 (https://www.rfc-editor.org/rfc/rfc6960.txt). RFC 8954 limits the size of the OCSP Nonce extension to 32 octets to make the OCSP transactions more secure. 

We understand that RFC 8954 may have a conflict with the way OCSP Nonce extension is proposed to be used in ISO 14533-4 and perhaps some other work which we are not aware of.  

We had a discussion about the use case in the LAMPS working group recently.  Based on how the OCSP nonce extension is used in the industry, it was recommended that a new OCSP extension should be used for the purpose of capturing OCSP response for long term validation of the signed documents.

We recognize that the IETF does not have a liaison relationship with ISO/TC 154; however, the IETF LAMPS working group is willing to work with you to resolve this conflict in the best possible way.

---

From: "Salz, Rich" <[email-masked]>
Date: Sat, 9 Jan 2021 18:26:08 +0000

>    I assume that everyone saw the note from the IAB Chair, Mirja Kühlewind.  I suggest that the LAMPS WG ask the IAB to send the following liaison statement.  We're asking the IAB to do this becaus…

Looks good, ship it.

---

From: Jonathan Hammell <[email-masked]>
Date: Sun, 10 Jan 2021 17:15:05 -0500

I support this constructive approach.

Jonathan

On Sat, Jan 9, 2021 at 1:23 PM Russ Housley <[email-masked]> wrote:
> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spasm

---

From: Russ Housley <[email-masked]>
Date: Wed, 27 Jan 2021 10:45:39 -0500

Dear IAB:

The LAMPS WG has been discussing the incompatibility between ISO 14533-4 and OCSP with the update in RFC 8954.  We would like to make sure that ISO/TC 154, the technical committee that produced ISO 14533-4, is aware of the incompatibility.  To that end, we ask the IAB to send the attacked Liaison Statement.  We think that the IAB should send it because the IETF doe not have a liaison relationship with ISO/TC 154.

On behalf of the LAMPS WG,
 Russ

== == == == ==

FROM: IAB
TO: ISO/TC 154

We recognize that the IETF does not have a liaison relationship with ISO/TC 154; however, the IETF LAMPS working group would like to work with you to resolve this conflict in the best possible way.

---

From: Mirja Kuehlewind <[email-masked]>
Date: Thu, 28 Jan 2021 15:51:18 +0100

Hi Russ, hi all,

The IAB would be ready to send this out.

There was one wording proposal by one of the IAB members:

OLD:

NEW:

We understand that the way OCSP Nonce extension is proposed to be used in ISO 14533-4 may conflict with RFC 8954. This may perhaps be true for other work that we are unaware of.

Please let me know if this editorial change is okay for you/the lamps group!

Do you already know who would be the right contact point at ISO/TC154? Is there a group list we should send this to? Or who would otherwise be the responsible contract person for TC 154?

Best,
Mirja

> On 27. Jan 2021, at 16:45, Russ Housley <[email-masked]> wrote:
> 
> Dear IAB:
>

---

From: Russ Housley <[email-masked]>
Date: Thu, 28 Jan 2021 11:17:07 -0500

Mirja:

I do not agree.  ISO 14533-4 is not a draft; it has already been approved.  So, "proposed" is not the right word.

Russ

> On Jan 28, 2021, at 9:51 AM, Mirja Kuehlewind <[email-masked]> wrote:
> 
> Hi Russ, hi all,
>

---

From: Ben Campbell <[email-masked]>
Date: Thu, 28 Jan 2021 10:27:51 -0600

Hi Russ,

The phrase “is proposed to be used” was from the original language. That being said, should that just change to “is used”?

Thanks!

Ben.

> On Jan 28, 2021, at 10:17 AM, Russ Housley <[email-masked]> wrote:
> 
> Mirja:
>

---

From: Russ Housley <[email-masked]>
Date: Thu, 28 Jan 2021 11:44:46 -0500

Ben:

Yes, that is better.  However, it is in conflict because the use exceeds 32 octets, so I suggest:

> We understand that the way OCSP Nonce extension is used in ISO 14533-4 conflicts with RFC 8954. This may perhaps be true for other work that we are unaware of.

Russ

> On Jan 28, 2021, at 11:27 AM, Ben Campbell <[email-masked]> wrote:
> 
> Hi Russ,
>

---

From: Ben Campbell <[email-masked]>
Date: Thu, 28 Jan 2021 11:00:43 -0600

Works for me.

Ben.

> On Jan 28, 2021, at 10:44 AM, Russ Housley <[email-masked]> wrote:
> 
> Ben:
>