Subject: [lamps] I-D Action: draft-ietf-lamps-cmp-algorithms-04.txt

From: [email-masked]
Date: Wed, 05 May 2021 08:37:36 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Limited Additional Mechanisms for PKIX and SMIME WG of the IETF.

        Title           : Certificate Management Protocol (CMP) Algorithms
        Authors         : Hendrik Brockhaus
                          Hans Aschauer
                          Mike Ounsworth
                          John Gray
	Filename        : draft-ietf-lamps-cmp-algorithms-04.txt
	Pages           : 29
	Date            : 2021-05-05

Abstract:
   This document describes the conventions for using concrete
   cryptographic algorithms with the Certificate Management Protocol
   (CMP).  CMP is used to enroll and further manage the lifecycle of
   X.509 certificates.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-lamps-cmp-algorithms/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-ietf-lamps-cmp-algorithms-04.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-lamps-cmp-algorithms-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Brockhaus, Hendrik" <[email-masked]>
Date: Wed, 5 May 2021 15:42:17 +0000

I just submitted a new version of CMP Algorithms with the following changes.

   *  Added John Gray to the list of authors due to his extensive
      support and valuable feedback
   *  Added some clarification of the use AES-GMAC to Section 6.2.1
   *  Extended the guidance on how to select a set of algorithms in
      Section 7 and deleted former Section 7.1
   *  Deleted the algorithms mandatory to support in Section 7.2 as
      discussed at IETF 110
   *  Extended the Security considerations in Section 9
   *  Minor changes in wording

The authors consider the draft quite complete and look forward to your review. Any feedback is welcome.

Hendrik

> Von: Spasm <[email-masked]> Im Auftrag von [email-masked]
> 
> https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatrac
> ker.ietf.org%2Fdoc%2Fdraft-ietf-lamps-cmp-
> algorithms%2F&amp;data=04%7C01%7Chendrik.brockhaus%40siemens.com%7
> C8323fe39a1ca415e0ba808d90fdbda54%7C38ae3bcd95794fd4addab42e1495d
> 55a%7C1%7C0%7C637558259203068469%7CUnknown%7CTWFpbGZsb3d8eyJ
> WIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C
> 1000&amp;sdata=0QUABRJRFEWBwKEm7FonvLPo%2B3Z4p3O1f32%2BfZllOd0
> %3D&amp;reserved=0
> 
> https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf
> .org%2Farchive%2Fid%2Fdraft-ietf-lamps-cmp-algorithms-
> 04.html&amp;data=04%7C01%7Chendrik.brockhaus%40siemens.com%7C8323f
> e39a1ca415e0ba808d90fdbda54%7C38ae3bcd95794fd4addab42e1495d55a%7C
> 1%7C0%7C637558259203068469%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4
> wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&am
> p;sdata=rzjjUQ2JwZ6kKZqfGqYoYZx3wC%2BVZS4F47wQChG3ByE%3D&amp;rese
> rved=0
> 
> https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf
> .org%2Frfcdiff%3Furl2%3Ddraft-ietf-lamps-cmp-algorithms-
> 04&amp;data=04%7C01%7Chendrik.brockhaus%40siemens.com%7C8323fe39a
> 1ca415e0ba808d90fdbda54%7C38ae3bcd95794fd4addab42e1495d55a%7C1%7
> C0%7C637558259203073461%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLj
> AwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sd
> ata=ClDQABcn%2FAJ%2FdVcocqSA2SFl8d%2BMgUtEcboSVoYhM60%3D&amp;re
> served=0
> 
> 
> https://eur01.safelinks.protection.outlook.com/?url=ftp%3A%2F%2Fftp.ietf.org
> %2Finternet-
> drafts%2F&amp;data=04%7C01%7Chendrik.brockhaus%40siemens.com%7C832
> 3fe39a1ca415e0ba808d90fdbda54%7C38ae3bcd95794fd4addab42e1495d55a%
> 7C1%7C0%7C637558259203073461%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiM
> C4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&a
> mp;sdata=e5fqiIB3X6yL4rQ00L%2BVECJrMarPODQ2wUaAnjaSV0M%3D&amp;re
> served=0
> 
> 
> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf
> .org%2Fmailman%2Flistinfo%2Fspasm&amp;data=04%7C01%7Chendrik.brockha
> us%40siemens.com%7C8323fe39a1ca415e0ba808d90fdbda54%7C38ae3bcd957
> 94fd4addab42e1495d55a%7C1%7C0%7C637558259203073461%7CUnknown%7
> CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJ
> XVCI6Mn0%3D%7C1000&amp;sdata=8tT%2F4x4oSM1%2F%2Fec2oSMV97dmqV
> ntqMjZ8Kmp4EDyp7o%3D&amp;reserved=0

---

From: Russ Housley <[email-masked]>
Date: Wed, 5 May 2021 12:48:53 -0400

Typo in Section 5:  s/proofe-of-possession/proof-of-possession/

In Section 7, it says "following guidelines should be followed".  That is a bit awkward.  More importantly, the things that follow are the criteria, and then there is a SHOULD statement.  I thnk the sentence introducing the bullets could reflect this better.

In Table 1, what mode of AES is used for PROT_SYM_ALG?  I think it should be CBC.

In section 9, I suggest a rewording of the AES-GMAC paragraph:

   AES-GMAC MUST NOT be used as the pseudo random function
   in PBKDF2; the use of AES-GMAC more than once with the same
   key and the same nonce will break the security.

Russ

> On May 5, 2021, at 11:37 AM, [email-masked] wrote:
> 
> 
> https://www.ietf.org/mailman/listinfo/spasm

---

From: "Brockhaus, Hendrik" <[email-masked]>
Date: Fri, 7 May 2021 06:32:59 +0000

Russ

Thank you for your comments.

> Von: Spasm <[email-masked]> Im Auftrag von Russ Housley
> 

Thanks, will be changed

> 
> In Section 7, it says "following guidelines should be followed".  That is a bit
> awkward.  More importantly, the things that follow are the criteria, and then
> there is a SHOULD statement.  I thnk the sentence introducing the bullets could
> reflect this better.

I suggest the following change:

Old
"the following guidelines should be followed."

New
"the following criteria SHOULD guide the choice of algorithms used for managing certificates."

> In Table 1, what mode of AES is used for PROT_SYM_ALG?  I think it should be

I will change from "AES" --> "AES-CBC" 

>    key and the same nonce will break the security.

Thank you for this suggestion. It reads much better.

Hendrik

---

From: Russ Housley <[email-masked]>
Date: Fri, 7 May 2021 09:36:20 -0400

> "the following criteria SHOULD guide the choice of algorithms used for managing certificates."

I suggest:
"the following criteria will help implementers choose appropriate algorithms for managing certificates:"

Russ

---

From: "Brockhaus, Hendrik" <[email-masked]>
Date: Fri, 7 May 2021 14:05:09 +0000

Russ 

Thank you for your suggestion.
The update of the draft is on it's way.

Hendrik

> -----Ursprüngliche Nachricht-----
> Von: Russ Housley <[email-masked]>
> 
> >>
> >> In Section 7, it says "following guidelines should be followed".
> >> That is a bit awkward.  More importantly, the things that follow are
> >> the criteria, and then there is a SHOULD statement.  I thnk the
> >> sentence introducing the bullets could reflect this better.
> >