Subject: RE: [Speermint] Re: [Enum] a suggestion re: using flags todistinguish post-ENUM signaling f lows

From: "Pfautz, Penn L, NEO" <[email-masked]>
Date: Mon, 6 Feb 2006 10:50:18 -0500

Right now, however, phone numbers are a little like democracy - "the
worst system imaginable except for all others"
P2P folks don't seem serious about interoperability  (look at IM) and
only TNs provide reachability from the PSTN.

Penn
(sorry, Henry, couldn't resist)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Henry Sinnreich
Sent: Monday, February 06, 2006 10:33 AM
To: 'Tony Rutkowski'; 'lconroy'; 'Stafford, Matthew'; 'Otmar Lendl'
Cc: [email-masked]; [email-masked]
Subject: RE: [Speermint] Re: [Enum] a suggestion re: using flags
todistinguish post-ENUM signaling f lows

The information provided by Tony Rutkowski are a welcome reminder that
phone
numbers are not only a crippled addressing system but a huge trap with
legacy telecom regulatory issues and big legal staffing costs.

Let's use the Internet and the DNS for what they were designed: URIs

The other alternative are the name spaces in P2P systems.

Sincere apology to all my friends working on ENUM: 
Keep it within strict bounds, simple and use with caution.

Thanks, Henry

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Tony Rutkowski
Sent: Sunday, February 05, 2006 10:42 AM
To: lconroy; Stafford, Matthew; Otmar Lendl
Cc: [email-masked]; [email-masked]
Subject: [Speermint] Re: [Enum] a suggestion re: using flags to
distinguish
post-ENUM signaling f lows

Hi Lawrence,

>The first is the process issue - what group (if any) coordinates
>between the different DDDS applications and their uses; this topic
...
>3761bis. It seems that your proposal is purely for Carrier/
Infrastructure/
>Private ENUM; in this case, changing 3761 has unintended consequences
>for Public/User ENUM applications.

These are great understatements.  The use of
E.164 identifiers, internationally and
domestically, is subject to more statutory,
regulatory, national security, and industry
practice requirements than any identifier
space in existence - not to mention well
established institutional jurisdiction.

The following list is a current tabulation
of E.164 resolver-directory capability
requirements, parsed into three categories,
currently in play in various industry NGN
forums.  The recently enacted EC Data
Retention Directive, and the U.S. Prevent
Cyberstalking law, add further complexity
to the mix. ;-)

best,
--tony

>basic resolver capability
>
>supplementary capability
>         Number Portability
>         Priority Access
>         Roaming
>         Quality of Service
>         Directory Assistance
>         CallerID
>         Disability Assistance
>         Language preference
>         Personal emergency (E112/911)
>         Public emergency alerts
>         Law enforcement assistance
>         DoNotCall
>         Payment Methods
>         Intercarrier Compensation
>         Profile Management
>         Presence
>         Availability
>         Location
>         Push Management
>         Digital Rights Management
>         Device Management
>         Authentication Credentials
>         Information verification level
>
>protocol feature
>         Authentication
>         Auditing
>         Multiple Syntax Support
>         Mutiple Language Support
>         Extensibility and Localisation Mechanisms

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: Duane <[email-masked]>
Date: Mon, 06 Feb 2006 11:01:23 -0500

> only TNs provide reachability from the PSTN.

Not entirely true, the guys from Jabber use enum lookups and resolve 
Jabber IDs from our zone (e164.org).

Also we're currently working on plugins for thunderbird/firefox to do 
phone number to email/website with the idea of unification on business 
cards of 10 different pieces of contact information to just a phone 
number if people want to go that route.

-- 

Best regards,
  Duane

---

From: Klaus Darilion <[email-masked]>
Date: Tue, 07 Feb 2006 09:29:00 +0100

> number if people want to go that route.

FYI: There already exists a firefox plugin (firefox 1.0.x only).
http://falb.at/enum4firefox/enummapper-0.1.0.xpi

regards
klaus

---

From: Duane <[email-masked]>
Date: Tue, 07 Feb 2006 09:07:53 -0500

> http://falb.at/enum4firefox/enummapper-0.1.0.xpi

I'm aware of that plugin but that only works on windows, and the 
binaries including in the plugin only link to their service.

-- 

Best regards,
  Duane

http://www.cacert.org - Free Security Certificates
http://www.nodedb.com - Think globally, network locally
http://www.sydneywireless.com - Telecommunications Freedom
http://e164.org - Using Enum.164 to interconnect asterisk servers

"In the long run the pessimist may be proved right,
     but the optimist has a better time on the trip."