Subject: [Speermint] RE: [Enum] a suggestion re: using flags to distinguish post-ENUM signaling f lows

From: "Stafford, Matthew" <[email-masked]>
Date: Tue, 7 Feb 2006 16:46:19 -0600

Richard- 

===> What I want to have is SIP URI portability too, or in other words: I
===> want to have my sip URI sip:[email-masked]
===> hosted by one provider and the possibility to port this to another.

No disagreement there. I guess I view these portability options as
complementary (i.e., both useful depending on individual preferences).

Thanks for the document pointers.

Matt

-----Original Message-----
From: Stastny Richard [mailto:[email-masked]] 
Sent: Tuesday, February 07, 2006 12:50 PM
To: Stafford, Matthew
Cc: [email-masked]; [email-masked]
Subject: Re: [Enum] a suggestion re: using flags to distinguish post-ENUM
signaling f lows

>The second one is (essentially) number portability. My SIP URI can change
from sip:[email-masked] to >sip:[email-masked]. As long
as my phone number stays the same, it can be used to obtain my current SIP
URI.

What I want to have is SIP URI portability too, or in other words: I want to
have my sip URI sip:[email-masked]
hosted by one provider and the possibility to port this to another.

Especially if I am a company.
 
For more information see the ECMA christmas wish-list presented today at
ETSI TISPAN:
Technical Report TR/91
Enterprise Communication in Next Generation Corporate Networks (NGCN)
involving Public Next Generation Networks (NGN)
(December 2005)
http://www.ecma-international.org/publications/files/ECMA-TR/TR-091.pdf
 
and also
Technical Report TR/92
Corporate Telecommunication Networks - Mobility for Enterprise
Communications
(December 2005)
http://www.ecma-international.org/publications/files/ECMA-TR/TR-092.pdf
 
The scenarios and requirements described in these two documents will not
be really easy to implement with NGNs ;-)
Of course they want to have best of both sides: peering with each other in
all variants
AND in addition to be connected to an NGN, just to be on the safe side.
One could also say: the overflow traffic is for the telcos (say max 20%)
 
Richard

________________________________

Von: [email-masked] im Auftrag von Stafford, Matthew
Gesendet: Di 07.02.2006 19:20
An: Tony Rutkowski
Cc: [email-masked]; [email-masked]
Betreff: RE: [Enum] a suggestion re: using flags to distinguish post-ENUM
signaling f lows

Tony- The E.164 space is a many-encumbered thing. No argument there. 

All the same, I see two benefits of E.164 numbers: although *some* mobile
devices have QWERTY keyboards, many of them still don't. IMO a telephone
number is far and away the easiest thing to punch into a cellphone keypad.
That's the first one. The second one is (essentially) number portability. My
SIP URI can change from sip:[email-masked] to
sip:[email-masked]. As long as my phone number stays the same, it
can be used to obtain my current SIP URI.

Best, 
Matt 

-----Original Message----- 
From: Tony Rutkowski [mailto:[email-masked]] 
Sent: Sunday, February 05, 2006 10:42 AM 
To: lconroy; Stafford, Matthew; Otmar Lendl 
Cc: [email-masked]; [email-masked] 
Subject: Re: [Enum] a suggestion re: using flags to distinguish post-ENUM
signaling f lows 

Hi Lawrence, 

>The first is the process issue - what group (if any) coordinates 
>between the different DDDS applications and their uses; this topic 
... 
>3761bis. It seems that your proposal is purely for Carrier/ Infrastructure/

>Private ENUM; in this case, changing 3761 has unintended consequences 
>for Public/User ENUM applications. 

These are great understatements.  The use of 
E.164 identifiers, internationally and 
domestically, is subject to more statutory, 
regulatory, national security, and industry 
practice requirements than any identifier 
space in existence - not to mention well 
established institutional jurisdiction. 

The following list is a current tabulation 
of E.164 resolver-directory capability 
requirements, parsed into three categories, 
currently in play in various industry NGN 
forums.  The recently enacted EC Data 
Retention Directive, and the U.S. Prevent 
Cyberstalking law, add further complexity 
to the mix. ;-) 

best, 
--tony 

>basic resolver capability 
> 
>supplementary capability 
>         Number Portability 
>         Priority Access 
>         Roaming 
>         Quality of Service 
>         Directory Assistance 
>         CallerID 
>         Disability Assistance 
>         Language preference 
>         Personal emergency (E112/911) 
>         Public emergency alerts 
>         Law enforcement assistance 
>         DoNotCall 
>         Payment Methods 
>         Intercarrier Compensation 
>         Profile Management 
>         Presence 
>         Availability 
>         Location 
>         Push Management 
>         Digital Rights Management 
>         Device Management 
>         Authentication Credentials 
>         Information verification level 
> 
>protocol feature 
>         Authentication 
>         Auditing 
>         Multiple Syntax Support 
>         Mutiple Language Support 
>         Extensibility and Localisation Mechanisms 
_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: Duane <[email-masked]>
Date: Tue, 07 Feb 2006 18:06:21 -0500

Stafford, Matthew wrote:
> Richard-
> 
> ===> What I want to have is SIP URI portability too, or in other words: 
> I ===> want to have my sip URI sip:[email-masked]
> 

Wouldn't that be the equivalent to an email provider doing an email 
forward, (or in this case a 3XX redirection) ?

If that's the case, phone number portability would solve that by letting 
the user updates their enum record to point to the new location, or 
having your old provider add a 3XX redirect to their software, a lot of 
ISPs have taken to charging a lot of money for simple email redirects if 
a user moves to another ISP but still wants to collect from their old 
address. Of course owning your own domain would overcome this, just like 
it does with email redirections. Kind of a moot point as far as I can tell.

-- 

Best regards,
  Duane