Subject: RE: [Speermint] SPEERMINT Routing Architecture Message Flows

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Thu, 13 Apr 2006 14:08:54 -0400

To the authors of draft-penno-message-flows-00.txt,

One part of this that didn't seem quite right to me was the use of
mutual Registrations between Proxy 1 or domain A and Proxy 2 of domain
B.  (e.g., Do you intend to do some type of Contact routing?)

Could I ask by way of suggestion why you don't use mutual
Subscribe/Notify?  That would require the same authentication and
authorization to the requesting domain and would likely be much richer
in terms of XML documents that could be supplied to the other domain in
a Notify.  An event package per federation type could be defined, for
example.

What do you think?

Mike

> -----Original Message-----
> From: Henry Sinnreich [mailto:[email-masked]] 
> Sent: Thursday, April 13, 2006 12:55 PM
> To: 'Reinaldo Penno'; [email-masked]
> Subject: RE: [Speermint] SPEERMINT Routing Architecture Message Flows 
> 
> The call flows shown are pretty much as would be expected 
> from the trapezoid model in RFC 3261 using well defined SIP 
> proxy behavior (lengthy section in RFC 3261).
> 
> Why use B2BUA that have no defined behavior at all?
> 
> Is it possible to standardize undefined behavior?
> 
> Thanks, Henry
> 
>  
> 
> -----Original Message-----
> From: Reinaldo Penno [mailto:[email-masked]]
> Sent: Wednesday, April 12, 2006 3:27 PM
> To: [email-masked]
> Subject: [Speermint] SPEERMINT Routing Architecture Message Flows 
> 
> Hello,
> 
> We wrote a draft to help frame our discussions. 
> 
> Thanks,
> 
> Reinaldo
> 
> 
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories.
> 
> 
> 	Title		: SPEERMINT Routing Architecture Message Flows  
> 	Author(s)	: R. Penno, et al.
> 	Filename	: draft-penno-message-flows-00.txt
> 	Pages		: 19
> 	Date		: 2006-4-12
> 	
> This draft describes the message flows associated with the 
> SPEERMINT routing architecture. We show message flows in 
> several peering scenarios.  
> 
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-penno-message-flows-00.txt
> 
> 
> 
> 
> _______________________________________________
> Speermint mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speermint
> 

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: "Hadriel Kaplan" <[email-masked]>
Date: Thu, 13 Apr 2006 22:31:58 -0400

I was confused by the registration as well but it must be for different
reasons because doing subscribe/notify doesn't solve my confusion.  :)  It
has benefits for other things, and was what I was assuming would be used for
some policy exchanges ultimately, but not the piece I was confused with this
draft.

In the draft it says it's used for mutual proxy authentication.  For a
typical register challenge method to do that, they have to have shared/known
passwords and usernames. (are we assuming that?)  If a "key" is exchanged in
the register to be used as the password, as shown in the draft I think, it
does nothing; a man-in-the-middle has a view of those keys and can use them,
and there's no authentication scheme for one proxy to believe the key of the
other anyway. (unless "key" means a nonce?) 

Regardless, why not just use mutually-authenticated TLS?  The details of how
to believe the certs of each side though are still being discussed in the
sip mailing list I think. (I haven't been following it) 

-hadriel

> From: Michael Hammer (mhammer) [mailto:[email-masked]]
> Sent: Thursday, April 13, 2006 2:09 PM
> To: [email-masked]; Reinaldo Penno; [email-masked]