Subject: RE: [Speermint] Reachability

From: "Reinaldo Penno" <[email-masked]>
Date: Thu, 6 Apr 2006 04:35:52 -0400

I understand, but in this specific example A and C _wants_ to peer.
Their firewalls would allow such connection. Are you saying B would
block it?

> -----Original Message-----
> From: Otmar Lendl [mailto:[email-masked]]
> Sent: Thursday, April 06, 2006 1:33 AM
> To: [email-masked]
> Subject: Re: [Speermint] Reachability
> 
> On 2006/04/06 09:04, Reinaldo Penno <[email-masked]> wrote:
> >
> > I can have a SIP TLS connection from my house over 5 different
backbones
> > and peer with another proxy server in Japan. That's the fundamental
of
> > Layer 5 peering, no? It is an overlay network over IP. Unless some
> > carrier/provider has some access list, I wonder what the problem is.
> >
> 
> Indeed.
> 
> If all providers ran open SIP proxies, SPEERMINT would hardly be
needed.
> (Some details on SIP message formats perhaps, but nothing more.)
> 
> As I see it, the real challenge for SPERRMINT is to find a peering
> solution in a world where (at least the big) providers run heavily
> firewalled SIP proxies.
> 
> /ol
> --
> < Otmar Lendl ([email-masked]) | nic.at Systems Engineer >
> 
> _______________________________________________
> Speermint mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speermint

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: Otmar Lendl <[email-masked]>
Date: Thu, 6 Apr 2006 11:08:42 +0200

> Their firewalls would allow such connection. Are you saying B would

No, quite the contrary.

First of all, I read the A-B-C as a SIP layer diagram. How the
actual L3 connectivity is established does not matter. It could be 

    A
    |
  B-X-C

where X is your favorite L3 provider. (the likes of Level3, Interoute,
Sprint, Eurorings, Telia, ...)

It may well be that A wants to peer with C and vice versa. But these
two might also want to peer with D, E, F, G, ...
These set of providers might come to the conclusion that it is more
convenient for them to 

 * just open up their firewalls to allow their SIP proxies to talk to B
 * use B quasi as outbound proxy for calls amoungst each other
 * pay B some money for that service

than to 

 * maintain the firewall settings suitable to enable direct SIP messages.

The first option scales with O(n), the second with O(n*n). 

Linear complexity always wins vs. quadratic as the cardinality of
the problem increases.

/ol

---

From: "Patrick Melampy" <[email-masked]>
Date: Thu, 6 Apr 2006 07:30:47 -0400

Continuing with your example ---
    A
    |
  B-X-C

This is very useful. So you're suggesting that B could be paid to help
establish a SIP connection between A and C. This of course is what we are
trying to figure out in this working group. However, why would anybody with
a brain pay B for this service when it is apparent that the media and thus
whole purpose of the communication is going from A-X-C?

---

From: Otmar Lendl <[email-masked]>
Date: Thu, 6 Apr 2006 13:49:22 +0200

> whole purpose of the communication is going from A-X-C?

In this case, X is just doing layer3 work. X just provides basic IP
connectivity between A, B, and C. It is completely ignorant to anything
that happens above layer 3.

It doesn't even matter whether the picture is in fact

     A
     |
   B-X-Y-C

or 
     A
     |\
   B-X-Y-C

or even

     A
     |\
   B-X-C

In other words, X could be the public Internet.

But going back to you question on why pay B and not just X:

X fulfills the role of supplying the L3 connectivity between A and C.
B fulfills the role of managing the SIP-layer connectivity between A and C.

Those two roles could be played by a single company. I do not
rule that out. 

But when designing any framework it is vitally important to keep 
the roles separate. Collapsing them in practice is simple. Divvying
up a role into separate entities later on is difficult.

/ol