Subject: RE: [Speermint] Notation?

From: "Stastny Richard" <[email-masked]>
Date: Thu, 6 Apr 2006 17:16:57 +0200

Hi Medhavi,
inline

> -----Original Message-----
> From: Medhavi Bhatia [mailto:[email-masked]]
> Sent: Thursday, April 06, 2006 5:01 PM
> To: Pfautz, Penn L, NEO; Otmar Lendl; [email-masked]
> Subject: RE: [Speermint] Notation?
> 
> IXP = L5 SP which sits for the duration of the complete call between
> Core-O and Core-T (from my draft). It may do just signaling or both
> signaling and media.

As far as I know there exist more types of IXP today, some offer
proxy services (which is L5 signaling in your model, some offer
also L3 media transit, and some offer just redirect services
(covered below - i.e. a location service), and some offer 
both proxy and redirect
> 
> This is different from a Federation or DNS Registry which may be
> involved only for lookups. So there is some form of SIP profile
> terminated to the IXP (we can deal with media later on).

Not necessarily, see below
> 
> Location of IXPs seems to be a problem today: How does Core-O locate
the
> IXP required to get to Core-T if it exists. It is almost like the SIP
> next hop required to get to the administrative domain of choice.

This is partially covered with the lendl I-D: you may derive from
the federation name the proxy servers if the federation is operated
via a an IXP

maybe Otmar could add some additional information such as
NAPTRs and SRVs (or pointers to) if the federation is operated
via on IXPs.

Richard
> 
> Why IXPs exist? Because of commercial, regulatory or market reasons.
> Sometimes they will exist even though they make no profit out of the
> business (consider few of the GRXs in the GSMA peering case). These
are
> just my thoughts. There may be more informed people on the list (who
> interact with IXPs or have the IXP business) who can speak to this...
> 
> -Medhavi.
> 
> 
> > -----Original Message-----
> > From: Pfautz, Penn L, NEO [mailto:[email-masked]]
> > Sent: Thursday, April 06, 2006 10:51 AM
> > To: Medhavi Bhatia; Otmar Lendl; [email-masked]
> > Subject: RE: [Speermint] Notation?
> >
> >  Can you define what you mean by IXP in this case?  This seems to be
> > another term that gets tossed around.
> >
> > -----Original Message-----
> > From: Medhavi Bhatia [mailto:[email-masked]]
> > Sent: Thursday, April 06, 2006 10:48 AM
> > To: Otmar Lendl; [email-masked]
> > Subject: RE: [Speermint] Notation?
> >
> > I think we need to formalize the notation for L5 peering and L3
> peering.
> > For example, when we write:
> >
> > A
> > |
> > B-X-C
> >
> > It is not obvious to me who are the L5 peers and who are the L3
peers.
> X
> > could be an internet provider for B/C and there could be many of
> those.
> > Signaling between B and C could be going through a different
provider
> > (say Y, which may or may not be L5 aware).
> >
> > Also interconnect SPs may sit in the middle (and frankly I think it
is
> > not worthwhile the debate how they get paid. They exist today
because
> of
> > market/regulatory reasons and disregarding them could be fatal in my
> > opinion). Another thing we can do is to place the IXP in []. So it
> looks
> > like as follows:
> >
> > A--[B]--C
> >         |
> >        X
> >
> > Any thoughts/comments?
> >
> > -Medhavi.
> >
> > > -----Original Message-----
> > > From: Otmar Lendl [mailto:[email-masked]]
> > > Sent: Thursday, April 06, 2006 7:49 AM
> > > To: [email-masked]
> > > Subject: Re: [Speermint] Reachability
> > >
> > > On 2006/04/06 13:04, Patrick Melampy <[email-masked]>
> wrote:
> > > >
> > > > Continuing with your example ---
> > > >     A
> > > >     |
> > > >   B-X-C
> > > >
> > > > This is very useful. So you're suggesting that B could be paid
to
> > help
> > > > establish a SIP connection between A and C. This of course is
what
> > we are
> > > > trying to figure out in this working group. However, why would
> > anybody with
> > > > a brain pay B for this service when it is apparent that the
media
> > and thus
> > > > whole purpose of the communication is going from A-X-C?
> > >
> > > In this case, X is just doing layer3 work. X just provides basic
IP
> > > connectivity between A, B, and C. It is completely ignorant to
> > anything
> > > that happens above layer 3.
> > >
> > > It doesn't even matter whether the picture is in fact
> > >
> > >      A
> > >      |
> > >    B-X-Y-C
> > >
> > > or
> > >      A
> > >      |\
> > >    B-X-Y-C
> > >
> > > or even
> > >
> > >      A
> > >      |\
> > >    B-X-C
> > >
> > > In other words, X could be the public Internet.
> > >
> > > But going back to you question on why pay B and not just X:
> > >
> > > X fulfills the role of supplying the L3 connectivity between A and
> C.
> > > B fulfills the role of managing the SIP-layer connectivity between
A
> > and C.
> > >
> > > Those two roles could be played by a single company. I do not
> > > rule that out.
> > >
> > > But when designing any framework it is vitally important to keep
> > > the roles separate. Collapsing them in practice is simple.
Divvying
> > > up a role into separate entities later on is difficult.
> > >
> > > /ol
> > > --
> > > < Otmar Lendl ([email-masked]) | nic.at Systems Engineer >
> > >
> > > _______________________________________________
> > > Speermint mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/speermint
> > >
> > > --
> > > No virus found in this incoming message.
> > > Checked by AVG Free Edition.
> > > Version: 7.1.385 / Virus Database: 268.3.5/302 - Release Date:
> > 4/5/2006
> > >
> >
> > _______________________________________________
> > Speermint mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/speermint
> >
> > --
> > No virus found in this incoming message.
> > Checked by AVG Free Edition.
> > Version: 7.1.385 / Virus Database: 268.3.5/302 - Release Date:
> 4/5/2006
> >
> 
> _______________________________________________
> Speermint mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speermint

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: Richard Shockey <[email-masked]>
Date: Thu, 06 Apr 2006 11:39:27 -0400

> (covered below - i.e. a location service), and some offer 

Use of the term IXP in this context is incorrect and misleading. You need to 
come up with something specific to the SPEERMINT context.

IXP means some thing in Internet Terminoogy.

Now peering arrangements can be organized at an IXP such as LINX / Equinix if 
two service providers choose to match their L3 and L5 traffic at those points 
and share access to common signaling databases such as ENUM or SIP Redirect.

> the IXP required to get to Core-T if it exists. It is almost like the SIP

No not necessarily each domain should have internal knowledge of its bilateral 
agreements and make decisions based at call origination as to what is the 
optimal point of transit interconnection.

>> Why IXPs exist? Because of commercial, regulatory or market reasons.

market reasons ... money is the answer what is the question?

> are just my thoughts. There may be more informed people on the list (who
>> interact with IXPs or have the IXP business) who can speak to this.

-- 

Richard Shockey, Director - Member of Technical Staff
NeuStar Inc.
46000 Center Oak Plaza  -   Sterling, VA  20166
sip:rshockey(at)iptel.org   sip:57141(at)fwd.pulver.com
ENUM +87810-13313-31331
PSTN Office +1 571.434.5651 PSTN Mobile +1 703.593.2683
Fax: +1 815.333.1237
<mailto:richard(at)shockey.us> or
<mailto:richard.shockey(at)neustar.biz>
<http://www.neustar.biz> ; <http://www.enum.org>
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

---

From: David Meyer <[email-masked]>
Date: Fri, 14 Apr 2006 10:03:30 -0700

On Thu, Apr 06, 2006 at 11:39:27AM -0400, Richard Shockey wrote:
> Use of the term IXP in this context is incorrect and misleading. You need 
> to come up with something specific to the SPEERMINT context.
> 

	Agreed, use of IXP in this context is going to confuse
	things (further).

> Now peering arrangements can be organized at an IXP such as LINX / Equinix 
> if two service providers choose to match their L3 and L5 traffic at those 
> points and share access to common signaling databases such as ENUM or SIP 
> Redirect.

	But by no means required.

> No not necessarily each domain should have internal knowledge of its 
> bilateral agreements and make decisions based at call origination as to 
> what is the optimal point of transit interconnection.

	Agree with the latter.

	Dave