Subject: RE: [Speermint] SPEERMINT Routing Architecture Message Flows

From: "Reinaldo Penno" <[email-masked]>
Date: Thu, 13 Apr 2006 14:00:38 -0400

Hello henry,

> -----Original Message-----
> From: Henry Sinnreich [mailto:[email-masked]]
> Sent: Thursday, April 13, 2006 9:55 AM
> To: Reinaldo Penno; [email-masked]
> Subject: RE: [Speermint] SPEERMINT Routing Architecture Message Flows
> 
> The call flows shown are pretty much as would be expected from the
> trapezoid
> model in RFC 3261 using well defined SIP proxy behavior (lengthy
section
> in
> RFC 3261).
[[Reinaldo]] 

You are right. At some point in the list there was this big discussion
on what we would need "besides" the current established RFCs, and if
anything, what. The purpose of those sections is to show some call flows
in peering scenarios and based on those ask the questions:

1) Do we need anything else? If we need, what would it be?
2) Is it SIP specific or more related to DNS?

> 
> Why use B2BUA that have no defined behavior at all?
[[Reinaldo]] 

On one hand I agree that B2BUA have no defined behavior (actually you
and me discussed this in the past in the sip-implementors mailing list).
On the other hand I do not want to take the "IPV6 will take over the
world and NAT is evil and will disappear" similar stance.

I'm taking the moderate approach here. I believe there are some specific
functions that a B2BUA could do in peering scenarios. Can it be done
some other way through clever network rollouts, NAT traversal, IPv6 etc?
Sure it can, and I mention that...But real networks do not work like
that. 

> 
> Is it possible to standardize undefined behavior?
[[Reinaldo]] 

That would be a difficult proposition, yes. Instead of mentioning
SBC/B2BUA all over, I tried to concentrate on media relay, which is a
function we might need, vis a vis:

1) How to get media to the peering point.
2) Private addresses when a NAT traversal cannot be used
3) Some media functions such as translation, quality measurement, etc 

I will rework some of the portions to make more specific on the
functions and needs to B2BUA. Maybe a couple of scenarios that combine
private address and media relay (when media would not normally make to
the peering point through layer 3 routing).

Thanks,

Reinaldo

> 
> Thanks, Henry
> 
> 
> 
> -----Original Message-----
> From: Reinaldo Penno [mailto:[email-masked]]
> Sent: Wednesday, April 12, 2006 3:27 PM
> To: [email-masked]
> Subject: [Speermint] SPEERMINT Routing Architecture Message Flows
> 
> Hello,
> 
> We wrote a draft to help frame our discussions.
> 
> Thanks,
> 
> Reinaldo
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> 
> 
> 	Title		: SPEERMINT Routing Architecture Message Flows
> 	Author(s)	: R. Penno, et al.
> 	Filename	: draft-penno-message-flows-00.txt
> 	Pages		: 19
> 	Date		: 2006-4-12
> 
> This draft describes the message flows associated with the SPEERMINT
> routing architecture. We show message flows in several peering
> scenarios.
> 
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-penno-message-flows-00.txt
> 

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: "Henry Sinnreich" <[email-masked]>
Date: Thu, 13 Apr 2006 17:44:50 -0500

Reinaldo,

>I believe there are some specific functions that a B2BUA could do in
>peering scenarios.

You are right. Specific functions like media relay are OK. 
I would also suggest to put this in the framework of BEHAVE, STUN, TURN,
ICE, Outbound, etc.

This will give designers a set of clear option what solution to choose, when
is media a relay required, etc. Such guidelines would be very useful.

Thanks, Henry

-----Original Message-----
From: Reinaldo Penno [mailto:[email-masked]] 
Sent: Thursday, April 13, 2006 1:01 PM
To: [email-masked]; [email-masked]
Subject: RE: [Speermint] SPEERMINT Routing Architecture Message Flows 

Hello henry,

section
[[Reinaldo]] 

[[Reinaldo]] 

[[Reinaldo]] 

Thanks,

Reinaldo