Subject: RE: [Speermint] RE: Background Reading on NGN Interconnect -transitvs peering

From: "Medhavi Bhatia" <[email-masked]>
Date: Thu, 6 Apr 2006 13:38:07 -0400

Reinaldo,

Do you have an example of an operator doing just media but is not an L3
carrier (e.g ISP/Transit)? If not, we can just talk about signaling only
or signaling and media.

-Medhavi.

> -----Original Message-----
> From: Reinaldo Penno [mailto:[email-masked]]
> Sent: Thursday, April 06, 2006 1:02 PM
> To: Otmar Lendl; [email-masked]
> Subject: RE: [Speermint] RE: Background Reading on NGN Interconnect
-transitvs peering
> 
> Okay, so when coming up with these terms we cannot forget about media.
> So, when somebody provides "peering" and/or "transit" services, we
need
> to specify in the context of speermint if that means:
> 
> a) all IP packets (which includes media)
> b) only signaling
> ...
> 
> Well, you get the idea...
> 
> > -----Original Message-----
> > From: Otmar Lendl [mailto:[email-masked]]
> > Sent: Thursday, April 06, 2006 8:44 AM
> > To: [email-masked]
> > Subject: Re: [Speermint] RE: Background Reading on NGN Interconnect
-
> > transitvs peering
> >
> > On 2006/04/06 17:04, Richard Shockey <[email-masked]> wrote:
> > > Stastny Richard wrote:
> > > >The problem I have with the FCC definition is that
> > > >is states that peering is always bi-lateral
> > > >
> > > >The major reason for setting up SPEERMINT was that
> > > >everybody seems at least to agree that bi-lateral
> > > >peering does not scale globally.
> > >
> > > All peering arrangements among IP backbones are bi-lateral and the
> > Internet
> > > seems to have scaled reasonably well.
> >
> > The reason for that is "transit". It is thus not necessary that
> > any Autonomous Systems peers with all other AS.
> >
> > I think we should define the difference between "Peering" and
> > "Interconnection" (which in my mind also allows for transit).
> >
> > Bi-lateral peering alone will definitly not solve the world-wide
> > reachability problem.
> >
> > /ol
> > --
> > < Otmar Lendl ([email-masked]) | nic.at Systems Engineer >
> >
> > _______________________________________________
> > Speermint mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/speermint
> 
> _______________________________________________
> Speermint mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speermint
> 
> --
> No virus found in this incoming message.
> Checked by AVG Free Edition.
> Version: 7.1.385 / Virus Database: 268.3.5/302 - Release Date:
4/5/2006

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: "Brian Rosen" <[email-masked]>
Date: Thu, 6 Apr 2006 14:57:30 -0400

I am sorry to be on a campaign to stop arguments that may be interesting and
amusing to us all, but could someone come up with a scenario in which any of
our anticipated documents would somehow differentiate between a peering
mechanism that had media relays and one that did not?

I think this whole line of discussion is interesting, but irrelevant to the
task at hand.

Peering occurs when a SIP INVITE, most often with an offer SDP body, which
contains some IP addresses and ports for it's desired media connections, is
presented to some proxy (a peering proxy which could be within the O
network, or could be in some special peering network) who is going to
determine a proxy in the T network to send the INVITE to.  The resulting 200
OK message, which most often will have an answer SDP with its own media
addresses and ports may traverse said proxies (if they Record Routed).

WHO CARES what the media address/ports are? 

WHO is going to do anything different if they are the endpoint's, an SBC in
the O-network, T-network or anything else.

Who in the O or T network would care if they were in an SBC inside a peering
service?

We need to think about media, because we have to deal with pinhole
firewalls, we have to deal with NAT traversal, and we could imagine dealing
with ancillary functions like transcoders, but really folks, whether there
are media relays anywhere just doesn't seem to matter; you can't tell if
there are or there aren't and you don't do anything differently.

Should anyone care, I personally think if systems are properly designed, the
only media relays in the path pretty that much have to be there are for
legal intercept, and if we did that correctly (at L3 or below) then even
they would not be needed and we could get back to the original idea that
media flows direct between the UAs.  That does not obviate any firewall
needs.  I am under no illusions that "properly designed" is often achieved.
That having been said, lots of folks seem to like media relays, I hope they
don't screw up when emergency calls are sent through, and we have to accept
that they may be all over the place.  But, again, who cares?

Brian

-----Original Message-----
From: Medhavi Bhatia [mailto:[email-masked]] 
Sent: Thursday, April 06, 2006 1:38 PM
To: Reinaldo Penno; Otmar Lendl; [email-masked]
Subject: RE: [Speermint] RE: Background Reading on NGN
Interconnect-transitvs peering

Reinaldo,

-Medhavi.

-transitvs peering
need
-
4/5/2006