Subject: RE: [Speermint] Reachability

From: "Reinaldo Penno" <[email-masked]>
Date: Thu, 6 Apr 2006 05:21:23 -0400

Okay, your explanation seems quite different than the original question.
This seems a quite different ball game, although a valid one. You are
talking about a kind of "SIP route reflector".  The purpose of the route
reflector as you states is to reduce the number of peers. 

The original question seemed to me related to the one of _trust_.

> -----Original Message-----
> From: Otmar Lendl [mailto:[email-masked]]
> Sent: Thursday, April 06, 2006 2:09 AM
> To: [email-masked]
> Subject: Re: [Speermint] Reachability
> 
> On 2006/04/06 10:04, Reinaldo Penno <[email-masked]> wrote:
> > I understand, but in this specific example A and C _wants_ to peer.
> > Their firewalls would allow such connection. Are you saying B would
> > block it?
> 
> No, quite the contrary.
> 
> First of all, I read the A-B-C as a SIP layer diagram. How the
> actual L3 connectivity is established does not matter. It could be
> 
>     A
>     |
>   B-X-C
> 
> where X is your favorite L3 provider. (the likes of Level3, Interoute,
> Sprint, Eurorings, Telia, ...)
> 
> It may well be that A wants to peer with C and vice versa. But these
> two might also want to peer with D, E, F, G, ...
> These set of providers might come to the conclusion that it is more
> convenient for them to
> 
>  * just open up their firewalls to allow their SIP proxies to talk to
B
>  * use B quasi as outbound proxy for calls amoungst each other
>  * pay B some money for that service
> 
> than to
> 
>  * maintain the firewall settings suitable to enable direct SIP
messages.
> 
> The first option scales with O(n), the second with O(n*n).
> 
> Linear complexity always wins vs. quadratic as the cardinality of
> the problem increases.
> 
> /ol
> --
> < Otmar Lendl ([email-masked]) | nic.at Systems Engineer >
> 
> _______________________________________________
> Speermint mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speermint

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: Otmar Lendl <[email-masked]>
Date: Thu, 6 Apr 2006 11:59:11 +0200

> reflector as you states is to reduce the number of peers. 

I like the term "SIP route reflector". 

> The original question seemed to me related to the one of _trust_.

Well, in this setting A trusts B to relay only calls from valid
providers. So does C. 

Thus we have trust relationships A-B and B-C.
Bbridges the trust such that A and C can talk to each other.

/ol