Subject: RE: [Speermint] RE: transit vs peering

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Thu, 6 Apr 2006 18:39:33 -0400

The association of media to L3 struck me as odd as well.  Last I checked
RTP was a L5 protocol up there with SIP.  I think some of the questions
floating on the list relate to folks differing topology perspectives.  I
think that the three questions that ground us are:

What is needed for peers to discover each other and exchange SIP
signaling?

What is needed for peers to exchange media packets?

What is the relationship between the signaling peering point and the
media peering point for a given call?

I also happen to agree with Brian Rosen's posts that despite the variety
of contextual aspects (like addressability) that make a given peering
public or private, the technical process might just be the same.  So,
rather than spin wheels defining all the contextual variations, best to
define the basic interaction first assuming just one context and split
out deltas later, if other contexts requires that.

Mike

> -----Original Message-----
> From: Pfautz, Penn L, NEO [mailto:[email-masked]] 
> Sent: Thursday, April 06, 2006 8:25 AM
> To: Stastny Richard; [email-masked]
> Subject: [Speermint] RE: transit vs peering
> 
> I heartily agree with the need to keep layer 3 and layer 5 
> clear in our discussions. But I don't think they necessarily 
> correspond to media versus signaling. Also, although I 
> personally, think intercarrier compensation is a swamp that I 
> 'd like to stay out of, in the US carriers do charge each 
> other for signaling traffic under certain circumstances.
> 
> Penn
> 
> -----Original Message-----
> From: Stastny Richard [mailto:[email-masked]]
> Sent: Thursday, April 06, 2006 8:21 AM
> To: Pfautz, Penn L, NEO; [email-masked]
> Subject: Re: transit vs peering
> 
> Penn,
>  
> I think we should start from even one step further back:
>  
> I always hear here that there is "traffic" exchanged between 
> "Provider A" or Provider "B", which requires some kind of 
> settlement This implies IMHO "bulk traffic" i.e. media, which 
> in turn implies the media is also touching "entites" of the 
> providers In the Internet model the bulk traffic is exchanged 
> between the UA.
>  
> In L5 peering the only traffic exchanged is signalling 
> traffic and I do not think there is any volume to cause 
> settlement for "traffic"
>  
> There is always an intrinsic mix-up of L5 and L3 peering IMHO 
> we should be very careful in our wording
>  
> Within the scope of SPEERMINT we should never user the term 
> "traffic" standalone, only in context with signalling (L5) 
> traffic or media (L3) traffic. and we should also make clear 
> where these "traffics" originate and terminate.
>  
> Richard
> 
> ________________________________
> 
> Von: Pfautz, Penn L, NEO [mailto:[email-masked]]
> Gesendet: Do 06.04.2006 13:59
> An: Stastny Richard; [email-masked]
> Betreff: transit vs peering
> 
> 
> 
> Richard:
> I think you are taking "bi-lateral" to mean something more 
> restrictive than I intend. The aspect of concern to me is 
> that traffic is being exchanged between the originating 
> provider and the terminating provider.
> Whether federations etc are used to establish whatever 
> relationship the parties require is a business issue.  In 
> either case this is different from paying a transit provider. 
> Transit is just wholesale. I'm not necessarily against it but 
> it's not peering.
> The global IP interconnect regime could still be bi-lateral. 
> The scaling issue is not a technical one. What you want to 
> avoid is negotiating interconnection agreements between all 
> possible pairs of parties.
> 
> Penn
> 
> -----Original Message-----
> From: Stastny Richard [mailto:[email-masked]]
> Sent: Thursday, April 06, 2006 3:29 AM
> To: Pfautz, Penn L, NEO; [email-masked]
> Subject: RE: Background Reading on NGN Interconnect - transit 
> vs peering
> 
> 
> The problem I have with the FCC definition is that is states 
> that peering is always bi-lateral
> 
> The major reason for setting up SPEERMINT was that everybody 
> seems at least to agree that bi-lateral peering does not 
> scale globally.
> 
> And our real goal is to achieve global connectivity and reachability.
> 
> Maybe the name of the WG is wrong in this context
> 
> I still believe that the task of SPEERMINT is to show a way 
> forward to overcome these bi-lateral peering. Away forward in 
> this direction are federations, but finally we should lay the 
> framework for a global IP Interconnect regime, at least protocol wise
> 
> It is obvious that this cannot be done only by protocols in a 
> vacuum, so I fully agree that co-operation with other 
> standard bodies e.g. ITU-T and national authorities will be required.
> 
> If all communication networks are finally migrated to IP, an 
> IP Interconnect regime is required.
> 
> The problem here is that currently there are national 
> interconnect regimes and the international regime on top 
> (hierarchical) as default.
> 
> The new regime allows global direct interconnect, mixing up 
> the current national and international regimes. In many 
> countries national forums are popping up (e.g. in UK and 
> Germany) talking about IP-based interconnect (with or without 
> L3 peering). But they still need to recognize that this is 
> only half of the picture.
> 
> Some of these discussions are going around in circles (like 
> the discussions here? ;-). Maybe one task of SPEERMINT could 
> also be to make scenarios and BCP, showing what works and 
> what not and why not, saving these other bodies some time on 
> useless discussions on not implementable or non-scalable models.
> 
> Richard
> 
> > -----Original Message-----
> > From: Pfautz, Penn L, NEO [mailto:[email-masked]]
> > Sent: Wednesday, April 05, 2006 5:12 PM
> > To: Stastny Richard; [email-masked]
> > Subject: Background Reading on NGN Interconnect - transit vs peering
> >
> > Richard:
> > Thanks for posting this. I recommend it to all. In 
> particular we ought 
> > to pay attention to the definition of peering versus transit offered
> by
> > the US FCC and cited in the Marcus paper:
> >
> >       Peering is an agreement between ISPs to carry traffic 
> for each 
> > other and for their respective
> >       customers. Peering does not include the obligation to carry 
> > traffic to third parties. Peering is usually a
> >       bilateral business and technical arrangement, where two 
> > providers agree to accept traffic from one
> >       another, and from one another's customers (and thus 
> from their 
> > customers' customers). ...
> >
> >       Transit is an agreement where an ISP agrees to carry 
> traffic on 
> > behalf of another ISP or end user. In
> >       most cases transit will include an obligation to 
> carry traffic 
> > to third parties. Transit is usually a
> >       bilateral business and technical arrangement, where 
> one provider 
> > (the transit provider) agrees to carry
> >       traffic to third parties on behalf of another 
> provider or an end 
> > user (the customer). In most cases, the
> >       transit provider carries traffic to and from its other 
> > customers, and to and from every destination on
> >       the Internet, as part of the transit arrangement. In 
> a transit 
> > agreement, the ISP often also provides
> >       ancillary services, such as Service Level Agreements, 
> > installation support, local telecom provisioning,
> >       and Network Operations Center (NOC) support.
> >
> > While we NEED not accept this definition I think it does 
> reflect the 
> > reality of layer 3 peering and it will not be helpful to use a 
> > definition for layer 5 that is at odds with layer 3 since 
> that's what 
> > people are familiar with.
> > If the will of the WG is to include transit in our charter 
> that's fine
> -
> > but not an excuse for calling apples and oranges both apples. If, at
> the
> > end of the day, there are no important differences in how 
> we treat the 
> > two cases - which I doubt - then life is good.
> >
> > We also ought to be thinking about how what Speermint is working on 
> > relates to what's going on in other bodies, e.g. the ITU. 
> (yes, I said 
> > it, we're not alone on the planet :-) Is what we want to do an
> enabling
> > piece of what NGN folks are looking toward or is it a fundamentally 
> > different animal? From the discussion on the list and at 
> the IETF I'm 
> > not entirely sure.
> >
> > -----Original Message-----
> > From: Stastny Richard [mailto:[email-masked]]
> > Sent: Friday, March 31, 2006 3:59 PM
> > To: [email-masked]
> > Subject: [Speermint] Background Reading on NGN Interconnect
> >
> > Folks,
> >
> > Weekend reading
> >
> > Since we obviosly are dealing more with NGN Interconnect in 
> Speermint, 
> > I recommend everybody on this this list to read the excellent
> Background
> > Paper
> > from Scott Marcus - Interconnection in an IP-based NGN Environment
> >
> http://www.itu.int/osg/spu/ngn/documents/Papers/Marcus-060323-
> Fin-v2.1.p
> > df
> >
> > to his presentation
> >
> http://www.itu.int/osg/spu/ngn/documents/presentations/marcus-
> 23-march-2
> > 006.ppt
> > given at the ITU-T Workshop last week
> > What Rules for Ip-eneabled NGNs?
> > http://www.itu.int/osg/spu/ngn/event-march-2006.phtml
> >
> > The agenda and some other excellent presentations can be downloaded
> from
> > here:
> > http://www.itu.int/osg/spu/ngn/presentations.html
> >
> > In addition I would also like to point to a CEPT ECC Draft 
> Report on 
> > the Future on Numbering, tabled for the next ITU-T SG2 
> Meeting as TD 
> > 198-GEN.
> >
> https://mail.oefeg.at/exchweb/bin/redir.asp?URL=http://www.ero
> .dk/271322
> > 2D-C8AF-4407-BE53-131EA2EED278?frames=no%26
> > The document is in public consultation and not final yet.
> > It contains also some statements regarding termination rates.
> >
> > The paper from Scott is on-topic regarding the current 
> discussion here 
> > and dealing with both the European and US situation
> >
> > Scott Marcus is currently living in Europe, but in his 
> former life he 
> > was Senior Advisor to the FCC and also CTO for GTE Interworking, so 
> > his knowledge is not only theoretical.
> >
> > In the document also contains a definition on peering and 
> transit from 
> > the FCC is given:
> >
> > The two most prevalent forms of Internet interconnection are peering
> and
> > transit. For a definition of these
> > terms, we turn to a publication of the Network Reliability and 
> > Interoperability Council (NRIC), an industry advisory panel to the 
> > U.S. FCC:
> >
> > Peering is an agreement between ISPs to carry traffic for each other
> and
> > for their respective
> > customers. Peering does not include the obligation to carry 
> traffic to 
> > third parties. Peering is usually a bilateral business and 
> technical 
> > arrangement, where two providers
> agree
> > to accept traffic from one
> > another, and from one another's customers (and thus from their 
> > customers' customers). ...
> >
> > Transit is an agreement where an ISP agrees to carry 
> traffic on behalf 
> > of another ISP or end user. In most cases transit will include an 
> > obligation to carry traffic to
> third
> > parties. Transit is usually a
> > bilateral business and technical arrangement, where one 
> provider (the 
> > transit provider) agrees to carry traffic to third parties 
> on behalf 
> > of another provider or an end user (the customer).  In most 
> cases, the 
> > transit provider carries traffic to and from its other 
> customers, and
> to
> > and from every destination on
> > the Internet, as part of the transit arrangement.  In a transit 
> > agreement, the ISP often also provides ancillary services, such as 
> > Service Level Agreements, installation support, local telecom 
> > provisioning, and Network Operations Center (NOC) support.
> >
> > Peering thus offers a provider access only to a single provider's 
> > customers. Transit, by contrast, usually provides access at a 
> > predictable price to the entire Internet.
> > ... Historically, peering has often
> > been done on a bill-and-keep basis, without cash payments. Peering
> where
> > there is no explicit
> > exchange of money between parties, and where each party 
> supports part
> of
> > the cost of the
> > interconnect, ... is typically used where both parties perceive a 
> > roughly equal exchange of value.
> > Peering therefore is fundamentally a barter relationship
> >
> > Here the Executive Summary of the paper:
> >
> > This report considers the likely evolution of interconnection 
> > arrangements in the context of IP-based Next Generation Networks 
> > (NGNs).
> >
> > The NGN represents a synthesis of existing world of the 
> "traditional"
> > Public Switched Telephone Network
> > (PSTN) with the world of the Internet. The economic and regulatory 
> > arrangements for the two have historically been very 
> different. What 
> > should happen when these two worlds collide?
> >
> > Many of the networks created over the past ten years contain most of
> the
> > key elements of an NGN. Most, if
> > not all, of the technology necessary for IP-based NGN 
> interconnection 
> > has been available for five to ten years. Advanced approaches to 
> > interconnection have been slow to
> deploy,
> > even where the technology has
> > been mature or within hailing distance of maturity.
> >
> > The NGN interconnection problem is best understood, not as a problem
> of
> > technology, but rather as a
> > problem in economics. With that in mind, this report seeks 
> to review 
> > what is known about interconnection from an economic 
> perspective, in 
> > order to reach conclusions about the prospects for deployment going 
> > forward and the corresponding implications for policymakers.
> >
> > A substantial body of economic theory has been developed 
> over the past 
> > decade as regards interconnection in the traditional PSTN. 
> A smaller 
> > body of solid economic research has emerged in regard to 
> > interconnection of IP-based networks. At the level of 
> economic theory, 
> > the PSTN and the Internet are not worlds apart.
> > Economics provides the necessary bridge between the two worlds, 
> > illuminating both the similarities and the differences in these two 
> > environments.
> >
> > This report begins by laying out, for the most part at a 
> non-technical 
> > level, the established theory of interconnection, for both the PSTN 
> > and the Internet. Wholesale and retail arrangements are considered 
> > separately. Most of the observed behavior of these economic networks
> can
> > be explained in terms of a
> > constellation of known economic effects: market power, the 
> termination 
> > monopoly, demand elasticity, network exernalities, 
> transaction costs, 
> > service differentiation,
> price
> > discrimination, and the Coase theorem
> > (which says that private parties can often negotiate 
> arrangements more 
> > efficiently than government regulators, provided that necessary 
> > preconditions have been met).
> >
> > With this theory in hand, the report considers the implications for
> the
> > deployment of differentiated Quality of Service, and of universal 
> > service. We also consider the implications
> of
> > IP-based technology - with the
> > layering, and the changes in industry structure that it implies - 
> > service providers become independent of the network, but neither is 
> > well equipped to measure or to charge for the other's resource 
> > consumption.
> >  The last section of the report represents a hypothetical 
> scenario, a 
> > "thought experiment", where the historic wired and mobile 
> incumbent of 
> > European country upgrades its networks
> to
> > an IP-based NGN. We consider
> > the likely results in terms of regulation of the access network, and
> of
> > interconnection; likely domestic and
> > international interconnection arrangements; and the 
> implications for 
> > ubiquitous support of QoS. Key findings
> > include:
> > *  Provided that markets for Internet transit and for consumer
> broadband
> > Internet access are effectively
> > competitive, a "Coasian" interconnection regime is likely 
> to be more 
> > efficient, and more consistent with consumer welfare, than 
> a regulated 
> > regime.
> > *  Conversely, where these markets are not effectively competitive, 
> > mandates for interconnection at the IP level may prove to be 
> > unavoidable, particularly once existing PSTN interconnection is 
> > withdrawn.
> > The migration to NGN potentially creates new sources of 
> market power,
> at
> > the same time that it
> > creates new possibilities for competition.
> > *  Policymakers might consequently be well advised  to focus their 
> > attention first on ensuring competitive markets, and only 
> secondarily 
> > on interconnection.
> >
> > Current Calling Party's Network Pays (CPNP) arrangements contain a 
> > number of implicit subsidies. In the world of the NGN, 
> where services 
> > providers and networks operators may
> be
> > different entities, these
> > subsidies need major re-thinking - call termination 
> payments that were 
> > intended to finance the terminating network would, by 
> default, flow to 
> > independent VoIP service provides
> who
> > have no network to support. In
> > the absence of termination fees, independent VoIP providers 
> would tend 
> > to compete price levels for telephony service, independent of the 
> > network, down to levels not greatly above cost, which would 
> appear to 
> > be a societally desirable outcome.
> >
> > The thought experiment does not flatly preclude the 
> possibility that 
> > governments might somehow erect a new system of subsidies 
> to replace 
> > the old, but it suggests that any subsidy system will be 
> difficult to 
> > sustain over time in the face of new forms of competition 
> enabled by 
> > the IP-based NGN - all provided, once again, that 
> underlying markets 
> > (especially for wholesale Internet transit and for retail Internet 
> > broadband access) remain effectively competitive. A system 
> of Coasian 
> > private arrangements, in the absence of vertically integrated 
> > competitive bottlenecks, seems likely to lead to
> unsubsidized
> > arrangements at wholesale and retail
> > price levels not greatly in excess of cost.
> >
> > cheer
> > Richard
> >
> > _______________________________________________
> > Speermint mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/speermint
> 
> 
> 
> _______________________________________________
> Speermint mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speermint
> 

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: "Stastny Richard" <[email-masked]>
Date: Fri, 7 Apr 2006 09:41:18 +0200

> So,

Agreed

Richard

> From: Michael Hammer (mhammer) [mailto:[email-masked]]
> Sent: Friday, April 07, 2006 12:40 AM
> To: Pfautz, Penn L, NEO; Stastny Richard; [email-masked]
> Subject: RE: [Speermint] RE: transit vs peering
>