Subject: RE: [Speermint] Reachability

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Thu, 6 Apr 2006 18:54:01 -0400

Be careful of saying that "media must follow signaling".  Given
mobility, that can lead to sub-optimal routes and possibly horrible QoS.
Maybe the media is handed from the control of A to control of B to C,
but that doesn't necessarily mean going through all the same boxes.

Mike

> -----Original Message-----
> From: Patrick Melampy [mailto:[email-masked]] 
> Sent: Thursday, April 06, 2006 7:52 AM
> To: 'Reinaldo Penno'; 'Stastny Richard'; 'Lee, Yiu'; 'Hadriel 
> Kaplan'; [email-masked]
> Subject: RE: [Speermint] Reachability
> 
> Reinaldo -- you wrote
> 
> >Are A and C paying B to carry _IP_ packets (which includes signaling 
> >and media)?
> 
> I think that a communication with media packets is like a day 
> without sunshine... I think the media packets are what the 
> service is all about.
> Guarantees, reliability, trust, signaling systems, bi-lateral 
> agreements, service level agreements are all about delivery 
> of media. Nobody would ever pay B if B doesn't carry the 
> communication request. If B only provided a location service, 
> then this business model is very close to what Nuestar is 
> doing with their public ENUM. People do pay for this, but 
> this is not what SPEERMINT is about.
> 
> >Can A send and receive packets from C? So, unless A and C want 
> >something special done to their signaling traffic I wonder 
> what B has 
> >to do with it... Why would I pay B to be a proxy hop if I can send 
> >packets directly?
> 
> This is exactly why managing the media flows is so important 
> to these business models. The media must follow the signaling 
> when a communication request goes from A to B to C for B to 
> have any value to A and C. If A and C can interconnect with 
> quality for free (A.K.A. the internet), why would A and C use 
> B? Well -- it is likely because they are unaware of each 
> other -- or B has some special attributes (such as QoS, 
> routing or aggregation) that the internet doesn't have.
> 
> I also believe that A and C may be telephone companies where 
> the telephone traffic might originate from PSTN phones 
> alongside IP originated calls.
> These operators have real expenses associated with receiving 
> and terminating a communication request. A and C could not 
> afford to connect to the internet and offer termination 
> services to just anybody. They would rather NOT do this. This 
> is the reason for the bi-lateral agreements. Since they can't 
> have infinity agreements, there is room for aggregating 
> carriers (B in this example). B aggregates signaling, media, 
> and business agreements.
> 
> If we got rid of the PSTN completely, and all of the 
> regulations in the world, then we can stop worrying about 
> these minor economic issues. I think this is unlikely.
> 
> 
> _______________________________________________
> Speermint mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speermint
> 

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: "Hadriel Kaplan" <[email-masked]>
Date: Fri, 7 Apr 2006 00:39:34 -0400

Indeed, and there are mechanisms to handle that; but in such a case one
wouldn't know whether it will lead to sub-optimal routes, nits, or better
routes.  I don't think he meant follow signaling hopy-by-hop, but rather
provider-by-provider (if the middle providers wanted it to).
-hadriel

> From: Michael Hammer (mhammer) [mailto:[email-masked]] 
> Sent: Thursday, April 06, 2006 6:54 PM
> To: Patrick Melampy; Reinaldo Penno; Stastny Richard; Lee, 
> Yiu; Hadriel Kaplan; [email-masked]
> Be careful of saying that "media must follow signaling".  
> Given mobility, that can lead to sub-optimal routes and 
> possibly horrible QoS.
> Maybe the media is handed from the control of A to control of 
> B to C, but that doesn't necessarily mean going through all 
> the same boxes.
> 
> Mike
>