Subject: [Speermint] Reachability

From: "Stastny Richard" <[email-masked]>
Date: Sat, 1 Apr 2006 21:45:56 +0200

Folks,
 
after reading the document from Scott Markus on NGN Interconnect 
I referenced for weekend reading in my last posting
http://www.itu.int/osg/spu/ngn/documents/Papers/Marcus-060323-Fin-v2.1.pdf
 
IMHO we started the discussion from the wrong end.
 
First we talked primarily about peering, which is according to
the FCC definition always bilateral and not about interconnect
and transit
 
and second we always started naturally at provider A in direction
of call set-up and not at provider B
 
Provider B is giving out a Public User Identity 
(an AoR (SIP URI), an E.164 number or both) to a user.
 
This Public User Identity can now be reached ONLY via
this provider, so he has a monopoly, or in EU terms, he
automatically has significant market power.

Provider B has now (currently only for Public User
Identities in the form of E.164 numbers) the OBLIGATION 
making this PUI reachable for the public by interconnecting 
with the public network (in this case at least via the PSTN)
 
Scott Marcus is indicating that this may be extended to IP-based
networks (and eventually also to SIP URIs)  very soon
if the regulators get their act together and if IP based interconnect
is introduced in some countries (e.g in UK)
 
In some countries also the obligation for provider A may exist to 
make the PUI in question reachable (in some not, because it is
not a monopoly, a customer has the choice to select another 
provider, in this case the obligation is only to providers with SMP),
but provider A can only do so AFTER provider B is reachable at all.
 
So IMHO we can assume that provider B hosting a Public User Identity
(a SIP URI) MUST make this PUI reachable in principle.
 
Question: Is provider B able to define conditions to be meet
and what are they? 
 
In the PSTN interconnect he must make an interconnection offer
public and if somebody is fulfilling the requirements stated in the offer, 
Provider B must accept interconnection non-discriminatory.

The NRA normally sets the limits to such an offer.

These offers contain normally technical and commercial issues
e.g protocols to be used and acccounting requirements, etc

speermint should not deal with commercial agreements, but it
could povide guidelines for the technical part, e.g.
be setting minimum requirements for signaling protocols, security, identifcation
of provider A and his users, etc.in other words a set of BCPs.

I said speermint should not be involved to much in commercial agreements, but
it may also provide some tools to make these workable and scaleable.

Bi-lateral agreements do not scale on a global level, so we may assume that
the agreements come in groups i.e. federations or whatever we may call it

So it may be useful to provide means for a provider B to annouce what kind
of agreements he is requesting to accept incoming calls.

I do not think that speermint should go into issues like how to exchange
accounting data (for this there exists protocoals such as OSP which may
be used)

To summarize: Provider B may have an obligation to make his
customers reachable, provided some technical and commercial
conditions are met by provider A

speermint should work what these conditions could be,
what is required protocol-wise to meet the technical conditions
and how these conditions (technical and commercial)
could be annonced from provider B to provider A,
taking into account that bi-laterel agreements do not scale

cheers

Richard

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: "Hadriel Kaplan" <[email-masked]>
Date: Sun, 2 Apr 2006 21:47:47 -0400

Hi Richard, comments inline...

> -----Original Message-----
> From: Stastny Richard [mailto:[email-masked]]
> Sent: Saturday, April 01, 2006 2:46 PM
> To: [email-masked]
> Subject: [Speermint] Reachability
> 

Indeed that was an interesting paper - thanks for the pointer! (not that I
agree with everything in it)

> of call set-up and not at provider B

Personally, I think the bigger "problem" is the provider C, the one after B.
:)  C trying to be reachable by A through B.  But that's out of scope I
guess.  It's too bad, because that's when BGP got interesting, for example.

> [snipped]

I would think that would only be true if you define the AoR to be a public
identity in the public domain, and such regulation was to be created for
AoRs.  E.164 numbers are by definition such numbers, I think.  But if, for
example, I build a private enterprise network - there's no way I'm obligated
to do so just because I use the same SIP fields AoRs are used in.

Having said that, I would think most providers _want_ to make them
reachable, because that increases their value.  But as the paper pointed
out, peering is difficult to manage beyond a few hundred peers, nor do IP or
PSTN providers peer with everyone directly to achieve universal
reachability.  That's why, for me, the more complex problem is the peer(s)
between.  But documenting A-B/B-A is a good start.

> The NRA normally sets the limits to such an offer.

The power of the national rifle association is staggering.  ;)

-hadriel