Subject: RE: [Speermint] Secure RTP

From: "Lee, Yiu" <[email-masked]>
Date: Tue, 1 Aug 2006 16:07:41 -0400

Hi Brain,

I was thinking what happened if the caller and callee negotiated the
keys directly to encrypt the stream. In this case, the network operators
wouldn't have the keys to decrypt the stream. However, if it happened,
this wouldn't be the operator responsibility to decrypt the stream. I
agree if the network is providing SRTP, the network operator should have
the key for CELEA.

Thanks,
Yiu  

-----Original Message-----
From: Brian Rosen [mailto:[email-masked]] 
Sent: Tuesday, August 01, 2006 3:25 PM
To: Lee, Yiu; 'Khan, Sohel Q [CTO]'; [email-masked]
Subject: RE: [Speermint] Secure RTP

<ianal>
As with any interexchange carrier situation, CALEA doesn't apply to the
peering, it applies to (possibly both) endpoints.

IANAL, but I think if the carrier has the keys, it must give them up,
and if it doesn't, it doesn't have to do anything except deliver the
(encrypted) media packets.

Brian
</ianal>

> -----Original Message-----
> From: Lee, Yiu [mailto:[email-masked]]
> Sent: Tuesday, August 01, 2006 3:11 PM
> To: Khan, Sohel Q [CTO]; [email-masked]
> Subject: RE: [Speermint] Secure RTP
> 
> What is the implication to CALEA if SPEERMINT requires SRTP?
> 
> -----Original Message-----
> From: Khan, Sohel Q [CTO] [mailto:[email-masked]]
> Sent: Tuesday, August 01, 2006 2:03 PM
> To: [email-masked]
> Subject: [Speermint] Secure RTP
> 
> 
> Should SPEERMINT require Secure RTP for VoIP peering?
> 
> (see section 3.4 ...  Editor's Note, SPEERMINT Requirements draft)
> 
> Thanks,
> 
> Sohel Khan
> 
> 
> _______________________________________________
> Speermint mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speermint
> 
> _______________________________________________
> Speermint mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speermint

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: "Brian Rosen" <[email-masked]>
Date: Tue, 1 Aug 2006 17:13:19 -0400

<ianal>
If the carrier doesn't have the keys, then he can't give them up in response
to a warrant.  I've never heard of any LEA telling a carrier that they have
to demand their customers stop using their own encryption. 

I think this is out of scope for SPEERMINT.

In general, support for legal intercept is out of scope in the IETF.

Brian
</ianal>

> Sent: Tuesday, August 01, 2006 4:08 PM
> To: Brian Rosen; Khan, Sohel Q [CTO]; [email-masked]