Subject: RE: [Speermint] Re: More comments on draft-ietf-speermint-terminology

From: "Khan, Sohel Q [CTO]" <[email-masked]>
Date: Tue, 15 Aug 2006 13:20:22 -0500

In Section 6.1 Federation Functionality

Can subscriber database and application servers be added?
A group of providers may use a set of common subscriber database and
application servers.

Sohel

-----Original Message-----
From: David Meyer [mailto:[email-masked]] 
Sent: Tuesday, August 15, 2006 11:24 AM
To: Otmar Lendl
Cc: speermint
Subject: [Speermint] Re: More comments on
draft-ietf-speermint-terminology

	OK, see

http://www.1-4-5.net/~dmm/draft-ietf-speermint-terminology-04.txt

	A couple of notes:

> I'd use "Call Addressing Data" for your definition of CRD.
  
	I have so far resisted this.

> As the term Service Provider (SP) doesn't indicate whether we're 
> talking about Layer3 or Layer5 services, I propose that we use
> 
> ISP: the SP which provides Layer 3 services (IP connectivity)
> VSP: the SP which provides Layer 5 services (SIP service)
>
> That leaves us to define terms to distinguish between L3/L5 integrated

> SP vs. L5 only VSPs and open vs. closed ones.
> 
> What about "IVSP" for L3/L5 Integrated VoIP Service Provider?
> We could then call VSPs which are not IVSPs (the vonage model) "nIVSP"
> for non-integrated VSP.
> 
> Regarding reachability via the Internet, I propose to use "open VSPs" 
> versus "closed VSPs".

	I've also (so far) resisted all of this terminology.
	My sense is that this is way too complicated for what we
	want to achieve.

	I'd be interested in what the WG thinks...

	--dmm

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: "Khan, Sohel Q [CTO]" <[email-masked]>
Date: Tue, 15 Aug 2006 13:40:32 -0500

In figure 1, the SPEERMINT Working group scope is defined as follows:
	| SPEERMINT Working Group Scope
                |
           SIP URI <--- Call Routing Data (CRD)
                |
                |
                | <--- Federation Detection, Policy
                |      Lookup, and Service Location
                |
                |
           Hostname <--- Addressing and session establishment
                |
                | SPEERMINT Working Group Scope

The CRD and Federation terms are well defined in the current draft.
The other terms "policy", "service location", and "addressing and
session establishment" are not well defined.
May be we need three more sections to define these terms and re-arrange
all the terms of the draft as above figure scope.

Thanks,

Sohel

-----Original Message-----
From: David Meyer [mailto:[email-masked]] 
Sent: Tuesday, August 15, 2006 11:24 AM
To: Otmar Lendl
Cc: speermint
Subject: [Speermint] Re: More comments on

	OK, see

  

	--dmm

---

From: "Livingood, Jason" <[email-masked]>
Date: Wed, 16 Aug 2006 09:00:20 -0400

Maybe I missed the earlier discussion, but I don't think a URI
constitues "routing" data at all.  Isn't a URI better described as
"addressing" data?  Then you take the addressing data to figure out
where to route, by consulting other sources (IP routes, etc.).  This
addressing data is sometimes called location information in the ENUM WG.
Once you know the location, then you figure out the route...

Jason 

> From: Khan, Sohel Q [CTO] [mailto:[email-masked]] 
> Sent: Tuesday, August 15, 2006 2:41 PM
> To: David Meyer
> Cc: speermint
> Subject: RE: [Speermint] Re: More comments on 
> The other terms "policy", "service location", and "addressing 
> and session establishment" are not well defined.
> May be we need three more sections to define these terms and 
> re-arrange all the terms of the draft as above figure scope.
> 
> Thanks,
> 
> Sohel
>

---

From: "Livingood, Jason" <[email-masked]>
Date: Wed, 16 Aug 2006 09:01:25 -0400

> 	I'd be interested in what the WG thinks...

That seems like unnecessary splitting of hairs...  And the definition of
closed and open is all relative anyway.  We should keep it simple...

Jason