Subject: [Speermint] RE: Comments on Requirements-03

From: "Jean-Francois Mule" <[email-masked]>
Date: Mon, 3 Dec 2007 04:28:36 -0700

John,

  Thx for the comments.  See inline.

Jean-Francois.

> -----Original Message-----
> From: Elwell, John [mailto:[email-masked]]
> Sent: Wednesday, November 21, 2007 10:45 AM
> To: [email-masked]; Jean-Francois Mule
> Subject: Comments on Requirements-03
> 
> Jean-Francois,
> 
> I am now a lot happier about the way the requirements in section 3 are
> formulated (in terms of "protocol mechanisms must...". Thanks.
> 
> I haven't done a complete review, but I happened to notice the
> following:
> 
> 1. "Requirement #1: protocol mechanisms must exist for SSPs to
>       communicate the egress and ingress points of its service
> domain."
> Why do ingress points need to be advertised?
> 

Putting NAPTR+SRV records in SSP domain name a la  RFC 3263 is a way of
advertising ingress points.  There are lower layer considerations and
traffic engineering considerations for which you would want to know in
advance which ingress points to use for a given peer.
Typically this kind of discussions happens today between 2 SSPs and a
few put down lists of hostnames or even IP addresses.

> 2. "a mechanism should exist to allow SSPs to advertize their
>    media border elements responsible for egress and ingress points so
>    called Signaling Path Data Elements (SDEs)."
> There is confusing use of terminology, not in line with terminology
> draft. What are "Signalling Path Data Elements (SDEs)" and, if they
> are
> on the signalling path, why are they another name for "media border
> elements"?

My bad use of terminology; to be fixed.

> 
> 3. "Requirement #2: protocol mechanisms must exist for SSPs to
>       communicate the egress and ingress media points or SDEs of its
>       service domain.
> 
>       Notes on solution space: SSPs engaged in SIP interconnects do
>       exchange this information today in a static manner."
> If SDEs are indeed media border elements, they are exchanged using SDP
> on a per call basis. Why is there a requirement for anything else? To
> me, the preceding paragraph does not really give convincing
> justification.

Ok, we should definitely have a debate on whether or not this is needed.
SSPs would like to know where media is going to flow from/to for traffic
engineering considerations and to optimize routing of media traffic.
It may not be a requirement for all types of SSPs (enterprise, user
groups) and all types of SIP exchanges (IM) but it is something done in
today SIP interconnects for VoIP traffic >

Anyone else?

> John

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: "Elwell, John" <[email-masked]>
Date: Tue, 04 Dec 2007 01:54:44 +0000

Jean-Francois,

See below.

> From: Jean-Francois Mule [mailto:[email-masked]] 
> Sent: 03 December 2007 11:29
> To: Elwell, John
> Cc: [email-masked]
> Subject: RE: Comments on Requirements-03
> 
> John,
> 
[JRE] My mistake. I meant why do egress points need to be advertised.

John