Subject: [Speermint] New version of architecture draft

From: Reinaldo Penno <[email-masked]>
Date: Fri, 02 May 2008 09:18:26 -0700

Hello,

I just submitted a new version (06) of the architecture draft that should
appear shortly. It hopefully addresses all comments made to the list and at
the IETF. It also incorporate feedback from other authors.

Email headers below for reference to the comments made to the list:

------ Forwarded Message
From: "Elwell, John" <[email-masked]>
Date: Mon, 03 Mar 2008 08:03:39 +0000
To: <[email-masked]>
Subject: [Speermint] Comments on draft-ietf-speermint-architecture-05

------ Forwarded Message
From: Hadriel Kaplan <[email-masked]>
Date: Tue, 4 Mar 2008 15:07:44 -0500
To: "[email-masked]" <[email-masked]>
Subject: [Speermint] Comments on draft-ietf-speermint-architecture-05

------ Forwarded Message
From: Hadriel Kaplan <[email-masked]>
Date: Tue, 4 Mar 2008 21:50:44 -0500
To: "[email-masked]" <[email-masked]>
Subject: [Speermint] Comments on section-4 of
draft-ietf-speermint-architecture-05

------ Forwarded Message
From: Hadriel Kaplan <[email-masked]>
Date: Tue, 4 Mar 2008 22:59:27 -0500
To: "[email-masked]" <[email-masked]>
Subject: Re: [Speermint] Comments on section-5.1 and 5.2 of
draft-ietf-speermint-architecture-05

Regards,

Reinaldo

_______________________________________________
Speermint mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/speermint

---

From: "Elwell, John" <[email-masked]>
Date: Tue, 06 May 2008 16:38:29 +0100

Reinaldo,

The first of my comments in the message you refer to below does not seem
to have been taken into account. Let me express it a different way. We
could have layer 5 peering between an enterprise or service provider
attached to the public Internet and an enterprise or service provider
attached to a private IP network. This possibility does not seem to be
acknowledged in section 2. Figure 1 quite rightly says that layer 3
peering between a public Internet and a private IP network is out of
scope, but I don't think layer 5 peering that happens to operate across
that same layer 3 peering point is out of scope.

John

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Reinaldo Penno
> Sent: 02 May 2008 17:18
> To: [email-masked]
> Subject: [Speermint] New version of architecture draft
> 
> Hello,
>

---

From: "Medhavi Bhatia" <[email-masked]>
Date: Tue, 6 May 2008 13:52:39 -0400

I haven't looked at the recent draft, but the previous one didn't have an
architecture we recently used for peering with a partner. I think this was
an interesting architecture. If it makes sense to discuss more, we can. Here
is what we used:

We terminated SIP signaling from an enterprise A to our network N and then
we "peer" that onto a service provider P which provides PSTN access.
Enterprise A is completely distributed across the internet while we use
secure peering between our network N and P. However, the media from nodes in
the enterprise A doesn't pass through our network and terminates directly
onto the service provider network P which performs NAT traversal if required
(TURN server and SBCs are hosted at the provider network P).

-Medhavi.

-- 
Medhavi Bhatia

CTO, 3CLogic
www.3clogic.com

---

From: "Uzelac, Adam" <[email-masked]>
Date: Tue, 6 May 2008 13:55:41 -0400

Medhavi - from what I can gather in your note, the use case that you
mentioned is captured in the use-case draft - for what it's worth.
 
Adam

________________________________

	From: [email-masked]
[mailto:[email-masked]] On Behalf Of Medhavi Bhatia
	Sent: Tuesday, May 06, 2008 1:53 PM
	To: Reinaldo Penno
	Cc: [email-masked]
	Subject: Re: [Speermint] New version of architecture draft

	I haven't looked at the recent draft, but the previous one
didn't have an architecture we recently used for peering with a partner.
I think this was an interesting architecture. If it makes sense to
discuss more, we can. Here is what we used:
	
	We terminated SIP signaling from an enterprise A to our network
N and then we "peer" that onto a service provider P which provides PSTN
access. Enterprise A is completely distributed across the internet while
we use secure peering between our network N and P. However, the media
from nodes in the enterprise A doesn't pass through our network and
terminates directly onto the service provider network P which performs
NAT traversal if required (TURN server and SBCs are hosted at the
provider network P).
	
	-Medhavi.

	On Fri, May 2, 2008 at 12:18 PM, Reinaldo Penno
<[email-masked]> wrote:

		Hello,
		
		I just submitted a new version (06) of the architecture
draft that should
		appear shortly. It hopefully addresses all comments made
to the list and at
		the IETF. It also incorporate feedback from other
authors.
		
		Email headers below for reference to the comments made
to the list:
		
		------ Forwarded Message
		From: "Elwell, John" <[email-masked]>
		Date: Mon, 03 Mar 2008 08:03:39 +0000
		To: <[email-masked]>
		Subject: [Speermint] Comments on
draft-ietf-speermint-architecture-05
		
		------ Forwarded Message
		Subject: [Speermint] Comments on
		
		------ Forwarded Message
		
		------ Forwarded Message
		Subject: Re: [Speermint] Comments on section-5.1 and 5.2
of
		
		Regards,
		
		Reinaldo

	-- 
	Medhavi Bhatia
	
	CTO, 3CLogic
	www.3clogic.com