Subject: Re: [Speermint] Issues and tickets - Architecture Draft

From: Otmar Lendl <[email-masked]>
Date: Tue, 04 May 2010 13:22:39 +0200

On 28.04.2010 18:29, Daryl Malas wrote:
> All,
> 
> In order to ensure we make progress on these open issues, we will hold a
> last call on these issues.  Please make any comments on these issues by
> May 7th.
> 

I haven't seen any action in the trac pages since Adam posted them.

As I raised the questions documented in these tickets, I'm left to wonder
whether

* the questions themselves just make no sense, or

* the group is not prepared to propose an architecture that nails down some
of the decisions one faces when actually implementing a peering scheme.

As it stands, the current architecture draft is a collection of vague
statements -- suitable perhaps for an executive level power-point
presentation -- but of very little use to any techie who is tasked with
building a real-world SSP network and its interconnections.

As I see it, speermint is stuck in power-point space.

otmar
-- 
// Otmar Lendl <[email-masked]>, T: +43 1 5056416 - 33, F: - 933 //

---

From: Daryl Malas <[email-masked]>
Date: Tue, 11 May 2010 11:18:06 -0600

Otmar,

Part of this issue has been other priorities on my part.  I am guilty of not taking the time to respond to these tickets, but I do care about them.  Each of the questions make sense, and I finally responded to them.  

Why others are not, is beyond me.  So, you say the architecture is a "collection of vague statements."  Like all work within the working group, it is development by committee.  This is a "working group item."  This means, suggest wording to fix it.  There are those who talk and those who do.  Let's fix it, otherwise it will just float around until it dies (which, the defibrillator has already been used.)

I know from experience there is a lot of peering going on.  Whether SSPs call it "IP transit," "peering," "IP termination," etc.  It's happening.  People need to share there experiences, as well as help the industry move past the LERG and NPAC.  These are legacy databases, which are anchors to innovation.

Also, for some reason all of the IETF vendor representatives do not seem to want to evolve peering.  They are all happy with PSTN replacement.  Personally, this is not what I had in mind when it comes to peering.  I do not want to see us simply replicating the PSTN.  I've heard a similar statement in other SIP groups, but yet here we are.  While I agree we needed to get some basic frameworks around supporting voice in a peering scenario, the way we support voice does not have to simply replicate the PSTN.  If I said this in the past, then shame on me.  The landscape is changing, and we need to use our collective brain power to make sure it goes in the right direction.

Before I get to far down this path, there have been innovative discussions and drafts in the IETF applying to peering.  Unfotunately, due to scattered application, they have been discussed in many different forums.  Some examples include ViPR (http://tools.ietf.org/html/draft-rosenberg-dispatch-vipr-overview-02), Session ID (http://tools.ietf.org/html/draft-kaplan-sip-session-id-02), Performance metrics (http://tools.ietf.org/html/draft-ietf-pmol-sip-perf-metrics-05), "Re: [dispatch] Thoughts on SIP routing, TRIP, and ENUM (Long!) (http://www.ietf.org/mail-archive/web/dispatch/current/msg01686.html), Egress Route in ENUM (http://tools.ietf.org/html/draft-malas-dispatch-sip-egress-route-00), etc.

Peering is being dealt with in the IETF, but it's just not all addressed in the Speermint working group (which, may be fine...not the point of this rant).

Regards,

Daryl  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Otmar Lendl
Sent: Tuesday, May 04, 2010 5:23 AM
To: [email-masked]
Subject: Re: [Speermint] Issues and tickets - Architecture Draft

On 28.04.2010 18:29, Daryl Malas wrote:
> All,
> 
> In order to ensure we make progress on these open issues, we will hold 
> a last call on these issues.  Please make any comments on these issues 
> by May 7th.
> 

As I raised the questions documented in these tickets, I'm left to wonder whether

* the group is not prepared to propose an architecture that nails down some of the decisions one faces when actually implementing a peering scheme.

As it stands, the current architecture draft is a collection of vague statements -- suitable perhaps for an executive level power-point presentation -- but of very little use to any techie who is tasked with building a real-world SSP network and its interconnections.

otmar
--
// Otmar Lendl <[email-masked]>, T: +43 1 5056416 - 33, F: - 933 // _______________________________________________
Speermint mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/speermint

---

From: Daryl Malas <[email-masked]>
Date: Tue, 11 May 2010 11:23:26 -0600

...by the way, this email was sent as a contributor and not as the working group chair.  :-)

--Daryl 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daryl Malas
Sent: Tuesday, May 11, 2010 11:18 AM
To: Otmar Lendl; [email-masked]
Subject: Re: [Speermint] Issues and tickets - Architecture Draft & Rant

Otmar,

Regards,

Daryl  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Otmar Lendl
Sent: Tuesday, May 04, 2010 5:23 AM
To: [email-masked]
Subject: Re: [Speermint] Issues and tickets - Architecture Draft

otmar
--
// Otmar Lendl <[email-masked]>, T: +43 1 5056416 - 33, F: - 933 // _______________________________________________
Speermint mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/speermint
_______________________________________________
Speermint mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/speermint