Subject: [spring] Note for clarify with regards to draft-srcomdt-spring-compression-requirements-05

From: James Guichard <[email-masked]>
Date: Tue, 16 Mar 2021 15:42:22 +0000

Dear WG:

A quick note from the chairs for clarity with regards to draft-srcomdt-spring-compression and as a matter of process for future unrelated documents.

With regard to section 5.2 of draft-srcomdt-spring-compression-requirements-05, the chairs note that this is primarily an IETF process issue, not a technical issue about solutions.  The chairs also remind people of two aspects of IETF process:

  1.  First, an IETF draft which modifies an existing PS or BCP requirement will not be adopted by the SPRING WG without a corresponding document that explicitly modifies or updates the requirement being sent for consideration by the relevant WG.
  2.  Second, the document which makes such a modification or update will need to be approved by the IETF working group which owns the existing requirement before the SPRING document will be advanced out of the SPRING WG.

Thanks!

Jim, Joel & Bruno

---

From: Bob Hinden <[email-masked]>
Date: Sat, 20 Mar 2021 09:49:20 -0700

Jim, Joel & Bruno,

> On Mar 16, 2021, at 8:42 AM, James Guichard <[email-masked]> wrote:
> 
> Dear WG:
> 
> 	• First, an IETF draft which modifies an existing PS or BCP requirement will not be adopted by the SPRING WG without a corresponding document that explicitly modifies or updates the requirement being sent for consideration by the relevant WG.
> 	• Second, the document which makes such a modification or update will need to be approved by the IETF working group which owns the existing requirement before the SPRING document will be advanced out of the SPRING WG.

I don’t see why a single document can’t update both.   IDs are allowed to update multiple documents, the changes need to be clear, but I don’t see why separate documents are required.  Please explain.

Bob

---

From: "Joel M. Halpern" <[email-masked]>
Date: Sat, 20 Mar 2021 13:22:23 -0400

It can be the same document.  We could not find wording that made it 
clear that the update had to be approved by the owning WG, and that 
SPRING approval would be conditional on such.  And still alow for them 
being the same or different documents.

On the other hand, the usual practice has been to separate them as it 
makes for cleaner discussions.

Yours,
Joel

---

From: Bob Hinden <[email-masked]>
Date: Sat, 20 Mar 2021 10:35:28 -0700

Joel,

Thanks for clarifying.   I agree if the updated documents were done in separate w.g., then having separate documents makes sense.

Bob

> On Mar 20, 2021, at 10:22 AM, Joel M. Halpern <[email-masked]> wrote:
> 
> It can be the same document.  We could not find wording that made it clear that the update had to be approved by the owning WG, and that SPRING approval would be conditional on such.  And still alow for them being the same or different documents.
> 
> On the other hand, the usual practice has been to separate them as it makes for cleaner discussions.
> 
> Yours,
> Joel
>