Subject: Re: [spring] New drafts from SRCOMP design team

From: "Weiqiang Cheng" <[email-masked]>
Date: Tue, 2 Mar 2021 13:27:36 +0800

Hi Rishabh,

Thanks for your comments.

It is good point, and DT will consider the it in.

B.R.

Weiqiang Cheng

发件人: spring [mailto:[email-masked]] 代表 Rishabh Parekh
发送时间: 2021年2月27日 01:50
收件人: Weiqiang Cheng
抄送: [email-masked]; SPRING WG List
主题: Re: [spring] New drafts from SRCOMP design team

Weiqiang,

Text quoted below from the SPRING charter indirectly covers Point-to-Multipoint requirement which is addressed by SR Replication Segment draft https://datatracker.ietf.org/doc/draft-ietf-spring-sr-replication-segment/

New types of segments mapping to forwarding behaviour (e.g., local
ingress replication, local forwarding resources, a pre-existing
replication structure) if needed for new usages.

For the Point-to-Multipoint compression requirement, what exactly is "multicast address" in the Metric? Is this an IPv6 multicast address? If so, it really does not conform to SRv6 data plane. 

I would rather consider the SRv6 Replication SID, described in the latest version of SR Replication segment draft, to be the Metric for measuring P2MP requirement. Maybe we should also consider adding it to SRv6 Functionality Section 4.2.1 of the compression requirements draft.

-Rishabh

On Thu, Feb 25, 2021 at 9:25 AM Weiqiang Cheng <[email-masked]> wrote:

Hi All,

Two drafts have been submitted.  Please review them and any comments are welcomed.

Compression requirement draft -04 version provided two more requirements: 

https://www.ietf.org/archive/id/draft-srcompdt-spring-compression-requirement-04.txt

Compression analysis draft -00 provided a skeleton for the analysis of 4 candidate proposals.

https://www.ietf.org/archive/id/draft-srcompdt-spring-compression-analysis-00.txt

B.R.

Weiqiang

_______________________________________________
spring mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/spring

---

From: Ron Bonica <[email-masked]>
Date: Tue, 2 Mar 2021 17:09:11 +0000

Rishabh,

Is Section 2 of the SR replication segment draft compliant with Section 2.7 of RFC 4291? Could it be brought into compliance by using the high order 16 bits that RFC 4291 recommends?

                                                                           Ron

Juniper Business Use Only
From: Srcomp <[email-masked]> On Behalf Of Weiqiang Cheng
Sent: Tuesday, March 2, 2021 12:28 AM
To: 'Rishabh Parekh' <[email-masked]>
Cc: [email-masked]; 'SPRING WG List' <[email-masked]>
Subject: Re: [Srcomp] [spring] New drafts from SRCOMP design team

[External Email. Be cautious of content]

Hi Rishabh,

B.R.
Weiqiang Cheng

发件人: spring [mailto:[email-masked]] 代表 Rishabh Parekh
发送时间: 2021年2月27日 01:50
收件人: Weiqiang Cheng
抄送: [email-masked]<mailto:[email-masked]>; SPRING WG List
主题: Re: [spring] New drafts from SRCOMP design team

Weiqiang,
Text quoted below from the SPRING charter indirectly covers Point-to-Multipoint requirement which is addressed by SR Replication Segment draft https://datatracker.ietf.org/doc/draft-ietf-spring-sr-replication-segment/<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-ietf-spring-sr-replication-segment/__;!!NEt6yMaO-gk!VjURp3oglqwAJJ06ixqEz0o9WjgWaU6W5fQ7MthNrQdg-dWAsLJnab_Ce0i_WdUG$>

-Rishabh

On Thu, Feb 25, 2021 at 9:25 AM Weiqiang Cheng <[email-masked]<mailto:[email-masked]>> wrote:
Hi All,
Two drafts have been submitted.  Please review them and any comments are welcomed.

https://www.ietf.org/archive/id/draft-srcompdt-spring-compression-requirement-04.txt<https://urldefense.com/v3/__https:/www.ietf.org/archive/id/draft-srcompdt-spring-compression-requirement-04.txt__;!!NEt6yMaO-gk!VjURp3oglqwAJJ06ixqEz0o9WjgWaU6W5fQ7MthNrQdg-dWAsLJnab_Ce1UWnkzI$>

Compression analysis draft -00 provided a skeleton for the analysis of 4 candidate proposals.
https://www.ietf.org/archive/id/draft-srcompdt-spring-compression-analysis-00.txt<https://urldefense.com/v3/__https:/www.ietf.org/archive/id/draft-srcompdt-spring-compression-analysis-00.txt__;!!NEt6yMaO-gk!VjURp3oglqwAJJ06ixqEz0o9WjgWaU6W5fQ7MthNrQdg-dWAsLJnab_Ce4mNqDYS$>

B.R.
Weiqiang
_______________________________________________
spring mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/spring<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/spring__;!!NEt6yMaO-gk!VjURp3oglqwAJJ06ixqEz0o9WjgWaU6W5fQ7MthNrQdg-dWAsLJnab_Ce6GLiq7Z$>

---

From: Rishabh Parekh <[email-masked]>
Date: Mon, 8 Mar 2021 09:46:55 -0800

Ron,
SRv6 Replication SID does not need to follow IPv6 multicast address format
since it is an IPv6 unicast address like any other SRv6 SID.

-Rishabh

On Tue, Mar 2, 2021 at 9:09 AM Ron Bonica <[email-masked]> wrote:

> Rishabh,
>
>
>
> Is Section 2 of the SR replication segment draft compliant with Section
> 2.7 of RFC 4291? Could it be brought into compliance by using the high
> order 16 bits that RFC 4291 recommends?
>
>
>
>
>                                                                            Ron
>
>
>
>
>
>
>
> *From:* Srcomp <[email-masked]> *On Behalf Of *Weiqiang Cheng
> *Sent:* Tuesday, March 2, 2021 12:28 AM
> *To:* 'Rishabh Parekh' <[email-masked]>
> *Cc:* [email-masked]; 'SPRING WG List' <[email-masked]>
> *Subject:* Re: [Srcomp] [spring] New drafts from SRCOMP design team
>
>
>
> *[External Email. Be cautious of content]*
>
>
>
> Hi Rishabh,
>
> *发件人**:* spring [mailto:[email-masked] <[email-masked]>]
> *代表 *Rishabh Parekh
> *发送时间:* 2021年2月27日 01:50
> *收件人:* Weiqiang Cheng
> *抄送:* [email-masked]; SPRING WG List
> *主题:* Re: [spring] New drafts from SRCOMP design team
>
>
>
> Weiqiang,
>
> Text quoted below from the SPRING charter indirectly covers
> Point-to-Multipoint requirement which is addressed by SR Replication
> Segment draft
> https://datatracker.ietf.org/doc/draft-ietf-spring-sr-replication-segment/
> <https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-ietf-spring-sr-replication-segment/__;!!NEt6yMaO-gk!VjURp3oglqwAJJ06ixqEz0o9WjgWaU6W5fQ7MthNrQdg-dWAsLJnab_Ce0i_WdUG$>
>
> For the Point-to-Multipoint compression requirement, what exactly is
> "multicast address" in the Metric? Is this an IPv6 multicast address? If
> so, it really does not conform to SRv6 data plane.
>
>
>
> I would rather consider the SRv6 Replication SID, described in the latest
> version of SR Replication segment draft, to be the Metric for measuring
> P2MP requirement. Maybe we should also consider adding it to SRv6
> Functionality Section 4.2.1 of the compression requirements draft.
>
>
>
> -Rishabh
>
>
>
>
>
> <https://urldefense.com/v3/__https:/www.ietf.org/archive/id/draft-srcompdt-spring-compression-requirement-04.txt__;!!NEt6yMaO-gk!VjURp3oglqwAJJ06ixqEz0o9WjgWaU6W5fQ7MthNrQdg-dWAsLJnab_Ce1UWnkzI$>
>
>
>
> <https://urldefense.com/v3/__https:/www.ietf.org/archive/id/draft-srcompdt-spring-compression-analysis-00.txt__;!!NEt6yMaO-gk!VjURp3oglqwAJJ06ixqEz0o9WjgWaU6W5fQ7MthNrQdg-dWAsLJnab_Ce4mNqDYS$>
>
>
>
> B.R.
>
> Weiqiang
>
> <https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/spring__;!!NEt6yMaO-gk!VjURp3oglqwAJJ06ixqEz0o9WjgWaU6W5fQ7MthNrQdg-dWAsLJnab_Ce6GLiq7Z$>
>
>