Subject: [Spud] Middlebox to middlebox declarations in SPUD?

From: Szilveszter Nadas <[email-masked]>
Date: Fri, 6 Mar 2015 15:59:29 +0000

Hi,

An option we came up with in one of the discussions is whether there are use cases for middlebox to middlebox communications in SPUD (or Path to Path as in the Use Case doc terminology). At first glance it is hard to find a reason to use SPUD for this purpose, still it might be worth some thinking to not rule out this too fast.

A related topic, which occurred to me is the separation of trust domains in end-user devices. What if both the application and the user/OS would like to communicate declarations? They might have different relations, intents and authority. Shall the user be able to override app declarations or vice versa? Shall both be able to make and receive declarations?

Philosophically, we could look at the user/OS as a middlebox in this scenario. In that case some it is easier to find middlebox to middlebox use cases. If this philosophy is applied it might also be easier to solve these questions.

(Of course there can be even more actors in the OS, like middleware, TP, Browser, App running in browser.)

Cheers,
Sz.

---

From: "Joe Hildebrand (jhildebr)" <[email-masked]>
Date: Mon, 9 Mar 2015 21:30:46 +0000

>Philosophically, we could look at the user/OS as a middlebox in this scenario. In that case some it is easier to find middlebox to middlebox use cases. If this philosophy is applied it might also be…

That feels right to me.  Similarly, as I've been prototyping, I was worried about what to do with packets I missed, since the OS isn't queueing for me.  Once I started thinking about those packets as just lost on a different segment of the path, I stopped worrying about them.

-- 
Joe Hildebrand