Subject: [Spud] SPUD for Datacenters

From: Caitlin Bestler <[email-masked]>
Date: Thu, 26 Mar 2015 09:06:34 -0700

Almost all of the SPUD discussion deals with long-haul networking, but 
virtually
all of the infrormational declarations discussed would be just as 
applicable for
datacenter switches, rbridges and routers.

This is especially important when you consider that the same application 
might be
run either on a machine in a home network or on a virtual machine in a 
datacenter.

---

From: Mirja Kühlewind <[email-masked]>
Date: Mon, 30 Mar 2015 11:24:07 -0700

Hi Caitlin,

just a quick response. To my experience designing thing for the Internet is usually harder that for data centers. However, what works in the Internet should usually also work in data centers. (If that’s the most efficient way to do things in a data center, is a different question). However, I think it is most important that we can come up with something that can be use in the Internet. And as this is today hard problem, I’d prefer to focus on this part.

Mirja

> Am 26.03.2015 um 09:06 schrieb Caitlin Bestler <[email-masked]>:
> 
> Almost all of the SPUD discussion deals with long-haul networking, but virtually
> all of the infrormational declarations discussed would be just as applicable for
> This is especially important when you consider that the same application might be
> run either on a machine in a home network or on a virtual machine in a datacenter.
> 
> _______________________________________________
> Spud mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spud

---

From: Caitlin Bestler <[email-masked]>
Date: Mon, 30 Mar 2015 13:06:13 -0700

> just a quick response. To my experience designing thing for the Internet is usually harder that for data centers. However, what works in the Internet should usually also work in data centers. (If t…
I would agree that getting things to work for the Internet is harder.

What I am suggesting is that we at least think about the datacenter 
impact for each specific method we come up with.
Careful phrasing of requirements can result in no additional work for 
the Internet deployment but enable an efficient
datacenter implementation as well. But if we don't do that check before 
we freeze language we will end up forcing
some inefficiency for datacenter implementations.

Datacenter specific optimizations, such as enhanced interactions for 
short round-trip-times, should be deferred.
Make it work everywhere first.