Subject: Re: [Spud] Multipath UDP as a SPUD usecase?

From: "Joe Hildebrand (jhildebr)" <[email-masked]>
Date: Thu, 19 Mar 2015 17:05:51 +0000

On 3/19/15, 9:57 AM, "Pal Martinsen (palmarti)" <[email-masked]> wrote:

>Another potential use-case SPUD could help solve is multipath UDP. I do not have enough insight regarding bits on the wire to accomplish this but to me it would be a compelling usecase.
>
>It might:
>  - Provide easy “media mobility” when a device switches network.
>  - Better throughput (Not sure about this..)
>
>Since we already have this for TCP and there is a multi-path RTP draft there seems to be some interest in solving this.

This may be mostly an issue for the t' layer (t' = "transport prime"; the transport semantics inside of SPUD), particularly since we're leaning toward tube ID's being bound to a 5-tuple.  The t' code would create a new tube (probably with a new tube ID) for each address pair.  In the case of mptcp', every time mptcp would have sent a new SYN, mptcp' would send a SPUD OPEN.

-- 
Joe Hildebrand

---

From: "Pal Martinsen (palmarti)" <[email-masked]>
Date: Thu, 19 Mar 2015 20:27:49 +0000

> On 19 Mar 2015, at 18:05, Joe Hildebrand (jhildebr) <[email-masked]> wrote:
> 
> This may be mostly an issue for the t' layer (t' = "transport prime"; the transport semantics inside of SPUD), particularly since we're leaning toward tube ID's being bound to a 5-tuple.  The t' code would create a new tube (probably with a new tube ID) for each address pair.  In the case of mptcp’, every time mptcp would have sent a new SYN, mptcp' would send a SPUD OPEN.
> 
That make sense. As long as we not decide on anythin that make this hard/impossible I am happy.Not even sure if this belongs to the core spec, maybe better suited as a extension?

.-.
Pål-Erik

---

From: "Joe Hildebrand (jhildebr)" <[email-masked]>
Date: Thu, 19 Mar 2015 20:32:21 +0000

>That make sense. As long as we not decide on anythin that make this hard/impossible I am happy.Not even sure if this belongs to the core spec, maybe better suited as a extension?

I think we'll learn a lot more as we get a mptcp' implementation started.  My gut feel is that we just need a extra paragraph in the spec that says what the scope of a tube ID is, and when to start a new tube.

-- 
Joe Hildebrand