Subject: [stir] Performance

From: Eric Burger <[email-masked]>
Date: Tue, 30 Jul 2013 08:39:32 +0200

One thing I do not see in the charter discussions or the drafts are any performance requirements. For example, I can well imagine some of the out-of-band proposals adding seconds to call setup time. Given that one of the drivers for the work is swatting, this means a big use case of the solution will be for emergency services. In that environment, seconds count in an absolute sense. From a user experience perspective, listening to seconds of digital silence when calling a PSAP is inviting the caller to hang up and try again. That is not a good use of resources, and may result in more dead people. Regulators do not like to be responsible for that, which means we may see "less than ideal" solutions imposed on us.

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 30 Jul 2013 09:54:07 +0200

Hi Eric,

please have a look at this document when it comes to attacks against the emergency infrastructure:
http://tools.ietf.org/html/draft-ietf-ecrit-trustworthy-location-06

A feature of the emergency services infrastructure is that you do not want to reject incoming calls. For swatting the problem is that the location retrieval process uses a form of the calling number as input to the location determination process. The calling party identity is therefore more useful there for an analysis after an attack.

Ciao
Hannes

On Jul 30, 2013, at 8:39 AM, Eric Burger wrote:

> One thing I do not see in the charter discussions or the drafts are any performance requirements. For example, I can well imagine some of the out-of-band proposals adding seconds to call setup time. Given that one of the drivers for the work is swatting, this means a big use case of the solution will be for emergency services. In that environment, seconds count in an absolute sense. From a user experience perspective, listening to seconds of digital silence when calling a PSAP is inviting the caller to hang up and try again. That is not a good use of resources, and may result in more dead people. Regulators do not like to be responsible for that, which means we may see "less than ideal" solutions imposed on us._______________________________________________
> stir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/stir