Subject: [stir] H.323 etc.

From: "Anton Tveretin" <[email-masked]>
Date: Mon, 19 Aug 2013 18:54:34 +0600

Obviously, I failed to formulate my question.
It was: Is IKES, any other in-band and out-of-band signalling only for SIP 
or for other clients also? In other words, will there be validators in 
non-SIP networks? (or rather, do we expect them?).
If no, we expect non-SIP networks just to transfer any extra information 
transparently (as UUI). So do not bother gatekeepers with it.
If yes, that information should be delivered to wherever a validator might 
be.
Also, I think PSTN/ISDN is "sterile" and trusted. I do not expect validators 
to be deployed inside native PSTN soon, but ingress gateway must try their 
best. I see one more problem here: how to supply keys (certificates) there?
Sincerely yours, Anton.

---

From: Hadriel Kaplan <[email-masked]>
Date: Mon, 19 Aug 2013 09:50:56 -0400

Hi Anton,
Your question sounds like you're asking for a definitive answer - as if the group has come to a consensus regarding this topic already. No consensus decisions been reached beyond the the stuff in the current charter, as far as I know.  The STIR group isn't even a Working Group yet. :)

Comments inline...

On Aug 19, 2013, at 8:54 AM, Anton Tveretin <[email-masked]> wrote:

> It was: Is IKES, any other in-band and out-of-band signalling only for SIP or for other clients also? In other words, will there be validators in non-SIP networks? (or rather, do we expect them?).

The focus is clearly on SIP, but at least in IKES it allows SS7 and XMPP devices to be validators.  The question of "do we expect them?" is a hard one, because I don't have a crystal ball.  As far as I know XMPP rarely uses E.164 numbers and rarely is involved in PSTN-style calls; so I don't expect it to do IKES anytime soon.  But if XMPP usage continues to grow, it's possible that someday it might need to do it.  The SS7 side is also hard to gauge - in the US and Europe the SS7 market is basically stagnant.  One can still buy SS7 equipment from multiple vendors, but there isn't a lot of R&D spent in it.  It's possible though that a SS7 STP be upgraded to do IKES validation, if IKES is popular enough.

> If no, we expect non-SIP networks just to transfer any extra information transparently (as UUI). So do not bother gatekeepers with it.

I expect that to also occur, yes.

> If yes, that information should be delivered to wherever a validator might be.

The IKES mechanism is an "in-band" one.  An in-band mechanism follows the call signaling path, by definition.  If the validator is not in the call signaling path, I don't believe it's in scope for an in-band mechanism.

> Also, I think PSTN/ISDN is "sterile" and trusted. I do not expect validators to be deployed inside native PSTN soon, but ingress gateway must try their best.

I doubt ingress gateways to the PSTN will perform validation.

> I see one more problem here: how to supply keys (certificates) there?

There have been several proposals for how the keys/certs are retrieved by validators.  The CIDER draft is one, and draft-4474bis has another.

-hadriel

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 19 Aug 2013 15:38:38 -0400

On 8/19/13 9:50 AM, Hadriel Kaplan wrote:

> The focus is clearly on SIP, but at least in IKES it allows SS7 and XMPP devices to be validators.  The question of "do we expect them?" is a hard one, because I don't have a crystal ball.
> As far as I know XMPP rarely uses E.164 numbers and rarely is involved in PSTN-style calls; so I don't expect it to do IKES anytime soon.  But if XMPP usage continues to grow, it's possible that someday it might need to do it.

Doesn't Google Voice use Jingle with phone numbers?

	Thanks,
	Paul