Subject: [stir] Charter revisions after IESG review

From: Richard Barnes <[email-masked]>
Date: Mon, 19 Aug 2013 10:53:52 -0400

Dear STIR,

In response to some comments from the IESG, we've made a few changes to the
STIR charter. The new proposed text has been uploaded to the datatracker:
<https://datatracker.ietf.org/doc/charter-ietf-stir/>
Diff here:
<
http://www.ietf.org/rfcdiff/rfcdiff.pyht?url1=http://www.ietf.org/charter/charter-ietf-stir-00-01.txt&url2=http://www.ietf.org/charter/charter-ietf-stir-00-03.txt

Please reply to this message by Wednesday, 21 Aug if you have any issues
with these changes.

Thanks,
--Richard

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 19 Aug 2013 15:18:38 +0000

My suggestion would be to replaced "based on the PSTN" with "based on SS7 or similar TDM technologies" or "based on circuit-switched technologies". The new text implies that SIP-based systems are not part of the PSTN.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Richard Barnes
Sent: Monday, August 19, 2013 10:54 AM
To: [email-masked]
Subject: [stir] Charter revisions after IESG review

Dear STIR,

In response to some comments from the IESG, we've made a few changes to the STIR charter. The new proposed text has been uploaded to the datatracker:
<https://datatracker.ietf.org/doc/charter-ietf-stir/>
Diff here:
<http://www.ietf.org/rfcdiff/rfcdiff.pyht?url1=http://www.ietf.org/charter/charter-ietf-stir-00-01.txt&url2=http://www.ietf.org/charter/charter-ietf-stir-00-03.txt>

Please reply to this message by Wednesday, 21 Aug if you have any issues with these changes.

Thanks,
--Richard

---

From: "Olle E. Johansson" <[email-masked]>
Date: Mon, 19 Aug 2013 17:29:25 +0200

"
 		
 	The working group welcomes input form potential implementors or operators	
 	of parts of the STIR system. 
"
form => from

I'm not very comfortable with "STIR system" either. "Platforms based on solutions created by this wg" or something along those lines would feel better.

/O

19 aug 2013 kl. 17:18 skrev Henning Schulzrinne <[email-masked]>:

> My suggestion would be to replaced “based on the PSTN” with “based on SS7 or similar TDM technologies” or “based on circuit-switched technologies”. The new text implies that SIP-based systems are not part of the PSTN.
>  
> _______________________________________________
> stir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/stir

---

From: Richard Barnes <[email-masked]>
Date: Mon, 19 Aug 2013 11:56:44 -0400

On Mon, Aug 19, 2013 at 11:18 AM, Henning Schulzrinne <
[email-masked]> wrote:

>  My suggestion would be to replaced “based on the PSTN” with “based on
> SS7 or similar TDM technologies” or “based on circuit-switched
> technologies”. The new text implies that SIP-based systems are not part of
> the PSTN.
>

Thanks.  Revised to "circuit-switched technologies" in my working copy.
--Richard

> ****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Richard Barnes
> *Sent:* Monday, August 19, 2013 10:54 AM
> *To:* [email-masked]
> *Subject:* [stir] Charter revisions after IESG review****
>
> ** **
>
> Dear STIR,****
>
> ** **
>
> In response to some comments from the IESG, we've made a few changes to
> the STIR charter. The new proposed text has been uploaded to the
> datatracker:****
>
> <https://datatracker.ietf.org/doc/charter-ietf-stir/>****
>
> Diff here:****
>
> <
> >****
> ** **
> with these changes.****
> ** **
> Thanks,****
> --Richard****
> ** **
> ** **
> ** **
> ** **
> ** **
> ** **

---

From: Richard Barnes <[email-masked]>
Date: Mon, 19 Aug 2013 11:57:33 -0400

On Mon, Aug 19, 2013 at 11:29 AM, Olle E. Johansson <[email-masked]> wrote:

> "
>  The working group welcomes input form potential implementors or operators of
> parts of the STIR system.
> "
> form => from
>
> I'm not very comfortable with "STIR system" either. "Platforms based on
> solutions created by this wg" or something along those lines would feel
> better.
>

Revised to "... implementors or operators of technologies developed by this
working group" in my working copy.

--Richard

> My suggestion would be to replaced “based on the PSTN” with “based on SS7
> or similar TDM technologies” or “based on circuit-switched technologies”.
> The new text implies that SIP-based systems are not part of the PSTN.****
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of
>  *Richard Barnes

---

From: Hadriel Kaplan <[email-masked]>
Date: Mon, 19 Aug 2013 12:05:36 -0400

I don't know what this means:
 	It is important to note that while the main focus of this working group	
 	is telephone numbers, the STIR working group will not develop any	
 	technologies based on the PSTN.

What was the rationale behind adding that, and what was the intent?

-hadriel

---

From: Hadriel Kaplan <[email-masked]>
Date: Mon, 19 Aug 2013 14:51:34 -0400

[I got some off-list comments on my question, so sending a clarification to the list]

To be clear, I literally don't know what that text means in terms of its English meaning as it relates to this WG-to-be.
What does it mean to "not develop any technologies based on the PSTN"? 

Does it mean that we can't develop a technology which is also usable in the PSTN?  For example, does it mean we can't select IKES as part of the STIR solution, because the IKES draft also describes how to perform validation in SS7, instead of just in SIP?  Does it mean if I want to propose IKES, I need to pull out the SS7-related content?

I asked what the rationale was because usually what happens is an IESG member raises some concern about something, and addressing the concern results in such text getting added to a charter with the intention of preventing something bad from happening in the WG... but the IESG review page for the STIR charter doesn't show anything about that for this case.

-hadriel

---

From: Brian Rosen <[email-masked]>
Date: Mon, 19 Aug 2013 14:57:34 -0400

I certainly did not read the text as prohibiting the kind of thing you
proposed, but now I guess I am worried.
If we need to, we could weasel word standards text like "this bag of bits
can be carried in any signaling protocol that provides ..., such as SS7
UUI", but I would rather have the freedom to be more explicit.  Since
defining a bag of bits to be carried in UUI in no way attempts to affect
SS7 signaling, I think the concerns raised would not apply to doing that.

Brian

On Mon, Aug 19, 2013 at 2:51 PM, Hadriel Kaplan
<[email-masked]>wrote:

> To be clear, I literally don't know what that text means in terms of its
> English meaning as it relates to this WG-to-be.
> Does it mean that we can't develop a technology which is also usable in
> the PSTN?  For example, does it mean we can't select IKES as part of the
> STIR solution, because the IKES draft also describes how to perform
> validation in SS7, instead of just in SIP?  Does it mean if I want to
> propose IKES, I need to pull out the SS7-related content?
>
> I asked what the rationale was because usually what happens is an IESG
> member raises some concern about something, and addressing the concern
> results in such text getting added to a charter with the intention of
> preventing something bad from happening in the WG... but the IESG review
> page for the STIR charter doesn't show anything about that for this case.
>
> -hadriel
>
>
> datatracker:

---

From: Richard Barnes <[email-masked]>
Date: Tue, 20 Aug 2013 11:15:19 -0400

New version with a few more edits:
<https://datatracker.ietf.org/doc/charter-ietf-stir/>
<
http://www.ietf.org/rfcdiff/rfcdiff.pyht?url1=http://www.ietf.org/charter/charter-ietf-stir-00-03.txt&url2=http://www.ietf.org/charter/charter-ietf-stir-00-04.txt

---

From: Richard Barnes <[email-masked]>
Date: Tue, 20 Aug 2013 11:17:35 -0400

> page for the STIR charter doesn't show anything about that for this case.
The concern here was that some other organization (like ITU or 3GPP) could
get confused that we were going to, say, develop some new "mega-UUIE"
extension of SS7.  I think everyone here agrees that we're don't want to
change the PSTN, but we might want to use it.

IKES is clearly close to the border line, but ISTM that it's on the right
side.  It doesn't change the POTS protocols, it just uses them, and says
how to compare the authentication data to what is in SS7.  The same would
probably be true of OOB solutions that want to compare things to elements
of a PSTN call.

The updated draft I just posted incorporates Henning's suggestion:
"""
It is important to note that while the main focus of this working group
is telephone numbers, the STIR working group will not develop any
technologies based on circuit-switched technologies.
"""

Does that make any more sense?

--Richard

---

From: Hadriel Kaplan <[email-masked]>
Date: Tue, 20 Aug 2013 11:36:47 -0400

> Does that make any more sense?  

No, other than to imply we won't base our technology on ATM.  ;)

I think what you really want to say is this:
    It is important to note that while the main focus of this working group 
    is telephone numbers, the STIR working group will not develop any 
    mechanisms that require changes to circuit-switched technologies.

-hadriel

---

From: Richard Barnes <[email-masked]>
Date: Tue, 20 Aug 2013 11:41:06 -0400

>     mechanisms that require changes to circuit-switched technologies.
That works for me.  Unless people reply negatively here, I'll plan to
include it.

--Richard

---

From: Hadriel Kaplan <[email-masked]>
Date: Tue, 20 Aug 2013 11:41:29 -0400

This latest version has the following changed text:
    Expansion of the authorization mechanism to identities using the
    user@domain form is out of scope.  The work of this group is limited to
    developing a solution for telephone numbers.

I'd always assumed that something being "out of scope" didn't mean you couldn't also solve that problem at the same time with the same mechanism if you got it "for free".  But the above second sentence actually prevents it, I think.

I mention this because IKES, CIDER, and draft-4474bis happen to also cover/apply-to 'user@domain' type of identities.

-hadriel

On Aug 20, 2013, at 11:15 AM, Richard Barnes <[email-masked]> wrote:

> <http://www.ietf.org/rfcdiff/rfcdiff.pyht?url1=http://www.ietf.org/charter/charter-ietf-stir-00-03.txt&url2=http://www.ietf.org/charter/charter-ietf-stir-00-04.txt>
> 
>

---

From: Richard Barnes <[email-masked]>
Date: Tue, 20 Aug 2013 11:54:06 -0400

On Tue, Aug 20, 2013 at 11:41 AM, Hadriel Kaplan
<[email-masked]>wrote:

> I'd always assumed that something being "out of scope" didn't mean you
> couldn't also solve that problem at the same time with the same mechanism
> if you got it "for free".  But the above second sentence actually prevents
> it, I think.
>
> I mention this because IKES, CIDER, and draft-4474bis happen to also
> cover/apply-to 'user@domain' type of identities.
>
> -hadriel

I don't think that should rule out "for free".  But if there's going to be
significant effort expended, we would want a re-charter.

--Richard