Subject: [straw] Raw notes from Honolulu STRAW session

From: "Rauschenbach, Uwe (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 13 Nov 2014 02:17:36 +0000

Resending due to email errors...

Hi STRAWers,

Here are my raw notes from today's session.

Kind regards,
Uwe

WEDNESDAY, November 12, 2014
1520-1650 HST Wednesday Afternoon Session II -- Hibiscus

Agenda bashing and IETF Note Well (Chairs) 5min
======================================================
There were no changes to the agenda.

WG status (Chairs) 10min
======================================================
http://www.ietf.org/proceedings/91/slides/slides-91-straw-0.pptx  

The chair presented the status: 
Since Toronto, we have RFC7403 published. There is an individual draft proposing a resolution to the controversial debate regarding DTLS-SRTP. The STUN and RTCP drafts are active WG items.

draft-ietf-straw-b2bua-rtcp (Lorenzo M.) 30min
======================================================
http://www.ietf.org/proceedings/91/slides/slides-91-straw-3.pdf
 
Presentation (Lorenzo): 
The new version of the draft has updated the terminology to be in line with the RTP grouping taxonomy. Some changes regarding NACK/retransmissions (to avoid SRTP retransmission errors at the receiving side). Solutions mainly from RFC4588. Further, the draft now clarifies that end2end security is broken, i.e. users need to trust the B2BUA. The way this was formulated was already criticized at the list. However, if we want to avoid this controversy completely, we would need to give up Media aware and Media termination cases. However, schemes like this are already deployed.

Discussion: 
Jonathan stated that in AVTCore, there was a discussion about middleboxes modifying RTCP headers. Does straw want to give guidance regarding this as part of this draft? It was suggested that Jonathan sends this as review comment to the list.

draft-ram-straw-b2bua-dtls-srtp (Tiru R.) 30min
======================================================
http://www.ietf.org/proceedings/91/slides/slides-91-straw-3.pdf  

Chair's intro: 
In Toronto, it was criticized that this is about man-in-the-middle attacks and this will not fly. STRAW should either reduce the scope and only talk about media relays or drop the work completely. The chair asked whether there was any objection in the group to this proposal. There was none; hence, STRAW will _not_ define DTLS B2BUA behavior and only focus on media relays. 

Presentation by Tiru:
The presentation distinguishes between media relay, media aware and media termination use cases. For each mode, Tiru described security risks and possible mitigations. 

Discussion regarding the text on STIR / malicious B2BUA in media-relay section:
It was questioned why STIR usage is in scope of this document. This may create the impression that the use of this technology is required for a B2BUA. 
Change proposal: We should just cite the STIR document and state that this is a possibility to mitigate the attack, nothing more. More generally, the draft should just provide guidance to the B2BUA - "don't touch the fingerprint". Otherwise, mechanisms like STIR (and possibly others, reference them) will detect an error. 

Discussion on multi-encryption in media-aware:
Proposed changes: There might be a short section on media-aware modes and why they are currently not in the document. We should also briefly mention upcoming new activities such as draft-cheng-srtp-cloud-00) that look at separate encryption of header and payload which may provide a solution for this issue mid-term. 

Discussion on Media-terminator:
Proposed changes: Again, we could have a note that there is no end-to-end security guarantee but that the B2BUA is the endpoint of the security context, and that this document does not detail this mode further.

Way forward: update draft with these changes, then call for adoption.

Next steps (Chairs) 5min
======================================================
-	RTCP document: Review, then WGLC
-	DTLS document: Update according to discussion in this meeting, then call for adoption
-	STUN draft: not discussed here, encourage WG to read and provide comments on the list

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 12 Nov 2014 20:30:22 -1000

Here are my notes from the Straw session. (Uwe did a much better job 
than I did.)

* draft-ietf-straw-b2bua-rtcp - Lorenzo M.

media path security is the big issue – controversial elsewhere. Will 
talk about this a little later.

Christer proposes to sent notice to avtcore about this. He asks for 
people to review.

Jonathan: avtcore talked about RTP header extensions. He thinks there is 
need for some buidance on those. Asks if it should be addressed in this 
document.

Christer asked Jonathan to submit that comment as a review on this 
document. But don’t want to expand the document scope much.

* draft-ram-straw-b2bua-dtls-srtp - Tiru R.

Christer Holmberg (as chair): noted that this draft was criticized at 
IETF90 for sanctioning MiTH attacks. He asked if the group was willing 
to reduce scope to fix this. The group agreed to reduce the scope of 
this document - it won’t discuss DTLS behavior for media B2BUAs, only 
covering DTLS for media relays.

Richard Barnes (during discussion of malicious B2BUA media relay): why 
go into detail about identity mgmt.? E2E security requires identity 
management.

Jonathan Lennox: cite STIR documents and ensure we don’t break STIR.

Richard: since this is guidance for B2BUA, the guidance should be “don’t 
mess with fingerprints” because they are used by STIR, WebRTC, etc.

Richard: should briefly mention of why the out of scope modes aren’t 
being discussed. For instance, that we don’t have a solution now, but 
work is in progress. (E.g., draft…srtp-cloud.)

Jonathan (re Media Terminator): this type is by definition a MiTM.

Richard: same story here: as above, just a statement of why things 
aren’t being discussed.

Martin Dolly: ATTs definition of “end” differently (so that some 
components we are calling middleboxes are really the “end”) so some 
B2BUA middleboxes aren’t really MiTM attacks.

Richard: however you define “end”, if you have one of these between 
B2BUAs between those ends you don’t have security.

	Thanks,
	Paul

On 11/12/14 4:17 PM, Rauschenbach, Uwe (NSN - DE/Munich) wrote:
> _______________________________________________
> straw mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/straw
>