Subject: [Suit] MCUboot/Zephyr involvement

From: David Brown <[email-masked]>
Date: Fri, 15 Jun 2018 11:10:18 +0200

This week, Linaro held a SPRINT where among other things, we discussed our future direction for firmware upgrade, especially in regards to two configurations: a Secure/Non-secure dual image system on a single CPU, and a similar dual image running on two separate CPUs.

At this point, management of multiple images is not deeply discussed by the proposed documents, and I’m wondering if this kind of support would best be left to additional documentation.

One thing I’d like to consider is how multiple images could be supported by a single manifest. There are possibilities, such as concatenating the manifests, or just having to track the multiple manifests separately. Most of the fields in the manifest allow multiple instances of that field, except for the payload, where the manifest only describes a single payload. What would be the ramifications of allowing 1 or more payload blocks in the manifest?

Thanks,

David

---

From: Henk Birkholz <[email-masked]>
Date: Fri, 15 Jun 2018 11:13:35 +0200

Hello David,

thank you for brining that up! Actually, at the last SUIT Hackathon, 
follow-up Virtual Interim and then Design-Team meeting, there was a 
strong tendency to allow for more than one "payload" (and corresponding 
metadata) in one "manifest" (with its own corresponding metadata). The 
drafts do not reflect that yet, but I am under the impression that on 
one hand, this will be incorporated soon, and on the other hand, every 
"user story" that a set of corresponding requirements can be derived 
from is welcomed in the context of the SUIT information model.

Dear WG, please bash my answer, if I am writing anything misleading here :)

Viele Grüße,

Henk

On 06/15/2018 11:10 AM, David Brown wrote:
> This week, Linaro held a SPRINT where among other things, we discussed 
> our future direction for firmware upgrade, especially in regards to two 
> configurations: a Secure/Non-secure dual image system on a single CPU, 
> and a similar dual image running on two separate CPUs.
> 
> At this point, management of multiple images is not deeply discussed by 
> the proposed documents, and I’m wondering if this kind of support would 
> best be left to additional documentation.
> 
> One thing I’d like to consider is how multiple images could be supported 
> by a single manifest. There are possibilities, such as concatenating the 
> manifests, or just having to track the multiple manifests separately. 
> Most of the fields in the manifest allow multiple instances of that 
> field, except for the payload, where the manifest only describes a 
> single payload. What would be the ramifications of allowing 1 or more 
> payload blocks in the manifest?
> 
> Thanks,
> 
> David__
> 
> 
> 
> _______________________________________________
> Suit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/suit
>

---

From: David Brown <[email-masked]>
Date: Fri, 15 Jun 2018 11:35:26 +0200

Would it be helpful for me to write up my "user stories" a bit more formally?

Thanks,
David

On 6/15/18, 11:18 AM, "Henk Birkholz" <[email-masked]> wrote:

    Hello David,

    
    Viele Grüße,
    
    Henk

---

From: Brendan Moran <[email-masked]>
Date: Fri, 15 Jun 2018 09:36:48 +0000

Hi David,
That would be very helpful.

Thanks,
Brendan

> On 15 Jun 2018, at 10:35, David Brown <[email-masked]> wrote:
>

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Henk Birkholz <[email-masked]>
Date: Fri, 15 Jun 2018 11:40:09 +0200

A quick addendum.

If your require guidance or examples, the current SUIT IM draft already 
includes a set of user stories and provides a good guideline, I think

> https://tools.ietf.org/html/draft-ietf-suit-information-model-00#section-3.4

Viele Grüße,

Henk