Subject: [Suit] Add a user story for multiple image update

From: David Brown <[email-masked]>
Date: Fri, 29 Jun 2018 09:03:57 -0600

---
I'd like to propose this change to the information model to include
support for multiple image support.  I'm not sure that MFSR4 satisfies
this requirement, or we will need another security model and/or threat
to cover this case.

The situation on these devices is that there are multiple firmware
images, such as for a secure processor and an application processor.
Sometimes, these images can be upgraded independently, but we also
need to be able to capture when both must be upgraded together,
atomically.

This also applies to situations such as Arm's Trust Zone M, where a
single CPU is partitioned into a secure and a non-secure domain.

 draft-ietf-suit-information-model.md | 6 ++++++
 1 file changed, 6 insertions(+)

diff --git a/draft-ietf-suit-information-model.md b/draft-ietf-suit-information-model.md
index d534c97..7cd8410 100644
--- a/draft-ietf-suit-information-model.md
+++ b/draft-ietf-suit-information-model.md
@@ -332,6 +332,12 @@ As an OEM or developer for IoT devices, I want to protect the IP contained in th
 
 Satisfied by: MFSR7
 
+### Use Case MFCU7: Multiple Images
+
+As an OEM or developer for IoT devices containing either multiple CPUs, or a single CPU with multiple security domains, I want to be able to update these multiple firmware images either independently, or require that both be updated together, atomically, depending on the needs of the particular update.
+
+Satistfied by: ???
+
 ## Usability Requirements
 
 The following usability requirements satisfy the user stories listed above.
-- 
2.16.4

---

From: David Brown <[email-masked]>
Date: Fri, 29 Jun 2018 09:09:05 -0600

---
An update from before, linking this user story into the dependency
manifest field.

 draft-ietf-suit-information-model.md | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

index d534c97..b164330 100644
 
 Satisfied by: MFSR7
 
+### Use Case MFCU7: Multiple Images
+
+As an OEM or developer for IoT devices containing either multiple CPUs, or a single CPU with multiple security domains, I want to be able to update these multiple firmware images either independently, or require that both be updated together, atomically, depending on the needs of the particular update.
+
+Satistfied by: Manifest Field: Dependencies
+
 ## Usability Requirements
 
 The following usability requirements satisfy the user stories listed above.
@@ -465,7 +471,7 @@ Implements: Usability Requirement MFUR2
 
 A list of URI/Digest pairs that refer to other manifests by digest. The manifests that are linked in this way must be acquired and installed simultaneously in order to form a complete update.
 
-Implements: Usability Requirement MFUR3
+Implements: Usability Requirement MFUR3, User Story MFCU7
 
 ## Manifest Field: Content Key Distribution Method
 
-- 
2.16.4