Subject: Re: [sunset4] ietf-nat64 - Internet VPN clients

From: "Heatley, Nick" <[email-masked]>
Date: Wed, 16 Nov 2016 09:24:15 +0000

To learn on VPNs it would be good to record:

·         VPN client, sw version

·         Whether it is clear on whether IPsec is the protocol (some resort to SSL, some continue with IPsec)

·         Is the destination VPN gateway IPv4-only or dualstack

·         Is the VPN invoked by URL or by IP address
Only the person performing the test will discern the last 2 aspects, it is particular to their intranet.

The VPN I am most familiar with is IPsec, is stuck to an IP address destination.
If the VPN gateway is IPv4-only and you are on an IPv6-only network (without a transition tech that fixes this, for example, allowing a 192.0.0.X source) then it breaks.
This is not a NAT64 issue, this is a reachability issue.
SSL VPNs connecting via URLs have been ok AFAIK.
My expectation is that a significant # of users fall into the IPsec to IPv4-only destination category, enough to callout IPv6-only + NAT64/DNS64 as deficient. Better consensus would be good.
Nick

From: sunset4 [mailto:[email-masked]] On Behalf Of Bill Fenner
Sent: 16 November 2016 08:36
To: Lee Howard
Cc: Carlos M. Martinez; Marc Blanchet; [email-masked]
Subject: Re: [sunset4] ietf-nat64

I tried for a couple of hours; neither of my two VPN clients works properly.  I haven't noticed anything else so far.

  Bill

On Wed, Nov 16, 2016 at 3:39 PM, Lee Howard <[email-masked]<mailto:[email-masked]>> wrote:
Good question. It is not on the agenda, but it could be raised at open
mike.

However, I just opened a ticket because I can¹t access my POP mail account
when I¹m on ietf-nat64. Works fine on ietf.

Have other folks been living on ietf-nat64 this week? Any issues?

Lee

On 11/16/16, 1:24 AM, "Carlos M. Martinez" <[email-masked]<mailto:[email-masked]>> wrote:

>Hi all,
>
>do you know if this hum is happening ?
>
>-Carlos
>
>On 7 Oct 2016, at 4:12, Marc Blanchet wrote:
>
>> On 6 Oct 2016, at 15:03, Lee Howard wrote:
>>
>>> Run IPv6+NAT64 as the default IETF SSID. I've discussed with Jari and
>>> Jim, and they're only reluctant if doing this impedes participants
>>> getting work done. Does anyone have any ideas for how to show this?
>>> Volunteers?
>>
>> I would suggest to have the IETF Chair to take a humm on this during
>> the plenary.
>>
>> Marc.
>>
>>>
>>> On this list, I'd like to hear ideas about how to structure
>>> work/followup on #5 and #6.
>>>
>>> Are there other topics we should discuss?
>>>
>>> Thanks,
>>>
>>> Lee
>>
>>> _______________________________________________
>>> sunset4 mailing list
>>> [email-masked]<mailto:[email-masked]>
>>> https://www.ietf.org/mailman/listinfo/sunset4
>>
>> _______________________________________________
>> sunset4 mailing list
>> [email-masked]<mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/sunset4
>

_______________________________________________
sunset4 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sunset4

NOTICE AND DISCLAIMER
This email contains BT information, which may be privileged or confidential. It's meant only for the individual(s) or entity named above. 
If you're not the intended recipient, note that disclosing, copying, distributing or using this information is prohibited. 
If you've received this email in error, please let me know immediately on the email address above. Thank you.

We monitor our email system, and may record your emails.

EE Limited 
Registered office:Trident Place, Mosquito Way, Hatfield, Hertfordshire, AL10 9BW
Registered in England no: 02382161

EE Limited is a wholly owned subsidiary of:

British Telecommunications plc
Registered office: 81 Newgate Street London EC1A 7AJ
Registered in England no: 1800000

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Thu, 17 Nov 2016 01:16:33 +0000

Indeed, SSL VPN are usually OK (such as the one I am currently using)

-éric

From: sunset4 <[email-masked]<mailto:[email-masked]>> on behalf of "Heatley, Nick" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday 16 November 2016 at 18:24
To: Bill Fenner <[email-masked]<mailto:[email-masked]>>, Lee Howard <[email-masked]<mailto:[email-masked]>>
Cc: "Carlos M. Martinez" <[email-masked]<mailto:[email-masked]>>, Marc Blanchet <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [sunset4] ietf-nat64 - Internet VPN clients

·         VPN client, sw version

From: sunset4 [mailto:[email-masked]] On Behalf Of Bill Fenner
Sent: 16 November 2016 08:36
To: Lee Howard
Cc: Carlos M. Martinez; Marc Blanchet; [email-masked]<mailto:[email-masked]>
Subject: Re: [sunset4] ietf-nat64

  Bill

Lee

NOTICE AND DISCLAIMER

EE Limited