Subject: Re: [Supa] [netmod] SUPA drafts related to YANG model

From: Ying Cheng <[email-masked]>
Date: Sun, 2 Nov 2014 10:00:30 +0800

Hi Thomas,

Thanks for your attention and comments. Yes, you are right. Currently, SUPA is not an IETF WG. It is needed to emphasize its justification. Attached please kindly find the updated draft charter discussed in SUPA email list two weeks ago. The short description is summarised as follows.

The main goal of YMCA is to provide Yang models of vendor neutral service specific abstractions for the VPN and Inter-DCs traffic steering and tunneling network services, which allow applications to request these network services from network controllers of all types, e.g., single or multiple controllers, to be quickly and dynamically created/deleted/modified, using mechanisms for exchanging information to and from the NEs.  

Although several organizations outside and inside of the IETF have defined various schemes for the configuration of network devices and specific network controllers, none of them offer a vendor-neutral and technology-wide (i.e., L0 to L7) standardized way for applications to transmit their needs to controllers.

Thanks and best regards,
Ying

2014-11-02

Ying CHENG  程莹
China Unicom Network Technology Research Institute 中国联通网络技术研究院
Tel: +86-10-68799999-7702
Mobile: +86-18601102971

From: "Thomas D. Nadeau" <[email-masked]>
Date: October 31, 2014 at 2:39:56 PM GMT+1
To: Tina TSOU <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [netmod] SUPA drafts related to YANG model

Rather than dropping a big list of models here for “optional reading”, it might help if you explain the context and why people might spend time reviewing these. 

It should be pointed out that SUPA is not an IETF WG, so understanding where this fits into the universe and why its relevant would be helpful.

―Tom

On Oct 31, 2014:5:12 AM, at 5:12 AM, Tina TSOU <[email-masked]> wrote:

Dear all,

Some SUPA drafts related to YANG model for your reading pleasure and comments.
http://datatracker.ietf.org/doc/draft-contreras-supa-yang-network-topo/
http://datatracker.ietf.org/doc/draft-zaalouk-supa-configuration-model/

More context could be found at
http://datatracker.ietf.org/doc/search/?name=Supa&rfcs=on&activedrafts=on&sort=&by=author&author=

Document Title Date Status IPR AD / Shepherd 
Active Internet-Drafts
draft-bi-supa-gap-analysis-00Shared Unified Policy Automation (SUPA) Gap Analysis2014-09-25I-D Exists
draft-bi-supa-sdsavi-00A SUPA Use Case for SAVI2014-09-26I-D Exists
draft-cheng-supa-ddc-use-cases-01Use Cases for Distributed Data Center Applications in SUPA2014-10-27 
newI-D Exists
draft-contreras-supa-yang-network-topo-01A YANG Data Model for Network Topologies2014-10-27 
newI-D Exists
draft-karagiannis-supa-problem-statement-02Problem Statement for Shared Unified Policy Automation (SUPA)2014-10-27 
newI-D Exists
draft-pentikousis-supa-mapping-00SUPA Configuration and Policy Mapping2014-09-23I-D Exists
draft-sun-supa-openv6-use-cases-00Use case of IPv6 transition in SUPA2014-09-25I-D Exists
draft-zaalouk-supa-configuration-model-01YANG Data Model for Configuration of Shared Unified Policy Automation (SUPA)2014-10-27 
newI-D Exists
draft-zhou-supa-architecture-00The Architecture for Shared Unified Policy Automation (SUPA)2014-10-27 
newI-D Exists

Thank you,
Tina
_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

如果您错误接收了该邮件，请通过电子邮件立即通知我们。[email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除。
If you have received this email in error please notify us immediately by e-mail. Please reply to [email-masked] if you want to unsubscribe from this mail. We will immediately remove your information from our sending catalogue.

---

From: Ying Cheng <[email-masked]>
Date: Sun, 2 Nov 2014 15:30:16 +0800

Send this once more in order that Thomas can receive it.

BR,
Ying

2014-11-02

Ying CHENG  程莹

发件人： Ying Cheng
发送时间： 2014-11-02 10:00:26
收件人： netmod
抄送： supa
主题： Re: Re: [netmod] SUPA drafts related to YANG model

Hi Thomas,

Thanks and best regards,
Ying

2014-11-02

Ying CHENG  程莹

―Tom

Dear all,

Thank you,
Tina

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Fri, 31 Oct 2014 09:39:56 -0400

—Tom

> http://datatracker.ietf.org/doc/draft-contreras-supa-yang-network-topo/ <http://datatracker.ietf.org/doc/draft-contreras-supa-yang-network-topo/>
> http://datatracker.ietf.org/doc/draft-zaalouk-supa-configuration-model/ <http://datatracker.ietf.org/doc/draft-zaalouk-supa-configuration-model/>
> 
> http://datatracker.ietf.org/doc/search/?name=Supa&rfcs=on&activedrafts=on&sort=&by=author&author= <http://datatracker.ietf.org/doc/search/?name=Supa&rfcs=on&activedrafts=on&sort=&by=author&author=>
> 
> Document  <http://datatracker.ietf.org/doc/search/?sort=document&name=Supa&activedrafts=on&author=&rfcs=on&by=author>	Title  <http://datatracker.ietf.org/doc/search/?sort=title&name=Supa&activedrafts=on&author=&rfcs=on&by=author>	Date  <http://datatracker.ietf.org/doc/search/?sort=date&name=Supa&activedrafts=on&author=&rfcs=on&by=author>	Status  <http://datatracker.ietf.org/doc/search/?sort=status&name=Supa&activedrafts=on&author=&rfcs=on&by=author>	IPR  <http://datatracker.ietf.org/doc/search/?sort=ipr&name=Supa&activedrafts=on&author=&rfcs=on&by=author>	AD / Shepherd  <http://datatracker.ietf.org/doc/search/?sort=ad&name=Supa&activedrafts=on&author=&rfcs=on&by=author>
> Active Internet-Drafts
> draft-bi-supa-gap-analysis-00 <http://datatracker.ietf.org/doc/draft-bi-supa-gap-analysis/>	Shared Unified Policy Automation (SUPA) Gap Analysis	2014-09-25	I-D Exists			
> draft-bi-supa-sdsavi-00 <http://datatracker.ietf.org/doc/draft-bi-supa-sdsavi/>	A SUPA Use Case for SAVI	2014-09-26	I-D Exists			
> draft-cheng-supa-ddc-use-cases-01 <http://datatracker.ietf.org/doc/draft-cheng-supa-ddc-use-cases/>	Use Cases for Distributed Data Center Applications in SUPA	2014-10-27
> new <http://www.ietf.org/rfcdiff?url2=draft-cheng-supa-ddc-use-cases-01>	I-D Exists			
> draft-contreras-supa-yang-network-topo-01 <http://datatracker.ietf.org/doc/draft-contreras-supa-yang-network-topo/>	A YANG Data Model for Network Topologies	2014-10-27
> new <http://www.ietf.org/rfcdiff?url2=draft-contreras-supa-yang-network-topo-01>	I-D Exists			
> draft-karagiannis-supa-problem-statement-02 <http://datatracker.ietf.org/doc/draft-karagiannis-supa-problem-statement/>	Problem Statement for Shared Unified Policy Automation (SUPA)	2014-10-27
> new <http://www.ietf.org/rfcdiff?url2=draft-karagiannis-supa-problem-statement-02>	I-D Exists			
> draft-pentikousis-supa-mapping-00 <http://datatracker.ietf.org/doc/draft-pentikousis-supa-mapping/>	SUPA Configuration and Policy Mapping	2014-09-23	I-D Exists			
> draft-sun-supa-openv6-use-cases-00 <http://datatracker.ietf.org/doc/draft-sun-supa-openv6-use-cases/>	Use case of IPv6 transition in SUPA	2014-09-25	I-D Exists			
> draft-zaalouk-supa-configuration-model-01 <http://datatracker.ietf.org/doc/draft-zaalouk-supa-configuration-model/>	YANG Data Model for Configuration of Shared Unified Policy Automation (SUPA)	2014-10-27
> new <http://www.ietf.org/rfcdiff?url2=draft-zaalouk-supa-configuration-model-01>	I-D Exists			
> draft-zhou-supa-architecture-00 <http://datatracker.ietf.org/doc/draft-zhou-supa-architecture/>	The Architecture for Shared Unified Policy Automation (SUPA)	2014-10-27
> new <http://www.ietf.org/rfcdiff?url2=draft-zhou-supa-architecture-00>	I-D Exists			
> 
> 
> Thank you,
> Tina

---

From: Parviz Yegani <[email-masked]>
Date: Sun, 2 Nov 2014 21:29:11 -0800

(I'm receiving Tom's email after 2 days;) Don't know why?

Hello, Tom,

You may want to have a look at the proposed charter and the problem
statement of SUPA/YMCA. The charter should be available online. You may
find it interesting. If you want we can talk about it during the IETF
meeting (peharps during coffee break). Your point is well-taken and yes,
it's important that the folks who are interested in participating in SUPA
discussions adhere to the IETF guidelines. We're going to have a Bar BoF in
Honolulu. Hope you can join.

Thanks,
Parviz

On Fri, Oct 31, 2014 at 6:39 AM, Thomas D. Nadeau <[email-masked]>
wrote:

>
> Rather than dropping a big list of models here for “optional reading”, it
> might help if you explain the context and why people might spend time
> reviewing these.
>
> It should be pointed out that SUPA is not an IETF WG, so understanding
> where this fits into the universe and why its relevant would be helpful.
>
> —Tom
>
>
>
>    Document
> <http://datatracker.ietf.org/doc/search/?sort=document&name=Supa&activedrafts=on&author=&rfcs=on&by=author>
> Title
> <http://datatracker.ietf.org/doc/search/?sort=title&name=Supa&activedrafts=on&author=&rfcs=on&by=author>
> Date
> <http://datatracker.ietf.org/doc/search/?sort=date&name=Supa&activedrafts=on&author=&rfcs=on&by=author>
> Status
> <http://datatracker.ietf.org/doc/search/?sort=status&name=Supa&activedrafts=on&author=&rfcs=on&by=author>
> IPR
> <http://datatracker.ietf.org/doc/search/?sort=ipr&name=Supa&activedrafts=on&author=&rfcs=on&by=author> AD
> / Shepherd
> <http://datatracker.ietf.org/doc/search/?sort=ad&name=Supa&activedrafts=on&author=&rfcs=on&by=author>  Active
> Internet-Drafts  draft-bi-supa-gap-analysis-00
> <http://datatracker.ietf.org/doc/draft-bi-supa-gap-analysis/> Shared
> Unified Policy Automation (SUPA) Gap Analysis 2014-09-25 I-D Exists
>   draft-bi-supa-sdsavi-00
> <http://datatracker.ietf.org/doc/draft-bi-supa-sdsavi/> A SUPA Use Case
> for SAVI 2014-09-26 I-D Exists
>   draft-cheng-supa-ddc-use-cases-01
> <http://datatracker.ietf.org/doc/draft-cheng-supa-ddc-use-cases/> Use
> Cases for Distributed Data Center Applications in SUPA 2014-10-27
>   draft-contreras-supa-yang-network-topo-01
> <http://datatracker.ietf.org/doc/draft-contreras-supa-yang-network-topo/> A
> YANG Data Model for Network Topologies 2014-10-27
> new
> <http://www.ietf.org/rfcdiff?url2=draft-contreras-supa-yang-network-topo-01>
>  I-D Exists
>   draft-karagiannis-supa-problem-statement-02
> <http://datatracker.ietf.org/doc/draft-karagiannis-supa-problem-statement/> Problem
> Statement for Shared Unified Policy Automation (SUPA) 2014-10-27
> new
> <http://www.ietf.org/rfcdiff?url2=draft-karagiannis-supa-problem-statement-02>
>  I-D Exists
>   draft-pentikousis-supa-mapping-00
> <http://datatracker.ietf.org/doc/draft-pentikousis-supa-mapping/> SUPA
> Configuration and Policy Mapping 2014-09-23 I-D Exists
>   draft-sun-supa-openv6-use-cases-00
> <http://datatracker.ietf.org/doc/draft-sun-supa-openv6-use-cases/> Use
> case of IPv6 transition in SUPA 2014-09-25 I-D Exists
>   draft-zaalouk-supa-configuration-model-01
> <http://datatracker.ietf.org/doc/draft-zaalouk-supa-configuration-model/> YANG
> Data Model for Configuration of Shared Unified Policy Automation (SUPA)
> 2014-10-27
> new
> <http://www.ietf.org/rfcdiff?url2=draft-zaalouk-supa-configuration-model-01>
>  I-D Exists
>   draft-zhou-supa-architecture-00
> <http://datatracker.ietf.org/doc/draft-zhou-supa-architecture/> The
> Architecture for Shared Unified Policy Automation (SUPA) 2014-10-27
> Supa mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/supa
>
>

-- 
Dr. Parviz Yegani
(408) 759-1973 mobile
[email-masked]

---

From: Tina TSOU <[email-masked]>
Date: Mon, 3 Nov 2014 06:27:01 +0000

Dear Parviz and Ying,

Thanks for your prompt reply.

Dear all,

The SUPA bar BoF will be held
Where: Room South Pacific 2
When: 8 - 9:30pm Monday

You are welcome to join.

Thank you,
Tina

On Nov 3, 2014, at 6:29 AM, "Parviz Yegani" <[email-masked]<mailto:[email-masked]>> wrote:

Hello, Tom,

You may want to have a look at the proposed charter and the problem statement of SUPA/YMCA. The charter should be available online. You may find it interesting. If you want we can talk about it during the IETF meeting (peharps during coffee break). Your point is well-taken and yes, it's important that the folks who are interested in participating in SUPA discussions adhere to the IETF guidelines. We're going to have a Bar BoF in Honolulu. Hope you can join.

Thanks,
Parviz

On Fri, Oct 31, 2014 at 6:39 AM, Thomas D. Nadeau <[email-masked]<mailto:[email-masked]>> wrote:

—Tom

On Oct 31, 2014:5:12 AM, at 5:12 AM, Tina TSOU <[email-masked]<mailto:[email-masked]>> wrote:

Dear all,

Document [http://datatracker.ietf.org/images/sort-header-clear.png] <http://datatracker.ietf.org/doc/search/?sort=document&name=Supa&activedrafts=on&author=&rfcs=on&by=author>         Title [http://datatracker.ietf.org/images/sort-header-clear.png] <http://datatracker.ietf.org/doc/search/?sort=title&name=Supa&activedrafts=on&author=&rfcs=on&by=author>       Date [http://datatracker.ietf.org/images/sort-header-clear.png] <http://datatracker.ietf.org/doc/search/?sort=date&name=Supa&activedrafts=on&author=&rfcs=on&by=author>         Status [http://datatracker.ietf.org/images/sort-header-clear.png] <http://datatracker.ietf.org/doc/search/?sort=status&name=Supa&activedrafts=on&author=&rfcs=on&by=author>     IPR [http://datatracker.ietf.org/images/sort-header-clear.png] <http://datatracker.ietf.org/doc/search/?sort=ipr&name=Supa&activedrafts=on&author=&rfcs=on&by=author>   AD / Shepherd [http://datatracker.ietf.org/images/sort-header-clear.png] <http://datatracker.ietf.org/doc/search/?sort=ad&name=Supa&activedrafts=on&author=&rfcs=on&by=author>
Active Internet-Drafts
draft-bi-supa-gap-analysis-00<http://datatracker.ietf.org/doc/draft-bi-supa-gap-analysis/>      Shared Unified Policy Automation (SUPA) Gap Analysis    2014-09-25      I-D Exists

draft-bi-supa-sdsavi-00<http://datatracker.ietf.org/doc/draft-bi-supa-sdsavi/>  A SUPA Use Case for SAVI        2014-09-26      I-D Exists

draft-cheng-supa-ddc-use-cases-01<http://datatracker.ietf.org/doc/draft-cheng-supa-ddc-use-cases/>      Use Cases for Distributed Data Center Applications in SUPA      2014-10-27
new<http://www.ietf.org/rfcdiff?url2=draft-cheng-supa-ddc-use-cases-01>
        I-D Exists

draft-contreras-supa-yang-network-topo-01<http://datatracker.ietf.org/doc/draft-contreras-supa-yang-network-topo/>      A YANG Data Model for Network Topologies        2014-10-27
new<http://www.ietf.org/rfcdiff?url2=draft-contreras-supa-yang-network-topo-01>
        I-D Exists

draft-karagiannis-supa-problem-statement-02<http://datatracker.ietf.org/doc/draft-karagiannis-supa-problem-statement/>  Problem Statement for Shared Unified Policy Automation (SUPA)   2014-10-27
new<http://www.ietf.org/rfcdiff?url2=draft-karagiannis-supa-problem-statement-02>
        I-D Exists

draft-pentikousis-supa-mapping-00<http://datatracker.ietf.org/doc/draft-pentikousis-supa-mapping/>      SUPA Configuration and Policy Mapping   2014-09-23      I-D Exists

draft-sun-supa-openv6-use-cases-00<http://datatracker.ietf.org/doc/draft-sun-supa-openv6-use-cases/>    Use case of IPv6 transition in SUPA     2014-09-25      I-D Exists

draft-zaalouk-supa-configuration-model-01<http://datatracker.ietf.org/doc/draft-zaalouk-supa-configuration-model/>      YANG Data Model for Configuration of Shared Unified Policy Automation (SUPA)    2014-10-27
new<http://www.ietf.org/rfcdiff?url2=draft-zaalouk-supa-configuration-model-01>
        I-D Exists

draft-zhou-supa-architecture-00<http://datatracker.ietf.org/doc/draft-zhou-supa-architecture/>  The Architecture for Shared Unified Policy Automation (SUPA)    2014-10-27
new<http://www.ietf.org/rfcdiff?url2=draft-zhou-supa-architecture-00>
        I-D Exists

Thank you,
Tina
_______________________________________________
netmod mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod

_______________________________________________
Supa mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/supa

--
Dr. Parviz Yegani
(408) 759-1973 mobile
[email-masked]<mailto:[email-masked]>

---

From: "Liushucheng (Will)" <[email-masked]>
Date: Tue, 4 Nov 2014 09:15:58 +0000

Hi Parviz,

The reason is this email was blocked by IETF mail system and asked for the supervisor to approve. Now I add Tom into subscriber and it should be OK from now on.

Regards,
Will

From: Supa [mailto:[email-masked]] On Behalf Of Parviz Yegani
Sent: Monday, November 03, 2014 1:29 PM
To: Thomas D. Nadeau
Cc: [email-masked]; [email-masked]; Tina TSOU
Subject: Re: [Supa] [netmod] SUPA drafts related to YANG model

Hello, Tom,

Thanks,
Parviz

—Tom

Dear all,

Document [http://datatracker.ietf.org/images/sort-header-clear.png] <http://datatracker.ietf.org/doc/search/?sort=document&name=Supa&activedrafts=on&author=&rfcs=on&by=author>

Title [http://datatracker.ietf.org/images/sort-header-clear.png] <http://datatracker.ietf.org/doc/search/?sort=title&name=Supa&activedrafts=on&author=&rfcs=on&by=author>

Date [http://datatracker.ietf.org/images/sort-header-clear.png] <http://datatracker.ietf.org/doc/search/?sort=date&name=Supa&activedrafts=on&author=&rfcs=on&by=author>

Status [http://datatracker.ietf.org/images/sort-header-clear.png] <http://datatracker.ietf.org/doc/search/?sort=status&name=Supa&activedrafts=on&author=&rfcs=on&by=author>

IPR [http://datatracker.ietf.org/images/sort-header-clear.png] <http://datatracker.ietf.org/doc/search/?sort=ipr&name=Supa&activedrafts=on&author=&rfcs=on&by=author>

AD / Shepherd [http://datatracker.ietf.org/images/sort-header-clear.png] <http://datatracker.ietf.org/doc/search/?sort=ad&name=Supa&activedrafts=on&author=&rfcs=on&by=author>

Active Internet-Drafts

draft-bi-supa-gap-analysis-00<http://datatracker.ietf.org/doc/draft-bi-supa-gap-analysis/>

Shared Unified Policy Automation (SUPA) Gap Analysis

2014-09-25

I-D Exists

draft-bi-supa-sdsavi-00<http://datatracker.ietf.org/doc/draft-bi-supa-sdsavi/>

A SUPA Use Case for SAVI

2014-09-26

I-D Exists

draft-cheng-supa-ddc-use-cases-01<http://datatracker.ietf.org/doc/draft-cheng-supa-ddc-use-cases/>

Use Cases for Distributed Data Center Applications in SUPA

2014-10-27

I-D Exists

draft-contreras-supa-yang-network-topo-01<http://datatracker.ietf.org/doc/draft-contreras-supa-yang-network-topo/>

A YANG Data Model for Network Topologies

2014-10-27

I-D Exists

draft-karagiannis-supa-problem-statement-02<http://datatracker.ietf.org/doc/draft-karagiannis-supa-problem-statement/>

Problem Statement for Shared Unified Policy Automation (SUPA)

2014-10-27

I-D Exists

draft-pentikousis-supa-mapping-00<http://datatracker.ietf.org/doc/draft-pentikousis-supa-mapping/>

SUPA Configuration and Policy Mapping

2014-09-23

I-D Exists

draft-sun-supa-openv6-use-cases-00<http://datatracker.ietf.org/doc/draft-sun-supa-openv6-use-cases/>

Use case of IPv6 transition in SUPA

2014-09-25

I-D Exists

draft-zaalouk-supa-configuration-model-01<http://datatracker.ietf.org/doc/draft-zaalouk-supa-configuration-model/>

YANG Data Model for Configuration of Shared Unified Policy Automation (SUPA)

2014-10-27

I-D Exists

draft-zhou-supa-architecture-00<http://datatracker.ietf.org/doc/draft-zhou-supa-architecture/>

The Architecture for Shared Unified Policy Automation (SUPA)

2014-10-27

I-D Exists

Thank you,
Tina

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 4 Nov 2014 11:55:17 +0100

> On Nov 3, 2014:6:29 AM, at 6:29 AM, Parviz Yegani <[email-masked]> wrote:
> 

	Its not me that needs to find it interesting, but the NETMOD WG. *)  Thanks for posting the references.

	—Tom

> 
> Thanks,
> Parviz
> 
> 
> 
> On Fri, Oct 31, 2014 at 6:39 AM, Thomas D. Nadeau <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> On Oct 31, 2014:5:12 AM, at 5:12 AM, Tina TSOU <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Dear all,
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/netmod <https://www.ietf.org/mailman/listinfo/netmod>
> 
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/supa <https://www.ietf.org/mailman/listinfo/supa>
> 
> 
> 
> 
> -- 
> Dr. Parviz Yegani
> (408) 759-1973 mobile
> [email-masked] <mailto:[email-masked]>

---

From: Benoit Claise <[email-masked]>
Date: Tue, 04 Nov 2014 17:14:01 +0100

Proposal: let's have the SUPA discussion on the SUPA mailing list, and 
let's avoid double-posting.

Regards, Benoit
>
>> On Nov 3, 2014:6:29 AM, at 6:29 AM, Parviz Yegani <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>> statement of SUPA/YMCA. The charter should be available online. You 
>> may find it interesting. If you want we can talk about it during the 
>> IETF meeting (peharps during coffee break). Your point is well-taken 
>> and yes, it's important that the folks who are interested in 
>> participating in SUPA discussions adhere to the IETF guidelines. 
>> We're going to have a Bar BoF in Honolulu. Hope you can join.
>
> ---Tom
>> On Fri, Oct 31, 2014 at 6:39 AM, Thomas D. Nadeau 
>> <[email-masked] <mailto:[email-masked]>> wrote:
>>
>>
>>     Rather than dropping a big list of models here for "optional
>>     reading", it might help if you explain the context and why people
>>     might spend time reviewing these.
>>
>>     It should be pointed out that SUPA is not an IETF WG, so
>>     understanding where this fits into the universe and why its
>>     relevant would be helpful.
>>
>>     ---Tom
>>
>>
>>
>>>     On Oct 31, 2014:5:12 AM, at 5:12 AM, Tina TSOU
>>>     <[email-masked]
>>>     <mailto:[email-masked]>> wrote:
>>>
>>>     Dear all,
>>>
>>>     <http://datatracker.ietf.org/doc/search/?sort=ipr&name=Supa&activedrafts=on&author=&rfcs=on&by=author>
>>>     	AD / Shepherd
>>>     <http://datatracker.ietf.org/doc/search/?sort=ad&name=Supa&activedrafts=on&author=&rfcs=on&by=author>
>>>
>>>     Active Internet-Drafts
>>>     draft-bi-supa-gap-analysis-00
>>>     <http://datatracker.ietf.org/doc/draft-bi-supa-gap-analysis/>
>>>     2014-09-25 	I-D Exists 	
>>>     <http://datatracker.ietf.org/doc/draft-bi-supa-sdsavi/> 	A SUPA
>>>     Use Case for SAVI 	2014-09-26 	I-D Exists 	
>>>     	
>>>     	
>>>     <http://datatracker.ietf.org/doc/draft-cheng-supa-ddc-use-cases/>
>>>     <http://www.ietf.org/rfcdiff?url2=draft-cheng-supa-ddc-use-cases-01>
>>>     	I-D Exists 	
>>>     	
>>>     	
>>>     <http://datatracker.ietf.org/doc/draft-contreras-supa-yang-network-topo/>
>>>     	A YANG Data Model for Network Topologies 	2014-10-27
>>>     new
>>>     <http://datatracker.ietf.org/doc/draft-karagiannis-supa-problem-statement/>
>>>     <http://datatracker.ietf.org/doc/draft-pentikousis-supa-mapping/>
>>>     SUPA Configuration and Policy Mapping 	2014-09-23 	I-D Exists 	
>>>     	
>>>     	
>>>     <http://datatracker.ietf.org/doc/draft-sun-supa-openv6-use-cases/>
>>>     	Use case of IPv6 transition in SUPA 	2014-09-25 	I-D Exists 	
>>>     	
>>>     	
>>>     <http://datatracker.ietf.org/doc/draft-zaalouk-supa-configuration-model/>
>>>     	YANG Data Model for Configuration of Shared Unified Policy
>>>     Automation (SUPA) 	2014-10-27
>>>     new
>>>     <http://www.ietf.org/rfcdiff?url2=draft-zhou-supa-architecture-00>
>>>     	I-D Exists 	
>>>     	
>>>     	
>>>
>>>
>>>
>>>     Thank you,
>>>     Tina

---

From: Kostas Pentikousis <[email-masked]>
Date: Wed, 5 Nov 2014 19:01:16 +0100

Hi Ying,

As I'm going through the charter text you sent out on Sunday, I think that partly the motivation for this work may not be clear to those who have not being working in the drafts.

A key point in the charter text is the need for "standardized interfaces between applications and network controllers of all types" [that] "could be established and automatic and programmable configuration can be achieved based on these interfaces". 

First of all, why is this proposed work falling under the OPS area? We're talking multi-vendor/level/technology programmability, and "Yang models of vendor neutral service specific abstractions for the VPN and Inter-DCs traffic". Is this the only reason? This needs to be well-described (and perhaps could be a topic for the Bar BoF or side discussions next week). Maybe another area is more appropriate? Just a thought.

Second, it's not clear in the current text why YANG is the only way to do this. Is it only because YANG is our hammer at the IETF? Should be discussed as well.

It is also not clear from the charter text who benefits (and how) from the outcomes of this WG. Obviously operators seem to like it. What about others, perhaps smaller vendors, startups, software companies? Could the kind of programmability envisioned in the drafts help those too? The needs addressed needs to be better explained.

I understand why the narrowing-down-the-scope effort has streamlined the text to avoid boiling the ocean. But maybe this standardized technology could have a wider reach and other users?

Then, perhaps we could have a presentation on the gaps that SUPA addresses compared to other existing WGs.

Finally, I second Eric: I'm not sure that YMCA is a suitable acronym for the WG.

Best regards,

Kostas

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Sat, 8 Nov 2014 12:00:27 +0100

On Sat, Nov 08, 2014 at 06:19:08PM +0800, Ying Cheng wrote:
> 
> Second, it's not clear in the current text why YANG is the only way
> to do this. Is it only because YANG is our hammer at the IETF?
> Should be discussed as well.
>
> [Ying]Good capture. We also need to discuss whether there is other
> more appropriate modeling manner.

If people make concrete proposals, ideally before the meeting, then
there is something concrete to discuss. So Kostas, what is your
proposal (so that people can come prepared and informed)?

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Kostas Pentikousis <[email-masked]>
Date: Mon, 10 Nov 2014 14:24:58 +0100

Hi Juergen,

| If people make concrete proposals, ideally before the meeting, then
| there is something concrete to discuss. So Kostas, what is your
| proposal (so that people can come prepared and informed)?

A concrete first draft of a proposal is available at https://datatracker.ietf.org/doc/draft-zaalouk-supa-configuration-model/ and https://datatracker.ietf.org/doc/draft-pentikousis-supa-mapping/, where indeed YANG is employed. That, however, does not mean that the charter (let alone the WG name) need to mention YANG but as an example. After all, "YANG is a language used to model data for the NETCONF protocol."

I don't doubt that YANG is an excellent way of doing this (hence the drafts), but this is a solution space issue, not a problem/charter issue.

Best regards,

Kostas

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 10 Nov 2014 15:33:32 +0100

> I don't doubt that YANG is an excellent way of doing this (hence the drafts), but this is a solution space issue, not a problem/charter issue.

The more precise a charter is (that is the more the charter
constraints the solution space), the more likely a WG delivers
something implementable in a reasonable amount of time. WG charters
that say the WG first has to find agreement which problem exactly to
solve, which tool to use to solve the problem, etc. have a track
record of not being very efficient.

Hence, if there are other candidates, please speak up now since this
is the time to sort this out in order to narrow down the scope of this
work and the solution space. Having a narrow solution space is a
feature, not a bug.

/js

---

From: Kostas Pentikousis <[email-masked]>
Date: Mon, 10 Nov 2014 15:58:31 +0100

Hi Juergen,

| The more precise a charter is (that is the more the charter constraints
| the solution space), the more likely a WG delivers something
| implementable in a reasonable amount of time.

I'm not sure this would do service. As for "reasonable amount of time" we could take timescales of I2RS/SFC as indicative for the duration of this work.

| WG charters that say the WG first has to find agreement which problem
| exactly to solve, which tool to use to solve the problem, etc.

<snip>

I actually would have liked to see text along the following lines (=similar to):

"The SFC working group will document a new approach to service delivery
and operation. It will produce an architecture for service function
chaining that includes the necessary protocols or protocol extensions to
convey the Service Function Chain and Service Function Path information
to nodes that are involved in the implementation of service functions
and Service Function Chains, as well as mechanisms for steering traffic
through service functions. The WG will examine existing identifier schemes,
if there is a need for such identifiers in the context of the Generic SFC
encapsulation, before defining any new identifier scheme."

For example,

NEW: 

"The [SUPA] working group will document a new approach to configuration automation by introducing multi-level and multi-technology network abstractions. It will produce an architecture for [shared unified policy automation] that includes the necessary models, protocols or protocol extensions to convey the intent of the [unified policy] in order to allow network operators to manipulate the network infrastructure as a whole rather than individual devices, as well as mechanisms for a wide range of granularity for various application needs. The WG will examine existing modeling languages, such as YANG, and protocols before defining any new ones".

OLD:

"[The WG] plans to create YANG model of general network topology and YANG model of application-specific configuration to provide topology information as applications expect and map network-wide configuration/topology into individual device-recognized configuration." (and similar language)

Best regards,

Kostas

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 10 Nov 2014 19:53:05 +0100

> I'm not sure this would do service. As for "reasonable amount of time" we could take timescales of I2RS/SFC as indicative for the duration of this work.

You think I2RS is a good model to follow? They were chartered in
February 2013. Where are they now? Is it useful if it takes several
years before the work that is actually implementable in running code
starts?

Now we are getting into an abstract discussion I do not have much time
for. Why do you not simply answer my question what the other options
are so that we can make forward progress? Why do you first want to
have a WG chartered to answer my question?

/js