Subject: [Supa] Network Topology Data Model and Network Configration Data Model

From: Tina TSOU <[email-masked]>
Date: Tue, 11 Nov 2014 08:43:57 +0000

Dear all,

As time not allowed, these are the slides for agenda item: Network Topology Data Model and Network Configration Data Model, which I received.

o) Detailed YANG models - topology, configuration (if we have time)
- Andrew Qu, Adel Zaalouk
draft-contreras-supa-yang-network-topo-01<http://datatracker.ietf.org/doc/draft-contreras-supa-yang-network-topo/>
draft-zaalouk-supa-configuration-model-01<http://datatracker.ietf.org/doc/draft-zaalouk-supa-configuration-model/>

And below is the discussion minutes on Sunday afternoon Yang Advice and Editing Session.

Balazs Lengyel,<mailto:Lengyel@ericsson> Ericsson, Bert Wijnen, Nlnet, et al

Motivation:

Similar to draft-shaikh-idr-bgp-model-00<http://datatracker.ietf.org/doc/draft-shaikh-idr-bgp-model/>

Suggestions:

1. Don't use layer number. Prepare the different layer relationship. Change physical to copper or optical
2. Description of container extnodes need to be better. Write more for reasonable.
3. Reference to describes the higher and lower relationship.
4. Status need to include those status from lower layers.
5. Multi-control through different controller to the same YANG model. How to handle this?
6. adminStatus and operStatus should use the common Yang type? Don't have it now YANG common type rfc (rfc6991).
7. Define the same type and refer it multiple times at least in the same draft. Don't define it many times with similar definition.
8. Similar definitions can be defined as groups.
9. There is one guide as rfc6887.
10.ID should use the YANG type UUID.
11.rfc7224, interface-type should be referred.
12.rfc6087 defaults. Check the "config" meanings.
13.Kbps already has the unit statements in RFC6020.

Thank you,
Tina

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 11 Nov 2014 10:17:05 +0100

> As time not allowed, these are the slides for agenda item: Network Topology Data Model and Network Configration Data Model, which I received.

In the IP world, we usually talk about nodes, links, and interfaces.
And interfaces have been generalized to cover multiple layers. Is
there a specific reason why you prefer the term 'TerminationPoint'?
How is a 'TerminationPoint' different from an interface (and what
is the relationship between them)?

What is the difference of this topology data model from other
proposals on the table, such as draft-clemm-i2rs-yang-network-topo-01
and draft-hares-i2rs-info-model-service-topo-01 (there there might
be more)?

If topology data models are crucial for 'northbound' applications, why
is lets say draft-zaalouk-supa-configuration-model-01 not using a
topology data model but instead coming up with its own notion of
interfaces and node identifiers?

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>
Date: Thu, 13 Nov 2014 11:47:51 +0000

Hi all,

As a general consideration there is a need to develop models to help the operators to perform actions in the network in a uniform manner without dealing with the specific details of the technology implementations. The most clear action is the creation of services. To reach that goal topology abstractions are needed, able to cover network areas end-to-end (from access to interconnection), in a comprehensive way.

So, from that point of view, I support the work of this group.

Regards

Luis

De: Tina TSOU [mailto:[email-masked]]
Enviado el: martes, 11 de noviembre de 2014 9:44
Para: [email-masked]
CC: [email-masked]; LUIS MIGUEL CONTRERAS MURILLO; [email-masked]; xiechf; sunqiong; 'Hui Deng'; [email-masked]
Asunto: Network Topology Data Model and Network Configration Data Model

Dear all,

Motivation:

Suggestions:

Thank you,
Tina

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Tina TSOU <[email-masked]>
Date: Thu, 13 Nov 2014 16:22:48 +0000

Begin forwarded message:

From: Chongfeng Xie <[email-masked]<mailto:[email-masked]>>
Date: November 11, 2014 at 10:18:57 PM HST
To: Tina.Tsou.Zouting <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: Network Topology Data Model and Network Configration Data Model

Dear all,

         I think network topology abstraction and the related work being done in SUPA will be very valuable for opertors , especially to lower the threshold and increase the speed of service creation,  so I support of this working group. Thanks

Chongfeng Xie

From: Tina TSOU<mailto:[email-masked]>
Date: 2014-11-11 16:43
To: [email-masked]<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>; LUIS MIGUEL CONTRERAS MURILLO<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; xiechf<mailto:[email-masked]>; sunqiong<mailto:[email-masked]>; 'Hui Deng'<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Network Topology Data Model and Network Configration Data Model
Dear all,

Motivation:

Suggestions:

Thank you,
Tina