Subject: [Supa] Minutes from today's call

From: JF Tremblay <[email-masked]>
Date: Mon, 23 Feb 2015 11:16:04 -0500

Very rough minutes below. The sound was cutting from time to time. 

SUPA Interim Meeting 
2015-02-23
--------------------

Present:

Lou Berger
Marc Blanchet
JF Tremblay
Tina Tsou
Georgios Karagiannis
Dan Romascanu
Benoit Claise
Juergen Schoenwaelder

(Susan Hares absent, sick)

Lou: 
- I can present TEAS documents. It's all in the proceedings I sent anyway. 
- Comes CCAMP and PCE. 
- Responsibility for core RSVP. 
- Specifics happen in MPLS for packets, CCAMP for everything else.
- Yang models that covers the breadth of TE, config and operational state. 
- Includes RSVP in scope, but beyond TE signaling. 
- Includes topologies and tunnels. Physical and virtual topologies and nodes. 
- Two design teams. One formal design team focused on TE topologies. 
- Models covers TE types (basic definition of common types for traffic engineering, 
TE interfaces, TE topologies, tunnels (similar to services), signaling of RSVP and RSVP-TE)
- Not sure where the routing TE extensions will end up. 
- If you hear there are holes in the models, we'd love to hear about it. 
- We don't expect everything to be complete for Dallas. 

Dan: 
- A few clarification questions: 
- What is in scope for topology.

Lou: 
- The scope is around TE. 
- But some tunnels may not be RSVP-TE controlled. 

Benoit:
- Thanks for sharing. 
- What is the link with I2RS? Is that one generic and yours specific to TE?

Lou
- I2RS worries about non-TE topologies only. Probably also about L2VPN and L3VPN, but you should ask Sue.
- The TE toplogy would include the resources. 
- How the two bind together is a bit of an open question. 
- Both should relate. We should see how in 6 to 9 months. 
- Expectations is to have them being complementary. 

Benoit: 
- I expected I2RS to be generic and TE a subset of it. 
- You mentioned resources information. Which TE resources. 

Lou
- That would come from the routing protocol. 
- What kind of switching, link capacity, what's available. 
- Once the documents are done, we'll synch up. 
- We haven't tried to do that synchronization before we have documents. 
- I hope to do it without changing what has a already be advanced. 
- We only represent information necessary to represent TE. 
- I fully expect it to be a subset of what has been done. 
- Information model coming from ITU-T

Dan: 
- What about policy?

Lou:
- We've always dealt with policy in routing groups. 
- It's always implicit that there's always policy in routing
- There hasn't been a lot of effort to standardize 
- Having a common language, for example with RTSL
- There has been some resistance. 
- The COPS work was an attempt to do this, was standardized. 
- RTSL has some usage. 
- Wrote a document on policy in PCE. Wasn't enough interest. 
- To define a way to transmit policies, I think that would belong to a group that does yang. 

Benoit: 
- That would be true. 
- The policy would be on top of the topology. 
- Supa is stuck because they need the topology. 

Lou
- I tried to do it in the scope of PCE, but there was no interest. 
- I would expect I2RS to address multi-layer
- There hasn't been a lot of discussions on formalizing policy, 
but that would be a call for the ADs. 
- Policy has been addressed by the wgs, maybe not to the point everybody wants.

Tina: 
- But is this network-wide, across the whole topology?
- Isn't this orthogonal to the protocols?

Lou
- The models are network wide in the routing groups. 
- Do you think the work done in I2RS fits your need for policy?

Juerguen
- Concerning YANG, I am not aware of any specific requests to extend YANG to model topology.
- I am also not aware of any concrete requests to extend YANG to model policy - but as Dan said, this might be too early.

Lou
- If it's topology related, it belongs in I2RS, otherwise if it's TE, it belongs in TEAS.
- Look at RFC5394 - Policy enabled path computation, it explains some of the early efforts. 

Dan
- A bit of administrativa. Having people working on the bof banner would be good.
- (nobody proposed)
- We'll also need to update the bof agenda. 

Georgios: 
- I'll update the gap analysis. 

Benoit
- We'll discuss the I2RS topology next week?

Dan
- Right. John should also present. 

Benoit: 
- I have people for OpenStack and OpenNFV.

Tina: 
- And there's a volunteer to present Congress. 

Benoit
- May need to synchronize presentations from the same project. 
- If we have a small figure explaining for the banner, that would be great.
- TEAS would be doing a subset of the I2RS topology. 
- Supa would take a subset of I2RS topology and make it specific for a service. 
- The big concern from the routing guys is that they are working on this.

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 23 Feb 2015 16:17:06 +0000

Thanks for taking notes, JF!

Regards,

Dan

> -----Original Message-----
> From: Supa [mailto:[email-masked]] On Behalf Of JF Tremblay
> Sent: Monday, February 23, 2015 6:16 PM
> To: [email-masked]
> Subject: [Supa] Minutes from today's call
> 
> - Models covers TE types (basic definition of common types for traffic
> engineering, TE interfaces, TE topologies, tunnels (similar to services),
> signaling of RSVP and RSVP-TE)
> - There hasn't been a lot of discussions on formalizing policy, but that would
> be a call for the ADs.
> - I am also not aware of any concrete requests to extend YANG to model
> policy - but as Dan said, this might be too early.
> 
> Lou
> _______________________________________________
> Supa mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_supa&d=AwICAg&c=BFpWQw8bsuKpl1
> SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=p3zurV0
> PmVce5S7G2fMEjd9Jo0bSFHFeidX4rA_C0OI&s=SXh0uUuKeOYcUKS54P37Ob
> HCgSG9E2h2JsYhnz_0GmQ&e=