Subject: [Supa] draft-bi-supa-gap-analysis

From: Tina TSOU <[email-masked]>
Date: Tue, 24 Feb 2015 04:43:53 +0000

Dear Jun and JF,

Per this Monday's meeting, the gap analysis draft is one of the drafts that must be updated by Mar 9.

http://datatracker.ietf.org/doc/draft-bi-supa-gap-analysis/

Would you work on it?

I remember you signed up to work on this draft. I may miss the other people who also signed up for this. Pls team up with Jun and JF.

Thank you,
Tina

---

From: Marc Blanchet <[email-masked]>
Date: Tue, 24 Feb 2015 11:18:08 -0500

> Le 2015-02-23 à 23:43, Tina TSOU <[email-masked]> a écrit :
> 
> Dear Jun and JF,
> 
> http://datatracker.ietf.org/doc/draft-bi-supa-gap-analysis/ <http://datatracker.ietf.org/doc/draft-bi-supa-gap-analysis/>
> 
> Would you work on it?
> 

Dear Tina,

I see two kind of gap analysis:
a) a full blown internet draft with all the details of everything
b) one slide or two that describes where each wg is shown and what is supa would be doing. I could even see some graphic representation.

The overall goal is to  have a good discussion during the BOF.  From that perspective, I think we should work on b), not a).

my 2 cents.

Marc.

> 
> 
> Thank you,
> Tina
> _______________________________________________
> Supa mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/supa

---

From: Ying Cheng <[email-masked]>
Date: Wed, 25 Feb 2015 13:59:27 +0800

Hi all,

I agree with Marc's suggestion. Slides of gap analysis with figures are more helpful for discussion.

BR,
Ying

2015-02-25 

Ying CHENG  程莹
China Unicom Network Technology Research Institute 中国联通网络技术研究院
Tel: +86-10-68799999-7702
Mobile: +86-18601102971

发件人： Marc Blanchet 
发送时间： 2015-02-25  00:21:24 
收件人： Tina Tsou 
抄送： Jun Bi; Jean-François Tremblay; [email-masked] 
主题： Re: [Supa] draft-bi-supa-gap-analysis 

Dear Jun and JF, 

Would you work on it?

Dear Tina,

my 2 cents.

Marc.

Thank you,
Tina

如果您错误接收了该邮件，请通过电子邮件立即通知我们。[email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除。
If you have received this email in error please notify us immediately by e-mail. Please reply to [email-masked] if you want to unsubscribe from this mail. We will immediately remove your information from our sending catalogue.

---

From: "Natale, Bob" <[email-masked]>
Date: Wed, 25 Feb 2015 06:44:52 +0000

+1 … should be relatively easy to represent visually and, once agreed upon, would form the basis of the corresponding I-D.

Avanti,
BobN

From: Supa [mailto:[email-masked]] On Behalf Of Ying Cheng
Sent: Wednesday, February 25, 2015 12:59 AM
To: Marc Blanchet; Tina Tsou
Cc: Jun Bi; Jean-François Tremblay; [email-masked]
Subject: Re: [Supa] draft-bi-supa-gap-analysis

Hi all,

BR,
Ying

2015-02-25
________________________________
Ying CHENG  程莹
China Unicom Network Technology Research Institute 中国联通网络技术研究院
Tel: +86-10-68799999-7702
Mobile: +86-18601102971
________________________________
发件人： Marc Blanchet
发送时间： 2015-02-25  00:21:24
收件人： Tina Tsou
抄送： Jun Bi; Jean-François Tremblay; [email-masked]<mailto:[email-masked]>
主题： Re: [Supa] draft-bi-supa-gap-analysis

Le 2015-02-23 à 23:43, Tina TSOU <[email-masked]<mailto:[email-masked]>> a écrit :

Dear Jun and JF,

Would you work on it?

Dear Tina,

my 2 cents.

Marc.

Thank you,
Tina
_______________________________________________
Supa mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/supa

如果您错误接收了该邮件，请通过电子邮件立即通知我们。[email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除<mailto:[email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除>。 If you have received this email in error please notify us immediately by e-mail. Please reply to [email-masked]<mailto:[email-masked]> if you want to unsubscribe from this mail. We will immediately remove your information from our sending catalogue.

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 25 Feb 2015 10:08:37 +0000

I agree that for the purpose of the discussions at the BOF slides are useful. However, the IETF mode of work gives preference to Internet-Drafts, and when chartering will be considered ‘are there relevant Internet-Drafts?’ is one of the questions the IESG will ask. My experience is that the IESG prefers I-Ds to powerpoint. The current I-D on gaps analysis was not updated since last September and for somebody searching and reading I-Ds the reading of this document can be mis-leading about where the team is in the discussions.

Regards,

Dan

From: Supa [mailto:[email-masked]] On Behalf Of Natale, Bob
Sent: Wednesday, February 25, 2015 8:45 AM
To: Ying Cheng; Marc Blanchet; Tina Tsou
Cc: Jun Bi; Jean-François Tremblay; [email-masked]
Subject: Re: [Supa] draft-bi-supa-gap-analysis

Avanti,
BobN

Cc: Jun Bi; Jean-François Tremblay; [email-masked]<mailto:[email-masked]>

Hi all,

BR,
Ying

2015-02-25

Dear Jun and JF,

http://datatracker.ietf.org/doc/draft-bi-supa-gap-analysis/<https://urldefense.proofpoint.com/v2/url?u=http-3A__datatracker.ietf.org_doc_draft-2Dbi-2Dsupa-2Dgap-2Danalysis_&d=AwMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=75NnaKfHSnJEyTvLp9a5KStGqK_KqY0aUr8JpCuvi2A&s=d_YdL_lV5dqUgzvEw-Y8PvZYpUd4Q0aB-mAZj_0niGc&e=>

Would you work on it?

Dear Tina,

my 2 cents.

Marc.

Thank you,
Tina
_______________________________________________
Supa mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/supa<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_supa&d=AwMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=75NnaKfHSnJEyTvLp9a5KStGqK_KqY0aUr8JpCuvi2A&s=xtw8PCJw-uH3Na6nOv2ntoPkGf7N9UkqKDggiMM681s&e=>

---

From: Tina TSOU <[email-masked]>
Date: Thu, 26 Feb 2015 15:18:35 +0000

Dear Dan et al,

Good point.

I would suggest the following template to facilitate gap analysis discussion? Proposals? Let's see who fills it quickly;)
Ideally, there should be a figure.
SUPA scope and focus: xxx
Relationship with ir2s: xxx
Relationship with teas: xxx
Relationship with OpenStack Congress: xxx
Relationship with ODL NIC: xxx

Thank you,
Tina

On Feb 25, 2015, at 6:08 PM, Romascanu, Dan (Dan) <[email-masked]<mailto:[email-masked]>> wrote:

Regards,

Dan

Avanti,
BobN

Hi all,

BR,
Ying

2015-02-25

Dear Jun and JF,

Would you work on it?

Dear Tina,

my 2 cents.

Marc.

Thank you,
Tina

---

From: "Dacheng Zhang" <[email-masked]>
Date: Fri, 27 Feb 2015 22:25:56 +0800

SUPA Scope and Focus：
SUPA will focus in the first phase on inter-datacenter traffic management in
the use case of a distributed data center, including the automated
provisioning of site-to-site virtual private networks of various types,
including service configuratioin model ,generic topology model and generic
network-level policy model. All of them describe network behaviors for a
service. Specially, the existing WG charters do not specify which WG is in
charge to provide a generic toplogy model and that SUPA is happy to work
with any WG that might get chartered to provide the generic topology model.
 
Relationship with I2RS:
I2RS defines a collection of protocol-based control or management
interfaces for route system；
SUPA can leverage the exsiting protocol and models defined I2RS;
 
Relationship with BESS:
BESS defines, specifies and extends network services based on BGP and sets
up VPNs by configurating BGP;
SUPA doesn't care how to set up VPNs by some specific protocol;
SUPA can leverage the exsiting protocol and models defined BESS;
 
Relationship with OpenStack Congress:
Congress is intended to be a general-purpose, high-level policy component of
OpenStack.  To enforce the policies across compute, storage and networking,
Congress would carve off subpolicies and send them to the appropriate
enforcement point in the cloud, Supa could be one of them in the networking
domain.
 
Relationship with TEAS:
TEAS is responsible for defining MPLS and GMPLS traffic engineering
architecture, standardizing the RSVP-TE signaling protocol, and identifying
required related control-protocol functions.
SUPA is responsible for defining ECA policy model to implement TE.
 
Relationship with I2nsf:
The relation or intersection between the SUPA and I2NSF may be in the
information and data model for policies. I2NSF does not have or care about
topologies.

发件人:  Tina TSOU <[email-masked]>
日期:  2015年2月26日 星期四 下午11:18
至:  "Romascanu, Dan (Dan)" <[email-masked]>
抄送:  Ying Cheng <[email-masked]>, Jun Bi
<[email-masked]>, Jean-François Tremblay
<[email-masked]>, Marc Blanchet
<[email-masked]>, "Natale, Bob" <[email-masked]>,
"[email-masked]" <[email-masked]>
主题:  Re: [Supa] draft-bi-supa-gap-analysis

Dear Dan et al,

Good point.

I would suggest the following template to facilitate gap analysis
discussion? Proposals? Let's see who fills it quickly;)
Ideally, there should be a figure.
SUPA scope and focus: xxx
Relationship with ir2s: xxx
Relationship with teas: xxx
Relationship with OpenStack Congress: xxx
Relationship with ODL NIC: xxx

Thank you,
Tina

On Feb 25, 2015, at 6:08 PM, Romascanu, Dan (Dan) <[email-masked]>
wrote:

> I agree that for the purpose of the discussions at the BOF slides are useful.
> However, the IETF mode of work gives preference to Internet-Drafts, and when
> chartering will be considered ‘are there relevant Internet-Drafts?’ is one of
> the questions the IESG will ask. My experience is that the IESG prefers I-Ds
> to powerpoint. The current I-D on gaps analysis was not updated since last
> September and for somebody searching and reading I-Ds the reading of this
> document can be mis-leading about where the team is in the discussions.
>  
> Regards,
>  
> Dan
>  
>  
> 
> +1 … should be relatively easy to represent visually and, once agreed upon,
> would form the basis of the corresponding I-D.
>  
> 
> Avanti,
> BobN
>  
> 
>> <https://urldefense.proofpoint.com/v2/url?u=http-3A__datatracker.ietf.org_doc
>> _draft-2Dbi-2Dsupa-2Dgap-2Danalysis_&d=AwMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dz
>> GxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=75NnaKfHSnJEyTvLp9a5KStGqK_KqY0aUr8
>> JpCuvi2A&s=d_YdL_lV5dqUgzvEw-Y8PvZYpUd4Q0aB-mAZj_0niGc&e=>
>> 
>>  
>> 
>> Would you work on it?
>> 
>>  
>> 
>> I remember you signed up to work on this draft. I may miss the other people
>> who also signed up for this. Pls team up with Jun and JF.
> 
>  
> 
> Dear Tina,
> 
>  
> 
> b) one slide or two that describes where each wg is shown and what is supa
> would be doing. I could even see some graphic representation.
> 
>  
> 
> The overall goal is to  have a good discussion during the BOF.  From that
> perspective, I think we should work on b), not a).
> 
>  
> 
> my 2 cents.
> 
>  
> 
> Marc.
> 
>  
>> 
>>  
>> 
>>  
>> 
>> Thank you,
>> 
>> Tina
>> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_li
>> stinfo_supa&d=AwMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBX
>> RucPvdrphpBsFA&m=75NnaKfHSnJEyTvLp9a5KStGqK_KqY0aUr8JpCuvi2A&s=xtw8PCJw-uH3Na
>> 6nOv2ntoPkGf7N9UkqKDggiMM681s&e=>
>  
> 如果您错误接收了该邮件，请通过电子邮件立即通知我们。请回复邮件
> [email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除
> <mailto:[email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的
> 发送目录中删除> 。 If you have received this email in error please notify us
> immediately by e-mail. Please reply to [email-masked] if you want to
> unsubscribe from this mail. We will immediately remove your information from
> our sending catalogue.
_______________________________________________ Supa mailing list
[email-masked] https://www.ietf.org/mailman/listinfo/supa

---

From: Ying Cheng <[email-masked]>
Date: Sat, 28 Feb 2015 15:06:13 +0800

Hi all,

Based upon Dacheng's texts on SUPA scope, it is proposed to add the following figure as the starting point for our further discussion.  

Any comments are welcomed and appreciated.

BR,
Ying

2015-02-28 

Ying CHENG  程莹

发件人： Dacheng Zhang 
发送时间： 2015-02-27  22:26:06 
收件人： Tina TSOU; Romascanu, Dan (Dan) 
抄送： Ying Cheng(联通集团联通网络技术研究院); Jun Bi; Jean-François Tremblay; Marc Blanchet; Natale, Bob; [email-masked] 
主题： Re: [Supa] draft-bi-supa-gap-analysis 
 
SUPA Scope and Focus：
SUPA will focus in the first phase on inter-datacenter traffic management in the use case of a distributed data center, including the automated provisioning of site-to-site virtual private networks of various types, including service configuratioin model ,generic topology model and generic network-level policy model. All of them describe network behaviors for a service. Specially, the existing WG charters do not specify which WG is in charge to provide a generic toplogy model and that SUPA is happy to work with any WG that might get chartered to provide the generic topology model.
 
Relationship with I2RS:
 
Relationship with BESS:
BESS defines, specifies and extends network services based on BGP and sets up VPNs by configurating BGP;
SUPA doesn't care how to set up VPNs by some specific protocol;
SUPA can leverage the exsiting protocol and models defined BESS;
 
Relationship with OpenStack Congress:             
Congress is intended to be a general-purpose, high-level policy component of OpenStack.  To enforce the policies across compute, storage and networking, Congress would carve off subpolicies and send them to the appropriate enforcement point in the cloud, Supa could be one of them in the networking domain.
 
Relationship with TEAS:
TEAS is responsible for defining MPLS and GMPLS traffic engineering architecture, standardizing the RSVP-TE signaling protocol, and identifying required related control-protocol functions.
SUPA is responsible for defining ECA policy model to implement TE.
 
Relationship with I2nsf:
The relation or intersection between the SUPA and I2NSF may be in the information and data model for policies. I2NSF does not have or care about topologies.

抄送: Ying Cheng <[email-masked]>, Jun Bi <[email-masked]>, Jean-François Tremblay <[email-masked]>, Marc Blanchet <[email-masked]>, "Natale, Bob" <[email-masked]>, "[email-masked]" <[email-masked]>

Dear Dan et al,

Good point.

Thank you,
Tina

On Feb 25, 2015, at 6:08 PM, Romascanu, Dan (Dan) <[email-masked]> wrote:

<!--[if mso 9]--><!--[endif]-->
I agree that for the purpose of the discussions at the BOF slides are useful. However, the IETF mode of work gives preference to Internet-Drafts, and when chartering will be considered ‘are there relevant Internet-Drafts?’ is one of the questions the IESG will ask. My experience is that the IESG prefers I-Ds to powerpoint. The current I-D on gaps analysis was not updated since last September and for somebody searching and reading I-Ds the reading of this document can be mis-leading about where the team is in the discussions. 
 
Regards,
 
Dan

 
Avanti,
BobN

Hi all,

BR,
Ying

2015-02-25 

Ying CHENG  程莹

发件人： Marc Blanchet 

Dear Jun and JF, 

 
Would you work on it?

Dear Tina,

 
my 2 cents.
 
Marc.

Thank you,
Tina
 
如果您错误接收了该邮件，请通过电子邮件立即通知我们。[email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除。 If you have received this email in error please notify us immediately by e-mail. Please reply to [email-masked] if you want to unsubscribe from this mail. We will immediately remove your information from our sending catalogue.
_______________________________________________ Supa mailing list [email-masked] https://www.ietf.org/mailman/listinfo/supa

---

From: "Natale, Bob" <[email-masked]>
Date: Sat, 28 Feb 2015 07:59:32 +0000

Hi Ying,

Looks good to me with one possible refinement and a couple of nits:

1. I don’t fully understand the implied dichotomy between “Intent” and “Policy” … are you sure they are mutually exclusive categories that completely describe some higher-order category space?  E.g., to quote from Dave Lenrow’s introduction to the “Intent Based Network Summit 2015” (slide #13), “Intent” can be seen as a subset of “Policy”:

“• Not all Policy based infrastructure or networking is Intent Based
   • All Intent based networking could be said to be policy based”

Maybe it should be something like “Intent-based Policy” and “Rules-based Policy” …?

2. Just a nit: “Supa Focus Area” should be “SUPA Focus Area”

3. The graphics might need some clean-up/normalization … e.g.:
a. The “Network Services Deployment” label on the right side should be centered across the “Intent” and “Policy” arrows
b. The “Network Services Deployment” label on the left side should be centered under the “Core API” arrows, and
c. it probably should be “boxed” in a rectangle like the “Ext Module for Rich Controller” on the right side of the “Network Manager Controller” box
d. “End User APP” seems a bit limiting … maybe just “Applications” would suffice, allowing for a broader range of using applications…?

Avanti,
BobN

From: Ying Cheng [mailto:[email-masked]]
Sent: Saturday, February 28, 2015 2:06 AM
To: Dacheng Zhang; Tina TSOU; Romascanu, Dan (Dan)
Cc: Jun Bi; Jean-François Tremblay; Marc Blanchet; Natale, Bob; [email-masked]
Subject: Re: Re: [Supa] draft-bi-supa-gap-analysis

Hi all,

BR,
Ying

2015-02-28
抄送： Ying Cheng(联通集团联通网络技术研究院); Jun Bi; Jean-François Tremblay; Marc Blanchet; Natale, Bob; [email-masked]<mailto:[email-masked]>

Relationship with I2RS:

Relationship with BESS:

Relationship with TEAS:

Relationship with I2nsf:

发件人: Tina TSOU <[email-masked]<mailto:[email-masked]>>
日期: 2015年2月26日 星期四 下午11:18
至: "Romascanu, Dan (Dan)" <[email-masked]<mailto:[email-masked]>>
抄送: Ying Cheng <[email-masked]<mailto:[email-masked]>>, Jun Bi <[email-masked]<mailto:[email-masked]>>, Jean-François Tremblay <[email-masked]<mailto:[email-masked]>>, Marc Blanchet <[email-masked]<mailto:[email-masked]>>, "Natale, Bob" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
主题: Re: [Supa] draft-bi-supa-gap-analysis

Dear Dan et al,

Good point.

Thank you,
Tina

On Feb 25, 2015, at 6:08 PM, Romascanu, Dan (Dan) <[email-masked]<mailto:[email-masked]>> wrote:
<!--[if mso 9]--> <!--[endif]-->
I agree that for the purpose of the discussions at the BOF slides are useful. However, the IETF mode of work gives preference to Internet-Drafts, and when chartering will be considered ‘are there relevant Internet-Drafts?’ is one of the questions the IESG will ask. My experience is that the IESG prefers I-Ds to powerpoint. The current I-D on gaps analysis was not updated since last September and for somebody searching and reading I-Ds the reading of this document can be mis-leading about where the team is in the discussions.

Regards,

Dan

Avanti,
BobN

Hi all,

BR,
Ying

2015-02-25

Dear Jun and JF,

Would you work on it?

Dear Tina,

my 2 cents.

Marc.

Thank you,
Tina

如果您错误接收了该邮件，请通过电子邮件立即通知我们。[email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除<mailto:[email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除>。 If you have received this email in error please notify us immediately by e-mail. Please reply to [email-masked]<mailto:[email-masked]> if you want to unsubscribe from this mail. We will immediately remove your information from our sending catalogue.
_______________________________________________ Supa mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/supa