Subject: Re: [Supa] SUPA: next potential steps after the BoF?

From: Tina TSOU <[email-masked]>
Date: Mon, 4 May 2015 09:41:17 +0000

Dear Benoit,

Thank you for your action list. This response is from the Chairs, Juergen, and John.

Replies are below in line.

Thank you,
Tina

From: Supa [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: Monday, April 27, 2015 9:58 PM
To: [email-masked]
Subject: [Supa] SUPA: next potential steps after the BoF?

Dear all,

Sorry for delaying this message for too long (vacation and other IESG issues...)

Based on my BoF summary, and discussions after the BoF, here are a couple of points/concerns I heard from the community.

- What would help is a clear definition of the different deliverables/the concrete results from a potential WG.
Answer: Various authors have started updating their drafts to take comments from IETF92 and the mail list into account. In addition, a new draft defining the policy model has been created. Discussions on the charter will start on the weekly call of next week.

-
There are already some policy efforts (in IETF YANG models): How is service-specify policy different than let's say routing policy?
Answer: First, YANG is a data model. Proliferating data models without a common framework that the data models can all plug into will simply lead to siloed data models, which impede interoperability. When policy is added to the silos, either the silos will become larger and/or more silos will be created.

Second, SUPA has two primary purposes:
1)    to define a generic policy model that can support different types of policies, and
2)    to show how a generic information model can be mapped into YANG data models

For example, in draft-strassner-supa-generic-policy-info-model-00, SUPA is defining a superset of what is shown in Fig 3 of draft-wang-netmod-yang-policy-dm-01. In this approach (which draft-wang-netmod-yang-policy-dm-01 also uses), policy is independent of the specific application, whether that is routing policy, service policy, or a generic policy for configuring or monitoring a device.

Btw, do you already have a draft on this deliverable? I've looked at draft-zaalouk-supa-vpn-service-management-model-03<http://datatracker.ietf.org/doc/draft-zaalouk-supa-vpn-service-management-model/> , and it doesn't seem to be that deliverable? From John Strassner's ppt during the BoF (page 17/18), I understand that this work is "currently not started". However, I see http://tools.ietf.org/html/draft-wang-netmod-yang-policy-dm-01, in I2RS (as mentioned in the SUPA list already).
Answer: draft-strassner-supa-generic-policy-info-model-00 was submitted on 4/28. This draft defines three models:
1)    an information model that defines a generic framework for representing policy rules of any type
2)    an information model that refines the generic framework for representing ECA Policy Rules
3)    an information model that refines the generic framework for representing intent-based policies, in the form of first-order logic

This is significant. ECA and intent-based policies are very different in syntax and semantics, but SUPA is defining a common framework for representing these and other types of policies. To keep the WG focused, only ECA and intent-based policies are proposed to be worked on in its first phase.

More importantly, after some technical corrections, draft-wang-netmod-yang-policy-dm-01 will be able to be fit into this hierarchy.

- The link with the L3SM WG should be clarified, for example in the gap analysis.
Answer: The gap analysis will be updated as well as made more complete, as requested in the BoF (e.g., with adding MEF and TMF analyses).

- The "Intend" should be be clarified, like John Strassner did during the BoF
Answer: this will be done in detail, with examples, in the next version of draft-strassner-supa-generic-policy-info-model-00.

- I also heard the following concerns. What do you answer to ...
    - the people telling that the IETF should not go into the business layer? Or that this is too early?
Answer: SUPA is not defining anything that is specific to business people. For example, OpenStack Congress defines intent-based policies as Datalog statements, but has demonstrated that this is applicable to multiple actors, and not simply network administrators.

    - the people telling that the IETF is not even in the business to develop services (note: L3SM is a generic L3VPN model)?
Answer: SUPA is focusing on standardizing mechanisms for managing services. It does not intend to manage the actual services themselves.

Regards, Benoit

---

From: Benoit Claise <[email-masked]>
Date: Mon, 11 May 2015 15:23:33 +0200

Dear Tina,

See in-line.
> *From:*Supa [mailto:[email-masked]] *On Behalf Of *Benoit Claise
> *Sent:* Monday, April 27, 2015 9:58 PM
> *To:* [email-masked]
> *Subject:* [Supa] SUPA: next potential steps after the BoF?
>
> Dear all,
>
> Based on my BoF summary, and discussions after the BoF, here are a 
> couple of points/concerns I heard from the community.
>
> - What would help is a clear definition of the different 
> deliverables/the concrete results from a potential WG.
>
> Answer: Various authors have started updating their drafts to take 
> comments from IETF92 and the mail list into account. In addition, a 
> new draft defining the policy model has been created. Discussions on 
> the charter will start on the weekly call of next week.
>
>
>
> -
>
> There are already some policy efforts (in IETF YANG models): How is 
> service-specify policy different than let's say routing policy?
> Answer: First, YANG is a data model. Proliferating data models without 
> a common framework that the data models can all plug into will simply 
> lead to siloed data models, which impede interoperability. When policy 
> is added to the silos, either the silos will become larger and/or more 
> silos will be created.
>
> For example, in draft-strassner-supa-generic-policy-info-model-00, 
> SUPA is defining a superset of what is shown in Fig 3 of 
> draft-wang-netmod-yang-policy-dm-01. In this approach (which 
> draft-wang-netmod-yang-policy-dm-01 also uses), policy is independent 
> of the specific application, whether that is routing policy, service 
> policy, or a generic policy for configuring or monitoring a device.
>
What I understood was that SUPA is specific to service policies, as 
opposed to all sort of policies.
 From the BoF slides: "SUPA defines how policy rules are used to manage 
service behavior"
And now, you are telling me that the SUPA about a generic policy policy?
>
>
> Btw, do you already have a draft on this deliverable? I've looked at 
> draft-zaalouk-supa-vpn-service-management-model-03 
> <http://datatracker.ietf.org/doc/draft-zaalouk-supa-vpn-service-management-model/> 
> , and it doesn't seem to be that deliverable? From John Strassner's 
> ppt during the BoF (page 17/18), I understand that this work is 
> "currently not started". However, I see 
> http://tools.ietf.org/html/draft-wang-netmod-yang-policy-dm-01, in 
> I2RS (as mentioned in the SUPA list already).
>
> Answer: draft-strassner-supa-generic-policy-info-model-00 was 
> submitted on 4/28. This draft defines three models:
>
> 3) an information model that refines the generic framework for 
> representing intent-based policies, in the form of first-order logic
>
> This is significant. ECA and intent-based policies are very different 
> in syntax and semantics, but SUPA is defining a common framework for 
> representing these and other types of policies. To keep the WG 
> focused, only ECA and intent-based policies are proposed to be worked 
> on in its first phase.
>
During the BoF, I understood that you wanted to create a YANG data model.
Now, you speak about an information model with 
draft-strassner-supa-generic-policy-info-model-01?

As you can see, I'm confused (disclaimer: maybe this was 
discussed/answered in a different email thread... I'm a little bit behind)

Btw, I'm not sure I've seen an answer to: how is this different than RFC 
3060?
>
> More importantly, after some technical corrections, 
> draft-wang-netmod-yang-policy-dm-01 will be able to be fit into this 
> hierarchy.
>
>
>
> Answer: The gap analysis will be updated as well as made more 
> complete, as requested in the BoF (e.g., with adding MEF and TMF 
> analyses).
>
>
>
> Answer: this will be done in detail, with examples, in the next 
> version of draft-strassner-supa-generic-policy-info-model-00.
>
>
>
> Answer: SUPA is not defining anything that is specific to business 
> people. For example, OpenStack Congress defines intent-based policies 
> as Datalog statements, but has demonstrated that this is applicable to 
> multiple actors, and not simply network administrators.
>
>
>     - the people telling that the IETF is not even in the business to 
> develop services (note: L3SM is a generic L3VPN model)?
>
> Answer: SUPA is focusing on standardizing mechanisms for managing 
> services. It does not intend to manage the actual services themselves.
>
>
Regards, Benoit
>
>
> Regards, Benoit
>
>
>
> _______________________________________________
> Supa mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/supa

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 11 May 2015 15:59:17 +0200

> discussed/answered in a different email thread... I'm a little bit behind)

The revised charter text explains that the plan is to do both.

http://cnds.eecs.jacobs-university.de/users/schoenw/supa/supa-charter-2015-05-08.txt
 
> Btw, I'm not sure I've seen an answer to: how is this different than RFC 

John's draft has details about this, see section 4.6 of
draft-strassner-supa-generic-policy-info-model-01.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Benoit Claise <[email-masked]>
Date: Mon, 11 May 2015 16:34:37 +0200

> http://cnds.eecs.jacobs-university.de/users/schoenw/supa/supa-charter-2015-05-08.txt
Thanks, I read it now.
> draft-strassner-supa-generic-policy-info-model-01.
thanks.

Regards, Benoit