Subject: [Supa] question: will SUPA be successful?

From: Benoit Claise <[email-masked]>
Date: Mon, 18 May 2015 17:48:26 +0200

Dear all,

As we know, the IETF already tried a policy core information model with 
RFC 3060 and RFC3460.
As mentioned during the call, those were not terribly successful.
What is different this time?

Regards,Benoit

---

From: Tina TSOU <[email-masked]>
Date: Mon, 18 May 2015 17:23:02 +0000

Dear Benoit,

IMHO, the existing policy initiatives inside IETF you listed in another thread are the exact reasons why SUPA would be successful this time.

Sorry my flight got delayed due to summer thunders and rain, during today's call.

Thank you,
Tina

On May 18, 2015, at 11:48 PM, Benoit Claise <[email-masked]<mailto:[email-masked]>> wrote:

Dear all,

As we know, the IETF already tried a policy core information model with RFC 3060 and RFC3460.
As mentioned during the call, those were not terribly successful.
What is different this time?

Regards,Benoit

_______________________________________________
Supa mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/supa

---

From: "Chongfeng Xie" <[email-masked]>
Date: Thu, 21 May 2015 19:04:33 +0800

I think there is text in John's I-D talking about why the information models done back in the late 90s do have problems and limitations.

Chongfeng Xie

From: Tina TSOU
Date: 2015-05-19 01:23
To: Benoit Claise
CC: Keith Burns; [email-masked]
Subject: Re: [Supa] question: will SUPA be successful?
Dear Benoit,

Thank you,
Tina

On May 18, 2015, at 11:48 PM, Benoit Claise <[email-masked]> wrote:

Dear all,

Regards,Benoit

[email-masked]

---

From: Andy Bierman <[email-masked]>
Date: Thu, 21 May 2015 10:40:08 -0700

> What is different this time?

This is a really important question.

I think CIM failed because it did not integrate with existing technology.
There was too much new stuff to implement and no consensus that
programmatic network management was interesting, let alone important.

Remember Randy Bush's "It's the CLI, Stupid!" discussion at an IETF plenary?
Nobody questioned back then that CLI is King.  Nobody admitted to
enabling SNMP-Set in their networks.  Well the data modeling got better
and now anybody trying to sell CLI as a programmatic interface is getting
laughed out of the room.

The other thing that is different is the willingness of the vendors to work
on standard YANG models. In order for the policy layer to succeed,
it needs a solid programmatic foundation on which the policy
can be implemented.

There is still a lot of new stuff to implement, but it seems more
likely it will get done this time.

> Regards,Benoit

Andy