Subject: [Supa] Milestones [Was: SUPA charter proposal]

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 9 Aug 2015 16:38:42 +0100

Just picking part of Andy's comments...

> There are no milestones mentioned at all.
> I guess this is the new normal in the IETF?

Well, I think it is also the old normal, at least for quite a few years.
Milestones are not treated a contract between the participants, but are tools used between the chairs and the AD.

This is notwithstanding RFC 2418 that is much more assertive...

   Hence, a charter is a contract between the IETF and the working group
   which is committing to meet explicit milestones and delivering
   specific "products".

Nevertheless, your question is really valid and I think it is worth taking the time now to understand how quickly a working group could deliver on this work since, as you say...

> I share Adrian's concern about taking too long to deliver (3),
> because other policy work is not going to wait for SUPA.

So it would be good to know how quickly people think they can deliver. >From my perspective, the timeline depends mainly on how much work people are willing to do. Will they work all year round, or just in the week before the cut-off deadline? Will they work constructively on text and ideas, or will they just have endless virtual interim meetings?

I can't answer those questions because I predict my input will not go deeper than a high-level review from time to time. But if some people were able to answer with "My manager has said I should spend at least 20% of my time on this if the WG is formed" then I would know how to set my expectations.

Cheers,
Adrian

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 9 Aug 2015 16:26:44 +0000

<philosophical brackets: I am in favor of specifying milestones, trying to meet them, and update them often; the E in the IETF stands for Engineering, and engineering projects typically have milestones>

 Yes, in this case it would be more useful to have milestones specified by the time the charter is approved. Let us try to draft some to help the discussion - also make sure that we have committed owners for each of the deliverables. It may seem early as this charter AFAIK did not yet enter IESG internal review, but taking into account the level of scrutiny enjoyed by SUPA, and its relation with other work in the IETF, maybe it is not too early. 

Regards,

Dan

> -----Original Message-----
> From: Supa [mailto:[email-masked]] On Behalf Of Adrian Farrel
> Sent: Sunday, August 09, 2015 6:39 PM
> To: 'Andy Bierman'; 'Benoit Claise'
> Cc: 'Eggert, Lars'; [email-masked]
> Subject: [Supa] Milestones [Was: SUPA charter proposal]
> 
> Nevertheless, your question is really valid and I think it is worth taking the
> time now to understand how quickly a working group could deliver on this
> work since, as you say...
> 
> > I share Adrian's concern about taking too long to deliver (3), because
> > other policy work is not going to wait for SUPA.
> 
> So it would be good to know how quickly people think they can deliver.
> >From my perspective, the timeline depends mainly on how much work
> people are willing to do. Will they work all year round, or just in the week
> before the cut-off deadline? Will they work constructively on text and ideas,
> or will they just have endless virtual interim meetings?
> 
> I can't answer those questions because I predict my input will not go deeper
> than a high-level review from time to time. But if some people were able to
> answer with "My manager has said I should spend at least 20% of my time on
> this if the WG is formed" then I would know how to set my expectations.
> 
> Cheers,
> Adrian
>

---

From: Andy Bierman <[email-masked]>
Date: Sun, 9 Aug 2015 09:42:02 -0700

On Sun, Aug 9, 2015 at 8:38 AM, Adrian Farrel <[email-masked]> wrote:

> Milestones are not treated a contract between the participants, but are
> tools used between the chairs and the AD.
>
>

IMO this is a bug not a feature.
I understand that engineers don't like to
be told how fast to work. "It will be done
when I say it's done" is much more satisfying
to engineers.

As somebody who has often needed to explain to bosses or customers
why any answer to the question "when will it be done"
is just pure speculation -- not so satisfactory.
I have to explain that the IETF cares so little about
that question that it has eliminated any pretense of schedules.

> Nevertheless, your question is really valid and I think it is worth taking
> the time now to understand how quickly a working group could deliver on
> this work since, as you say...
>
> From my perspective, the timeline depends mainly on how much work people
> are willing to do. Will they work all year round, or just in the week
> before the cut-off deadline? Will they work constructively on text and
> ideas, or will they just have endless virtual interim meetings?
>
> I can't answer those questions because I predict my input will not go
> deeper than a high-level review from time to time. But if some people were
> able to answer with "My manager has said I should spend at least 20% of my
> time on this if the WG is formed" then I would know how to set my
> expectations.
>
>

But the boss is going to ask for a duration to this 20% commitment.
The answer "between 6 months and 6 years -- nobody knows,
and nobody cares" might not help win approval.

That said, the IETF has a reputation for writing absurdly short
schedules that are almost never met. IMO it would be better
to attempt to write realistic schedules, instead of just eliminate them.

Cheers,
> Adrian

Andy

---

From: John Strassner <[email-masked]>
Date: Sun, 9 Aug 2015 14:07:39 -0700

I will likely spend at least 40% of my time, split between IETF and TMF,
working on policy design and implementation (i.e., code).

HTH and kind regards,
John

On Sun, Aug 9, 2015 at 8:38 AM, Adrian Farrel <[email-masked]> wrote:

> _______________________________________________
> Supa mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/supa
>

-- 
regards,
John

---

From: Benoit Claise <[email-masked]>
Date: Wed, 12 Aug 2015 18:32:11 +0200

So do I, I prefer to have realistic milestones at charter time, like 
commitments from the WG.
So far, my top priority has been to evaluate if we could converge on the 
BoF open issues.

For committed owners, I believe this is a little early. We're not after 
editors at this point in time.
Note: Dan is correct, this charter has not yet entered IESG internal review.

Regards, Benoit

> .