Subject: Re: [Supa] Information models and Data models - WG adoption?

From: Zhoutianran <[email-masked]>
Date: Tue, 8 Mar 2016 07:58:37 +0000

> 1. A good way to answer that is with several other questions, e.g.: "Before
> YANG there was what?" "After YANG there will be what?" "From the broader
> marketplace perspective, how many other non-YANG approaches to DM expression
> must/should be supported?"

If YANG DM is not the only derivable DM in this WG, I would like to withdraw this question.

> -----Original Message-----
> From: Natale, Bob [mailto:[email-masked]]
> Sent: Tuesday, March 08, 2016 3:26 PM
> To: Zhoutianran; [email-masked]
> Cc: SUPA list
> Subject: RE: [Supa] Information models and Data models - WG adoption?
> 
> Hi Tianran,
> 
> From a distant lurker (calibrate accordingly)....
> 
> From some of your other posts, I believe you already know the answers to
> your questions below, so please don't consider my responses here to be a
> sign of disrespect ... but I hate to see such questions left dangling, so
> just to close the loop, so to speak:
> 
> 1. A good way to answer that is with several other questions, e.g.: "Before
> YANG there was what?" "After YANG there will be what?" "From the broader
> marketplace perspective, how many other non-YANG approaches to DM expression
> must/should be supported?"
> 
> 2. Established knowledge. RFC 3444, for a start.
> 
> 3. See #1 and #2 above.
> 
> While it is often pragmatically utilitarian for the IETF to take a narrow
> view about WHAT to standardize -- i.e., such an approach often has a positive
> ROI for all concerned -- such is not the case for policy-based management,
> given the relative offsets from state-of-practice to need. However (while
> this is not my position), it is reasonable to suggest that in such cases
> the IETF should decline to pursue the requisite standards and hand that
> task off to some other SDO. That's a more reasonable position when it is
> NOT accompanied by a decision to pursue yet-another-niche-solution (YANS)
> in the interim. In the PBM case, it is the plethora of YANS in the absence
> of a general model that is now an equal contributor (along with the nature
> of the beast itself)  to the complexity of finding a more general solution.
> (Note that "more general" does not equate to a "universal" solution ...
> solution scope should be slightly problem space and marketplace driven
> however.)
> 
> As Juergen has noted since I started composing this post, the more general
> solution adds a time delay relative to the possibility of any viable discrete
> solution. However, if my assertion that each new such discrete solution
> merely adds to both the need for and the difficulty of designing the more
> general solution is true, then ... well, you can do the math for yourself.
> 
> Avanti,
> BobN
> 
> -----Original Message-----
> From: Supa [mailto:[email-masked]] On Behalf Of Zhoutianran
> Sent: Sunday, March 06, 2016 10:49 PM
> To: [email-masked]
> Cc: SUPA list <[email-masked]>
> Subject: Re: [Supa] Information models and Data models - WG adopion?
> 
> Hi Jason,
> 
> >As for the information model versus data model discussion, I think that
> an information model is required to allow for different data models to follow
> a common structure.
> 
> >The architecture document would define the role of the information
> >model clearly
> 
> I would very like to see this been discussed and addressed in the architecture
> document.
> Especially,
> 1. How the information model can help data model generation if we know we
> will deliver YANG DMs? I mean on one hand we can improve the information
> model, then generate a YANG DM; on the other hand, we can just work on a
> YANG DMs and improve it. What's the difference?
> 2. What should be defined in IM, what in DM. Best with some examples. After
> all, IM cannot be used in a system implementation, we need DMs.
> 3. We can define a YANG DM with "augment", "grouping-use", or design items
> with "type-value" pair. So that there will be generic DM and specific DM.
> Then how can IM be more for DM.
> 
> If those could be address, I think that will be much help.
> 
> Best,
> Tianran
> 
> > -----Original Message-----
> > From: Jason Coleman (colemaj) [mailto:[email-masked]] On Behalf Of
> > colemaj
> > Sent: Saturday, March 05, 2016 1:28 AM
> > To: King, Daniel; Bert Wijnen (IETF); Joel M. Halpern; Andy Bierman;
> > John Strassner; Zhoutianran
> > Cc: Nevil Brownlee; SUPA list
> > Subject: Re: [Supa] Information models and Data models - WG adopion?
> >
> > I would like to be part of working on an architecture document as well.
> >
> > As for the information model versus data model discussion, I think
> > that an information model is required to allow for different data
> > models to follow a common structure.
> > It is possible to create a data model first, but that data model may
> > not fit in well with other data models.  This is why the information
> > model exists to allow for things that may extend that data model or
> > are in place for other data models.
> >
> > At this time the focus is on Event, Condition, Action, but there will
> > be further management structures to define.
> > The information model supports a general structure and then provides
> > details on ECA.  That general structure is important for future data models
> as well.
> > Those may be YANG or other people may chose to use the information
> > model to create a data model in a different way.
> >
> > The architecture document would define the role of the information
> > model clearly, which I think that part of the ID that John, Joel, and
> > I worked on attempts to do as well, and then can show how the data
> > models will be supported by the information model and what else the WG
> > Charter has defined and possibly where we go next.
> >
> > Jason
> >
> >
> >
> > On 3/4/16, 7:34 AM, "Supa on behalf of King, Daniel"
> > <[email-masked] on behalf of [email-masked]> wrote:
> >
> > >Hi Bert,
> > >
> > >Thank for taking the initiative. We can make sure there is time on
> > >the
> > agenda for the I-D.
> > >
> > >BR, Dan.
> > >
> > >-----Original Message-----
> > >From: Bert Wijnen (IETF) [mailto:[email-masked]]
> > >Sent: 04 March 2016 10:11
> > >To: King, Daniel <[email-masked]>; Joel M. Halpern
> > ><[email-masked]>; Andy Bierman <[email-masked]>; John
> > >Strassner <[email-masked]>; Zhoutianran
> > ><[email-masked]>
> > >Cc: Nevil Brownlee <[email-masked]>; SUPA list
> > ><[email-masked]>
> > >Subject: Re: [Supa] Information models and Data models - WG adopion?
> > >
> > >On 03/03/16 17:41, King, Daniel wrote:
> > >> Hi  All.
> > >>
> > >> We have a placeholder in the SUPA Charter for:
> > >>
> > >> 1) An explanation of the scope of the policy-based management
> > >> framework
> > and how it relates to existing work of the IETF.
> > >>
> > >> A proposal for this document has not been forthcoming thus far. It
> > >> would
> > seem that a "Policy-based Management Framework" discussing
> > architecture, applicability and relationships ("system overview")
> > would be reasonable content for a framework document mentioned in the
> Charter?
> > >>
> > >> Furthermore, Andy, Tianran and Bert all seem willing to support
> > development (via direct contributions) for the framework/architecture
> > document?
> > >Dan, I am willing to take initiative on this.
> > >
> > >I saw in one of Johns postings:
> > >    Well, we don't have an architecture document currently in our charter
> > >    (though I would support amending the charter to include this). In
> the
> > >    (now expired) proposition draft (which we are now working on to
> reissue),
> > >    there was an exemplary architecture.
> > >
> > >John, do you have the piece of text in an XML file (I-D source file)
> > >and
> > if so, can you send that to me. I assume you are OK with us using that
> > as a starting point?
> > >
> > >Dan/Nevil, if we submit an in initial I-D timely, do you think we can
> > >spend
> > some time on it in our IETF95 session?
> > >
> > >Thanks,
> > >Bert
> > >
> > >
> > >
> > >> BR, Dan.
> > >>
> > >> -----Original Message-----
> > >> From: Supa [mailto:[email-masked]] On Behalf Of Bert Wijnen
> > >> (IETF)
> > >> Sent: 03 March 2016 16:13
> > >> To: Joel M. Halpern <[email-masked]>; Andy Bierman
> > >> <[email-masked]>; John Strassner <[email-masked]>
> > >> Cc: Zhoutianran <[email-masked]>; Nevil Brownlee
> > >> <[email-masked]>; SUPA list <[email-masked]>
> > >> Subject: Re: [Supa] Information models and Data models - WG adopion?
> > >>
> > >> Inline
> > >>
> > >> On 03/03/16 16:48, Joel M. Halpern wrote:
> > >>> Two separate but related quesitons.
> > >>>
> > >>> 1) Can you help use find the places where the model / text is too
> > >>> implementation specific?  There are a few places where in
> > >>> describing enumerations the model calls for integers.  In the
> > >>> mapping to YANG, I
> > have already started replacing those with Enumerations.  Are there
> > other kinds of over-specificity?
> > >>>
> > >>> 2) The charter allows for a range of implementations of the SUPA
> > >>> system.  Folks may recall I asked in the room at the last meeting
> > >>> whether our chartered allowd both communication between a control
> > >>> system and a device, and communication between a policy repository
> > >>> and
> > a policy engine.  I was told by the AD that the chartered allowed
> > both.  This does make it rather interesting to define the "architecture".
> > >> Mmmm... both concurrently, or did he mean that we as a WG can make
> > >> a
> > choice what we prefer and standardize that?
> > >> If we do both concurrently or a longside each other, can we then
> > >> still
> > guarantee interoperability (which I think is one of our main
> > objctives, no)?
> > >>> 2') I do think that there are a few places in the model,
> > >>> particularly with regard to policy execution status, where the
> > >>> model
> > makes some assumptions about the structure of policy delivery.  For
> > the most part, those should be removed.  Assistance in finding
> > >>> them is appreciated.  I suspect that some of them are necessary,
> > >>> and
> > those should be explicitly described.   (And we should make
> > >>> sure the working group agrees with the assumptions.)
> > >>>
> > >>> 3) (minor) The charter permits the information model.  I presume
> > >>> we could
> > amend the charter to permit an architecture document.
> > >>>
> > >> I would say an "Architecture" or "System Overview" document would
> > >> be
> > a good thing.
> > >>
> > >> Bert
> > >>> Yours,
> > >>> Joel
> > >>>
> > >>> On 3/3/16 10:27 AM, Bert Wijnen (IETF) wrote:
> > >>>> Very good and practical question raised by Andy!
> > >>>>
> > >>>> Bert
> > >>>>
> > >>>> On 03/03/16 06:06, Andy Bierman wrote:
> > >>>>>
> > >>>>> On Wed, Mar 2, 2016 at 7:21 PM, John Strassner
> > >>>>> <[email-masked]
> > >>>>> <mailto:[email-masked]>>
> > >>>>> wrote:
> > >>>>>
> > >>>>>      We should work on an information model for several reasons,
> > >>>>> even
> > if
> > >>>>>      there is only target data model (i.e., YANG):
> > >>>>>
> > >>>>>        1) An information model can define how data are related to
> each
> > >>>>>           other independent of implementation. This is much
> > >>>>> harder to
> > do
> > >>>>>           in YANG. Hence, the information model may make these inherent
> > >>>>>           relationships easier to visualize and define.
> > >>>>>        2) An information model separates the logical design from the
> > >>>>>           physical design of the system, enabling a deeper
> > understanding
> > >>>>>           of both independent of implementation. This can be used
> to
> > >>>>>           produce more powerful implementations.
> > >>>>>        3) If an information model is worked on in another organization,
> > >>>>>           there is no guarantee that its output will be useful to
> the
> > >>>>>           IETF. I am active in the TM Forum, which you cited; they
> are
> > >>>>>           in general not worried about implementing YANG models, much
> > >>>>>           less producing optimal YANG models.
> > >>>>>        4) This enables other SDOs and fora, which do not use YANG,
> to
> > >>>>>           more easily understand our output.
> > >>>>>
> > >>>>>
> > >>>>>
> > >>>>> It seems to me that your draft has many details related to the
> > >>>>> abstraction of policy logic, but also many aspects that look
> > >>>>> like implementation details.
> > >>>>> Perhaps it can be simplified if the implementation details were
> > removed.
> > >>>>>
> > >>>>> I am more interested in the SUPA Architecture document first.
> > >>>>> I don't see how we can agree on an info-model in the absence of
> > >>>>> a system architecture.
> > >>>>>
> > >>>>> Does SUPA run anywhere? What does it even mean to implement SUPA?
> > >>>>> Will people be able to build interoperable SUPA engines from the
> RFCs?
> > >>>>> Is there a difference between a SUPA engine running at the
> > >>>>> device level or the controller level?  What data is available
> > >>>>> for policy enforcement analysis?
> > >>>>> Is this configurable through YANG modules implemented by a SUPA
> engine?
> > >>>>> How are policies defined and managed within the SUPA implementation?
> > >>>>> How is device config altered to implement policy?
> > >>>>> How are device operational state and statistics used to verify
> > >>>>> policy implementation?
> > >>>>>
> > >>>>> A precise description of policy logic might be a good thing to have.
> > >>>>> I am not objecting to an info model doc.  A system architecture
> > >>>>> and a workable solution will require a lot more than that.
> > >>>>>
> > >>>>>
> > >>>>>
> > >>>>>
> > >>>>>
> > >>>>>
> > >>>>>
> > >>>>>      John
> > >>>>>
> > >>>>>
> > >>>>>
> > >>>>> Andy
> > >>>>>
> > >>>>>
> > >>>>>      -----Original Message-----
> > >>>>>      From: Supa [mailto:[email-masked]
> > >>>>> <mailto:[email-masked]>] On Behalf Of Zhoutianran
> > >>>>>      Sent: Tuesday, March 01, 2016 7:29 PM
> > >>>>>      To: Nevil Brownlee
> > >>>>>      Cc: SUPA list
> > >>>>>      Subject: Re: [Supa] Information models and Data models - WG
> > adopion?
> > >>>>>
> > >>>>>      Hi Nevil,
> > >>>>>
> > >>>>>      I am not arguing information model is useless, but it can
> > >>>>> be worked out in other organizations if necessary, e.g. TMF.
> > >>>>>      If in SUPA we can worked on YANG data models directly, why
> > >>>>> we firstly work on an information model and then translate it to
> > >>>>>      YANG data model?
> > >>>>>      It just not makes sense to me.
> > >>>>>
> > >>>>>      Tianran
> > >>>>>
> > >>>>>      > -----Original Message-----
> > >>>>>      > From: Supa [mailto:[email-masked]
> > >>>>> <mailto:[email-masked]>] On Behalf Of Nevil Brownlee
> > >>>>>      > Sent: Wednesday, March 02, 2016 6:56 AM
> > >>>>>      > To: Zhoutianran
> > >>>>>      > Cc: SUPA list
> > >>>>>      > Subject: Re: [Supa] Information models and Data models -
> > >>>>> WG adopion?
> > >>>>>      >
> > >>>>>      >
> > >>>>>      > Hi Tianran:
> > >>>>>      >
> > >>>>>      > In my experiences, having a well-defined information
> > >>>>> model is a good starting
> > >>>>>      > point.  It allows different implementations, each of
> > >>>>> which can develop it's
> > >>>>>      > own data model - in other words, the information model is
> > >>>>> a good unifying
> > >>>>>      > influence - which is why publishing such a document is
> > >>>>> the second of our
> > >>>>>      > chart items.  I hope that getting a good data model will
> > >>>>> help us with the
> > >>>>>      > first chart item ("scope of the policy-based management
> > >>>>> framework").
> > >>>>>      >
> > >>>>>      > draft-strassner-supa-generic-policy-info-model is the
> > >>>>> only
> > SUPA
> > >>>>>      > information model that's had any work done on it since
> > >>>>> IETF 95, therefore
> > >>>>>      > I've proposed it for WG adoption.
> > >>>>>      >
> > >>>>>      > As for the third charter item - "set of YANG data
> > >>>>> models", there are two
> > >>>>>      > of these on the SUPA documents page.  It would help at
> > >>>>> this stage if their
> > >>>>>      > authors could comment on this list about the status of
> > >>>>> these drafts.  In
> > >>>>>      > particular, jave they been working on a new version?
> > >>>>>      >
> > >>>>>      > Overall, we really need more discussion on the list of
> > >>>>> what's happening
> > >>>>>      > with the SUPA work!
> > >>>>>      >
> > >>>>>      > Cheers, Nevil
> > >>>>>      >
> > >>>>>      >
> > >>>>>      > On 1/03/16 6:13 pm, Zhoutianran wrote:
> > >>>>>      > > If this is a poll for WG adoption, I would say not support.
> > >>>>>      > >
> > >>>>>      > > If we want to finally generate YANG data models here,
> > >>>>> why do we spend
> > >>>>>      > time working on this information model?
> > >>>>>      > >
> > >>>>>      > > Why not focus on the ECA YANG data model directly as
> > >>>>> standard track?
> > >>>>>      > >
> > >>>>>      > >
> > >>>>>      > > Tianran
> > >>>>>      > >
> > >>>>>      > >> -----Original Message-----
> > >>>>>      > >> From: Supa [mailto:[email-masked]
> > >>>>> <mailto:[email-masked]>] On Behalf Of IETF
> > >>>>>      > >> Secretariat
> > >>>>>      > >> Sent: Monday, February 29, 2016 6:35 AM
> > >>>>>      > >> To:
> > >>>>> [email-masked]
> > >>>>>
> <mailto:[email-masked]>;
> > >>>>>      > >> [email-masked] <mailto:[email-masked]>;
> > >>>>> [email-masked] <mailto:[email-masked]>
> > >>>>>      > >> Subject: [Supa] The SUPA WG has placed
> > >>>>>      > >> draft-strassner-supa-generic-policy-info-model in
> > >>>>> state "Call For
> > >>>>>      > >> Adoption By WG Issued"
> > >>>>>      > >>
> > >>>>>      > >>
> > >>>>>      > >> The SUPA WG has placed
> > >>>>> draft-strassner-supa-generic-policy-info-model
> > >>>>>      > >> in state Call For Adoption By WG Issued (entered by
> > >>>>> Nevil
> > >>>>> Brownlee)
> > >>>>>      > >>
> > >>>>>      > >> The document is available at
> > >>>>>      > >>
> > >>>>>      >
> > >>>>>
> > https://datatracker.ietf.org/doc/draft-strassner-supa-generic-policy-
> > >>>>>      > >> i
> > >>>>>      > >> nfo-model/
> > >>>>>      > >>
> > >>>>>      > >>
> > >>>>>      > >> Comment:
> > >>>>>      > >> This is the first of our charter documents, the other
> > >>>>> charter items
> > >>>>>      > >> build on this
> > >>>>>      > >>
> > >>>>>      > >> _______________________________________________
> > >>>>>      > >> Supa mailing list
> > >>>>>      > >> [email-masked] <mailto:[email-masked]>
> > >>>>>      > >> https://www.ietf.org/mailman/listinfo/supa
> > >>>>>      >
> > >>>>>      >
> > >>>>>      > --
> > >>>>>      >
> > >>>>>
> > ---------------------------------------------------------------------
> > >>>>>      >   Nevil Brownlee                          Computer Science
> > >>>>> Department
> > >>>>>      >   Phone: +64 9 373 7599 x88941             The University of
> > >>>>> Auckland
> > >>>>>      >   FAX: +64 9 373 7453   Private Bag 92019, Auckland 1142, New
> > >>>>> Zealand
> > >>>>>      >
> > >>>>>      > _______________________________________________
> > >>>>>      > Supa mailing list
> > >>>>>      > [email-masked] <mailto:[email-masked]>
> > >>>>>      > https://www.ietf.org/mailman/listinfo/supa
> > >>>>>
> > >>>>>      _______________________________________________
> > >>>>>      Supa mailing list
> > >>>>>      [email-masked] <mailto:[email-masked]>
> > >>>>>      https://www.ietf.org/mailman/listinfo/supa
> > >>>>>
> > >>>>>      _______________________________________________
> > >>>>>      Supa mailing list
> > >>>>>      [email-masked] <mailto:[email-masked]>
> > >>>>>      https://www.ietf.org/mailman/listinfo/supa
> > >>>>>
> > >>>>>
> > >>>>>
> > >>>>>
> > >>>>> _______________________________________________
> > >>>>> Supa mailing list
> > >>>>> [email-masked]
> > >>>>> https://www.ietf.org/mailman/listinfo/supa
> > >>>> _______________________________________________
> > >>>> Supa mailing list
> > >>>> [email-masked]
> > >>>> https://www.ietf.org/mailman/listinfo/supa
> > >>>>
> > >>> _______________________________________________
> > >>> Supa mailing list
> > >>> [email-masked]
> > >>> https://www.ietf.org/mailman/listinfo/supa
> > >>>
> > >> _______________________________________________
> > >> Supa mailing list
> > >> [email-masked]
> > >> https://www.ietf.org/mailman/listinfo/supa
> > >>
> > >> _______________________________________________
> > >> Supa mailing list
> > >> [email-masked]
> > >> https://www.ietf.org/mailman/listinfo/supa
> > >>
> > >
> > >_______________________________________________
> > >Supa mailing list
> > >[email-masked]
> > >https://www.ietf.org/mailman/listinfo/supa
> 
> _______________________________________________
> Supa mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/supa

---

From: "Natale, Bob" <[email-masked]>
Date: Tue, 8 Mar 2016 07:26:26 +0000

Hi Tianran,

>From some of your other posts, I believe you already know the answers to your questions below, so please don't consider my responses here to be a sign of disrespect ... but I hate to see such questions left dangling, so just to close the loop, so to speak:

1. A good way to answer that is with several other questions, e.g.: "Before YANG there was what?" "After YANG there will be what?" "From the broader marketplace perspective, how many other non-YANG approaches to DM expression must/should be supported?"

3. See #1 and #2 above.

While it is often pragmatically utilitarian for the IETF to take a narrow view about WHAT to standardize -- i.e., such an approach often has a positive ROI for all concerned -- such is not the case for policy-based management, given the relative offsets from state-of-practice to need. However (while this is not my position), it is reasonable to suggest that in such cases the IETF should decline to pursue the requisite standards and hand that task off to some other SDO. That's a more reasonable position when it is NOT accompanied by a decision to pursue yet-another-niche-solution (YANS) in the interim. In the PBM case, it is the plethora of YANS in the absence of a general model that is now an equal contributor (along with the nature of the beast itself)  to the complexity of finding a more general solution. (Note that "more general" does not equate to a "universal" solution ... solution scope should be slightly problem space and marketplace driven however.)

As Juergen has noted since I started composing this post, the more general solution adds a time delay relative to the possibility of any viable discrete solution. However, if my assertion that each new such discrete solution merely adds to both the need for and the difficulty of designing the more general solution is true, then ... well, you can do the math for yourself.

Avanti,
BobN

-----Original Message-----
From: Supa [mailto:[email-masked]] On Behalf Of Zhoutianran
Sent: Sunday, March 06, 2016 10:49 PM
To: [email-masked]
Cc: SUPA list <[email-masked]>
Subject: Re: [Supa] Information models and Data models - WG adopion?

Hi Jason,

>As for the information model versus data model discussion, I think that an information model is required to allow for different data models to follow a common structure.

>The architecture document would define the role of the information 

I would very like to see this been discussed and addressed in the architecture document.
Especially,
1. How the information model can help data model generation if we know we will deliver YANG DMs? I mean on one hand we can improve the information model, then generate a YANG DM; on the other hand, we can just work on a YANG DMs and improve it. What's the difference? 
2. What should be defined in IM, what in DM. Best with some examples. After all, IM cannot be used in a system implementation, we need DMs. 
3. We can define a YANG DM with "augment", "grouping-use", or design items with "type-value" pair. So that there will be generic DM and specific DM. Then how can IM be more for DM.

Best,
Tianran

> details on ECA.  That general structure is important for future data models as well.
> would be reasonable content for a framework document mentioned in the Charter?
> >>
> >    (though I would support amending the charter to include this). In the
> >    (now expired) proposition draft (which we are now working on to reissue),
> >>>>>        1) An information model can define how data are related to each
> >>>>>           of both independent of implementation. This can be used to
> >>>>>           there is no guarantee that its output will be useful to the
> >>>>>           IETF. I am active in the TM Forum, which you cited; they are
> >>>>>        4) This enables other SDOs and fora, which do not use YANG, to
> >>>>> Will people be able to build interoperable SUPA engines from the RFCs?
> >>>>> Is this configurable through YANG modules implemented by a SUPA engine?

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Tue, 8 Mar 2016 11:39:33 +0100

> If YANG DM is not the only derivable DM in this WG, I would like to withdraw this question.
I suppose that a YANG DM will be one of the deliverables of this WG.
And this WG will probably not do any data modeling in any other language.

But other SDOs might have/use a different language to do data modeling.
And as Bob stated, maybe a few (many) years from now, there is a YANS
(or some other data modeling language that we(IETF) like better than
YANG (I cannot yet imagine that, but that is an aside), then we may
want to re-do the YANG DM in this new language. Much like we are now
re-doing a lot of stuff in YANG modules that already exists in MIB
modules.

I do agree though that we SHOULD do the real DM as well as the IM
(in whatever form we do the IM) so that we can prove that we can define
an implementable DM.

Hope this helps.
Bert

---

From: Zhoutianran <[email-masked]>
Date: Tue, 8 Mar 2016 15:38:23 +0000

That makes sense to me.
And the DM document should be more on how to represent informaitons in YANG.
While the IM can have more words introducing what an item is and why we need an item.

Tianran
________________________________________
发件人: Bert Wijnen (IETF) [[email-masked]]
发送时间: 2016年3月8日 18:39
收件人: Zhoutianran; Natale, Bob; [email-masked]
抄送: SUPA list
主题: Re: [Supa] Information models and Data models - WG adoption?

Hope this helps.
Bert