Subject: [T2TRG] CoAP Implementation Workshop?

From: Carsten Bormann <[email-masked]>
Date: Tue, 21 Jun 2016 10:46:17 +0200

This is a heads-up that a T2TRG workshop focusing on CoAP implementation
might materialize in week 37 (w/c September 12) in the London area.

Potential topics might include:

* High-performance backend implementations
* Requirements and implementation strategies for load balancers and
  other CoAP intermediates

* Low-resource implementation strategies
* Minimal implementations, "how low can you go"
* Benefits from cross-layer optimizations with network stack

* Integrating with security
* APIs, both backend and on the constrained device

(We have an LWIG document on CoAP implementation that might also count
as input and benefit from this workshop:
https://tools.ietf.org/html/draft-ietf-lwig-coap)

If there is interest, we might also want to include CBOR implementations
for both backends and devices in the topics.

We are likely going for a submission-based approach, where the
submission might be a position paper, a blog article, a demo proposal, a
slide deck, a github repo with some interesting issue discussions...
So the participants can prepare for the workshop by finding out about
the other participants' work, ideas, and pain points.

So how does that sound?  If you are interested or might be, please drop
a line to the T2TRG list (Reply-To set up for this) or to the chairs
(Ari and me).

Grüße, Carsten

---

From: "Kovatsch, Matthias" <[email-masked]>
Date: Tue, 21 Jun 2016 10:12:29 +0000

Ups, da war ich wohl zu langsam mit meinem Kalenderabgleich. 12.9. geht leider nicht bei mir...
Im Prinzip geht es September erst nach dem T2TRG Meeting bei mir.

Ciao
Matthias

> -----Ursprüngliche Nachricht-----
> Von: T2TRG [mailto:[email-masked]] Im Auftrag von Carsten Bormann
> Gesendet: Dienstag, 21. Juni 2016 10:46
> An: [email-masked] WG; [email-masked]; [email-masked]
> Cc: Ari Keränen
> Betreff: [T2TRG] CoAP Implementation Workshop?
> 
> (We have an LWIG document on CoAP implementation that might also count as
> input and benefit from this workshop:
> If there is interest, we might also want to include CBOR implementations for both
> backends and devices in the topics.
> 
> We are likely going for a submission-based approach, where the submission
> might be a position paper, a blog article, a demo proposal, a slide deck, a github
> repo with some interesting issue discussions...
> So the participants can prepare for the workshop by finding out about the other
> participants' work, ideas, and pain points.
> 
> So how does that sound?  If you are interested or might be, please drop a line to
> the T2TRG list (Reply-To set up for this) or to the chairs (Ari and me).
> 
> Grüße, Carsten
> 
> _______________________________________________
> T2TRG mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/t2trg

---

From: "Kovatsch, Matthias" <[email-masked]>
Date: Tue, 21 Jun 2016 10:15:17 +0000

Sorry, weird behavior of the reply button... the German was meant for Carsten.
Quick translation: I will not be able to make in week 37.

Best
Matthias

> Von: T2TRG [mailto:[email-masked]] Im Auftrag von Kovatsch, Matthias
> Gesendet: Dienstag, 21. Juni 2016 12:12
> An: [email-masked]
> Betreff: Re: [T2TRG] CoAP Implementation Workshop?
> 
> > This is a heads-up that a T2TRG workshop focusing on CoAP
> > implementation might materialize in week 37 (w/c September 12) in the London
> area.
> >
> > If there is interest, we might also want to include CBOR
> > implementations for both backends and devices in the topics.
> >
> > submission might be a position paper, a blog article, a demo proposal,
> > a slide deck, a github repo with some interesting issue discussions...
> > So how does that sound?  If you are interested or might be, please
> > drop a line to the T2TRG list (Reply-To set up for this) or to the chairs (Ari and
> me).
> >
> > Grüße, Carsten
> >

---

From: Olaf Bergmann <[email-masked]>
Date: Tue, 21 Jun 2016 14:05:34 +0200

> Quick translation: I will not be able to make in week 37.

Me neither. Also not week 36 or 39.

Grüße
Olaf

---

From: Christian Groves <[email-masked]>
Date: Wed, 22 Jun 2016 10:25:41 +1000

Hello Carsten,

There was some prior discussion about having a possible T2TRG meeting in 
conjunction with the W3C TPAC meeting (19-23 September). Is the proposed 
workshop a replacement for that meeting?

Also to facilitate travel to both the T2TRG and W3C meeting it would be 
good if the T2TRG workshop was scheduled toward the end of week 37.

Regards, Christian

---

From: Ari Keränen <[email-masked]>
Date: Wed, 22 Jun 2016 17:50:24 +0000

Hi Christian,

This workshop is not planned to be a replacement for the joint meeting with W3C at Lisbon. We are still working on logistics to make that possible.

Cheers,
Ari

> On 22 Jun 2016, at 03:25, Christian Groves <[email-masked]> wrote:
> 
> Hello Carsten,
> 
> There was some prior discussion about having a possible T2TRG meeting in conjunction with the W3C TPAC meeting (19-23 September). Is the proposed workshop a replacement for that meeting?
> 
> Also to facilitate travel to both the T2TRG and W3C meeting it would be good if the T2TRG workshop was scheduled toward the end of week 37.
> 
> Regards, Christian
> 
>