Subject: [T2TRG] Fwd: New Version Notification for draft-hartke-t2trg-bulletin-board-00.txt

From: Klaus Hartke <[email-masked]>
Date: Mon, 24 Oct 2016 03:56:14 +0200

I've submitted an initial version of the "bulletin board" idea.

Feedback is welcome.

Klaus

---------- Forwarded message ----------
From:  <[email-masked]>
Date: 24 October 2016 at 03:47
Subject: New Version Notification for draft-hartke-t2trg-bulletin-board-00.txt
To: Klaus Hartke <[email-masked]>

A new version of I-D, draft-hartke-t2trg-bulletin-board-00.txt
has been successfully submitted by Klaus Hartke and posted to the
IETF repository.

Name:           draft-hartke-t2trg-bulletin-board
Revision:       00
Title:          Thing-to-Thing Bulletin Board
Document date:  2016-10-23
Group:          Individual Submission
Pages:          12
URL:
https://www.ietf.org/internet-drafts/draft-hartke-t2trg-bulletin-board-00.txt
Status:
https://datatracker.ietf.org/doc/draft-hartke-t2trg-bulletin-board/
Htmlized:       https://tools.ietf.org/html/draft-hartke-t2trg-bulletin-board-00

Abstract:
   A Thing-to-Thing Bulletin Board is a RESTful, hypermedia-driven Web
   application that can be used in Thing-to-Thing communication to
   publish information such as thing descriptions, configurations,
   resource descriptions or sleep schedules at a central location.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Alexander Pelov <[email-masked]>
Date: Tue, 25 Oct 2016 11:31:41 +0200

Dear Klaus,

Thanks for this draft, which presents a concept I would like to see explored further. 

A couple of questions:
- how does it relate to the RD?
- how do you think you’ll expire entries?
- is there any particular security model you envision? If one node publishes an item, maybe it should be the only one to be able to delete it?

Thanks again!
Alexander

> Le 24 oct. 2016 à 03:56, Klaus Hartke <[email-masked]> a écrit :
> 
> _______________________________________________
> T2TRG mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/t2trg

---

From: Klaus Hartke <[email-masked]>
Date: Tue, 25 Oct 2016 17:03:15 +0200

Hi Alex!

> - how does it relate to the RD?

On a conceptual level, resource directory and bulletin board are very
similar as both are instances of the collection pattern. The bulletin
board is slightly more general since a resource directory publishes
only links (with a growing appetite for new link attributes) and a
bulletin board can publish any representation. So it might be possible
to use a bulletin board wherever a resource directory is used; I
haven't tried to map the full feature set of resource directories to
bulletin boards yet, though. The resource directory is a working group
document anyway; the bulletin board is just a proof-of-concept.

> - how do you think you’ll expire entries?

Both publish-subscribe and resource directory allow a client to
specify a lifetime in a publication request. I guess something similar
could be done for bulletin boards.

> - is there any particular security model you envision? If one node publishes an item, maybe it should be the only one to be able to delete it?

I haven't thought about that much, yet. Both publish-subscribe and
resource directory recommend that fine-grained access control is
deployed, but do not specify a particular mechanism or any rules.

Klaus

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 25 Oct 2016 18:56:26 +0200

I haven't thought about that much, yet. Both publish-subscribe and 
resource directory recommend that fine-grained access control is 
deployed, but do not specify a particular mechanism or any rules. 
Indeed, this is really a point that RD and BB share — we need to think about good authorization models for both, and what we come up with for one of them probably will transfer well to the other one.

I believe that good authorization models for this kind of directory or BB information that glueing together a Web of things is a rather interesting research topic:

 — designs for such models

 — criteria for their evaluation

 — scenarios and benchmarks we want to use for those.

(And, yes, W3C WoT has the same problem with their TD repository.)

Grüße, Carsten

---

From: Alexander Pelov <[email-masked]>
Date: Wed, 26 Oct 2016 14:01:48 +0200

Thanks Carsten and Klaus,

I agree with you that this is a tough one to be solved. In general, when you see the same problem popping up in different places, it may be a symptom of trying to do too much, or simply being too complex of an issue (with no single simple solution).

I’d be very interested in following the discussions around this question, though. 

Best,
Alexander

PS.
Maybe a good exercice could be to write RD as a BB app (the way you did for PubSub).

> Le 25 oct. 2016 à 18:56, Carsten Bormann <[email-masked]> a écrit :
> 
> On 25 October 2016 at 17:04:18, Klaus Hartke ([email-masked] <mailto:[email-masked]>) wrote:
> [email-masked] <mailto:[email-masked]>
> https://www.irtf.org/mailman/listinfo/t2trg <https://www.irtf.org/mailman/listinfo/t2trg>