Subject: [T2TRG] Save the date: July 15/16, 2017: Workshop on IoT Semantic/Hypermedia Interoperability (at IETF99 in Prague)

From: Ari Keränen <[email-masked]>
Date: Thu, 4 May 2017 15:45:46 +0000

Save the date July 15/16, 2017 for Workshop on IoT Semantic/Hypermedia Interoperability, in Prague at IETF99.

See the description below and up to date information with registration instructions here: https://github.com/t2trg/2017-07-wishi

Cheers,
Ari & Carsten

One of the interesting questions in the IoT space is the role of hypermedia and/or semantic interoperability for reducing setup overhead and thus TCO, and, more generally, enabling interoperation in the first place.

For example, OMA and IPSO smart objects use the LWM2M object model, which defines a set of pre-structured URI templates and registry of object identifiers with semantics attached. This provides machine- readable representations of the semantics, but self description is not being used much.

OCF has a hypermedia approach with discovery using /oic/res etc., which relies on self-description via pointing to predefined resource types and interface types, which in turn use a number of specification techniques, including JSON schema and RAML.

There is also iot.schema.org, which will allow us to gather further semantic interoperability information in potentially a more granular way.

W3C WoT cares a lot about self-description, with an RDF-based take on semantics and describing things.

T2TRG cares about pulling all this together.

On July 15, we will have a workshop that includes people from these organizations/groups. The focus will be on building a landscape that can benefit from the various approaches, without necessarily papering over all the holes or filling in all the rifts. On July 16, we will have additional time for follow-on work groups that want to make progress on specific issues.

The venue is the Prague Hilton, the same hotel that will host IETF99 directly after that. To further minimize travel, we chose the weekend directly after the July W3C WoT meeting in close by Düsseldorf.

Elements of the agenda:

State of the union

We will have "state of the union" talks from each of the organizations, discussing from a personal perspective where we are on interoperability in the organization and what are the next steps.

Research contributions, prototypes

We will issue a call for contributions, with a goal of getting new views and new voices into the mix. This will be research on the approaches available for building hybrid, overarching systems, as well as some practical systems that are already demonstrating how this could be made to work in practice, such as systems for converting some of the formal notations and/or self descriptions into each other.

Specific topics

The below topics (and any other that come up) could be discussed on Saturday and/or result in more detailed breakouts on Sunday.

Interops

The "device ecosystem" oriented SDOs are now increasingly using common protocols and formats (CBOR, CoAP, IPv6) which is creating one narrow waist in the system, and we can look into creating a narrow waist also around semantic interoperability and hypermedia design patterns. Ultimately, it should not matter which device ecosystem(s) you use for your application. The device ecosystems can maintain their focus on intra-op and certification while an over arching web-like layer of interoperability can add more value to all of them.

Now is a good time to start to organize cross-ecosystem interops, where we attempt to orchestrate devices and sources from these different device ecosystems. At this point we need to consider orchestration across applications as well as device to device interoperability.

We have also discussed a lot about conducting more of the actual testing over the Internet. This seems like a good concept to build in from the beginning. What are the tools we need to conduct an online hyper-semantic interop series? Is it staged, from basic to more sophisticated?

This seems to represent the canonical use case for both W3C WoT and iot.schema.org, as well as the various translators and bridges being created.

Hypermedia forms

HTML has a form element that can be used to construct POST request bodies (and other request payloads, such as for PATCH). An M2M equivalent has been lacking for quite some time, although there are proposals. Now that we have FETCH and PATCH (RFC 8132), the need is even more pronounced. What are the next steps towards common Hypermedia "forms", which would help at least T2TRG, OCF, and WoT?

Hypermedia-driven applications in general

T2TRG has a number of drafts documenting how application developers use hypermedia to aid in building thing-to-thing (and thing-to-cloud) systems. Are these complete? What else do we know about that? What about documents from, say, W3C or IPSO?

Model translation

We now have multiple proposals for data modeling (YANG, CDDL, JSON Schema, JSON Content Rules) as well as ad-hoc metamodels. What are the semantic powers of these modeling approaches? Can we automatically translate between them so we can make models of one ecosystem available for the other ones? How do we tap hidden Gems such as the ZigBee Cluster Library or the Bluetooth GATT specs? What about interaction modeling (also YANG, RAML, Swagger, ...)?

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 5 May 2017 12:45:47 +0200

Hi Ari,

thanks for sharing.

Although I will not be able to attend the workshop (due to the overlap
with the Hackathon and the interop event Carsten proposed a month ago) I
would like to learn from the workshop participants whether they have
gained some deployment experience with IoT and what types of problems
(with regards to data models) they had run into.

The reason why I am pointing this out is because I see a lot of ideas
flying around but very few people who actually have real world problems
to solve.

Ciao
Hannes

On 05/04/2017 05:45 PM, Ari Keränen wrote:
> _______________________________________________
> T2TRG mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/t2trg
>

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 5 May 2017 13:23:35 +0200

> flying around but very few people who actually have real world problems

That may actually be a good element of the discussion:

Should research and standards development be focused on the today's, often single-purpose deployments of IoT or should we try for a more medium term vision of low-TCO, repurposable, loosely coupled, more Web-like deployments?  What are the real problems in the latter?  How can we keep the machine spinning that is doing the former and smoothly transition?  How do we avoid generating/succumbing to a lot of fiction in the process?  These are most definitely not easy questions.

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 18 May 2017 17:01:00 +0200

We have now produced the call for contributions for WISHI, as reproduced below.

See https://github.com/t2trg/2017-07-wishi/blob/master/CALL-FOR-CONTRIBUTIONS.md for a version with links.
Please forward this message to groups that might find it useful.

Please also don’t forget to register: https://goo.gl/forms/yUTebqK9C84Ef01i2

Grüße, Carsten

# Workshop on IoT Semantic/Hypermedia Interoperability: Call for Contributions

When: July 15/16, 2017 (weekend before IETF99)

Where: Hilton Prague (IETF meeting hotel). Pobřežní 1, Prague, Czech Republic.

Registration: https://goo.gl/forms/yUTebqK9C84Ef01i2

# Workshop overview

Please have a look at: https://github.com/t2trg/2017-07-wishi

# Call for contributions

We are soliciting contributions that are on topic for the workshop in one of
four forms (or any mixture thereof):

1. State-of-the-union speeches: Where is your favorite IoT
   standards-settings organization on the road to semantic/hypermedia
   interoperability, and what are its next steps?  What role could it
   play in the emerging IoT semantic interoperability ecosystem?

2. Research contributions:  What did you try?  What did you learn
   about the self-description properties of the devices and the
   modeling languages in use?  How can you translate between different
   approaches?  What are the semantic limitations that you
   encountered?  What can you say about what properties modeling
   languages and self-description formats should have?

3. Prototypes:  What did you build?  What did you learn from it?

4. Work proposals:  What should be done?  Can you give a roadmap of
   what analyses, experiments, prototypical artifacts should the
   community try next?

Some slots for #1 are already allocated, so please check
with <mailto:[email-masked]> to avoid duplication.

For all contributions, a short position paper is the preferred form of
input.  For a selected subset of these contributions, we will allocate
presentation and discussion time.

Don't let our request for a paper discourage you from proposing other
interesting forms of contributions.  If you have a great demo, or an
existing paper a discussion of which would help us forward, please do
suggest it.  (You can always write a few additional paragraphs for the
workshop so people can come prepared and understand how your work fits
in.)

# Important dates

For the state-of-the-union speeches (type #1 above), please discuss
your request with the chairs by May 31.

For the other types, please register your intent to submit a
contribution with [the chairs][] as soon as you can do.

[the chairs]: mailto:[email-masked]

The position paper form of the contribution will be made available to
the participants on July 1, 2017.  Please send in your contribution by
**June 25, 2017**.