Subject: [T2TRG] I-D Action: draft-irtf-t2trg-iot-seccons-03.txt

From: [email-masked]
Date: Wed, 24 May 2017 01:49:29 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Thing-to-Thing of the IETF.

        Title           : State of the Art and Challenges for the Internet of Things
        Authors         : Oscar Garcia-Morchon
                          Sandeep S. Kumar
                          Mohit Sethi
	Filename        : draft-irtf-t2trg-iot-seccons-03.txt
	Pages           : 46
	Date            : 2017-05-24

Abstract:
   The Internet of Things (IoT) concept refers to the usage of standard
   Internet protocols to allow for human-to-thing and thing-to-thing
   communication.  The security needs are well-recognized and and many
   standardization steps for providing security have been taken, for
   example, the specification of Constrained Application Protocol (CoAP)
   over Datagram Transport Layer Security (DTLS).  However, security
   challenges still exist and there are some use cases that lack a
   suitable solution.  In this document, we first discuss the various
   stages in the lifecycle of a thing.  We then look at the security
   building blocks available for securing the different layers of the
   Internet protocol suite.  Next, we document the various security
   threats to a thing and the challenges that one might face in order to
   protect against these threats.  Lastly, we discuss the next steps
   needed to ensure roll out of secure Internet of Things services.

   This document is a product of the IRTF Thing-to-Thing Research Group
   (T2TRG).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-irtf-t2trg-iot-seccons/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-irtf-t2trg-iot-seccons-03
https://datatracker.ietf.org/doc/html/draft-irtf-t2trg-iot-seccons-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-irtf-t2trg-iot-seccons-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Mohit Sethi <[email-masked]>
Date: Sun, 28 May 2017 15:32:44 +0300

Hi folks,

We have updated the security considerations draft based on the extensive 
feedback we have received on the SAAG and T2TRG mailing lists. The 
current version of the draft can be found here:

We have now made the document more concise and it focuses on the 
state-of-the-art and challenges for IoT security. We will work on a 
separate document that contains the security profiles and mitigation 
mechanisms based on the feedback from the group. The authors believe 
that the document is now more or less ready and in good shape. Your 
feedback and comments are appreciated as always.

Oscar, Sandeep and Mohit

-------- Forwarded Message --------
Subject: 	[T2TRG] I-D Action: draft-irtf-t2trg-iot-seccons-03.txt
Date: 	Wed, 24 May 2017 01:49:29 -0700
From: 	[email-masked]
To: 	[email-masked]
CC: 	[email-masked]

Abstract:

_______________________________________________
T2TRG mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/t2trg

---

From: Thorsten Dahm <[email-masked]>
Date: Mon, 29 May 2017 15:24:37 +0100

Hello,

I don't want to be pedantic but please go over the document one more time
and fix the typo and grammar mistakes. I've found a few, nothing that would
make a difference but just easier to read.

Some of the things I saw:

smart phone vs. smartphone -> debatable, but I think the spelling without
the blank in the middle is more common
Distribute -> should be Distributed
software reserve engineered -> should be reverse engineered
( summarized in Section 5.1) -> should be (summarized in Section 5.1)

Thanks,
Thorsten

On 28 May 2017 at 13:32, Mohit Sethi <[email-masked]> wrote:

> feedback we have received on the SAAG and T2TRG mailing lists. The current
> version of the draft can be found here:
>
> mechanisms based on the feedback from the group. The authors believe that
> the document is now more or less ready and in good shape. Your feedback and
> comments are appreciated as always.
>
> Oscar, Sandeep and Mohit
>
>
> The IETF datatracker status page for this draft is:https://datatracker.ietf.org/doc/draft-irtf-t2trg-iot-seccons/
>
> There are also htmlized versions available at:https://tools.ietf.org/html/draft-irtf-t2trg-iot-seccons-03https://datatracker.ietf.org/doc/html/draft-irtf-t2trg-iot-seccons-03
>
> A diff from the previous version is available at:https://www.ietf.org/rfcdiff?url2=draft-irtf-t2trg-iot-seccons-03
>
>
> Internet-Drafts are also available by anonymous FTP at:ftp://ftp.ietf.org/internet-drafts/
>
> T2TRG mailing [email-masked]://www.irtf.org/mailman/listinfo/t2trg
>
>

-- 
Thorsten Dahm

Network Engineer
Google Ireland Ltd.
The Gasworks, Barrow Street
Dublin 4,  Ireland

Registered in Dublin, Ireland
Registration Number: 368047

---

From: Mohit Sethi <[email-masked]>
Date: Tue, 30 May 2017 08:06:59 +0300

Hi Thorsten

Thanks again for the fixes. We will address these in the next revision. 
We are hoping that the chairs would assign a document shepherd who would 
help us iron out all such issues.

/--Mohit

On 05/29/2017 05:24 PM, Thorsten Dahm wrote:
> Hello,
>
> I don't want to be pedantic but please go over the document one more 
> time and fix the typo and grammar mistakes. I've found a few, nothing 
> that would make a difference but just easier to read.
>
> smart phone vs. smartphone -> debatable, but I think the spelling 
> without the blank in the middle is more common
> On 28 May 2017 at 13:32, Mohit Sethi <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Hi folks,
>
>     We have updated the security considerations draft based on the
>     extensive feedback we have received on the SAAG and T2TRG mailing
>     lists. The current version of the draft can be found here:
>
>     <https://tools.ietf.org/html/draft-irtf-t2trg-iot-seccons-03>
>
>     state-of-the-art and challenges for IoT security. We will work on
>     a separate document that contains the security profiles and
>     mitigation mechanisms based on the feedback from the group. The
>     authors believe that the document is now more or less ready and in
>     good shape. Your feedback and comments are appreciated as always.
>
>     Oscar, Sandeep and Mohit
>
>
>
>     From: 	[email-masked] <mailto:[email-masked]>
>     To: 	[email-masked] <mailto:[email-masked]>
>     CC: 	[email-masked] <mailto:[email-masked]>
>
>
>
>     <https://datatracker.ietf.org/doc/draft-irtf-t2trg-iot-seccons/>
>
>     <https://tools.ietf.org/html/draft-irtf-t2trg-iot-seccons-03>
>     <https://datatracker.ietf.org/doc/html/draft-irtf-t2trg-iot-seccons-03>
>
>     <https://www.ietf.org/rfcdiff?url2=draft-irtf-t2trg-iot-seccons-03>
>
>
>     until the htmlized version and diff are available attools.ietf.org <http://tools.ietf.org>.
>
>     <ftp://ftp.ietf.org/internet-drafts/>
>
>     [email-masked] <mailto:[email-masked]>
>     <https://www.irtf.org/mailman/listinfo/t2trg>
>
>
>     [email-masked] <mailto:[email-masked]>
>     <https://www.irtf.org/mailman/listinfo/t2trg>
>
>
>
>
> -- 
> Thorsten Dahm
>
> Network Engineer
> Google Ireland Ltd.

---

From: Ari Keränen <[email-masked]>
Date: Tue, 30 May 2017 13:01:27 +0000

Hi Mohit,

Thanks for the update! Usually document shepherd is not responsible as such for editorial issues but we rely on the editors and all reviewers (especially in late stages as with this document) to report and fix such issues. The RFC editor will also do a final round of editorial fixes before publication.

Cheers,
Ari

On 30 May 2017, at 14:06, Mohit Sethi <[email-masked]<mailto:[email-masked]>> wrote:

Hi Thorsten

Thanks again for the fixes. We will address these in the next revision. We are hoping that the chairs would assign a document shepherd who would help us iron out all such issues.

/--Mohit

I don't want to be pedantic but please go over the document one more time and fix the typo and grammar mistakes. I've found a few, nothing that would make a difference but just easier to read.

smart phone vs. smartphone -> debatable, but I think the spelling without the blank in the middle is more common
Distribute -> should be Distributed
software reserve engineered -> should be reverse engineered
( summarized in Section 5.1) -> should be (summarized in Section 5.1)

Thanks,
Thorsten

On 28 May 2017 at 13:32, Mohit Sethi <[email-masked]<mailto:[email-masked]>> wrote:

Hi folks,

We have updated the security considerations draft based on the extensive feedback we have received on the SAAG and T2TRG mailing lists. The current version of the draft can be found here:

We have now made the document more concise and it focuses on the state-of-the-art and challenges for IoT security. We will work on a separate document that contains the security profiles and mitigation mechanisms based on the feedback from the group. The authors believe that the document is now more or less ready and in good shape. Your feedback and comments are appreciated as always.

Oscar, Sandeep and Mohit

-------- Forwarded Message --------
Subject:        [T2TRG] I-D Action: draft-irtf-t2trg-iot-seccons-03.txt
Date:   Wed, 24 May 2017 01:49:29 -0700
From:   [email-masked]<mailto:[email-masked]>
To:     [email-masked]<mailto:[email-masked]>
CC:     [email-masked]<mailto:[email-masked]>

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org/>.

_______________________________________________
T2TRG mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/t2trg

_______________________________________________
T2TRG mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/t2trg

--
Thorsten Dahm

Network Engineer
Google Ireland Ltd.

_______________________________________________
T2TRG mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/t2trg

_______________________________________________
T2TRG mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/t2trg