Subject: [T2TRG] Side meeting on Distributed Internet Infrastructure at IETF-99

From: "Dirk Kutscher" <[email-masked]>
Date: Tue, 04 Jul 2017 22:46:24 +0200

[This is hopefully of interest to T2TRG]

Hi all,

we are holding another side meeting on Distributed Internet 
Infrastructure at IETF-99. We had some good discussions with interested 
folks in and outside the IRTF in the past months and thought that it 
might be a good time now to try to start a more structured activity in 
the IRTF.

The scope would be “Distributed Internet Infrastructure”, I.e., 
applying distributed ledger technologies (such as blockchain, but not 
limited to it) to Internet technologies, for example to decentralized 
name registries, identity management, decentralized web etc.

We have some people looking at the topic from different angles, i.e., 
IoT, decentralized web, Internet architecture and think that there is an 
interesting and potentially very productive scope we could work in the 
IRTF.

The meeting to discuss this will be a side meeting on Monday, July 17, 
18:50 to 20:50 in the Tyrolka room of the Hilton hotel (meeting hotel).

The agenda (as of current planning):

1) Background and Purpose
2) Selected Use Cases and Related Efforts
- Decentralized OAuth
- IoT
- COALA.global
3) Ledger Technology
4) Next steps, RG Formation

We’ll post agenda details, updated etc. on 
https://trac.ietf.org/trac/irtf/wiki/blockchain-federation

Let us know in case you have any question or are interested to get 
involved!

Best regards,
Dirk (on behalf of co-organizers)

---

From: "Dirk Kutscher" <[email-masked]>
Date: Mon, 17 Jul 2017 17:00:38 +0200

(Apologies if you receive this multiple times).

We have changed the room to Karlin III — see below.

Dirk

Forwarded message:

> From: Dirk Kutscher <[email-masked]>
> To: [email-masked], [email-masked], [email-masked]
> Cc: Melinda Shore <[email-masked]>, Allison Mankin 
> <[email-masked]>
> Subject: Re: Side meeting on Distributed Internet Infrastructure at 
> IETF-99
> Date: Mon, 17 Jul 2017 12:41:20 +0200
>
> OK, updated meeting logistics and agenda:
>
> Coordinates
>
> Date & Time: Monday, July 17, 18:50 -- 20:30
> Room: Karlin III, Hilton (Meeting hotel)
> remote participation: ​http://www.meetecho.com/ietf99/irtf17
>
>
> Draft Agenda
>
> 1) Background and Purpose (Dirk & Melinda)
>   - An analysis of the applicability of blockchain to secure IP 
> addresses allocation, delegation and bindings (Jordi Paillissé 
> Vilanova) 
> https://datatracker.ietf.org/doc/draft-paillisse-sidrops-blockchain/
>   - Lightest Project Overview (Benno Overeinder) http://lightest.eu/
>   - Cloudless IoT (Lixia Zhang)
> 3) Discussion of Next steps
>
>
> —-
> Dirk and Melinda
>
>
>
> On 16 Jul 2017, at 23:14, Dirk Kutscher wrote:
>
>> Hi,
>>
>> Just a reminder that this is happening tomorrow. We might move to 
>> another room for MeetEcho coverage — we’ll update the webpage 
>> (see below) and send a notification if that happens.
>>
>> Best regards,
>> Dirk
>>
>> On 26 Jun 2017, at 23:27, Dirk Kutscher wrote:
>>
>>> Hi all,
>>>
>>> Infrastructure at IETF-99. We had some good discussions with 
>>> interested folks in and outside the IRTF in the past months and 
>>> thought that it might be a good time now to try to start a more 
>>> structured activity in the IRTF.
>>>
>>> applying distributed ledger technologies (such as blockchain, but 
>>> not limited to it) to Internet technologies, for example to 
>>> decentralized name registries, identity management, decentralized 
>>> web etc.
>>>
>>> We have some people looking at the topic from different angles, 
>>> i.e., IoT, decentralized web, Internet architecture and think that 
>>> there is an interesting and potentially very productive scope we 
>>> could work in the IRTF.
>>>
>>> The meeting to discuss this will be a side meeting on Monday, July 
>>> 17, 18:50 to 20:50 in the Tyrolka room of the Hilton hotel (meeting 
>>> hotel).
>>>