Subject: [tap] TAP::Spec::Parser 0.05 on CPAN

From: Andrew Rodland <[email-masked]>
Date: Sun, 20 Mar 2011 13:21:40 -0500

I'm pleased to release version 0.05 of TAP::Spec::Parser to the CPAN, 
featuring a completely rewritten parser based on Paul Evans' Parser::MGC. It's 
not as pretty as the Regexp::Grammars one, and the parallels to the BNF are 
not quite as easy to see, but it's more correct, *much* faster, and doesn't 
have the stability issues that plagued previous versions because it no longer 
tries to execute Perl code inside of regexes.

The spec tests and example scripts are working with no known regressions from 
version 0.04.

Now that the issues with stability and extreme slowdowns on complex test input 
are (hopefully) behind us, it may be time to work on adding more test cases to 
t/spec-tests.

Schwern, are http://svn.hexten.net/tapx/tap-tests/t/source/ the test cases 
from the Oslo QA Hackathon that you were alluding to? If they're good stuff I 
can put some effort into converting them to mesh with the TAP::Spec objects.

Andrew

---

From: Ovid <[email-masked]>
Date: Sun, 20 Mar 2011 12:52:35 -0700 (PDT)

Any chance we can get some documentation for this? I honestly can't tell what's supposed to be happening here other than a TAP parser is somehow implemented.

Cheers,
Ovid
--
Live and work overseas - http://overseas-exile.blogspot.com/
Buy the book           - http://www.oreilly.com/catalog/perlhks/
Tech blog              - http://blogs.perl.org/users/ovid/
Twitter                - http://twitter.com/OvidPerl/

>________________________________
>From: Andrew Rodland <[email-masked]>
>To: [email-masked]; Test Anything Protocol <[email-masked]>
>Sent: Sunday, 20 March 2011, 19:21
>Subject: [tap-l] TAP::Spec::Parser 0.05 on CPAN
>
>_______________________________________________
>tap-l mailing list
>[email-masked]
>http://testanything.org/mailman/listinfo/tap-l
>
>
>