Subject: Re: [tap] W3C Evaluation and Report Language (EARL)

From: "Bruno P. Kinoshita" <[email-masked]>
Date: Thu, 20 Dec 2012 03:26:54 -0800 (PST)

Hi all, 

For the last three weeks or so, testanything.org has been down. I tried pinging the tap mailing list, but got no response. Tried to contact Test::More maintainer to see if he knew someone with karma to update the web site but got no response so far.

This is the last message I found in my inbox regarding TAP, so I apologize beforehand for bothering you all :-)

Does anybody know where I can find one of the testanything.org administrators, please? 

Thank you in advance, and sorry for the trouble.

All the best,

Bruno P. Kinoshita
http://kinoshita.eti.br
http://tupilabs.com

>________________________________
> From: Steffen Schwigon <[email-masked]>
>To: Christophe Strobbe <[email-masked]> 
>Cc: [email-masked]; Shadi Abou-Zahra <[email-masked]> 
>Sent: Wednesday, November 9, 2011 6:25 PM
>Subject: Re: [tap] W3C Evaluation and Report Language (EARL)
> 
>Christophe Strobbe <[email-masked]> writes:
>> Report Language (EARL) and a few related specifications. EARL's core
>> use case is reporting the results of accessibility evaluations of
>> websites (i.e. accessibility for persons with disabilities), but the
>> language itself is generic, so it can also be used in other
>> contexts. The language is based on RDF;
>> […]
>> During our last call for comments, one of the reviewers asked the
>> working group if EARL duplicates TAP's efforts, or vice versa. The
>> working group thinks that this is not the case; we think that EARL
>> could be an alternative report format for TAP if a TAP consumer could
>> be written that produces EARL. For this reason, we thought it would be
>> interesting to contact you and to make sure we are aware of each
>> other's work.
>
>Thanks for sync'ing this back to us. I just skimmed through the specs
>and it was indeed interesting. As far as I understand from my (very
>short) skimming I think it's not that many duplication of effort as the
>main difference is a philosophical one.
>
>- EARL is similar to other W3C specs in respect to specifying a
>  comprehensive snapshot of known existing topics. For example, it
>  particularly covers all known HTTP methods (POST, GET, PUT, …). That
>  enables it to build tools on top of it that sematically “know” what
>  the document is about.
>
>- TAP in contrast is about specifying test results, really just the
>  *result* focus without hard specification of the tested topic, i.e., a
>  single test has a “description”, so someone reading it knows what it
>  is about but that part does not have a specification. 
>
>  For instance, a test about a HTTP method could have any description
>  from “POST” to “that strange other method that I never remember but
>  always use when GET is not sufficient”.
>
>
>See [1] for some related discussion of this aspect.
>
>In this respect I think TAP is more like your RDF with some extensions
>from EARL to describe test success.
>
>That makes the use-cases of TAP and EARL a bit different: 
>
>- TAP allows to be produced by anything simple without toolchain
>  support, like embedded devices with nothing but a “print” function,
>  but you can not *sematically* evaluate results.
>
>- EARL seems to require more heavy toolchain support to produce but
>  allows more semantic result evaluation.
>
>Converting TAP to EARL is difficult. 
>Converting EARL to TAP is easy.
>
>On the evaluation of TAP I can point to TAP::DOM and Data::DPath, which
>provide a more structured approach to evaluate test results, see my “TAP
>Juggling” slides[2], page 30ff.
>
>Kind regards,
>Steffen
>
>
>Footnotes: 
>[1]  http://grokbase.com/p/perl.org/qa/2008/04/re-tap-l-user-supplied-yaml-diagnostic-keys-descriptive-version/11ymnpm2765ztojoinznq2lz5674
>
>[2]  http://www.amd64.org/fileadmin/user_upload/pub/yapc_eu_2011_tapjuggling.pdf
>
>-- 
>Steffen Schwigon <[email-masked]>
>Dresden Perl Mongers <http://dresden-pm.org/>
>_______________________________________________
>tap mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/tap
>
>
>

---

From: Salve J Nilsen <[email-masked]>
Date: Thu, 20 Dec 2012 17:15:02 +0100 (CET)

Hi Bruno & all,

[Cc: Andy, since he's hosting the domain]

Bruno P. Kinoshita said:
> 
> Hi all, 
>
> For the last three weeks or so, testanything.org has been down. I 
> tried pinging the tap mailing list, but got no response. Tried to 
> contact Test::More maintainer to see if he knew someone with karma 
> to update the web site but got no response so far.
>
> This is the last message I found in my inbox regarding TAP, so I 
> apologize beforehand for bothering you all :-)
>

  $ whois testanything.org | grep ^Admin | grep -v :$

Admin ID:tulY0yUXw7Xkuxmn
Admin Name:Andy Armstrong
Admin Organization:Hexten
Admin Street1:Bridge End Barn
Admin City:Garrigill
Admin State/Province:Cumbria
Admin Postal Code:CA93DR
Admin Country:GB
Admin Phone:+44.01434381641
Admin Email:[email-masked]

Apparently Andy's pretty busy these days. He also hasn't been on the 
#perl-qa IRC channel on irc.perl.org either in a while (TAP is 
discussed now and then in that channel).

Maybe Andy can tell us a little about what's going on? :)

- Salve J. Nilsen

-- 
#!/usr/bin/perl
sub AUTOLOAD{$AUTOLOAD=~/.*::(\d+)/;seek(DATA,$1,0);print#  Salve Joshua Nilsen
getc DATA}$"="'};&{'";@_=unpack("C*",unpack("u*",':4@,$'.#     <[email-masked]>
'2!--"5-(50P%$PL,!0X354UC-PP%/0\`'."\n"));eval "&{'@_'}";   __END__ is near! :)

---

From: Andy Armstrong <[email-masked]>
Date: Thu, 20 Dec 2012 16:52:23 +0000

On 20 Dec 2012, at 16:15, Salve J Nilsen <[email-masked]> wrote:
> Apparently Andy's pretty busy these days. He also hasn't been on the #perl-qa IRC channel on irc.perl.org either in a while (TAP is discussed now and then in that channel).
> 

Yeah, sorry folks. My best hope right now is that I get a moment to look at it over Xmas.

As Salve says I'm busy in all sorts of non TAP related areas at the moment.

Sorry!

-- 
Andy Armstrong, Hexten