Subject: [Taps] terminology and RFC2126

From: Mirja Kühlewind <[email-masked]>
Date: Wed, 03 Dec 2014 12:34:24 +0100

Hi,

just been quickly checking the transport service definition in RFC 2126. From my 
understanding this is in line with the proposed definition of a transport 
service (composition) (but not inline with the definition as given in the 
charter). I still believe that we cannot only refer to RFC2126 though (but 
probobly should refer RFC2116 somehow) because we really should define this term 
in the set of the other terms to avoid confusion and provide a common set of 
terms so we can actually talk to each other.

Please let me know if you disagree!

Mirja

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Wed, 3 Dec 2014 16:42:34 +0000

On Dec 3, 2014, at 3:34 AM, Mirja Kühlewind <[email-masked]> wrote:

> just been quickly checking the transport service definition in RFC 2126. From my understanding this is in line with the proposed definition of a transport service (composition) (but not inline with the definition as given in the charter). I still believe that we cannot only refer to RFC2126 though (but probobly should refer RFC2116 somehow) because we really should define this term in the set of the other terms to avoid confusion and provide a common set of terms so we can actually talk to each other.

Where does 1006 come in? 2126 updates 1006, and as near as I can tell the difference is in what gets left out - TP-2, TP-0, and a couple of other things. I believe that IEC documents refer primarily to 1006.

2126 defines an interface for TP-4. That would be SCTP’s message service. What is needed to make the transport definition also allow for an SCTP underpinning?