Subject: [Taps] I-D Action: draft-ietf-taps-transports-02.txt

From: [email-masked]
Date: Sat, 07 Feb 2015 04:07:02 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Transport Services Working Group of the IETF.

        Title           : Services provided by IETF transport protocols and congestion control mechanisms
        Authors         : Godred Fairhurst
                          Brian Trammell
                          Mirja Kuehlewind
	Filename        : draft-ietf-taps-transports-02.txt
	Pages           : 20
	Date            : 2015-02-07

Abstract:
   This document describes services provided by existing IETF protocols
   and congestion control mechanisms.  It is designed to help
   application and network stack programmers and to inform the work of
   the IETF TAPS Working Group.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-taps-transports/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-taps-transports-02

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-taps-transports-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Brian Trammell <[email-masked]>
Date: Sat, 7 Feb 2015 13:41:32 +0100

Greetings, all,

We've submitted the -02 rev of the transports document, addressing comments to date and including additional content for some of the transport protocols.

Markdown (kramdown-rfc2629) source and toolchain is available at https://github.com/britram/taps-transports. Subsection authors: feel free to send pull requests against either the markdown or XML source (we'll convert the latter back to the former) or text to the editors via email. We'd like to get at least one more rev of the document out before Dallas.

Not-yet-subsection-authors who would like to contribute: there are a couple of sections we'd like to have (HTTP(S) as a pseudotransport, and WebSockets which removes some of the "pseudo" therefrom) that don't yet have contributors associated; additionally, if there are transport (or transport-like) protocols we're missing here, please send text and we'll get it integrated.

Many thanks, best regards,

Brian (for the editors of taps-transports).

> Begin forwarded message:
> 
> From: [email-masked]
> To: <[email-masked]>
> Date: 7 Feb 2015 13:07:02 CET
> Cc: [email-masked]
> Subject: [Taps] I-D Action: draft-ietf-taps-transports-02.txt
> 
> 
> _______________________________________________
> Taps mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/taps

---

From: Gorry Fairhurst <[email-masked]>
Date: Mon, 09 Feb 2015 16:48:06 +0000

This version includes my first go at a table, in section 4.1, I'm hoping 
this will stimulate some input/corrections, or even perhaps alternate 
list of what to see here. Please discuss, or send comments via the TAPS 
list.

gorry

---

From: Michael Tuexen <[email-masked]>
Date: Tue, 10 Feb 2015 20:05:30 +0100

> On 09 Feb 2015, at 17:48, Gorry Fairhurst <[email-masked]> wrote:
> 
> 
> 
> This version includes my first go at a table, in section 4.1, I'm hoping this will stimulate some input/corrections, or even perhaps alternate list of what to see here. Please discuss, or send comments via the TAPS list.
Hi Gorry,

maybe I didn't understand the table entries correctly, but I think the following
changes improve the description of SCTP:
https://github.com/britram/taps-transports/pull/1

* SCTP is message oriented, so Dgram seems to be more appropriate than Stream.
* Bundling of DATA chunks and the Nagle algorithm is supported, so multiple
  user messages can fit into a single IP packet.
* ECN support needs to be clarified.

Best regards
Michael