Subject: Re: [Taps] Charter change for security

From: Tommy Pauly <[email-masked]>
Date: Wed, 03 Jan 2018 13:13:21 -0800

Hi Aaron,

We’ve just posted an update to the Transport Security protocol survey (https://tools.ietf.org/html/draft-pauly-taps-transport-security-01 <https://tools.ietf.org/html/draft-pauly-taps-transport-security-01>), and noted that the charter for TAPS is still waiting for the update to the text as proposed by Kyle.

Can you give an update on the status of this, and if we have the request already sent to the ADs?

Best,
Tommy

> On Jul 18, 2017, at 5:21 AM, Aaron Falk <[email-masked]> wrote:
> 
> This is fine with me.  Brief pause for any objections before making the charter change request to the ADs…
> 
> —aaron
> 
> 
> On 18 Jul 2017, at 13:40, Robert Moskowitz wrote:
> 
>> I just joined this list.
>> 
>> I can work with this.
>> 
>> Bob
>> 
>> On 07/18/2017 01:36 PM, Tommy Pauly wrote:
>>> Agreed. Thanks for the text proposal, Kyle!
>>> 
>>> Tommy
>>> 
>>>> On Jul 18, 2017, at 12:15 PM, Brian Trammell (IETF) <[email-masked]> wrote:
>>>> 
>>>> +1.
>>>> 
>>>> Cheers,
>>>> 
>>>> Brian
>>>> 
>>>>> On 18 Jul 2017, at 12:02, Michael Welzl <[email-masked]> wrote:
>>>>> 
>>>>> Agree 100% - I think this proposal is exactly the right way to do it.
>>>>> 
>>>>> Cheers,
>>>>> Michael
>>>>> 
>>>>> 
>>>>>> On Jul 18, 2017, at 11:12 AM, Kyle Rose <[email-masked]> wrote:
>>>>>> 
>>>>>> Proposal:
>>>>>> 
>>>>>> (1) Strike the last paragraph of the charter ("TAPS is not chartered to perform detailed analysis...").
>>>>>> 
>>>>>> (2) Change the third bullet right above it to read "Extension, modification, or creation of transport or security protocols"
>>>>>> 
>>>>>> The idea being to permit analysis of the properties of security protocols with respect to the requirements of TAPS systems, but not to permit creation or customization of security protocols.
>>>>>> 
>>>>>> Thoughts?
>>>>>> 
>>>>>> Kyle
>>>>>> _______________________________________________
>>>>>> Taps mailing list
>>>>>> [email-masked]
>>>>>> https://www.ietf.org/mailman/listinfo/taps
>>>>> _______________________________________________
>>>>> Taps mailing list
>>>>> [email-masked]
>>>>> https://www.ietf.org/mailman/listinfo/taps
>>>> _______________________________________________
>>>> Taps mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/listinfo/taps
>>> _______________________________________________
>>> Taps mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/taps
>> 
>> _______________________________________________
>> Taps mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/taps
> 
> _______________________________________________
> Taps mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/taps

---

From: "Aaron Falk" <[email-masked]>
Date: Wed, 03 Jan 2018 16:15:09 -0500

Thanks for the revision, Tommy.  The status is ‘no progress’ but 
(surprise!) in response to your note I will do something now. :)

—aaron

On 3 Jan 2018, at 16:13, Tommy Pauly wrote:

> Hi Aaron,
>
> We’ve just posted an update to the Transport Security protocol 
> survey 
> (https://tools.ietf.org/html/draft-pauly-taps-transport-security-01 
> <https://tools.ietf.org/html/draft-pauly-taps-transport-security-01>), 
> and noted that the charter for TAPS is still waiting for the update to 
> the text as proposed by Kyle.
>
>>>>>>> (1) Strike the last paragraph of the charter ("TAPS is not 
>>>>>>> chartered to perform detailed analysis...").
>>>>>>>
>>>>>>> (2) Change the third bullet right above it to read "Extension, 
>>>>>>> modification, or creation of transport or security protocols"
>>>>>>>
>>>>>>> The idea being to permit analysis of the properties of security 
>>>>>>> protocols with respect to the requirements of TAPS systems, but 
>>>>>>> not to permit creation or customization of security protocols.
>>>>>>>
>>>>>>> Thoughts?
>>>>>>>
>>>>>>> Kyle

---

From: Kyle Rose <[email-masked]>
Date: Wed, 3 Jan 2018 16:35:24 -0500

Thanks.

FWIW, I am very familiar with the concept of an interrupt-driven WG chair,
being one myself. :-)

On Wed, Jan 3, 2018 at 4:15 PM, Aaron Falk <[email-masked]> wrote:

> We’ve just posted an update to the Transport Security protocol survey (
> https://tools.ietf.org/html/draft-pauly-taps-transport-security-01), and
> noted that the charter for TAPS is still waiting for the update to the text
> as proposed by Kyle.
>
> The idea being to permit analysis of the properties of security protocols
> with respect to the requirements of TAPS systems, but not to permit
> creation or customization of security protocols.
>
> Thoughts?
>
> Kyle