Subject: [Taps] Call for agenda item for IETF 102

From: Zaheduzzaman Sarker <[email-masked]>
Date: Thu, 28 Jun 2018 11:53:25 +0000

Hi TAPS,

We are planning for the IETF 102 Session. Please send your proposal(s) for agenda item and also mention –

  *   The duration of timeslot you prefer.
  *   The points you would like to discuss during the IETF102 meeting during your timeslot.

BR

Zahed & Aaron

---

From: Tommy Pauly <[email-masked]>
Date: Thu, 28 Jun 2018 06:41:04 -0700

It looks like TAPS has a 2.5 hour slot, which is good!

We’ll be publishing some -01 versions of the architecture, interface, and implementation drafts before the submission deadline, so I think we should have slots for those documents. We haven’t worked out the details yet, but I imagine having 15 minutes architecture, 20 minutes interface, and 10 minutes implementation would make sense based on the diffs. 

There should also be a rev of the transport security survey and some initial feedback from the security area, so an update from Chris or Kyle on that (15?) would be good. 

One other agenda proposal I’d like to make is a section highlighting some implementation experiences that can influence our drafts. I think NEAT has some details they’d like to share, and now that Apple has released its Network.framework new transport API, I’d like to give a 10 minute talk sharing how it looks and some decisions we made while implementing. 

Best,
Tommy

> On Jun 28, 2018, at 4:53 AM, Zaheduzzaman Sarker <[email-masked]> wrote:
> 
> Hi TAPS,
>  
> The duration of timeslot you prefer.
> The points you would like to discuss during the IETF102 meeting during your timeslot.
>  
> BR
>  
> Zahed & Aaron
>  
> _______________________________________________
> Taps mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/taps

---

From: Tommy Pauly <[email-masked]>
Date: Thu, 28 Jun 2018 08:07:43 -0700

> On Jun 28, 2018, at 7:40 AM, Tom Jones <[email-masked]> wrote:
> 
>> On Thu, Jun 28, 2018 at 06:41:04AM -0700, Tommy Pauly wrote:
>> One other agenda proposal I’d like to make is a section highlighting
>> some implementation experiences that can influence our drafts. I think
>> NEAT has some details they’d like to share, and now that Apple has
>> released its Network.framework new transport API, I’d like to give a
>> 10 minute talk sharing how it looks and some decisions we made while
>> implementing. 
>> 
> 
> Hi taps,
> 
> I understood from the interim that we would talk about policy system
> implementations from implementers perspective (apple, neat, socket
> intents...). I would like to talk about the policy work we did in NEAT
> so we can feed this background into the drafts, ideally the other
> systems would present so we could compare.
> 
> For that I would like 10 minutes to cover the NEAT Policy System.
> 
> Tommy, do you plan to cover policy and Network.framework or would you
> just give an overview of the system? 
> 
> If both, is 10 minutes enough?

Good point. If we want a section on policy implementations in general as the focus, then I’d probably want 15 minutes to cover both the API surface and how policy selection works. 

Tommy
> - Tom

---

From: Tom Jones <[email-masked]>
Date: Thu, 28 Jun 2018 15:40:05 +0100

Hi taps,

- Tom