Subject: Re: [Taps] call for TAPS agenda items

From: "Philipp S. Tiesel" <[email-masked]>
Date: Mon, 1 Jul 2019 16:17:34 +0200

> On 30. Jun 2019, at 23:44, Michael Welzl <[email-masked]> wrote:
> 
> Hi,
> 
> Sounds like a good start!
> 
> About this:
> 
>> On Jun 30, 2019, at 11:34 PM, Aaron Falk <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> What shall we use our face-time for in Montreal?
>> 
>> Some topics from our last interim <https://etherpad.ietf.org/p/nots-interim-2019-taps-02?useMonospaceFont=true> seem like good candidates for updates. Can we refine them with specific to discuss (and ID someone to launch/lead the discussion)?
>> 
>> Framing
>> Implementations
>> Parameters & Defaults
>> Yang model
>> Why do people resist specific protocol selection? (from Yang discussion)
> I’d volunteer to lead this discussion, but I wonder: is this really worth the time - as in: do we really (still) have any resistance to this idea?

Looks like… but I guess we have two different topics here:
 - Property Profiles (shortcuts for common sets of properties)
 - Explicit Protocol Selection

I originally insisted to keep them separate, as I really like to have the first one and feared the discussion for the second one. As I opened PRs with proposals for both of them (https://github.com/ietf-tapswg/api-drafts/pull/328 <https://github.com/ietf-tapswg/api-drafts/pull/328> and https://github.com/ietf-tapswg/api-drafts/pull/327 <https://github.com/ietf-tapswg/api-drafts/pull/327>), I got no fire and fury, but only constructive feedback.
So I agree with Michael that we may really have a short discussion on whether to add these features.

> 
> Cheers,
> Michael
> 
> 
>> ARCH & API open topics
>> --aaron
>> 
>> _______________________________________________
>> Taps mailing list
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/taps
> 
> _______________________________________________
> Taps mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/taps

AVE!
   Philipp S. Tiesel

--
Philipp S. Tiesel
https://philipp.tiesel.net/

---

From: Michael Welzl <[email-masked]>
Date: Tue, 2 Jul 2019 09:24:23 +0200

Hi again,

> On Jul 1, 2019, at 4:17 PM, Philipp S. Tiesel <[email-masked]> wrote:
> 
> 
> 
>> On 30. Jun 2019, at 23:44, Michael Welzl <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi,
>> 
I’d volunteer for this one too.

> So I agree with Michael that we may really have a short discussion on whether to add these features.

Ok, it sounds to me like this slot should be called “Profiles / choosing specific protocols”.  Sounds like a nice short discussion to me.

Cheers,
Michael

>>> https://www.ietf.org/mailman/listinfo/taps <https://www.ietf.org/mailman/listinfo/taps>
>> 
> https://philipp.tiesel.net/ <https://philipp.tiesel.net/>

---

From: "Philipp S. Tiesel" <[email-masked]>
Date: Tue, 2 Jul 2019 10:20:41 +0200

Hi,
> Ok, it sounds to me like this slot should be called “Profiles / choosing specific protocols”.  Sounds like a nice short discussion to me.

I’ll volunteer to lead the discussion on the last one.

AVE!
   Philipp S. Tiesel

---

From: "Aaron Falk" <[email-masked]>
Date: Tue, 02 Jul 2019 09:55:41 -0400

On 2 Jul 2019, at 3:24, Michael Welzl wrote:

>>>>   * Parameters & Defaults

Michael-

Can you frame a question or decision we want to target for the 
discussion?  It would help me (& maybe others) keep the right focus.

--aaron

---

From: "Aaron Falk" <[email-masked]>
Date: Tue, 02 Jul 2019 09:57:21 -0400

On 2 Jul 2019, at 4:20, Philipp S. Tiesel wrote:

>>>>>   * ARCH & API open topics

Similar to my comment to Michael, I think it would be helpful to focus 
on the open items and frame a question or decision that is needed.  
Since this is a bit of a grab-bag, it doesn’t seem necessary to me to 
put those in the agenda although I’d be happy to include them if you 
can frame them now.

--aaron

---

From: Tommy Pauly <[email-masked]>
Date: Tue, 02 Jul 2019 12:26:32 -0700

> On Jun 30, 2019, at 2:34 PM, Aaron Falk <[email-masked]> wrote:
> 
I can give a brief update here on the status of framing, as we just merged in the PR (https://github.com/ietf-tapswg/api-drafts/pull/323 <https://github.com/ietf-tapswg/api-drafts/pull/323>). I’ll also pair that with some sample framers implemented in Swift and C that we added into our Network.framework API this year.

Thanks,
Tommy

---

From: "Aaron Falk" <[email-masked]>
Date: Tue, 02 Jul 2019 15:29:01 -0400

On 2 Jul 2019, at 15:26, Tommy Pauly wrote:

>>   * Framing
>>
>
> I can give a brief update here on the status of framing, as we just 
> merged in the PR 
> (<https://github.com/ietf-tapswg/api-drafts/pull/323>). I’ll also 
> pair that with some sample framers implemented in Swift and C that we 
> added into our Network.framework API this year.

Sounds good.  During the interim there seemed to be some confusion about 
when and how to apply framing.  What would you say the open issues are?

--aaron

---

From: Michael Welzl <[email-masked]>
Date: Wed, 3 Jul 2019 09:27:59 +0200

> On Jul 2, 2019, at 3:55 PM, Aaron Falk <[email-masked]> wrote:
> 
> Can you frame a question or decision we want to target for the discussion? It would help me (& maybe others) keep the right focus.
> 
Yes:

Should we specify rather than recommend default values? (github issue #317)

Cheers,
Michael

---

From: Theresa Enghardt <[email-masked]>
Date: Wed, 3 Jul 2019 17:39:02 +0200

Hi,

On 30.06.19 23:34, Aaron Falk wrote:
> Some topics from our last interim
> <https://etherpad.ietf.org/p/nots-interim-2019-taps-02?useMonospaceFont=true>
> seem like good candidates for updates. Can we refine them with
> specific to discuss (and ID someone to launch/lead the discussion)?
>
>   * Framing
>   * Implementations
>   * Parameters & Defaults
>   * Yang model
>
I can lead a discussion on the Yang model, as unfortunately Jake has a
conflict with the MOPS BoF.

Specifics:

Benefits and pain points of using Yang within our PyTAPS implementation

Suggested changes to the model we come up with during the hackathon

Best,
Theresa

---

From: "Aaron Falk" <[email-masked]>
Date: Wed, 03 Jul 2019 11:40:05 -0400

Thanks, Theresa!

---

From: "Holland, Jake" <[email-masked]>
Date: Wed, 3 Jul 2019 17:56:58 +0000

Thanks Theresa!

Ordinarily I’d have happily volunteered to lead the yang discussion, and I appreciate you covering me.  I’ll be at the taps table for the hackathon, and hopefully if I’ve got anything useful to add I can pass it along there or on the list.

I’m annoyed to have to miss taps, but media ops is life for the part of my company that employs me, so I need to support a venue to discuss it as a higher priority, even though I would dearly love to see a better socket API standardized and I love what taps is doing to make that happen.

So please accept my regrets, everyone, and I’ll try to be there next time.

Best,
Jake

From: Aaron Falk <[email-masked]>
Date: 2019-07-03 at 08:40
To: Theresa Enghardt <[email-masked]>
Cc: Zaheduzzaman Sarker <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Taps] call for TAPS agenda items

Thanks, Theresa!

Some topics from our last interim<https://urldefense.proofpoint.com/v2/url?u=https-3A__etherpad.ietf.org_p_nots-2Dinterim-2D2019-2Dtaps-2D02-3FuseMonospaceFont-3Dtrue&d=DwMFAg&c=96ZbZZcaMF4w0F4jpN6LZg&r=bqnFROivDo_4iF8Z3R4DyNWKbbMeXr0LOgLnElT1Ook&m=eTRhoRvkcYrtVgzNT-j0a9WSOun64v11CD8g7S4wtAY&s=tkHahoC2xCxDkPSA7-1MBaIRhNyVN67IfZjnvbOCxj0&e=> seem like good candidates for updates. Can we refine them with specific to discuss (and ID someone to launch/lead the discussion)?
·         Framing
·         Implementations
·         Parameters & Defaults
·         Yang model

I can lead a discussion on the Yang model, as unfortunately Jake has a conflict with the MOPS BoF.

Specifics:

Best,
Theresa

---

From: "Philipp S. Tiesel" <[email-masked]>
Date: Mon, 8 Jul 2019 10:48:13 +0200

> On 2. Jul 2019, at 09:24, Michael Welzl <[email-masked]> wrote:
> 
> Hi again,
> 
>>>> On Jun 30, 2019, at 11:34 PM, Aaron Falk <[email-masked]> wrote:
>>>> 
>>>> Some topics from our last interim seem like good candidates for updates. Can we refine them with specific to discuss (and ID someone to launch/lead the discussion)?
>>>> 
>>>> 	• Framing
>>>> 	• Implementations
>>>> 	• Parameters & Defaults
>>>> 	• Yang model
>>>> 	• Why do people resist specific protocol selection? (from Yang discussion)
>> I originally insisted to keep them separate, as I really like to have the first one and feared the discussion for the second one. As I opened PRs with proposals for both of them (https://github.com/ietf-tapswg/api-drafts/pull/328 and https://github.com/ietf-tapswg/api-drafts/pull/327), I got no fire and fury, but only constructive feedback.

I would like to move this point before “Parameters and Defaults”, as the introduction of Profiles adds an additional resolution for disputed defaults: moving these defaults into the individual profiles and have no/implementation specific defaults for the case without profile.

>>>> 	• ARCH & API open topics

AVE!
   Philipp S. Tiesel

---

From: "Aaron Falk" <[email-masked]>
Date: Mon, 08 Jul 2019 09:46:29 -0400

>> I’d volunteer for this one too.

OK

>> Ok, it sounds to me like this slot should be called “Profiles / 
>> choosing specific protocols”.  Sounds like a nice short discussion 
>> to me.
>
> I would like to move this point before “Parameters and Defaults”, 
> as the introduction of Profiles adds an additional resolution for 
> disputed defaults: moving these defaults into the individual profiles 
> and have no/implementation specific defaults for the case without 
> profile.

Moved.

Updated agenda here: 
https://datatracker.ietf.org/meeting/105/materials/agenda-105-taps-02

--aaron