Subject: [Taps] Open source activities?

From: Martin Duke <[email-masked]>
Date: Mon, 31 Aug 2020 09:58:00 -0700

Can someone point me to any open source taps code out there? I would like
to get involved in this work.

---

From: "Holland, Jake" <[email-masked]>
Date: Mon, 31 Aug 2020 20:19:39 +0000

Hi Martin,

Here’s the one that Max and Theresa have been reporting on in the wg, trying to do a faithful implementation of the spec:
https://github.com/fg-inet/python-asyncio-taps

To me it’s been a really good place to tinker and gain good insights.

In addition to the examples and test apps in that project, we used the library as the transport library for another experimental project, which I don’t think we touched again yet since the hackathon when we worked on it:
https://github.com/GrumpyOldTroll/ambi

I’m not sure if you were looking only for open-source implementations of a taps-related library (which I’ve so far only used python-asyncio-taps, above), or whether you’re also looking for open-source resources about using taps-like libraries to build other things.  For instance, I’ve seen a few resources that dig into using Apple’s Network framework:
https://rderik.com/blog/building-a-server-client-aplication-using-apple-s-network-framework/
https://github.com/apple/swift-nio-transport-services

HTH.

Best,
Jake

From: Martin Duke <[email-masked]>
Date: Monday, August 31, 2020 at 9:58 AM
To: taps WG <[email-masked]>
Subject: [Taps] Open source activities?

Can someone point me to any open source taps code out there? I would like to get involved in this work.

---

From: Michael Welzl <[email-masked]>
Date: Mon, 31 Aug 2020 22:46:58 +0200

… and then there’s NEAT.

NEAT was a European project, active until 2018, which started almost exactly in sync with TAPS, and went along, building code.
The NEAT project page is here: https://www.neat-project.org
and the code is here: https://github.com/NEAT-project/neat

It’s a TAPS type of system offering access to SCTP, among many other things - I think it’s best classified as feature-rich, but with holes and bugs…  also, TAPS has changed after NEAT ended, and so I advised a master thesis to build some kind of a shim layer, to map a really up-to-date TAPS API in Python down to the functionality of NEAT. That’s brand new, and here:
https://github.com/theagilepadawan/NEATPy

We always dreamt of adding QUIC to this code, but QUIC was still very much a moving target when NEAT had long ended.

Cheers,
Michael

> On Aug 31, 2020, at 10:19 PM, Holland, Jake <jholland=[email-masked]> wrote:
> 
> Hi Martin,
>  
> https://github.com/fg-inet/python-asyncio-taps <https://github.com/fg-inet/python-asyncio-taps>
>  
> https://github.com/GrumpyOldTroll/ambi <https://github.com/GrumpyOldTroll/ambi>
>  
> https://rderik.com/blog/building-a-server-client-aplication-using-apple-s-network-framework/ <https://rderik.com/blog/building-a-server-client-aplication-using-apple-s-network-framework/>
> https://github.com/apple/swift-nio-transport-services <https://github.com/apple/swift-nio-transport-services>
>  
> HTH.
>  
> Best,
> Jake
>  
>  
> _______________________________________________
> Taps mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/taps