Subject: [Taps] [Editorial Errata Reported] RFC8303 (6373)

From: RFC Errata System <[email-masked]>
Date: Tue, 29 Dec 2020 00:58:37 -0800 (PST)

The following errata report has been submitted for RFC8303,
"On the Usage of Transport Features Provided by IETF Transport Protocols".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6373

--------------------------------------
Type: Editorial
Reported by: Nikolai Malykh <[email-masked]>

Section: 4.1

Original Text
-------------
   o  SET_TTL.UDP(-Lite) (IPV6_UNICAST_HOPS):

      Pass 1 primitive/event: 'Set_TTL' and 'Set_IPV6_Unicast_Hops'

      Parameters: IPv4 TTL value or IPv6 Hop Count value

      Comments: this allows an application to change the IPv4 TTL of
      IPv6 Hop Count value for outgoing UDP(-Lite) datagrams.

Corrected Text
--------------
   o  SET_TTL.UDP(-Lite) (IPV6_UNICAST_HOPS):

      Pass 1 primitive/event: 'Set_TTL' and 'Set_IPV6_Unicast_Hops'

      Parameters: IPv4 TTL value or IPv6 Hop Count value

      Comments: this allows an application to change the IPv4 TTL or
      IPv6 Hop Count value for outgoing UDP(-Lite) datagrams.

Notes
-----
typo: of instead or

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8303 (draft-ietf-taps-transports-usage-09)
--------------------------------------
Title               : On the Usage of Transport Features Provided by IETF Transport Protocols
Publication Date    : February 2018
Author(s)           : M. Welzl, M. Tuexen, N. Khademi
Category            : INFORMATIONAL
Source              : Transport Services
Area                : Transport
Stream              : IETF
Verifying Party     : IESG

---

From: Gorry Fairhurst <[email-masked]>
Date: Wed, 30 Dec 2020 09:23:27 +0000

*This seems like a typo that could be corrected, and I suggest the WG 
"Hold for Document Update", to correct future versions of the document 
when it is revised.

Gorry

*
**On 29/12/2020 08:58, RFC Errata System wrote:
> _______________________________________________
> Taps mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/taps

---

From: Erik Kline <[email-masked]>
Date: Wed, 30 Dec 2020 22:07:48 -0800

+1

On Wed, Dec 30, 2020 at 1:24 AM Gorry Fairhurst <[email-masked]>
wrote:

> "Hold for Document Update", to correct future versions of the document when
> it is revised. Gorry *
> On 29/12/2020 08:58, RFC Errata System wrote:
>
> You may review the report below and at:https://www.rfc-editor.org/errata/eid6373
>
> Reported by: Nikolai Malykh <[email-masked]> <[email-masked]>
>
> Section: 4.1
>
> Original Text
> -------------
> Taps mailing [email-masked]://www.ietf.org/mailman/listinfo/taps
>
>