Subject: [tcpm] Restarting Keepalive timer

From: "Vishal Study" <[email-masked]>
Date: Sat, 24 Mar 2007 04:33:47 -0700

Hi again:

Consider a one-way traffic scenario between host A and B (data traffic
from A to B).

Should host-A restart its Keepalive timer if it gets an ACK for its
data from host-B?
Or Keepalive timer can only be reset if host-A gets some data from host-B?

Thanks,
Vishal.

_______________________________________________
tcpm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tcpm

---

From: "Agarwal Anurag-A20729" <[email-masked]>
Date: Sun, 25 Mar 2007 00:19:44 +0800

Keep Alive is to detect 'Half-Open' connections, which basically means
whether the
other end is still alive. Other end might just be a passive listener and
just
generate ACKs for the data it receives. ACKs alone should be good enough
to 
restart the TCP Keep Alive timer.

Regards,
Anurag

-----Original Message-----
From: Vishal Study [mailto:[email-masked]] 
Sent: Saturday, March 24, 2007 5:04 PM
To: [email-masked]
Subject: [tcpm] Restarting Keepalive timer

Hi again:

Should host-A restart its Keepalive timer if it gets an ACK for its data
from host-B?
Or Keepalive timer can only be reset if host-A gets some data from
host-B?

Thanks,
Vishal.