Subject: [tcpm] New Version - draft-ietf-tcpm-newcwv-07.txt

From: [email-masked]
Date: Thu, 18 Sep 2014 15:29:22 +0100

The authors have submitted this update to CWV:

- It updates text on ECN to clarify the process where R is a reduction
based on ECN marks, and with the expectation this aligns better the
current work on ECN within TCPM.

-It notes that cwnd shouldn't be reduced below one MSS.

- It also contains very minor changes to addresses all the current issues
noted with the draft.

 We'd like to hear comments on this version.

Gorry & Co-authors

>
> A new version (-07) has been submitted for draft-ietf-tcpm-newcwv:
> http://www.ietf.org/internet-drafts/draft-ietf-tcpm-newcwv-07.txt
>
>
> The IETF datatracker page for this Internet-Draft is:
> https://datatracker.ietf.org/doc/draft-ietf-tcpm-newcwv/
>
> Diff from previous version:
> http://www.ietf.org/rfcdiff?url2=draft-ietf-tcpm-newcwv-07
>
> Please note that it may take a couple of minutes from the time of
> submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> IETF Secretariat.
>

---

From: "Zimmermann, Alexander" <[email-masked]>
Date: Mon, 22 Sep 2014 16:58:40 +0000

Hi Gorry,

C&P from the TCPM 90 minutes:

"Yuchung: Linux uses different algorithm to detect cwnd limited. We
recently submitted a patch. What are your comments about the
difference of the two? How does this interact with TSO?
          
Gorry: I don't know it.
          
Yuchung: Let's take it offline.
          
Gorry: Is it likely to change the spec?
          
Yuchung: We believe our idea is probably simpler. Yours is more
difficult to implement. Linux uses TSO which creates a different way
to see if cwnd is limited. These are interesting issues to consider
which are not addressed in this draft.“

Gorry can you comment on this? Is this already discussed w/ Yuchung?
Can change the draft to reflect his ideas or is this completely
incompatible w/ NewCVW?

Greetings
Alex

Am 18.09.2014 um 10:29 schrieb [email-masked]:

> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm

---

From: Yuchung Cheng <[email-masked]>
Date: Mon, 22 Sep 2014 19:40:57 +0000

> Can change the draft to reflect his ideas or is this completely
Gorry did reach to me and Neal but we couldn't quite parse the long email
so we didn't make much progress.

The latest Linux uses an algorithm by Neal Cardwell that incidentally is
similar to the proposed newcwv draft sec 4.2. The key differences are

1) it uses FlightSize instead of the pipe variable
2) it takes care of the TSO deferral. The TSO deferral part is important
because TCP may not always fill cwnd in order to build bigger packet.

http://patchwork.ozlabs.org/patch/351512/

Note there is a preceeding bug-fix patch done by Eric Dumazet, where TSO
and TCP small queue, could trick TCP not to slow start fast. This
demonstrates the complexity to determine if TCP is cwnd limited or not, in
modern networking stack.

http://patchwork.ozlabs.org/patch/344293/

Linux does not implement newcwv. I guess it's not clear if the other parts
are useful or not, other than not being so conservative in growing cwnd.
Lastly, I would recommend newcwv draft to be more specific on the algorithm
in Sec 4.2.

HTH