Subject: [tcpm] Fwd: New Version Notification for draft-zimmermann-tcpm-cubic-00.txt

From: "Zimmermann, Alexander" <[email-masked]>
Date: Mon, 1 Sep 2014 10:51:04 +0000

Hi TCPM WG,

after more or less 6 years after the last submission of CUBIC, we resubmit the
draft today. The current submission is exactly the same as old draft from 2008.

In upcoming versions we plan to document current version of CUBIC implementation
(may or may not including Hystart), so that it can be implemented by others
without needing to refer to the Linux code.

Alex

Anfang der weitergeleiteten Nachricht:

> Von: <[email-masked]>
> Betreff: New Version Notification for draft-zimmermann-tcpm-cubic-00.txt
> Datum: 1. September 2014 12:35:26 MESZ
> An: Lars Eggert <[email-masked]>, Lars Eggert <[email-masked]>, Lisong Xu <[email-masked]>, Injong Rhee <[email-masked]>, Alexander Zimmermann <[email-masked]>, Alexander Zimmermann <[email-masked]>, Sangtae Ha <[email-masked]>, Lisong Xu <[email-masked]>, "Injong Rhee" <[email-masked]>
> 
> 
> A new version of I-D, draft-zimmermann-tcpm-cubic-00.txt
> has been successfully submitted by Alexander Zimmermann and posted to the
> IETF repository.
> 
> Name:		draft-zimmermann-tcpm-cubic
> Revision:	00
> Title:		CUBIC for Fast Long-Distance Networks
> Document date:	2014-09-01
> Group:		Individual Submission
> Pages:		14
> URL:            http://www.ietf.org/internet-drafts/draft-zimmermann-tcpm-cubic-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-zimmermann-tcpm-cubic/
> Htmlized:       http://tools.ietf.org/html/draft-zimmermann-tcpm-cubic-00
> 
> 
> Abstract:
>   CUBIC is an extension to the current TCP standards.  The protocol
>   differs from the current TCP standards only in the congestion window
>   adjustment function in the sender side.  In particular, it uses a
>   cubic function instead of a linear window increase of the current TCP
>   standards to improve scalability and stability under fast and long
>   distance networks.  BIC-TCP, a predecessor of CUBIC, has been a
>   default TCP adopted by Linux since year 2005 and has already been
>   deployed globally and in use for several years by the Internet
>   community at large.  CUBIC is using a similar window growth function
>   as BIC-TCP and is designed to be less aggressive and fairer to TCP in
>   bandwidth usage than BIC-TCP while maintaining the strengths of BIC-
>   TCP such as stability, window scalability and RTT fairness.  Through
>   extensive testing in various Internet scenarios, we believe that
>   CUBIC is safe for deployment and testing in the global Internet.  The
>   intent of this document is to provide the protocol specification of
>   CUBIC for a third party implementation and solicit the community
>   feedback through experimentation on the performance of CUBIC.  We
>   expect this document to be eventually published as an experimental
>   RFC.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: Michael Welzl <[email-masked]>
Date: Mon, 1 Sep 2014 13:06:48 +0200

Wow! As ICCRG co-chair I think that's great!

The history of ICCRG evaluation is still there, at:
http://trac.tools.ietf.org/group/irtf/trac/wiki/ICCRG_cubic
It would be worthwhile going through the comments on this page and see if they've been addressed.

Cheers,
Michael

On 1. sep. 2014, at 12:51, Zimmermann, Alexander wrote:

> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm