Subject: [tcpm] Initial CWND

From: Ingemar Johansson S <[email-masked]>
Date: Tue, 17 Mar 2015 06:37:34 +0000

Hi

A humble question, anybody has any data on how widely spread the use of Initial CWND = 10MSS (or max 14600byte) is ?.
I have only looked at a few wireshark logs and cannot make any hard conclusion based on that.

/Ingemar
=================================
Ingemar Johansson  M.Sc.
Senior Researcher

Ericsson AB
Wireless Access Networks
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289
[email-masked]<mailto:[email-masked]>
www.ericsson.com

"The Earth is a very small stage in a
 vast cosmic arena"
Carl Sagan "Pale Blue Dot"
=================================

---

From: Michael Welzl <[email-masked]>
Date: Tue, 17 Mar 2015 11:44:18 +0000

Hi,

I think it's pretty widely used given the results in table 1 here:
http://heim.ifi.uio.no/~michawe/research/publications/networking2014.pdf

Now these are only a few data points, but from pretty large CDNs AFAIK. Then again, the data is old - I did this check in 2013.

If you want to repeat the test, this was pretty easy to do. Here's what I did:
- get a web page, watch wireshark, find a URL of an object (image or something) that's larger than 10 packets
- do the following with help of scapy  ( http://www.secdev.org/projects/scapy/ ):
  * send a TCP SYN, respond to the SYN/ACK with a correct ACK
  * disable all outgoing ACKs with the firewall
  * send a HTTP GET to the address of the large object with scapy
  * watch how many packets come back, in wireshark

...  since you never ACK anything, you only get the initial window, followed by single retransmits after an RTO on the server side. That can certainly be automatized, I did this half-manually.

I hope this helps... and I hope others have some more recent data.

Cheers,
Michael

> On 17 Mar 2015, at 07:37, Ingemar Johansson S <[email-masked]> wrote:
> 
> Hi
>  
> [email-masked]
> www.ericsson.com
>  
> “The Earth is a very small stage in a 
>  vast cosmic arena”
> Carl Sagan “Pale Blue Dot”
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm

---

From: Matthew Luckie <[email-masked]>
Date: Tue, 17 Mar 2015 07:11:27 -0700

> I hope this helps... and I hope others have some more recent data.

I have a student (Tiange Wu, cc'd) who has been working with various
tbit tests who has recent data for ICW.

http://www.caida.org/~mjl/icw-1460.png

That graph covers 6714 servers in the first alexa 10K on Feb 10 2015.
A 1460 MSS was advertised.

---

From: Ingemar Johansson S <[email-masked]>
Date: Tue, 17 Mar 2015 19:54:18 +0000

Hi

Thanks Michael and Mathew for the info. It was indeed helpful and answered my questions more than enough.

Regards
Ingemar

-----Original Message-----
From: Michael Welzl [mailto:[email-masked]] 
Sent: den 17 mars 2015 12:44
To: Ingemar Johansson S
Cc: [email-masked]
Subject: Re: [tcpm] Initial CWND

Hi,

Cheers,
Michael

> "The Earth is a very small stage in a  vast cosmic arena"

---

From: "Scheffenegger, Richard" <[email-masked]>
Date: Tue, 17 Mar 2015 21:12:40 +0000

Just a note of warning - the alexa top n (with n < something like 10 000) sites may not be representative of the overall population.

For starters, the topmost sites will all utilize CDNs, load balancers, reverse proxys etc, which you'll not find further down in the alexa top 1M list.

Picking a similar sample from some distributed sites further down the list, and comparing these two samples might be revealing to certain aspects (at the least, it would be statistically be more valid). We (Brian Trammel et. al.) found this in our recent ECN testing exercise).

Best regards,
  Richard

> From: tcpm [mailto:[email-masked]] On Behalf Of Matthew Luckie
> Sent: Dienstag, 17. März 2015 15:11
> To: Michael Welzl
> Cc: [email-masked]; [email-masked]
> I have a student (Tiange Wu, cc'd) who has been working with various tbit
> tests who has recent data for ICW.
>

---

From: Hagen Paul Pfeifer <[email-masked]>
Date: Sat, 21 Mar 2015 12:44:49 +0100

>   * watch how many packets come back, in wireshark

This could and should be less complicated if you want to do this on a
large basis:

- "Spider" over a list of websites and grab at least a MSS * 10 byte
object (probably more because some CDN violates IW10 and IW15 and
more).
- Capture all data in a pcap file
- Analyse the file and check for IW, using a python script:
   - Separate on a per TCP connection basis
   - Ignore TWH and HTTP GET request, count first burst

hgn

---

From: Michael Welzl <[email-masked]>
Date: Sat, 21 Mar 2015 13:59:08 +0000

well this is roughly what i meant when i said "could be automatized"  :)

Sent from my iPhone

> On 21. mars 2015, at 11:44, Hagen Paul Pfeifer <[email-masked]> wrote:
>