Subject: [tcpm] Cubic and LTE (was RE: some editorial comments on draft-ietf-tcpm-cubic-02)

From: Ingemar Johansson S <[email-masked]>
Date: Wed, 14 Sep 2016 07:35:32 +0000

Hi

A comment on section 4.3 "Difficult environments"
Based on LTE system simulation experience, I don't find Cubic to be worse than e.g. Reno, we see occasional issues with HyStart but that is another matter. With the use of proper AQM (or ECN) I can see that Cubic is actually quite well behaved.
The root problem is that LTE networks seem to be bufferbloated today, AQMs are in general not deployed or enabled. The outcome is that transport protocols with Cubic or Reno, or any other other loss based congestion control algorithm for that matter, can be claimed to operate in congestion avoidance. The results can be RTT in the order of seconds which may or may not cause problems with RTO and/or large burst losses at handover depending on the deployment of packet forwarding in LTE networks.
So at least my conclusion, based on my own experience is that Cubic is not the big problem here.

Regards
Ingemar

> 
> Message: 1
> Date: Tue, 13 Sep 2016 19:02:26 +0000
> From: Greg White <[email-masked]>
> 
> 
> 
> Comment 2:  Section 4.3 reads:
> 
> 4.3.  Difficult Environments
> 
>    CUBIC is designed to remedy the poor performance of TCP in fast long-
>    distance networks.  It is not designed for wireless networks.
> 
> Since a large proportion of TCP flows today cross a wireless link (WiFi or LTE),
> this statement and the heading seem kind of anachronistic.   Perhaps it
> would be better to describe what some of the concerns might be with
> operation across today?s networks that are likely to contain wireless links (if
> there are any), or state what properties of a wireless network would cause
> problems for CUBIC.
> 
> ************************************

---

From: Lisong Xu <[email-masked]>
Date: Wed, 14 Sep 2016 09:23:44 -0500

Thanks, Ingemar, for your comments.

Lisong

On 9/14/2016 2:35 AM, Ingemar Johansson S wrote:
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm