Subject: [tcpm] [Errata Held for Document Update] RFC5961 (4772)

From: RFC Errata System <[email-masked]>
Date: Mon, 12 Sep 2016 05:31:09 -0700 (PDT)

The following errata report has been held for document update 
for RFC5961, "Improving TCP's Robustness to Blind In-Window Attacks". 

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5961&eid=4772

--------------------------------------
Status: Held for Document Update
Type: Technical

Reported by: Stéphane Bortzmeyer <[email-masked]>
Date Reported: 2016-08-10
Held by: Mirja Kühlewind (IESG)

Section: 7

Original Text
-------------
[The entire section]

Corrected Text
--------------
No suggested text because it requires a much more serious analysis. 
May be adding that the rate-limit counter SHOULD be per-connection, 
in the spirit of RFC 6528?

Notes
-----
It appears the section does not specify that the counter for ACK throttling SHOULD be per-connection. In Linux, it is apparently global, which allowed its use as a side channel enabling nasty attacks (CVE-2016-5696 and the paper "Off-Path TCP Exploits: Global Rate Limit Considered Dangerous" <http://www.cs.ucr.edu/~zhiyunq/pub/sec16_TCP_pure_offpath.pdf>).
Also see discussion on tcpm list about this reported errata!

--------------------------------------
RFC5961 (draft-ietf-tcpm-tcpsecure-13)
--------------------------------------
Title               : Improving TCP's Robustness to Blind In-Window Attacks
Publication Date    : August 2010
Author(s)           : A. Ramaiah, R. Stewart, M. Dalal
Category            : PROPOSED STANDARD
Source              : TCP Maintenance and Minor Extensions
Area                : Transport
Stream              : IETF
Verifying Party     : IESG

---

From: Loganaden Velvindron <[email-masked]>
Date: Tue, 13 Sep 2016 10:45:39 +0400

On Fri, Aug 19, 2016 at 5:43 PM, Mirja Kühlewind
<[email-masked]> wrote:
>> sounds fine with me but do documents really get updated?
> That depends on the working group. However the point here is, if the doc gets updated, then this is still listed.
>
> Mirja
>
>

I received feedback on the draft I posted. I can update it, based on
the feedback I received so far, assuming there is interest to make the
specs more clear.