Subject: [tcpm] review of draft-ietf-tcpm-rack-04

From: Yi Huang <[email-masked]>
Date: Sat, 15 Dec 2018 00:22:03 +0000

Hi,

I have read draft-ietf-tcpm-rack-04 and have some thoughts to share with tcpm.

1. Page. 13, it seems there is a bug in the pseudocode of RACK_detect_loss() (Line 5).

For each packet, Packet, not acknowledged yet:

        If Packet.lost is TRUE or Packet.retransmitted is FALSE: // “or” should be changed to “and”

            Continue /* Lost packet not retransmitted yet */

The current logic would skip any packets that need to be retransmitted in scoreboard. Also, the comment after “Continue” also says “Lost packet not retransmitted yet” which implicitly is an AND.

2. In Page 19, the following statements are contradictory.

a. A sender considers both the original segment and TLP probe retransmission segment as acknowledged if either 1 or 2 are true:

b. If neither conditions are met, then the sender estimates that the receiver received both the original data segment and the TLP probe retransmission, and so the sender considers the TLP episode to be done, and records that fact by setting TLPRxtOut to false.

I think, in b, “neither” should be changed to “either” since the “then” part is the same for a and b, which says both the original segment and probe are acked.

3. Page 7, from "RACK.reo_wnd_persist" to the end of this paragraph, punctuations might be needed since several variable definitions stick together.

Thanks,

Yi

---

From: Yuchung Cheng <[email-masked]>
Date: Sun, 16 Dec 2018 19:18:39 -0800

Thanks for the good catches. Ack and will revise the three issues in
the next draft.

On Fri, Dec 14, 2018 at 4:22 PM Yi Huang
<huanyi=[email-masked]> wrote:
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm