Subject: RE: nt to nt tcpsat problems

From: "Robert Schellhase" <[email-masked]>
Date: Thu, 10 Feb 2000 18:45:35 -0500

Bill,

Thanks for the archive reference. I had not read it.

My own observation using a protocol analyzer was that the window size stays
at 8 kB. Some other folks here also tried it with the same result.

When making changes to the registry, it is necessary to reboot in order for
them to take effect, so I did this. I'm not sure what the Path MTU discovery
and black hole detect keys have to do with the TCP window size, but I did
not tamper with these. The link on Christophe's message to MSDN no longer
works, and the current MSDN documentation doesn't mention the need to set
these keys in the TcpWindowSize context.

Perhaps these two keys were what I was missing, or it is entirely possible
that I made some other more fundamental mistake. I would be more than happy
to hear from someone who has sucessfully gotten this to work.

Robert

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Shvodian, Bill
Sent: Thursday, February 10, 2000 5:38 PM
To: 'Robert Schellhase'
Cc: [email-masked]
Subject: RE: nt to nt tcpsat problems

Robert, When you say "it has no effect" do you mean that the window stays at
the default 8 kB?  Has this been reported anywhere?  I have read that the
machine needs to be re-booted before it takes effect.  Here is a tcpsat post
from someone named Christophe Orlhac and he doesn't mention a problem:

http://tcpsat.grc.nasa.gov/list/archive/0588.html

I am interested if you have any more information.  Thanks.

Bill Shvodian

> -----Original Message-----
> From:	Robert Schellhase [SMTP:[email-masked]]
> Sent:	Thursday, February 10, 2000 2:18 PM
> To:	[email-masked]
> Cc:	[email-masked]
> Subject:	RE: nt to nt tcpsat problems
>
> Hi Graham,
> I see you have found that Windows supports a registry key for
> TcpWindowSize.
> The sad news is that it has no effect, in spite of the fact that Microsoft
> has a white paper on its own TCP implementation that claims otherwise.
>
> You might try the NetManage OnNet kernel for Windows 95/98 at
> http://www.netmanage.com/products/onnetkernel4/index.asp
>
> I don't know what they charge for it, but I think it's affordable and they
> offer a free demo.
>
> Best regards,
> Robert Schellhase
> Senior Engineer
> INTELSAT
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Graham Street
> Sent: Thursday, February 10, 2000 9:04 AM
> To: [email-masked]
> Subject: nt to nt tcpsat problems
>
>
> Hi all,
>
> We're trying to run windows file sharing protocols over a tcp sat link
> and getting miserable performance, even after setting TcpWindowSize to
> 65536.   We can get about 100-250k max.  We are trying to get at least
> one megabit out of it.  Is this even possible?  We can get 1-2 megabits
> ftping from a sun box over satellite...
>
> does anyone know of any clever (cheap) solutions  (spoofing nacks?,
> translating
> to udp?)
>
> Thanks,
> Graham Street
> [email-masked]

---

From: "Shvodian, Bill" <[email-masked]>
Date: Thu, 10 Feb 2000 17:37:48 -0500

Bill Shvodian