Subject: bandwidth on VSAT transfer

From: "Thomas Wiard" <[email-masked]>
Date: Wed, 23 Feb 2000 11:06:55 +0100

Hi from France.

we are testing the Comsat VSAT solution (linkway 2000) but we have a limitation about the bandwidth on a TFTP, FTP and RTSP transfer.

for instance, on an FTP or TFTP transfer, we are up to 80 kbps on each to session.  That is to say, if I open 4 FTP sessions, I am able to transfer 4 different files at each 80 kbps. 
The purpose is to be able for me to transfer in one session up to 2 Mbps (my bandwidth on the sattelite)

I am using Windows 98 on each point of the connection.

Is anybody can help me ?

a++

Thomas Wiard
[email-masked]
phone : +33 1 42 30 18 66
mobile : +33 6 14 98 69 63

---

From: Fred Baker <[email-masked]>
Date: Wed, 23 Feb 2000 08:07:50 -0800

>Is anybody can help me ?

bottom line is that TCP will move one window per round trip, and it starts
at a pretty small amount. It sounds like your TCP is not using large
windows (RFC 1323) or is not using SACK (RFC 2018).

---

From: "David R. Beering" <[email-masked]>
Date: Wed, 23 Feb 2000 12:05:50 -0600

Thomas:

As an addendum to Fred's note ...

We did some testing about a year ago with the NetManage FTP Software
product. It is a third-party TCP stack for Win98 that supports RFC1323. See
to recall that we were getting something like 120 Mbps single-stream over a
GEO delay simulator. It is my understanding that NetManage has most of the
'knobs' to tweak the TCP parameters (window size, timers, etc.) exposed to
the user, so this should be relatively straightforward.

Good luck.

	Dave Beering

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Thomas Wiard
Sent: Wednesday, February 23, 2000 4:07 AM
To: [email-masked]
Cc: [email-masked]
Subject: bandwidth on VSAT transfer

Hi from France.

we are testing the Comsat VSAT solution (linkway 2000) but we have a
limitation about the bandwidth on a TFTP, FTP and RTSP transfer.

for instance, on an FTP or TFTP transfer, we are up to 80 kbps on each to
session.  That is to say, if I open 4 FTP sessions, I am able to transfer 4
different files at each 80 kbps.
The purpose is to be able for me to transfer in one session up to 2 Mbps (my
bandwidth on the sattelite)

Is anybody can help me ?

a++

Thomas Wiard

---

From: "Greg Otto" <[email-masked]>
Date: Wed, 23 Feb 2000 15:07:20 -0600

Thomas,

Based on my experiences with the Microsoft FTP servers and clients, there
are upper layer protocol limitations with respect to how it handles passing
data from into the TCP layers.  As a result, I concur with Dave on using non
MS products to get your throughput.

Also, TFTP is a single packet per RTT acknowledgement protocol.  Thus,
unless you want 512 byte/RTT throughput, you will NOT see anything better.

Greg

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of David R. Beering
Sent: Wednesday, February 23, 2000 12:06 PM
To: Thomas Wiard
Cc: [email-masked]; [email-masked]
Subject: RE: bandwidth on VSAT transfer

Thomas:

Good luck.

	Dave Beering

-----Original Message-----

Hi from France.

Is anybody can help me ?

a++

Thomas Wiard

---

From: Nalin Mehta <[email-masked]>
Date: Wed, 23 Feb 2000 17:02:06 -0500 (EST)

Thomas and Sylvain,
I just chanced on a URL that might be useful to you if you are thinking
of tweaking some of the TCP parameters in Windows 98 (and other OSes).
I feel that if you increase the window size you will see an increase in
throughput.

The URL is: http://www.psc.edu/networking/perf_tune.html

Regards,
Nalin Mehta
Comsat Labs, Clarksburg, MD 20871.
Ph: 1-301-428-4582.

On Wed, 23 Feb 2000, Greg Otto wrote:

> Date: Wed, 23 Feb 2000 15:07:20 -0600
> From: Greg Otto <[email-masked]>
> To: [email-masked], 'Thomas Wiard' <[email-masked]>
> Cc: [email-masked], [email-masked]

---

From: Nalin Mehta <[email-masked]>
Date: Fri, 25 Feb 2000 15:02:20 -0500 (EST)

Thomas and Sylvain,
I did a quick test and found that with the ordinary FTP client on
Windows 98 and FTP server on Solaris 2.6, the throughput for a large
file (18228147 bytes) FTPed across a GEO based satellite (Intelsat)
using COMSAT's Linkway 2000 IP product (that you referred to) was
741.84 kbps (on average) with Committed Allocation and 692.64
kbps (on average) with Bandwidth on Demand (with initial 64 kbps
seed allocation). The reason that there is a comparatively low
throughput with BoD is because of the chicken and egg problem faced
with running TCP over a BoD, large delay system. The only difference
between your setup and mine was that I used native IP from Linkway
and you used IP over Frame Relay but this is not relevant to the
case, I believe.

I configured only two parameters to see such a change in throughput:
the 'tcp_xmit_hiwat' param in Solaris and 'DefaultRcvWindow' in
Windows 98. I believe (not sure!) that support for Large Windows is
inherent to these two OSs by default. Both params were set to 64K.

Compare these values with a DefaultRcvWindow size of 8K which would
give a throughput of approx 80 kbps.

Best regards,
Nalin Mehta
Linkway 2000 IP development team,
Comsat Labs, Clarksburg, MD 20871.