Subject: RE: Setting the appropriate MTU

From: "Johnson, Gregory LCDR" <[email-masked]>
Date: Tue, 15 Feb 2000 10:38:30 -0500

Bigger is not better for slow networks. For a link speed of 4kbps you will
need to use much smaller MTU sizes since the transmission time for a packet
gets too long otherwise. It will also depend upon what the latency is in the
link because the total transmission time for a packet is a function of the
size and delay. For a typical GEO link, I would expect that you have
anywhere up to 600ms depending upon what kind of FEC and interleaving is
done on the link. I have found for Inmarsat-M/Mini-M type links (2.4 kbps)
that an MTU size of 500 works well. You also need to adjust the initial RTO
value larger (the default is 3 secs, try 5 secs). If you don't do this, you
will suffer a lot of timeouts and retransmissions. I'm not that familiar
with the protocol Citrix uses, but with only 4kbps of bandwidth, you also
don't want to run multiple simultaneous connections across your link as one
connection will probably saturate the link.

-Greg 

LCDR Gregory W. Johnson 
Ass't Prof. Electrical Engineering 

USCG Academy 
New London CT 

860-444-8683 

-----Original Message-----
From: Julien Godard [mailto:[email-masked]]
Sent: Tuesday, February 15, 2000 4:59 AM
To: 'Testasecca, Mariano'
Cc: [email-masked]'
Subject: RE: Setting the appropiate MTU

for performance, the bigger the better ! 
But it may depend also on your network because you may want to avoid
fragmentation. 
You can test your MTU with some free tools such as easyMTU
http://members.tripod.com/~EasyMTU/ <http://members.tripod.com/~EasyMTU/>  
For example if you use ethernet link, the MTU is 1500, leading to 1448 bytes
of data in each segment (20 IP + 20 TCP + 12 TCP timestamp option + 1448
data). If your router support this size without fragmentation, it's fine !

	-----Original Message----- 
From:   Testasecca, Mariano [SMTP:[email-masked]] 
Sent:   Monday, February 14, 2000 7:49 PM 
To:     [email-masked]' 
Subject:        Setting the appropiate MTU 

	What MTU value would be appropiate for Windows 95/98 terminals
working as a 
Windows NT 4.0 running Citrix MetaFrame under 
a satellite link of a VSAT that provides 4kbps of bandwidth? 

	Thanks to all. 

	Mariano Testasecca 
SIEMENS S.A. 
División Electromedicina 
Servicios de Salud - SHS 
Bolivar 177 1º Piso 
*+54-11-4340-8400 int. 2796 
* mailto:[email-masked]
<mailto:[email-masked]>

---

From: "Julien Godard" <[email-masked]>
Date: Tue, 15 Feb 2000 15:53:28 -0000

Oups ! Yes, correct !
I completelly forgot to look at the bandwidth. I am too use to run test with
x Mbps...

> From:	Johnson, Gregory LCDR [SMTP:[email-masked]]
> Sent:	Tuesday, February 15, 2000 3:39 PM
> To:	Godard, Julien [HAL02:HM90:EXCH]; 'Testasecca, Mariano'
> Subject:	RE: Setting the appropriate MTU
>

---

From: "Davenport, David M (CRD)" <[email-masked]>
Date: Tue, 15 Feb 2000 15:18:22 -0500

Now you've added mobility to the equation...

With Inmarsat-M/Mini-M and other low data-rate, mobile satellite services 
an appropriate MTU selection is driven primarily by the Rician/Rayleigh
fading channel and the trade-off:

Large data frames to increase throughput efficiency
                              - vs. -
Small data frames to reduce required retransmission due to fading/shadowing

For fixed site satellite with BER < 10^(-5), I'd suggest IP fragmentation along the
entire route dominates MTU selection...and the bigger the better.

David M. Davenport
GE Corporate Research and Development
One Research Circle, M/S KWC421
Niskayuna, NY   12309
Phone/Fax:  (518) 387-5041/4042  

***** Opinions contained herein are my own 
     and not necessarily those of my employer *****

-----Original Message-----
From: Johnson, Gregory LCDR [mailto:[email-masked]]
Sent: Tuesday, February 15, 2000 10:39 AM
To: Julien Godard; 'Testasecca, Mariano'
Cc: [email-masked]'
Subject: RE: Setting the appropriate MTU

-Greg 

LCDR Gregory W. Johnson 

USCG Academy 
New London CT 

860-444-8683 

	-----Original Message----- 
From:   Testasecca, Mariano [SMTP:[email-masked]] 
Sent:   Monday, February 14, 2000 7:49 PM 
To:     [email-masked]' 
Subject:        Setting the appropiate MTU 

	Thanks to all. 

	Mariano Testasecca 
SIEMENS S.A. 
Division Electromedicina 
Servicios de Salud - SHS 
Bolivar 177 1o Piso

---

From: "Julien Godard" <[email-masked]>
Date: Wed, 16 Feb 2000 10:13:36 -0000

without joking, the correct answer is yes...

In fact I run some tests for a fixed bandwidth (2 Mbps) and some over BoD
(max of 384 K) with a link delay of 600ms.
Due to TCP congestion avoidance behavior, in both case, the bigger MTU gives
the best results.
Of course, by increasing the MTU, you increase the RTT in the case of low
rate (time needed to transmit the packet) or BoD (ressources required to
transmit the packet). Thus you have to adapt your socket buffer size (and
thus your max window) to the BDP with the "real RTT", and not only the link
delay. In the case of Bod tests, my RTT was around 3-4s, which may be
comparable with large MTU on a low rate link. At the beginning of the
connection, the RTT is small, so you don't have problems with the RTO. When
you reach a steady state, the RTT increase, but the RTO is adjusted.

A good way to test the RTT during a connection without sophisticated tools
is simply to run on the same link a simple ping and a TCP bulk transfer.
With the ping you can get the real RTT, and then adjust your buffer size.

Hope it's helpfull !

Cheers
julien

> From:	Dave [SMTP:[email-masked]]
> Sent:	Wednesday, February 16, 2000 1:40 AM
> To:	Godard, Julien [HAL02:HM90:EXCH]; 'Johnson, Gregory LCDR';
> 'Testasecca, Mariano'
> Subject:	Re: Setting the appropriate MTU
> 
>  
> RE: ..."x Mbps. . ."
> Is that like Bandwidth-On-Demand?
> ;)
>  
> Cheers,
> Dave sends
> 
> 	----- Original Message ----- 
> 	From: Julien Godard <mailto:[email-masked]> 
> 	To: 'Johnson, Gregory LCDR' <mailto:[email-masked]> ;
> 'Testasecca, Mariano' <mailto:[email-masked]> 
> 	Cc: [email-masked]' <mailto:[email-masked]'> 
> 	Sent: Tuesday, February 15, 2000 10:53 AM
> 	I completelly forgot to look at the bandwidth. I am too use to run
> test with x Mbps... 
> 
> 	From:   Johnson, Gregory LCDR [ SMTP:[email-masked]
> <mailto:SMTP:[email-masked]>] 
> 	Cc:     [email-masked]' <mailto:[email-masked]'> 
> 	From: Julien Godard [ <mailto:[email-masked]>] 
> 	<http://members.tripod.com/~EasyMTU/> <
> <http://members.tripod.com/~EasyMTU/>>  
> 	* <mailto:[email-masked]> 
> 	< <mailto:[email-masked]>>  
> 
> 
> 
> 
> 
> 
>

---

From: Mark Allman <[email-masked]>
Date: Mon, 21 Feb 2000 08:58:27 -0500

> Of course, by increasing the MTU, you increase the RTT in the case
> of low rate (time needed to transmit the packet) or BoD
> (ressources required to transmit the packet). Thus you have to
> adapt your socket buffer size (and thus your max window) to the
> BDP with the "real RTT", and not only the link delay.

I *think* I disagree, but I am not completely sure what you're
saying...  Your buffer sizes need to be about 1*BDP of the unloaded
path.  If you use a higher delay that the propagation delay then you
are building a persistent queue somewhere.  Basically, the BDP of
the unloaded network is the number of bits that will "fit" into the
network at one time.  So, if your window is bigger than this you are
pushing more bits than the network itself is able to handle over the
path.  The bits either have to go into queues or in the bit-bucket.

(You might need to make a small change for the transmission time of
a packet ona slow link.  I'd have to think about that some more.
But, in general you do not want to track the "real" RTT to determine
how big your socket buffers should be.)

allman

---
http://roland.grc.nasa.gov/~mallman/