Subject: Re: Network Simulation Tools

From: Martin Koyabe <[email-masked]>
Date: Tue, 22 Feb 2000 18:01:37 +0000 (GMT)

Marc,

NS might be your reasonable choice !!

Check Tom's work on simulation TCP via LEO's with ns !!

http://www.cs.berkeley.edu:80/~tomh/thesis/

-- Martin

---------------------------------------------------------------------
Martin L.W.D Koyabe			e-mail: [email-masked]
Electronics Research Group		
Fraser Noble Building			
King's College, AB24 3UE		(Off) +44-01224-272813
Aberdeen, UK				(Mob) +44-07881-610825

> Date: Tue, 22 Feb 2000 16:49:30 +0100
> From: Marc Emmelmann <[email-masked]>
> X-Accept-Language: en-US,de,fr
> MIME-Version: 1.0
> To: "[email-masked]'" <[email-masked]>
> Subject: Network Simulation Tools
> Content-Transfer-Encoding: 7bit
> 
> Hello,
> 
> I need to run some experiments / simulations with TCP/IP in a LEO
> Satellite environment. My special interest is on how the different TCP
> flavors behave in the context of time-varying round trip delays.
> 
> I am planing to use the NS Network Simulator (ns2) for my trials and
> would like to ask if any of you has a suggestion about other simulator I
> should considder or (even better) has a pointer to previous work by some
> one else.
> 
> Thanks for your reply,
> 
> Marc
> 
> --
> German National Research            Research Center for
> Center for Information Technology   Open Communication Systems
> 
> Marc Emmelmann                      Phone:  +49-30-34 63 - 7265
> GMD-FOKUS                           Fax:    +49-30-34 63 - 8265
> Kaiserin-Augusta-Allee 31           e-mail: [email-masked]
> D-10589 Berlin, Germany             http://www.fokus.gmd.de
> 
> PGP Fingerprint: 9858 95FA 0705 9D81 AB2A  EE64 5D7F CEBA 2943 2BD5

---

From: "Shvodian, Bill" <[email-masked]>
Date: Tue, 22 Feb 2000 14:28:11 -0500

Marc, OPNET supports the different flavors of TCP, and it provides some LEO
models as user contributed models.  I have never used the LEO models, so I
can't comment on their usefulness.

http://www.mil3.com

Bill Shvodian 

> -----Original Message-----
> From:	Marc Emmelmann [SMTP:[email-masked]]
> Sent:	Tuesday, February 22, 2000 10:50 AM
> To:	[email-masked]'

---

From: "Julien Godard" <[email-masked]>
Date: Wed, 23 Feb 2000 08:42:54 -0000

for emulation (experiments) a good starting point is the RFC 2398 "TCP tools
for implementators"
I especially recommend the combinaison of tcpdump/tcptarce/xplot to analyse
TCP behavior.
I never try to use delay generators mentionned in this RFC, so I don't know
if they are capable to generate changing delay.

For NS, I know there is a TCP stack and some satellite tools. But I never
play with them.

Cheers
Julien

> Sent:	22 February 2000 15:50

---

From: Lovisolo Piero <[email-masked]>
Date: Wed, 23 Feb 2000 12:01:25 +0100

I agree, we use OPNET TCP model in our research and works fine, 
moreover OPNET has an STK interface su you can model satellite 
constellation using STK and import it into OPNET.

Piero Lovisolo

> ----------
> From: 	Shvodian, Bill[SMTP:[email-masked]]
> Sent: 	Tuesday, February 22, 2000 8:28 PM
> To: 	'Marc Emmelmann'; [email-masked]'
> Subject: 	RE: Network Simulation Tools
>