Subject: RE: TCP performance

From: "Johnson, Gregory LCDR" <[email-masked]>
Date: Thu, 17 May 2001 11:45:03 -0400

220 ms seems pretty low - have you measured the actual RTT on the satellite
link?  What speed is the satellite link? What MTU size are you using?

-Greg

LCDR Gregory W. Johnson
Ass't Prof. Electrical Engineering

USCG Academy
New London CT

860-444-8683

-----Original Message-----
From: Dusan Statelov [mailto:[email-masked]]
Sent: Thursday, May 17, 2001 11:13 AM
To: [email-masked]
Subject: TCP performance

Hello:

We are investigating reasons of poor TCP/ip performance over satellite.

We expect to get single TCP/ip performance of Windows size/RTT but in a
fact windows size does not influence performance at all.
We are working ni Windows NT platform.
In a LAN we get 180 kbyte/s the same system over sat falls to 25 kbyte/s

RTT is 220 ms windows size set to 64 kbyte.

I would appreciate your response and assistance.

--
Best regards

Dusan Statelov
Managing Director
Main Data,s.r.o.
mailto:[email-masked]

Tel:     +421 7 54789 586
Fax:     +421 7 54789 585
GSM:     +421 905 606 027
http://www.maindata.sk

---

From: "Andrew-Mark Pether" <[email-masked]>
Date: Fri, 18 May 2001 08:47:11 -0400

Hello

Maybe it would be useful to confirm we are talking GEO here and if that is true, the following from RFC 2488 maybe useful:

"The propagation time for a radio signal to travel twice that distance (corresponding to a ground station directly below the satellite) is 239.6 milliseconds (ms) [Mar78]. For ground stations at the edge of the view area of the satellite, the distance traveled is 2 x 41,756 km for a total propagation delay of 279.0 ms [Mar78]. These delays are for one ground station-to-satellite-to-ground station route (or "hop"). Therefore, the propagation delay for a message and the corresponding reply (one round-trip time or RTT) could be at least 558 ms. The RTT is not based solely on satellite propagation time. The RTT will be increased by other factors in the network, such as the transmission time and propagation time of other links in the network path and queueing delay in gateways."

So if the RTT (or even 1 hop) is 220ms this is not a GEO satellite link, nevermind full duplex or not.

Andrew Pether, M.Eng. ([email-masked])
EMS Technologies, Space & Technology Group
21025 TRANS CANADA HIGHWAY
STE-ANNE-DE-BELLEVUE, QUEBEC
CANADA, H9X 3R2

>>> Dusan Statelov <[email-masked]> 05/17 11:13 am >>>
Hello:

--
Best regards

Dusan Statelov
Managing Director
Main Data,s.r.o.

Tel:     +421 7 54789 586
Fax:     +421 7 54789 585
GSM:     +421 905 606 027
http://www.maindata.sk

---

From: "joe black" <[email-masked]>
Date: Sat, 19 May 2001 02:47:16 -0700

You make look into the issues of the satellite (uplink) bandwidth. There is always a maximum threshold of average queue size in the egress router which will limit the performace of incremental window size.

-----Original Message-----
From:    pambosc [email-masked]
Sent:    Fri, 18 May 2001 10:15:49 -0600
To:      [email-masked], [email-masked]
Subject: Re: TCP performance

Take a look at my reasearch and papers at
www.ittc.ukans.edu/~ccharala/research.html

Pambos
----- Original Message -----
From: "Dusan Statelov" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, May 17, 2001 9:13 AM
Subject: TCP performance

> I would appreciate your response and assistance.

___________________________________________________________________________
Visit http://www.visto.com/info, your free web-based communications center.
Visto.com. Life on the Dot.