Subject: information regarding use of TCP/IP in satellite communication

From: Prasad Rajesh <[email-masked]>
Date: Wed, 16 May 2001 16:50:58 -0500 (CDT)

Hello,
	I am a M.S(computer science) student at University of
Lousiana,lafayetet.I am doing a project on TCP/IP use in long
distance(satellite communication).
	Can you suggest from where I can get a free/cheap simulator in which i 
can simulate delay.
	Moreover can you suggest where i can get latest reserch information on 
this topic.
			My mail id is [email-masked]
				
					BYE,
					Rajesh Prasad

---

From: Luigi Rizzo <[email-masked]>
Date: Thu, 17 May 2001 01:09:17 +0200 (CEST)

> 	Can you suggest from where I can get a free/cheap simulator in which i 

one option is http://www.iet.unipi.it/~luigi/ip_dummynet/

(also part of FreeBSD)

	cheers
	luigi
----------------------------------+-----------------------------------------
 Luigi RIZZO, [email-masked]  . ACIRI/ICSI (on leave from Univ. di Pisa)
 http://www.iet.unipi.it/~luigi/  . 1947 Center St, Berkeley CA 94704
 Phone (510) 666 2927             .
----------------------------------+-----------------------------------------

---

From: Colin Paul Gloster <[email-masked]>
Date: Thu, 17 May 2001 15:40:43 +0100 (BST)

Also ONE was very recently announced on the list. If you can
get your university to pay for a package then you could try
one of the Radio versions of Mil3's OPNET. See
HTTP://WWW.OPNET.com/services/university/home.html

Also though it is not dedicated to satcoms, the free IP-oriented
Network Simulator ns is capable of modelling "wireless
(local and satellite) networks" and is used by for example
the famous owner and helpful ns-users maillist contributor
of the "Lloyd's satellite constellations" website.
See
HTTP://WWW.EE.Surrey.ac.UK/Personal/L.Wood/constellations/
HTTP://WWW.EE.Surrey.ac.UK/Personal/L.Wood/ns/
HTTP://WWW.ISI.edu/nsnam/archive/ns-users/webarch/current/maillist.html
HTTP://WWW.ISI.edu/nsnam/

Good luck.

"The Ohio Network Emulator (ONE) application is being made
available to outside researchers
in a open source format. The product will be supported
internally,
and ideally, benefit from having the wider external
distribution.

For additional information and to download the code:
http://irg.cs.ohiou.edu/one/

The ONE application is a network emulator that can be run on
an off
the shelf computer workstation. ONE provides an inexpensive
way to
perform the kinds of network emulation of interest in space
network
research. Effects that would be otherwise difficult or
impossible
to simulate (i.e. communication transit delays as seen by
satellites
and spacecraft) can be studied in the lab as new protocols
are
developed.

Other capabilities include: variable propagation delay,
[..]"

On Thu, 17 May 2001, Luigi Rizzo wrote:
"> 

(also part of FreeBSD)

	cheers
	luigi"