Subject: TCP performance

From: Dusan Statelov <[email-masked]>
Date: Thu, 17 May 2001 17:13:24 +0200

Hello:

We are investigating reasons of poor TCP/ip performance over satellite.

We expect to get single TCP/ip performance of Windows size/RTT but in a
fact windows size does not influence performance at all.
We are working ni Windows NT platform.
In a LAN we get 180 kbyte/s the same system over sat falls to 25 kbyte/s

RTT is 220 ms windows size set to 64 kbyte.

I would appreciate your response and assistance.

--
Best regards

Dusan Statelov
Managing Director
Main Data,s.r.o.
mailto:[email-masked]

Tel:     +421 7 54789 586
Fax:     +421 7 54789 585
GSM:     +421 905 606 027
http://www.maindata.sk

---

From: Loay Oweis <[email-masked]>
Date: Thu, 17 May 2001 16:40:32 -0400

Hello,

Please note that if your RTT is 220 ms, then your satellite link is not
duplex. Should you have a hybrid network
where your return channel is terrestrial and maybe dialup, then the window
size may not be ideal for your forward
channel.

There are products which include tcp acceleration. One is upcoming from
LMGT, LinkStar which will include tcp acceleration for upto a 10 Mbps rate.

Loay Oweis

--
---------------------------------------------------------------------
        Loay Oweis
        Technical Director/CO
        Oweitech - Independent Consultants
        4705 Hallowed Stream
        Ellicott City, MD 21042
        301-332-3930 Voice
        410-772-9573 Fax
        [email-masked]

---

From: "pambosc" <[email-masked]>
Date: Fri, 18 May 2001 10:15:49 -0600

Take a look at my reasearch and papers at
www.ittc.ukans.edu/~ccharala/research.html

Pambos

---

From: [email-masked] (Rainer Rucker)
Date: Sat, 19 May 2001 23:50:39 +0200

For Windows NT 4.0 you can make a hand tuning of the registry by modifying
the following keys:

You find the keys under
HKLM\SYSTEM\CurrentControlSet\Services\TCPIP\Parameters\

The Entries you can make are:
- TcpRecvSegmentSize (DWORD value)
- TcpWindowSize (DWORD value)
- PathMTUDiscovery (DWORD value)

Some time ago I speed up an 1 Mbps point to point link over satellite with
this global settings. It should also be possible to set this values by
Interface. Take a look at http://search.support.microsoft.com and
www.microsoft.com/technet/winnt (see Q158474 / Q199946) where you find
detailed information.

If you are installing a network monitor and make a trace you should be able
to see that these modifications are working or not. I use an application
called IPPERF. With this application you can make a measurement of your
throughput.

There's also a hardware solution possible. I've tried the SkyX XR10 Gateway
of www.mentat.com and it works good.

But at least NT 4.0 is not the best OS for Satellite networking. At the
moment I use W2k that support more options but my experience is that a
hardware solution works better.

Rainer Rucker
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Dusan Statelov
Sent: Donnerstag, 17. Mai 2001 17:13
To: [email-masked]
Subject: TCP performance

Hello:

--
Best regards

Dusan Statelov
Managing Director
Main Data,s.r.o.

Tel:     +421 7 54789 586
Fax:     +421 7 54789 585
GSM:     +421 905 606 027
http://www.maindata.sk