Subject: How to reach Large TCP window in Win (2000) or Linux

From: Dusan Statelov <[email-masked]>
Date: Mon, 28 May 2001 17:00:26 +0200

Hello:

As we are now in time pressure I would like ask you for advices how to
properly configure Win2000 or Linux Http data server in order to achieve
bigger TCP window and improve Single TCP connection from poor 20-30
kbyte/s (for RTT 240 ms) to according to us achievable 1 mbps.
We have changed "Default Receive Window", but TCP is running at only
20-30 kbyte/s what would corresponde to 8 kbyte Window rather then to 64
kbyte.
I assume there are other TCP registry entities which influence Sender
Window.

Here is a configuration emulating satellite internet:

Http Data Server [Linux or Win2000]  -> DVB/ip -> DVB-S Modulator -> L
band output -> PC DVB board [SkyMedia - Telemann, TT DVB Technotrend] ->

client PC [Win98] o---------------o  connected to DVB/ip GW in return
via LAN
LAN RTT 20 ms
Artefficial delay in DVB/ip GW 220 ms (in order to simulate long RTT for
satellite)

Windows98
Default Receive Window to max.values 65535
Data Sever Win2000
Default Receive Window to max.values 65535 (we tried even 0,5 Mbyte with
no effect)
RTT 240 ms
Single TCP connection 20 - 30 kbyte/s

Thanks in advance.

Dusan Statelov
Managing Director
Main Data,s.r.o.
mailto:[email-masked]

Tel:     +421 7 54789 586
Fax:     +421 7 54789 585
GSM:     +421 905 606 027
http://www.maindata.sk

---

From: Jon Mansey <[email-masked]>
Date: Mon, 28 May 2001 08:21:41 -0700

You need to increase the client's RECEIVE window, the server normally 
can scale up to quite large send windows by default.

Make sure you enable SACK and RFC1323. Use TCPTune for this

http://moat.nlanr.net/Software/TCPtune/

jm

At 5:00 PM +0200 5/28/01, Dusan Statelov wrote:
>Hello:
>
>As we are now in time pressure I would like ask you for advices how 
>to properly configure Win2000 or Linux Http data server in order to 
>achieve bigger TCP window and improve Single TCP connection from 
>poor 20-30 kbyte/s (for RTT 240 ms) to according to us achievable 1 
>mbps.
>20-30 kbyte/s what would corresponde to 8 kbyte Window rather then 
>to 64 kbyte.
>I assume there are other TCP registry entities which influence Sender Window.
>
>Http Data Server [Linux or Win2000]  -> DVB/ip -> DVB-S Modulator -> 
>L band output -> PC DVB board [SkyMedia - Telemann, TT DVB 
>Technotrend] ->
>client PC [Win98] o---------------o  connected to DVB/ip GW in return via LAN
>LAN RTT 20 ms
>Artefficial delay in DVB/ip GW 220 ms (in order to simulate long RTT 
>for satellite)
>
>Windows98
>Default Receive Window to max.values 65535 (we tried even 0,5 Mbyte 
>with no effect)
>RTT 240 ms
><mailto:[email-masked]>mailto:[email-masked]
>
>Tel:     +421 7 54789 586
>Fax:     +421 7 54789 585
>GSM:     +421 905 606 027
><http://www.maindata.sk>http://www.maindata.sk
>
>
>Content-Type: text/x-vcard; charset=iso-8859-2;
>  name="statelov.vcf"
>Content-Transfer-Encoding: 7bit
>Content-Description: Card for Dusan Statelov
>Content-Disposition: attachment;
>  filename="statelov.vcf"
>
>Attachment converted: Macintosh HD:statelov.vcf 1 (TEXT/ttxt) (000CAF94)

---

From: Eric Travis <[email-masked]>
Date: Mon, 28 May 2001 16:34:47 -0400 (EDT)

I normally wouldn't ask these questions (and I do apologize),
but since your data source is labeled as being an http server:

Are you convinced that you are passing enough data during the life
of the measured TCP connections to allow your congestion window to
fully open?

If yes, are you passing enough *additional* data to make the
time spent in slow-start negligible when calculating the average
throughput of the connection?

How large are your test data flows?

Tuning the TCP connection parameters is important, but that
can only remove artificial bounds on performance. You still
need to allow for TCP to probe for the capacity of the path;

It could be that you simply aren't transferring enough data...

Eric

Eric Travis
[email-masked]